Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
HPE Networking Instant On Switch 24p Gigabit 4p SFP+ 1930 - JL682A
- Part Number: JL682A#ABA
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- Model #: JL682A#ABA
- $314.99 –
- More options from $314.99 - $538.00
- Free Shipping

Quick View
Ubiquiti Standard 16 PoE, 16-port Layer 2 PoE Switch (USW-16-POE (42W))
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-16-POE
- Format: Rackmount
- Model #: USW-16-POE (42W)
- $322.00 –
- More options from $322.00 - $370.00
- $4.99 Shipping

Quick View
Netgear ProSafe GS728TP 24-Port Manageable Gigabit Ethernet Switch, GS728TP-300NAS
- Brand: NETGEAR
- Part Number: GS728TP-300NAS
- Network Management Type: Smart
- Primary Ports: 24 x RJ45 + 4 x SFP
- Model #: GS728TP-300NAS
- $399.99 –
- Free Shipping

Quick View
Netgear ProSafe GS510TPP 8-Port Gigabit Ethernet High-Power PoE+ Smart Switch with 2 Dedicated SFP Ports (190W), GS510TPP-100NAS
- Brand: NETGEAR
- Series: ProSafe
- Part Number: GS510TPP-100NAS
- Format: Rack-mountable Desktop
- Model #: GS510TPP-100NAS
- $345.99 –
- Free Shipping

Quick View
Netgear GS348 48-Port Gigabit Ethernet Unmanaged Essentials Switch, GS348-100NAS
- Brand: NETGEAR
- Part Number: GS348-100NAS
- Format: Desktop Rack-Mountable
- Standards: 802.3ab 1000BASE-T Gigabit Ethernet 802.3u 100BASE-TX Fast Ethernet 802.3i 10BASE-T Ethernet 802.3x Flow Control 802.1p Priority QoS (all models) 802.1p Priority QoS and Honors DSCP tags 802.3 CSMA / CD 802.3az Energy Efficient Ethernet
- Model #: GS348-100NAS
- $379.99 –
- Free Shipping

Quick View
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
- Brand: NETGEAR
- Format: Desktop / Rackmount
- Network Management Type: Unmanaged
- Primary Ports: 16 x RJ45
- Model #: GS516UP-100NAS
- $369.99 –
- Free Shipping

Quick View
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
- Brand: NETGEAR
- Part Number: GS516PP-100NAS
- Format: Desktop Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
- Model #: GS516PP-100NAS
- $309.99 –
- Free Shipping

Quick View
Netgear GS524PP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (300W), GS524PP-100NAS
- Brand: NETGEAR
- Format: Desktop / Rackmount
- Network Management Type: Unmanaged
- Primary Ports: 24 x RJ45
- Model #: GS524PP-100NAS
- $389.99 –
- Free Shipping

Quick View
Netgear MS108EUP 8-port Multi-Gigabit (2.5G) Ethernet Ultra 60 PoE++ Easy Smart Managed Switch, MS108EUP-100NAS
- Brand: NETGEAR
- Part Number: MS108EUP-100NAS
- Format: Wall Mountable Desktop
- Standards: IEEE 802.3 IEEE 802.3ab IEEE 802.3u IEEE 802.1p IEEE 802.3az IEEE 802.3ad IEEE 802.1Q IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3bt
- Model #: MS108EUP-100NAS
- $349.99 –
- Free Shipping

Quick View
Netgear Business GS728TXv3 24-Port Manageable Gigabit Ethernet Smart Switch, GS728TX-300NAS
- Brand: NETGEAR
- Series: Smart w/optional Cloud
- Part Number: GS728TX-300NAS
- Format: Rackmount
- Model #: GS728TX-300NAS
- $399.99 –
- Free Shipping

Quick View
Netgear MS108TUP 8-Port Multi-Gigabit (2.5G) Ethernet Ultra60 PoE++ Smart Switch, MS108TUP-100NAS
- Brand: NETGEAR
- Series: Smart
- Part Number: MS108TUP-100NAS
- Format: Desktop Wall Mountable Compact
- Model #: MS108TUP-100NAS
- $399.99 –
- Free Shipping

Quick View
Netgear GS324TP 24-Port Gigabit Ethernet PoE+ Smart Managed Essentials Switch with 2 Dedicated SFP Ports (190W), GS324TP-200NAS
- Brand: NETGEAR
- Series: S350
- Part Number: GS324TP-200NAS
- Standards: IEEE 802.3at IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.1Q IEEE 802.3ad IEEE 802.3x IEEE 802.1D IEEE 802.1s IEEE 802.1w IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3af IEEE 802.3z
- Model #: GS324TP-200NAS
- $335.99 –
- Free Shipping

Quick View
HPE Networking Instant On Switch 48p Gigabit 4p SFP 1830 (JL814A#ABA)
- Primary Ports: 48 x RJ45 + 4 x SFP
- Buffer Memory: 1.5 MB
- Layer: 2
- Power: 100 - 240 VAC
- Model #: JL814A#ABA
- $394.99 –
- More options from $394.99 - $578.00
- Free Shipping

Quick View
TP-Link TL-SX1008 | 8 Port 10G/Multi-Gig Unmanaged Ethernet Switch | Desktop/Rackmount | Plug & Play | Sturdy Metal Casing | Speed Auto-Negotiation
- Brand: TP-Link
- Model #: TL-SX1008-_V2
- $349.99 –
- More options from $349.99 - $420.08
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit CL4 PoE 2p SFP 195W 1830 (JL813A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- PoE: Yes
- Model #: JL813A#ABA
- $399.99 –
- More options from $399.99 - $588.00
- Free Shipping

Quick View
TP-Link Festa FS352G 52 Port Gigabit Smart Managed Network Switch - 48 RJ45 ports & 4 SFP slots, Free Cloud Access, Static Routing, Vlan, IGMP Snooping, rack-mountable, fanless, Does not work w/ Omada
- Brand: TP-Link
- Network Management Type: Managed
- Primary Ports: 48 x 10/100/1000 Mbps RJ45 ports and 4 x Gigabit SFP Slots to provide high-speeds and reliable connections
- VLAN Support: Yes
- Model #: Festa FS352G
- $398.99 –
- Free Shipping

Quick View
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
- Format: Rack-mountable Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Base-T
- Model #: DGS-1210-52
- $395.29 –
- Free Shipping

Quick View
Cisco Catalyst C1200-16T-2G Ethernet Switch - 16 Ports - Manageable - Gigabit Ethernet - 3 Layer Supported C1200-16T-2G
- Brand: CISCO
- Series: 1200
- Part Number: C120016T2G
- Switch Type: Ethernet Switch
- Model #: C1200-16T-2G
- $384.80
- $356.99 –
- Save: $27.81 (7%)
- Free Shipping

Quick View
SonicWall Switch SWS12-8POE 10 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 73.30 W Power Consumption - 55 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: 02-SSC-2463
- $314.99 –
- Free Shipping

Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
- Model #: GS-4210-16P4C
- $458.00
- See price in cart
- Free Shipping

Quick View
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
- Brand: NETGEAR
- Part Number: GS116EPP-100NAS
- Format: Desktop, Wall Mountable, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS116EP-100NAS
- $390.39 –
- $11.62 Shipping

Quick View
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
- Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
- MAC Address...
- Model #: GS-4210-16P2S
- $324.99 –
- More options from $324.99
- Free Shipping

Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: WGS-5225-8T2SV
- $341.99 –
- More options from $327.20 - $341.99
- Free Shipping

Quick View
QNAP QSW-M408S 6-port layer 2 managed switch. 6 x 2.5GbE (1G/100M) ports and 4 x 10G SFP+ ports. Easy management with web browser.
- Series: QSW-M408S 6-port
- Part Number: QSW-M2106-4S-US
- Model #: QSW-M2106-4S-US
- $369.00
- See price in cart
- Free Shipping

Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
- Brand: PLANET
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGSW-24040R
- $376.00
- See price in cart
- Free Shipping

Quick View
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet over Fiber-Optic IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 24 x 10/100BASE-TX RJ45 copper with 24-port IEEE 802.3at / af PoE injector 2 x 10/100/1000BASE-T Gigabit RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots, shared with port-25 to port-26
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSW-2624HPS4
- $556.00
- See price in cart
- Free Shipping

Quick View
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
- Format: DIN Rail Mountable Wall Mountable
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Weight: 15.20 oz
- Parts: 5 Year
- Model #: SISTP1040-342-LRT
- $302.69 –
- More options from $302.69 - $334.17
- Free Shipping

Quick View
Netgear GS724TP 24-Port Gigabit Ethernet PoE+ Smart Switch with 2x SFP Ports (190W), Optional Insight Cloud Management, GS724TP-300NAS
- Brand: NETGEAR
- Part Number: GS724TP-300NAS
- Format: Rack-mountable Desktop
- Standards: IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.3 IEEE 802.11ac IEEE 802.3at IEEE 802.3af IEEE 802.1Q IEEE 802.3ad IEEE 802.1D IEEE 802.1w IEEE 802.1s
- Model #: GS724TP-300NAS
- $369.99 –
- Free Shipping

Quick View
Ubiquiti Standard 24, 24-port Layer 2 Switch (USW-24)
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-24
- Format: Rackmount
- Model #: USW-24
- $326.11 –
- More options from $242.00 - $392.99
- Free Shipping

Quick View
TP-Link TL-SG3428X | 24 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG | Limited Lifetime Protection
- Format: Desktop
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 24 x 10/100/1000 Mbps RJ45 Ports 4 x 10G SFP+ Slots
- Model #: TL-SG3428X
- $334.99 –
- More options from $309.99 - $439.62

Quick View
TRENDnet TEG-S3160, 16-Port Unmanaged 2.5G Desktop Network Ethernet Switch
- Brand: TRENDnet
- Series: ProSafe
- Part Number: TEG-S3160
- Format: 16-Port 2.5G
- Model #: TEG-S3160
- $304.20 –
- More options from $259.99 - $562.99
- Free Shipping

Quick View
Cisco Catalyst C1200-8P-E-2G 8-Port Gigabit PoE+ Compliant Managed Network Switch (67W)
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1200-8P-E-2G
- Format: Rack-mountable
- Model #: C1200-8P-E-2G
- $307.99 –
- More options from $307.99 - $341.71
- Free Shipping

Quick View
Aruba Instant On 1830 48-Port Gb Smart Switch - 48x 1G | 4X SFP | US Cord (JL814A#ABA)
- Switch Type: Ethernet Switch
- Model #: JL814A#ABA
- $394.99 –
- More options from $379.99 - $916.99
- Free Shipping

Quick View
Axis TU8003 90 W Connectivity Midspan - For network and fiber installations up to 90 W - 02027-004
- Model #: 02027-004
- $319.00 –
- Free Shipping






