Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
  • $300 - $400
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
Quick View
Netgear Inc.
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
  • Brand: NETGEAR
  • Format: Desktop / Rackmount
  • Network Management Type: Unmanaged
  • Primary Ports: 16 x RJ45
  • Model #: GS516UP-100NAS
  •  
  • $369.99 –
  • Free Shipping
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
Quick View
Netgear Inc.
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS516PP-100NAS
  • Format: Desktop Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: GS516PP-100NAS
  •  
  • $309.99 –
  • Free Shipping
Netgear MS108TUP 8-Port Multi-Gigabit (2.5G) Ethernet Ultra60 PoE++ Smart Switch, MS108TUP-100NAS
Quick View
Netgear Inc.
Netgear MS108TUP 8-Port Multi-Gigabit (2.5G) Ethernet Ultra60 PoE++ Smart Switch, MS108TUP-100NAS
  • Brand: NETGEAR
  • Series: Smart
  • Part Number: MS108TUP-100NAS
  • Format: Desktop Wall Mountable Compact
  • Model #: MS108TUP-100NAS
  •  
  • $399.99 –
  • Free Shipping
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
Quick View
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: DGS-1210-52
  •  
  • $395.29 –
  • Free Shipping
Aruba Instant On 1830 48-Port Gb Smart Switch - 48x 1G | 4X SFP | US Cord (JL814A#ABA)
Quick View
SonicWall Switch SWS12-8POE 10 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 73.30 W Power Consumption - 55 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
Quick View
  •  
  • $314.99 –
  • Free Shipping
Cisco Catalyst C1200-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 2 Layer Supported
Quick View
Cisco Catalyst C1200-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 2 Layer Supported
  • Part Number: C1200-8FP-2G
  • Standards: Layer Supported: 2 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 1000Base-X 10/100/ 1000Base-T
  • Uplink Ports: Total Number of Network Ports: 10 Uplink Port: Yes Modular: Yes Network (RJ-45): Yes Port/Expansion Slot Details: 8 x Gigabit Ethernet Network Port 2 x Gigabit Ethernet Combo
  • Model #: C1200-8FP-2G
TRENDnet 10-Port Gigabit PoE++ Switch, TPE-BG102g, 8 x Gigabit  PoE++ Ports, 2 x Gigabit SFP Ports, 240W PoE Power Budget, 20Gbps,  Internal Power Supply, Lifetime Protection, Black
Quick View
TRENDnet 10-Port Gigabit PoE++ Switch, TPE-BG102g, 8 x Gigabit PoE++ Ports, 2 x Gigabit SFP Ports, 240W PoE Power Budget, 20Gbps, Internal Power Supply, Lifetime Protection, Black
  • Brand: TRENDnet
  • Standards: IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3af IEEE 802.3at IEEE 802.3bt
  • Primary Ports: 4 x Gigabit PoE++ ports 4 x Gigabit PoE+ ports 2 x Gigabit SFP Slots LED indicators
  • Primary Port Speed: Ethernet: 10Mbps (half duplex), 20Mbps (full duplex) Fast Ethernet: 100Mbps (half duplex), 200Mbps (full duplex) Gigabit: 2000Mbps (full duplex) Fiber: 2000Mbps (full duplex)
  • Model #: TPEBG102g
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
Quick View
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
  • Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
  • MAC Address...
  • Model #: GS-4210-16P2S
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
  • Model #: GS-4210-16P4C
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
Quick View
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
  • Format: DIN Rail Mountable Wall Mountable
  • Primary Port Speed: 1000Base-X 10/100/1000Base-T
  • Weight: 15.20 oz
  • Parts: 5 Year
  • Model #: SISTP1040-342-LRT
TRENDnet 6-Port Hardened Industrial Gigabit 10/100/1000 Mbps Ultra PoE DIN-Rail Switch, UPoE, IP30, DIN-Rail & Wall Mounts Included, TI-UPG62
Quick View
TRENDnet 6-Port Hardened Industrial Gigabit 10/100/1000 Mbps Ultra PoE DIN-Rail Switch, UPoE, IP30, DIN-Rail & Wall Mounts Included, TI-UPG62
  • Brand: TRENDnet
  • Format: Desktop
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at
  • Network Management Type: Managed
  • Model #: TI-UPG62
D-Link 28-Port Web Smart Gigabit Ethernet PoE Switch (DGS-1210-28P)
Quick View
D-Link 28-Port Web Smart Gigabit Ethernet PoE Switch (DGS-1210-28P)
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode IEEE 802.3af compliance (DGS-1210-28P only) Auto-negotiation
  • Primary Ports: 24 x 10/100/1000BASE-T PoE 4 x 4 SFP
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: DGS-1210-28P
StarTech.com Industrial 6-Port Gigabit Ethernet Switch w/ 4 PoE RJ45 +2 SFP Slots
Quick View
StarTech.com Industrial 6-Port Gigabit Ethernet Switch w/ 4 PoE RJ45 +2 SFP Slots
  • Switch Type: ethernet
  • Format: Desktop
  • Primary Ports: 4 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES1G52UP12V
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
Quick View
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
  • Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
  • Primary Port Speed: 20Gbps / non-blocking
  • Model #: MGSD-10080F
TRENDnet 20-Port Gigabit PoE+ Web Smart PoE+ Switch, 16 x Gigabit PoE+ Ports, 4 x Shared Gigabit Ports, Up To 30W Per Port, 185W Total Power Budget, Rack Mountable, Black, TPE-1620WS
Quick View
TRENDnet 20-Port Gigabit PoE+ Web Smart PoE+ Switch, 16 x Gigabit PoE+ Ports, 4 x Shared Gigabit Ports, Up To 30W Per Port, 185W Total Power Budget, Rack Mountable, Black, TPE-1620WS
  • Brand: TRENDnet
  • Format: Rackmount
  • Standards: IEEE 802.3/3u/3ab, IEEE 802.3af/at
  • Network Management Type: Smart
  • Model #: TPE-1620WS
TRENDnet 6-Port Hardened Industrial Gigabit Poe+ Layer 2 Managed DIN-Rail Switch, 4 x Gigabit PoE+ 802.3at Ports, 1 x Gigabit Port, 1 x Gigabit SFP Slot, 120W Power Budget, Black, TI-PG541i
Quick View
TRENDnet 6-Port Hardened Industrial Gigabit Poe+ Layer 2 Managed DIN-Rail Switch, 4 x Gigabit PoE+ 802.3at Ports, 1 x Gigabit Port, 1 x Gigabit SFP Slot, 120W Power Budget, Black, TI-PG541i
  • Switch Type: Switches
  • Format: DIN Rail Mount
  • Standards: IEEE 802.1p IEEE 802.1Q IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3af IEEE 802.3at IEEE 802.3az
  • Primary Ports: 4 x Gigabit PoE+ ports 1 x Gigabit port 1 x Gigabit SFP slot
  • Model #: TI-PG541i
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
  • Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES81GPOEW
ZyXEL 24-Port Gigabit Smart Managed PoE Switch, 24 PoE+ Ports at 170W with 2 SFP Uplinks, TAA Compliant, GS1900-24HPV2
Quick View
ZyXEL 24-Port Gigabit Smart Managed PoE Switch, 24 PoE+ Ports at 170W with 2 SFP Uplinks, TAA Compliant, GS1900-24HPV2
  • Brand: ZyXEL
  • Part Number: GS1900-24HPV2
  • Switch Type: Manageable: Yes
  • Format: Rack-mountable Desktop
  • Model #: GS1900-24HPV2
TRENDnet TPE-3018LS (V1.0R) Smart 18-Port Gigabit PoE+ Smart Surveillance Switch
Quick View
TRENDnet TPE-3018LS (V1.0R) Smart 18-Port Gigabit PoE+ Smart Surveillance Switch
  • Brand: TRENDnet
  • Model: TPE-3018LS (V1.0R)
  • Format: Desktop
  • Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
  • Model #: TPE-3018LS (V1.0R)
TRANSITION NETWORKS SM8TAT2SA-NA SMART MANAGED POE+ SWITCH8PORT
Quick View
  • $324.72 - $338.14
Digi AnywhereUSB 2 Plus Remote USB 3.1 External Hub Power Supply Not Included
Quick View
  • $369.32 - $381.72
ZyXEL GS1350-18HP 16-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 16 PoE+ Ports at 250W with 2 SFP Uplinks
Quick View
ZyXEL GS1350-18HP 16-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 16 PoE+ Ports at 250W with 2 SFP Uplinks
  • Part Number: GS1350-18HP
  • Format: Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair, Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Uplink Interface: Total Number of Network Ports: 16 Uplink Port: Yes Modular: Yes Port/Expansion Slot Details: 16 x Gigabit Ethernet PoE+ 2 x Gigabit Ethernet TP/SFP Combo
  • Model #: GS1350-18HP
TRENDnet 10-Port Industrial Gigabit PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 240W PoE Power Budget, Network Switch, IP30, QoS, Black, TI-PG102
Quick View
TRENDnet 10-Port Industrial Gigabit PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 240W PoE Power Budget, Network Switch, IP30, QoS, Black, TI-PG102
  • Format: Includes DIN-rail and wall mounts
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at
  • Primary Ports: 8 x Gigabit PoE+ ports 2 x Gigabit RJ-45 / SFP shared ports
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
  • Model #: TI-PG102
Available Direct from TRENDnet Available Direct from TRENDnet
Ubiquiti Networks EdgeSwitch 24 250W (ES-24-250W) Managed PoE+ Gigabit Switch with SFP,Black
Quick View
Ubiquiti Networks EdgeSwitch 24 250W (ES-24-250W) Managed PoE+ Gigabit Switch with SFP,Black
  • Part Number: UBI-ES-24-250W
  • Format: Rackmount
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: ES-24-250W
TRENDnet 10-Port Industrial Gigabit PoE+ Wall-Mounted Front Access Switch, TI-PG102F, 8x Gigabit PoE+ Ports, 2 x Gigabit SFP Slots, 240W PoE Budget, DIN-Rail & Wall Mount Brackets Included, IP30 Rated
Quick View
TRENDnet 10-Port Industrial Gigabit PoE+ Wall-Mounted Front Access Switch, TI-PG102F, 8x Gigabit PoE+ Ports, 2 x Gigabit SFP Slots, 240W PoE Budget, DIN-Rail & Wall Mount Brackets Included, IP30 Rated
  • Format: Wall Mountable
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TI-PG102F
  •  
  • $309.99 –
  • Free Shipping
Direct from TRENDnet Direct from TRENDnet
TRENDnet 7-Port Industrial Gigabit L2 Managed PoE+ DINRail Switch 24  - 57V  - Ethernet Splitter - 120W@48V DC or 120W@24V DC - 14Gbps - NDAA & TAA Compliant - IP40 Rated - TI-PG743BI
Quick View
Available Direct from TRENDnet Available Direct from TRENDnet
TRENDnet 16-Port Hardened Industrial Unmanaged Gigabit PoE+ DIN-Rail Switch, TI-PG162, 14 x Gigabit Ports, 2 x Gigabit SFP Slots, 32Gbps, IP30 Gigabit Network Ethernet Switch
Quick View
TRENDnet 16-Port Hardened Industrial Unmanaged Gigabit PoE+ DIN-Rail Switch, TI-PG162, 14 x Gigabit Ports, 2 x Gigabit SFP Slots, 32Gbps, IP30 Gigabit Network Ethernet Switch
  • Brand: TRENDnet
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x IEEE 802.3z IEEE 802.3af IEEE 802.3at
  • Primary Ports: 14 x RJ45 + 2 x SFP
  • Model #: TI-PG162 (V2)
  •  
  • $389.99 –
Direct from TRENDnet Direct from TRENDnet
TRENDnet 10-Port Industrial Gigabit L2 Managed DIN-Rail Switch, 8 X Gigabit, 2 X SFP Slots, DIN-Rail Mount, IP30, Ethernet Splitter, NDAA & TAA Compliant, TI-G102i
Quick View
TRENDnet 10-Port Industrial Gigabit L2 Managed DIN-Rail Switch, 8 X Gigabit, 2 X SFP Slots, DIN-Rail Mount, IP30, Ethernet Splitter, NDAA & TAA Compliant, TI-G102i
  • Format: DIN Rail Mount
  • Standards: IEEE 802.1d, IEEE 802.1p, IEEE 802.1Q, IEEE 802.1w, IEEE 802.1X, IEEE 802.1ab, IEEE 802.1ax, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3az
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TI-G102i
Available Direct from TRENDnet Available Direct from TRENDnet
Dell PowerConnect 2824 24 Port 10/100/1000 Gbps Smart Switch
Quick View
Dell PowerConnect 2824 24 Port 10/100/1000 Gbps Smart Switch
  • Format: Rackmount
  • Standards: 802.3 802.3u 802.3ab 802.1Q 802.3ad 802.1p
  • Uplink Ports: 2
  • Uplink Interface: SFP
  • Model #: 469-4244
  •  
  • $342.00 –
  • Free Shipping