Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Aten 4-Port USB 3.0 4K HDMI KVMP Switch CS1824
- Model #: CS1824
- $595.50 –
- More options from $389.23 - $975.90
- Free Shipping

Quick View
MIKROTIK NETPOWER External Switch 16P CRS318-16P-2S+Out
- Model #: 6434579082978ASDFA950931
- $510.15 –
- Free Shipping

Quick View
Moxa EDS-316-T - Industrial Unmanaged Ethernet Switch with 16 10/100BaseT(X) ports, -40 to 75 Degree C
- Model #: EDS-316-T
- $677.20 –
- More options from $677.20 - $712.48
- Free Shipping

Quick View
Antaira LRX-0200-T - Industrial Router with VPN/NAT Extended Temperature Version (-35C to 70C)
- Model #: LRX-0200-T
- $556.00 –
- Free Shipping

Quick View
Eaton Tripp Lite Series 16-Port Unmanaged Ethernet Switch with PoE+
- Brand: Eaton
- Parts: 3 Year
- Model #: NG16POE-1
- $538.10 –
- Free Shipping

Quick View
PLANET GS-5220-24P4X L2+ 24-Port 10/100/1000T 802.3at PoE+ 4-Port 10G SFP+ Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN tagging IEEE 802.1x port authentication network control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 24 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ injector 4 x 100/1000BASE-X mini-GBIC/SFP combo interface with Port-21 to Port-24 4 x 10GBASE-SR/LR ...
- Model #: GS-5220-24P4X
- $575.00 –
- $14.00 Shipping

Quick View
ONV-POE33018PFM-at 16 * 10/100/1000M PoE ports + 2 * Gigabit SFP optical ports POE Switch
- Model #: N-ONV-POE33018PFM-at
- $500.00 –
- $20.00 Shipping

Quick View
36 port 10G Managed L2+ Core PoE Switch 10/100/1000M PoE RJ45/Gigabit SFP ports ONV-POE36036PFM
- Type: Switch
- Model #: ONV-POE36036PFM
- $610.00 –
- $50.00 Shipping

Quick View
ONV-POE36028PFM 24*10/100/1000M PoE RJ45 ports + 4*10G SFP+ ports Managed PoE Switch
- Model #: N-ONV-POE36028PFM
- $560.00 –
- $50.00 Shipping

Quick View
26-Port Gigabit Managed PoE Switch TP/SFP 22*10/100/1000M RJ45 Ports 600W ONV-POE33026PFM-at
- Type: Switch
- Model #: ONV-POE33026PFM-at
- $540.00 –
- $50.00 Shipping

Quick View
Planet MGSW-24160F L2+ 16-Port 100/1000BASE-X SFP + 8-Port 10/100/1000BASE-T Managed Metro Ethernet Switch
- Model #: MGSW-24160F
- $576.00 –
- $14.00 Shipping

Quick View
ONV-POE36028PFM-at 36-port 10G Managed L2+ Core PoE Switch compatible with both IEEE 802.3af/at standard
- Model #: N-ONV-POE36028PFM-at
- $580.00 –
- $50.00 Shipping

Quick View
ONV-POE33026PFM 22*10/100/1000M RJ45 Ports + 2*TP/SFP Combo Ports + 2*Gigabit SFP Ports POE Switch
- Model #: N-ONV-POE33026PFM
- $500.00 –
- $20.00 Shipping

Quick View
Moxa EDS-P206A-4PoE - Unmanaged PoE Ethernet switch
- Model #: EDS-P206A-4PoE
- $624.20 –
- More options from $624.00 - $656.51
- Free Shipping

Quick View
36 port Million Gigabit POE Switch 24PG+8GF+4TF Power Supply Network Management ONV-POE36036PFM-at
- Type: Switch
- Model #: ONV-POE36036PFM-at
- $650.00 –
- $50.00 Shipping

Quick View
IGPS-1080-24V - Slim Type 8 x 10/100/1000TX (RJ-45) PoE+
- Model #: IGPS-1080-24V
- $559.00 –
- Free Shipping

Quick View
Tycon TP-SW5G-24HP IEEE802.3af PoE 12-36VDC High Power
- Format: DIN Rail Mount
- LEDs: Link (Green On), Activity (Green Blinking ); PoE Detect (Yellow On), PoE Detect Error (Yellow Blinking) Power On (Green On), Power On Alarm (Red On)
- Dimensions: 159 x 118 x 40mm (6.3 x 4.6 x 1.6”) (HP version has metal housing)
- Weight: 383g (13.5oz)
- Model #: TP-SW5G-24HP
- $529.95 –
- Free Shipping

Quick View
ONV-POE33048PFM 48x 10/100/1000M RJ45 ports 4x Gigabit SFP Managed Ring PoE Switch
- Model #: N-ONV-POE33048PFM
- $730.00 –
- $50.00 Shipping

Quick View
Moxa EDS-405A-EIP-T - Entry-level managed Ethernet switch
- Model #: EDS-405A-EIP-T
- $591.20 –
- More options from $591.00 - $664.10
- Free Shipping

Quick View
EDS-408A 8-port entry-level managed Ethernet switches
- Model #: EDS-408A
- $658.20 –
- More options from $658.00 - $738.19
- Free Shipping

Quick View
Perle IOLAN SDS1 GR Secure Device Server 04031824
- Brand: Perle Systems
- Model #: 04031824
- $538.00 –
- Free Shipping

Quick View
Perle IOLAN SDS1 G9 Secure Device Server 04031834
- Switch Type: other
- Model #: 04031834
- $538.00 –
- Free Shipping

Quick View
Allied Telesis AT-GS950/24-10 Managed Ethernet Switch
- Format: Rackmount
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 1000Mbps
- VLAN Support: Yes
- Model #: AT-GS950/24-10
- $502.89 –
- Free Shipping

Quick View
Cisco SG220-50 50-Port Gigabit Smart Plus Switch
- Format: Rack-mountable Wall Mountable
- Uplink Interface: SFP
- Primary Ports: 48 x RJ45 + 2 x SFP
- Primary Port Speed: 1000 Base-X 10/100/1000 Base-T
- Model #: SG220-50-K9-NA
- $669.95 –
- Free Shipping

Quick View
Meraki MS120-8LP 1G L2 Cloud Managed 8x GigE 64W PoE Switch License Required
- Format: Desktop Wall Mountable
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Weight: 2.76 lb
- Package Contents: Package Contents: MS120-8LP 1G L2 Cloud Managed 8x GigE 64W PoE Switch 1 x Mounting Screw Kit and Anchor 1 x External Power Supply
- Model #: MS120-8LP-HW
- $649.95 –
- Free Shipping

Quick View
Lenovo CE0128TB 24-Port 1GbE RJ45 + 4-Port SFP+ 10GbE Managed L2/L3 1U Rack-Mountable Campus Network Switch
- Format: Rackmount
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- VLAN Support: Yes
- Model #: SSG7A46646
- $658.90 –
- More options from $195.00 - $658.90
- Free Shipping

Quick View
EX4200-48PX - Juniper EX 4200 Switch - 48-pt GigE PoE+ L3 930W AC PS
- Switch Type: Layer 3 Switch
- Format: Rackmount
- Primary Ports: 48 x Gigabit Ethernet Network
- Primary Port Speed: 10/100/1000Base-T
- Model #: EX4200-48PX
- $540.36 –
- More options from $441.10 - $540.36
- Free Shipping

Quick View
Cisco Catalyst 1000 24-Port Fast Ethernet Switch with 2x 1G SFP and 2x 1G Combo Ports Refresh
- Model #: C1000FE-24T-4G-L
- $549.95 –
- Free Shipping

Quick View
Cloud Managed MS120-24P - switch - 24 ports - managed - rack-mountable
- Model #: MS120-24P-HW
- $599.95 –
- Free Shipping







