Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now
SHOP BY Primary Ports

Quick View
BRAINBOXES SW-508 INDUSTRIAL ETHERNET 8PORT SW
- Switch Type: Others
- Weight: 0.5
- Model #: SW-508
- $138.57
- $132.57 –
- More options from $132.57 - $193.59
- Free Shipping

Quick View
Planet FGSW-2622VHP 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Ethernet Switch with LCD PoE Monitor (300W)
- Model #: FGSW-2622VHP
- $337.99 –
- Free Shipping

Quick View
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
- Brand: PLANET
- Format: 19-inch Desktop size, 1U Height, Rack Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Network Management Type: Unmanaged
- Model #: GSW-2620VHP
- $432.00
- See price in cart
- Free Shipping

Quick View
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
- Format: Desktop
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 4-Port 10/100TX 802.3af/at PoE 2-Port 10/100TX
- Primary Port Speed: 10/100Mbps
- Model #: FSD-604HP
- $49.99 –
- Free Shipping

Quick View
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSD-1008HPS
- $236.00
- See price in cart
- Free Shipping

Quick View
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 10/100/1000T 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: IGS-4215-8P2T2S
- $530.99 –
- More options from $530.99 - $651.20
- Free Shipping

Quick View
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
- Brand: HPE
- Model: JL256A#ABA
- Part Number: JL256A
- Primary Ports: (48) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
- Model #: JL256A#ABA
- $3,369.00 –
- Free Shipping

Quick View
D-Link 24-Port Gigabit Smart Managed Switch | Web Managed | Cable Diagnostics | NDAA Compliant - (DGS-1100-24V2)
- Weight: 5
- Model #: DGS-1100-24V2
- $129.99
- $118.97 –
- Save: $11.02 (8%)
- More options from $118.97 - $154.99
- Free Shipping

Quick View
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port 10/100TX
- MAC Address Table: 8K
- Model #: FSD-1008HP
- $88.99 –
- Free Shipping

Quick View
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
- Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
- MAC Address...
- Model #: GS-4210-16P2S
- $324.99 –
- More options from $324.99
- Free Shipping

Quick View
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
- Primary Ports: (4) 10/100 MbE fast ports
- PoE: Yes
- Power: Power method PV panel (H4 connectors) Max. power consumption 2W Supported voltage range 10–60V (Reverse protection, surge protection) Max. open circuit voltage: 60V
- Dimensions: 202 x 190 x 50 mm (8 x 7.5 x 2")
- Model #: SM-SP-40
- $199.00 –
- Free Shipping

Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES101GP2SFW
- $451.99 –
- More options from $451.99 - $574.84
- Free Shipping

Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
- Model #: GS-4210-16P4C
- $458.00
- See price in cart
- Free Shipping

Quick View
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
- Primary Ports: 4 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-620TF
- $198.00
- See price in cart
- Free Shipping

Quick View
Transition Networks Managed Hardened Gigabit Ethernet PoE++ Switch
- Format: Wall Mountable
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Weight: 2.4
- Parts: 5 Year
- Model #: SISPM1040-582-LRT
- $888.80
- $880.49 –
- More options from $877.99 - $1,663.94
- Free Shipping

Quick View
Tripp Lite 8-Port PoE+ 30W Unmanaged Industrial GbE Switch NGI-U08C2POE8
- Switch Type: ethernet
- Parts: 3 Year
- Model #: NGIU08C2POE8
- $505.00 –
- More options from $505.00 - $616.42
- Free Shipping

Quick View
Fortinet FortiSwitch-148F-POE, Layer 2 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-148F-POE
- Part Number: FS-148F-POE
- Format: 1 RU Rack Mount
- Primary Ports: 48x GE RJ45 and 4x 10GE SFP+
- VLAN Support: Yes
- Model #: FS-148F-POE
- $1,596.99 –
- Free Shipping

Quick View
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 48 x RJ45 + 4 x SFP
- Layer: 3
- Model #: C1200-48T-4G
- $627.99 –
- More options from $627.99 - $701.81
- Free Shipping

Quick View
TRENDnet TI-WP100 Wi-Fi 5 IEEE 802.11ac Ethernet Wireless Router - TAA Compliant
- Brand: TRENDnet
- Model: TI-WP100
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.1Q IEEE 802.1X IEEE 802.11a IEEE 802.11b IEEE 802.11g IEEE 802.11n (up to 300Mbps @ 256QAM)* IEEE 802.11ac (5GHz: up to 867Mbps @ 256QAM)* IEEE 802.3af IEEE 802.3at
- Network Media: WAN Modes: NAT, Classical Routing or Bridge Mode (NAT Disabled) NAT Loopback Enable/Disable NAT Modes: NAT, PAT, One-to-One NAT VLAN tag assignment on WAN interface IPv4 WAN Modes: Dynamic IP (DHCP), Static IP, PPPoE, PPTP, L2TP Wireless WAN Mode: NAT enable/disable, Dynamic IP (DHCP), Static IP, fast roaming signal threshold/channels IPv6 WAN Modes: Static, Auto-configuration (SLAAC/DHCPv6),...
- Model #: TI-WP100

Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P4S
- $767.80
- See price in cart
- Free Shipping

Quick View
D-Link 28-Port 10-Gigabit Smart Managed PoE Switch DGS125028XMP6KV
- Switch Type: managed
- Model #: DGS125028XMP6KV
- $529.99
- $482.01 –
- Save: $47.98 (9%)
- More options from $482.01 - $558.99
- Free Shipping

Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-500T
- $117.99 –
- Free Shipping

Quick View
Planet ISW-800T IP30 Compact Size 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
- Model #: ISW-800T
- $97.99 –
- Free Shipping

Quick View
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 6-Port IEEE 802.3at / af / Ultra PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatible with 100BASE-FX SFP...
- Model #: GS-4210-16UP4C
- $853.60
- See price in cart
- Free Shipping

Quick View
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
- Brand: Cisco Systems, Inc
- Series: Business
- Part Number: CBS220-48FP-4X-NA
- Switch Type: managed
- Model #: CBS220-48FP-4X
- $1,446.13
- $1,303.99 –
- Save: $142.14 (9%)
- More options from $1,303.99 - $1,487.84
- Free Shipping

Quick View
Cisco C1300X-10NU-2X Ethernet Switch, 10-port managed Layer 3 switch | C1300X-10NU-2X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-10NU-2X
- Format: Rackmount
- Model #: C1300X-10NU-2X
- $849.99 –
- More options from $849.99 - $922.81
- Free Shipping

Quick View
Planet ISW-511T 4+1 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511T for up to 2 km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511T
- $112.99 –
- Free Shipping

Quick View
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
- Format: DIN Rail Mountable Wall Mountable
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Weight: 15.20 oz
- Parts: 5 Year
- Model #: SISTP1040-342-LRT
- $302.69 –
- More options from $302.69 - $334.17
- Free Shipping

Quick View
Extreme Networks 5320 24-port 30W PoE Switch, 8 x 1/10Gb SFP+ ports | 5320-24P-8XE
- Brand: Extreme Networks
- Series: 5320
- Standards: IEEE 802.3 Media Access Standards IEEE 802.3ab 1000BASE-T IEEE 802.3at PoE IEEE 802.3ae 10GBASE-X IEEE 802.3az Energy Efficient Ethernet
- Network Management Type: Managed
- Model #: 5320-24P-8XE
- $5,909.00
- $3,980.99 –
- Save: $1,928.01 (32%)
- Free Shipping

Quick View
Black Box Network - IC408A-R2 - 4 Port Usb 2.0 Extender Lan Or Direct Co
- Model #: IC408A-R2
- $481.00 –
- More options from $481.00 - $535.88
- Free Shipping

Quick View
Planet IGS-5225-8T2S2X Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 ~ 75 degrees C)
- Format: DIN Rail Mount
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Model #: IGS-5225-8T2S2X
- $887.80
- See price in cart
- Free Shipping

Quick View
SONICWALL 02-SSC-2466 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 530 W Power Consumption - 740 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - 1U - Rack-mountable
- Format: Desktop
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- MAC Address Table: 32K
- Model #: 02-SSC-2466
- $1,466.99 –
- Free Shipping

Quick View
Planet ISW-500T IP30 Compact Size 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
- Format: DIN Rail Mount
- Model #: ISW-500T
- $91.99 –
- More options from $81.40 - $91.99
- Free Shipping

Quick View
HPE Aruba Networking CX 6100, 48-port PoE Switch, 4 SFP+ ports 370W | JL675A#ABA
- Brand: HPE
- Series: CX 6100
- Part Number: JL675A
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: JL675A#ABA
- $3,602.99 –
- Free Shipping



