Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now
SHOP BY Primary Ports

Quick View
Planet ISW-500T IP30 Compact Size 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
- Format: DIN Rail Mount
- Model #: ISW-500T
- $87.00
- $81.40 –
- Save: $5.60 (6%)
- More options from $81.40 - $91.99
- $8.00 Shipping

Quick View
NETGEAR 24-Port Multi-Gigabit (2.5G) Ethernet Ultra60 PoE++ Smart Switch with 4 SFP+ Ports | MS324TXUP
- Parts: 5 Year
- Model #: MS324TXUP-100NAS
- $1,679.99 –
- Free Shipping

Quick View
HPE Aruba Networking CX 6100, 48-port PoE Switch, 4 SFP+ ports 370W | JL675A#ABA
- Brand: HPE
- Series: CX 6100
- Part Number: JL675A
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: JL675A#ABA
- $3,602.99 –
- Free Shipping

Quick View
Planet IGS-5225-8T2S2X Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 ~ 75 degrees C)
- Format: DIN Rail Mount
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Model #: IGS-5225-8T2S2X
- $887.80
- See price in cart
- Free Shipping

Quick View
Extreme Networks 5320 24-port 30W PoE Switch, 8 x 1/10Gb SFP+ ports | 5320-24P-8XE
- Brand: Extreme Networks
- Series: 5320
- Standards: IEEE 802.3 Media Access Standards IEEE 802.3ab 1000BASE-T IEEE 802.3at PoE IEEE 802.3ae 10GBASE-X IEEE 802.3az Energy Efficient Ethernet
- Network Management Type: Managed
- Model #: 5320-24P-8XE
- $4,030.99 –
- Free Shipping

Quick View
HPE Juniper Networking EX2300-C Switch, Compact Fanless 12-port 10/100/1000BASE-T, 2 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-C-12T
- Brand: Juniper Networks, Inc.
- Series: EX2300-C
- Part Number: EX2300-C-12T
- Format: Desktop
- Model #: EX2300-C-12T
- $1,680.00
- $894.99 –
- Save: $785.01 (46%)
- More options from $750.00 - $1,611.67
- Free Shipping

Quick View
Black Box Network - IC408A-R2 - 4 Port Usb 2.0 Extender Lan Or Direct Co
- Model #: IC408A-R2
- $481.00 –
- More options from $481.00 - $535.88
- Free Shipping

Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst C1300 Series
- Part Number: C1300-24MGP-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
- Model #: C1300-24MGP-4X
- $1,353.99 –
- More options from $1,353.99 - $1,588.43
- Free Shipping

Quick View
TRENDnet 20-Port Gigabit Web Smart Switch; 16 x Gigabit Ports; 4 x shared Gigabit Ports (RJ-45/SFP); VLAN; QoS; LACP; IPv6 Support; 40 Gbps Switching Capacity; Lifetime Protection; TEG-204WS
- Format: Rackmount
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az
- Primary Ports: 16 x Gigabit ports 4 x shared Gigabit ports (RJ-45 / SFP)
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
- Model #: TEG-204WS

Quick View
- $687.99 –
- More options from $687.99 - $772.77
- Free Shipping

Quick View
ZyXEL 24-Port Gigabit Smart Managed PoE Switch, 24 PoE+ Ports at 170W with 2 SFP Uplinks, TAA Compliant, GS1900-24HPV2
- Brand: ZyXEL
- Part Number: GS1900-24HPV2
- Switch Type: Manageable: Yes
- Format: Rack-mountable Desktop
- Model #: GS1900-24HPV2
- $275.53 –
- More options from $219.99 - $327.56
- Free Shipping

Quick View
HPE Aruba JL262A#ABA 2930F 48G PoE+ 4 SFP Switch
- Primary Ports: (48) RJ-45 autosensing 10/100/1000 ports (4) SFP
- Dimensions: 1.73" x 17.42" x 9.70"
- Weight: 9.83 lbs.
- Package Contents: (1) Aruba 2930F 48G PoE+ 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4)bumper feet, (1) cable tie
- Model #: JL262A#ABA
- $5,000.00
- $2,522.99 –
- Save: $2,477.01 (49%)
- Free Shipping

Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16FP-2G
- Format: Rack-mountable
- Model #: C1300-16FP-2G
- $1,130.99 –
- More options from $1,097.81 - $1,164.17
- Free Shipping

Quick View
HPE Aruba Networking 2930F 24G PoE+ 4SFP+ Switch | JL255A
- Brand: HPE
- Model: JL255A#ABA
- Part Number: JL255A
- Primary Ports: (24) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
- Model #: JL255A#ABA
- $1,996.00 –
- More options from $1,076.00 - $1,996.00
- Free Shipping

Quick View
D-Link 52-Port 10-Gigabit Smart Managed PoE Switch DGS125052XMP6KV
- Switch Type: managed
- Model #: DGS125052XMP6KV
- $837.22 –
- More options from $837.22 - $1,145.52
- Free Shipping

Quick View
Aruba 6100 24G Class4 PoE 4SFP+ 370W Switch - 24 Ports - Manageable - 3 Layer Supported - Modular - 370 W PoE Budget - Twisted Pair, Optical Fiber - PoE Ports - 1U High - Rack-mountable, Wall Mountabl
- Switch Type: Ethernet Switch
- Model #: JL677A#ABA
- $2,194.99 –
- More options from $1,238.21 - $2,194.99
- Free Shipping

Quick View
ZyXEL 48-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 48 PoE+ Ports at 375W with 2 SFP Uplinks, TAA Compliant, GS1920-48HPv2
- Brand: ZyXEL
- Part Number: GS1920-48HPv2
- Switch Type: Manageable
- Format: Rack-mountable
- Model #: GS1920-48HPV2
- $588.50 –
- More options from $484.99 - $825.00

Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P2S2X
- $979.80
- See price in cart
- Free Shipping

Quick View
Adder - CATX-USB - Computer Access Module RJ45 Socket - USB & VGA
- Model #: CATX-USB
- $115.20
- See price in cart
- Free Shipping

Quick View
ZyXEL 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 60W, GS1915-8EP
- Brand: ZyXEL
- Part Number: GS1915-8EP
- Switch Type: Manageable: Yes
- Format: Wall Mountable
- Model #: GS19158EP
- $170.88 –
- More options from $129.99 - $250.00
- Free Shipping

Quick View
Panasonic Toughmate G2 Enhanced Rotating Hand Strap ING2ERHSTP
- Model #: ING2ERHSTP
- $75.69 –
- More options from $75.69 - $83.38
- Free Shipping

Quick View
TRENDnet 8-Port Hardened Industrial Gigabit DIN-Rail Switch, TI-G80, 16 Gbps Switching Capacity, IP30 Rated, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
- Format: Includes DIN-rail and wall mounts Wall Mountable
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x
- Primary Ports: 8 x Gigabit ports
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
- Model #: TI-G80
- $121.91 –
- More options from $114.99 - $184.99
- Free Shipping

Quick View
D-Link DGS-1024C 24-Port 10/100/1000 Mbps Gigabit Unmanaged Desktop Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: DGS-1024C
- $89.00 –
- More options from $89.00 - $118.11
- Free Shipping

Quick View
Cisco Catalyst 1300-12XS Managed Switch, 10 Port 10G SFP+, 2x10GE SFP+ Combo, Limited Lifetime Protection (C1300-12XS)
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-12XS
- Switch Type: Manageable
- Model #: C1300-12XS
- $1,529.99 –
- More options from $1,529.99 - $1,676.71
- Free Shipping

Quick View
Vertiv Avocent ACS8048DAC-400 ACS8000 Serial Console - 48 port Console Server | Dual AC
- Type: Consumer Electronics
- Model #: ACS8048DAC-400
- $6,176.00
- See price in cart
- More options from $5,612.10 - $7,050.00
- Free Shipping

Quick View
Gigabit PoE+ Media Converter, 10/100/1000BASE-T to SFP
- Model #: LGC5210A
- $468.99 –
- Free Shipping

Quick View
EnGenius Fit 410W PoE+ 24 Port Gigabit Switch EWS7928FP-FIT
- Model #: EWS7928FPFIT
- $349.99 –
- More options from $349.99 - $405.59
- Free Shipping

Quick View
Black Box KV62-CBL 2-Port 4K60 DisplayPort Cable KVM Switch
- Model #: KV62-CBL
- $160.99 –
- Free Shipping

Quick View
TRENDnet Hardened Industrial SFP to Gigabit UPoE Media Converter, IP30 Rated Housing, Includes DIN-rail & Wall Mounts, Operating Temp. -40 to 75 °C (-40 to 167 °F), TI-UF11SFP
- Format: DIN Rail Mount
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3bt draft
- Primary Ports: 1 x Gigabit UPoE port 1 x 100/1000Mbps SFP slot
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
- Model #: TI-UF11SFP (V1.0R)
- $116.46 –
- More options from $101.30 - $123.85

Quick View
HPE Aruba 2930F 8G PoE+ 2SFP+ Switch JL258A#ABA
- Weight: 10.85
- Parts: Lifetime
- Model #: JL258A#ABA
- $1,805.99 –
- Free Shipping

Quick View
TRANSITION NETWORKS SISPM1040-362-LRT MNGDHRDNDPOE+SW 4X10/100/1000
- Switch Type: Others
- Weight: 2.1
- Parts: 5 Year
- Model #: SISPM1040-362-LRT
- $920.95
- See price in cart
- More options from $749.99 - $1,355.99
- Free Shipping

Quick View
SMART MGD POE+ SWITCH 24PORT
- Switch Type: managed
- Model #: SM24TAT2SA-NA
- $626.55 –
- More options from $617.99 - $858.60
- Free Shipping

Quick View
Tripp Lite 5-Port Lite Managed 10/100/1000 Mbps PoE+ Gigabit Ethernet Switch
- Model #: NGIS05C2POE4
- $454.30 –
- More options from $429.99 - $598.22
- Free Shipping

Quick View
TP-Link 16 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1016)
- Format: Rackmount
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1016




