Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now
SHOP BY Primary Ports

Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst C1300 Series
- Part Number: C1300-24MGP-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
- Model #: C1300-24MGP-4X
- $1,353.99 –
- More options from $1,353.99 - $1,588.43
- Free Shipping

Quick View
TelDaykemei 8+2 Ports 2.5G Ethernet Network Switch 2500BASE-TX Switch with 2*10G SFP Port for IP Camera/CCTV Security
- Switch Type: 10000 Mbps
- Format: Stackable
- Uplink Interface: SFP
- Uplink Speed: SFP+
- Model #: 10-port 2.5G+10G switch 8+2
- $56.50 –
- More options from $56.50
- Free Shipping

Quick View
Extreme Networks 5320 24-Port Ethernet Switch, 8 x 1/10Gb SFP+ ports | 5320-24T-8XE
- Switch Type: Ethernet Switch
- PoE: All 5320 models support 30W PoE that conforms with IEEE 802.3at. This enables the 5320 to address the needs of powered edge devices, while eliminating the need for additional electrical cabling and circuits. In addition, 5320 PoE models support perpetual and fast PoE for even more efficient and reliable powered edge device operation.
- Stackable: Yes
- Model #: 532024T8XE
- $3,270.99
- $2,841.99 –
- Save: $429.00 (13%)
- Free Shipping

Quick View
Black Box LIG1014A 14-Port Industrial Gigabit Ethe Rnet Switch Managed Extreme Temp.
- Model #: LIG1014A
- $717.99 –
- Free Shipping

Quick View
- $4,495.00
- $2,893.99 –
- Save: $1,601.01 (35%)
- More options from $2,893.99 - $4,000.92
- Free Shipping

Quick View
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48T-4X
- Format: Rack-mountable
- Model #: C1300-48T-4X
- $1,318.99
- $1,306.99 –
- More options from $1,306.99 - $1,495.35
- Free Shipping

Quick View
TRENDnet 16-Port Hardened Industrial Unmanaged Gigabit 10/100/1000Mbps DIN-Rail Switch w/ 16 Gigabit PoE+ Ports, Lifetime Protection, TI-PG160
- Features: • 16 x Gigabit PoE+ ports • 240W PoE power budget • 32Gbps switching capacity • Power supply sold separately (models: TI-S24052, TI-S24048, TI-S48048) • Hardened IP30 rated metal switch • Includes DIN-rail and wall mounts • Operating temperature range of -40° – 75° C (-40° – 167° F) • Dual redundant power inputs with overload current
- Weight: 2.3100
- Model #: TIPG160

Quick View
- $687.99 –
- More options from $687.99 - $772.77
- Free Shipping

Quick View
TP-Link 5 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1005D)
- Switch Type: Network Switch
- Format: Desktop
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
- Primary Ports: 5 x RJ45
- Model #: TL-SG1005D
- $18.80 –
- More options from $12.99 - $59.76
- Free Shipping

Quick View
ZyXEL 24-Port Gigabit Smart Managed PoE Switch, 24 PoE+ Ports at 170W with 2 SFP Uplinks, TAA Compliant, GS1900-24HPV2
- Brand: ZyXEL
- Part Number: GS1900-24HPV2
- Switch Type: Manageable: Yes
- Format: Rack-mountable Desktop
- Model #: GS1900-24HPV2
- $275.53 –
- More options from $219.99 - $327.56
- Free Shipping

Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16FP-2G
- Format: Rack-mountable
- Model #: C1300-16FP-2G
- $1,130.99 –
- More options from $1,097.81 - $1,164.17
- Free Shipping

Quick View
D-Link 52-Port 10-Gigabit Smart Managed PoE Switch DGS125052XMP6KV
- Switch Type: managed
- Model #: DGS125052XMP6KV
- $837.22 –
- More options from $837.22 - $1,145.52
- Free Shipping

Quick View
Aruba 6100 24G Class4 PoE 4SFP+ 370W Switch - 24 Ports - Manageable - 3 Layer Supported - Modular - 370 W PoE Budget - Twisted Pair, Optical Fiber - PoE Ports - 1U High - Rack-mountable, Wall Mountabl
- Switch Type: Ethernet Switch
- Model #: JL677A#ABA
- $2,194.99 –
- More options from $1,238.21 - $2,194.99
- Free Shipping

Quick View
ZyXEL 48-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 48 PoE+ Ports at 375W with 2 SFP Uplinks, TAA Compliant, GS1920-48HPv2
- Brand: ZyXEL
- Part Number: GS1920-48HPv2
- Switch Type: Manageable
- Format: Rack-mountable
- Model #: GS1920-48HPV2
- $588.50 –
- More options from $484.99 - $825.00

Quick View
Tripp Lite series 8-Port Managed Gigabit Ethernet Switch - Layer 2, 1 Gbps, 2x GbE SFP Ports - 1U Rack/Desktop - 8 Ports - Manageable - Gigabit Ethernet - NGS8C2-1
- Brand: Tripp Lite
- Part Number: NGS8C2-1
- Model #: NGS8C2-1
- $219.00
- $144.99 –
- Save: $74.01 (33%)
- More options from $144.99 - $158.71
- Free Shipping

Quick View
Cisco C1300X-24T-4X Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 3 Layer Supported - 32.10 W Power Consumption - Twisted Pair, Optical Fiber
- Brand: CISCO
- Series: C1300X Series
- Part Number: C1300X-24T-4X
- Format: Rackmount
- Model #: C1300X-24T-4X
- $1,060.52
- $864.99 –
- Save: $195.53 (18%)
- More options from $864.99 - $979.68
- Free Shipping

Quick View
EnGenius EWS7952P-FIT 48-Port Managed Ethernet Switch EWS7952PFIT
- Model #: EWS7952PFIT
- $589.00
- $529.18 –
- Save: $59.82 (10%)
- More options from $529.18 - $571.71
- Free Shipping

Quick View
ZyXEL 24-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 12 PoE+ Ports at 130W, GS1915-24EP
- Brand: ZyXEL
- Part Number: GS1915-24EP
- Switch Type: Manageable: Yes
- Format: Wall Mountable Rack-mountable
- Model #: GS191524EP
- $253.53 –
- More options from $199.99 - $305.10
- Free Shipping

Quick View
Adder - CATX-USB - Computer Access Module RJ45 Socket - USB & VGA
- Model #: CATX-USB
- $115.20
- See price in cart
- Free Shipping

Quick View
Netgear AV Line M4350-8X8F 8-Port Manageable 10 Gigabit Ethernet Switch, XSM4316-100NES
- Brand: NETGEAR
- Part Number: XSM4316100NES
- Network Management Type: Managed
- Primary Ports: 8 x RJ45 + 8 x SFP+
- Model #: XSM4316-100NES
- $2,199.99 –
- Free Shipping

Quick View
ZyXEL 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 60W, GS1915-8EP
- Brand: ZyXEL
- Part Number: GS1915-8EP
- Switch Type: Manageable: Yes
- Format: Wall Mountable
- Model #: GS19158EP
- $170.88 –
- More options from $129.99 - $250.00
- Free Shipping

Quick View
Black Box Industrial Gigabit Ethernet Managed L2+ Switch - Extreme Temperature (8) RJ-45
- Switch Type: Others
- Weight: 1.75
- Model #: LIG1080A
- $431.99 –
- More options from $431.99 - $565.99
- Free Shipping

Quick View
Panasonic Toughmate G2 Enhanced Rotating Hand Strap ING2ERHSTP
- Model #: ING2ERHSTP
- $75.69 –
- More options from $75.69 - $83.38
- Free Shipping

Quick View
Tripp Lite series NGI-S04C2P4-4 Ethernet Switch - 4 Ports - Manageable - Gigabit Ethernet, Fast Ethernet, Ethernet - 1000Base-T, 1000Base-SX/LX, 10Base-T, 100Base-TX, 100Base-FX - 2 Layer Supported
- Brand: Tripp Lite
- Part Number: NGI-S04C2P4-4
- Switch Type: Lite Managed
- Network Management Type: Lite Managed
- Model #: NGI-S04C2P4-4
- $381.48 –
- More options from $381.48 - $421.99
- Free Shipping

Quick View
EnGenius 90W 802.3af/at/bt 2.5GbE Ethernet Over Power Adapter EPA5090HBT
- Model #: EPA5090HBT
- $85.99 –
- More options from $85.99 - $137.00
- Free Shipping

Quick View
Tripp Lite series NGI-U08C2P8-4 Ethernet Switch - 8 Ports - Gigabit Ethernet, Fast Ethernet, Ethernet - 1000Base-T, 1000Base-SX/LX, 10Base-T, 100Base-TX, 100Base-FX - 2 Layer Supported - NGI-U08C2P8-4
- Brand: Tripp Lite
- Part Number: NGI-U08C2P8-4
- Switch Type: Unmanaged
- Network Management Type: Unmanaged
- Model #: NGI-U08C2P8-4
- $465.68 –
- More options from $465.68 - $515.99
- Free Shipping

Quick View
D-Link DGS-1024C 24-Port 10/100/1000 Mbps Gigabit Unmanaged Desktop Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: DGS-1024C
- $89.00 –
- More options from $89.00 - $118.11
- Free Shipping

Quick View
Tripp Lite series NGI-S08C2P8-4 Ethernet Switch - 8 Ports - Manageable - Gigabit Ethernet, Fast Ethernet, Ethernet - 1000Base-T, 1000Base-SX/LX, 10Base-T, 100Base-TX, 100Base-FX - NGI-S08C2P8-4
- Brand: Tripp Lite
- Part Number: NGI-S08C2P8-4
- Switch Type: Lite Managed
- Network Management Type: Lite Managed
- Model #: NGI-S08C2P8-4
- $521.81 –
- More options from $521.81 - $900.00
- Free Shipping

Quick View
Vertiv Avocent ACS8048DAC-400 ACS8000 Serial Console - 48 port Console Server | Dual AC
- Type: Consumer Electronics
- Model #: ACS8048DAC-400
- $6,176.00
- See price in cart
- More options from $5,612.10 - $7,050.00
- Free Shipping

Quick View
Gigabit PoE+ Media Converter, 10/100/1000BASE-T to SFP
- Model #: LGC5210A
- $468.99 –
- Free Shipping

Quick View
- $29.84 –
- More options from $29.84 - $38.36
- Free Shipping

Quick View
Cisco Business CBS110-24T Unmanaged Switch | 24 Port GE | 2x1G SFP Shared | Limited Lifetime Protection (CBS110-24T-NA)
- Part Number: CBS110-24T
- Format: Desktop Wall Mountable Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
- Model #: CBS11024TNA
- $238.00
- $188.99 –
- Save: $49.01 (20%)
- More options from $188.99 - $205.81
- $3.99 Shipping

Quick View
HPE CX 6200 Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported - Modular - 4 SFP Slots - 59 W Power Consumption - S0M81A#ABA
- Brand: HPE
- Part Number: S0M81A#ABA
- Standards: Gigabit Ethernet
- Uplink Ports: 4
- Model #: S0M81A#ABA
- $3,648.65 –
- More options from $1,036.91 - $4,747.00
- Free Shipping

Quick View
Tripp Lite 4K HDMI Audio De-Embedder/Extractor with TOSLINK P130000AUDIO2
- Model #: P130000AUDIO2





