Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
Sold by
VLAN Support
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
Quick View
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
  • Brand: CISCO
  • Series: Catalyst
  • Part Number: C1300-8P-E-2G
  • Format: Rack-mountable
  • Model #: C1300-8P-E-2G
  • $543.71
  •  
  • $459.99 –
  • Save: 15%
  • Free Shipping
Cisco Catalyst C1200-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 2 Layer Supported
Quick View
Cisco Catalyst C1200-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 2 Layer Supported
  • Part Number: C1200-8FP-2G
  • Standards: Layer Supported: 2 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 1000Base-X 10/100/ 1000Base-T
  • Uplink Ports: Total Number of Network Ports: 10 Uplink Port: Yes Modular: Yes Network (RJ-45): Yes Port/Expansion Slot Details: 8 x Gigabit Ethernet Network Port 2 x Gigabit Ethernet Combo
  • Model #: C1200-8FP-2G
  •  
  • $337.99 –
  • Free Shipping
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
Quick View
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Layer: 3
  • Model #: C1200-48T-4G
  •  
  • $627.99 –
  • Free Shipping
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
Quick View
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Layer: 2
  • Model #: CBS220-8T-E-2G
  •  
  • $142.99 –
  • Free Shipping
Cisco Catalyst C1200-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst C1200-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1200-16P-2G
  • Format: Manageable
  • Model #: C1200-16P-2G
  •  
  • $589.99 –
  • Free Shipping
Cisco Catalyst C1200-24P-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst C1200-24P-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
  • Part Number: C1200-24P-4G
  • Switch Type: Manageable
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Model #: C1200-24P-4G
  • $847.92
  •  
  • $647.99 –
  • Save: 23%
  • Free Shipping
Cisco Catalyst C1200-8T-E-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst C1200-8T-E-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
  • Part Number: C1200-8T-E-2G
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 1000Base-X 10/100/ 1000Base-T
  • Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
  • Model #: C1200-8T-E-2G
  •  
  • $254.99 –
  • Free Shipping
Cisco Catalyst C1300-8T-E-2G Ethernet Switch 10 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported - 2 SFP Slots - 10.65 W Power Consumption
Quick View
  •  
  • $384.99 –
  • Free Shipping
Cisco Catalyst 1300 C1300-8MGP-2X Layer 3 Switch, 8 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 2.5GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-8MGP-2X Layer 3 Switch, 8 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 2.5GBase-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1300-8MGP-2X
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 2.5 Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 2.5GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-8MGP-2X
  •  
  • $729.99 –
  • Free Shipping
Cisco Catalyst 1200-48P-4G Smart Switch, 48 Port GE, PoE, 4x1GE SFP, Limited Lifetime Protection (C1200-48P-4G)
Quick View
Cisco Catalyst 1200-48P-4G Smart Switch, 48 Port GE, PoE, 4x1GE SFP, Limited Lifetime Protection (C1200-48P-4G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • PoE: Yes
  • Model #: C1200-48P-4G
  •  
  • $1,038.99 –
  • Free Shipping
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
Quick View
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
  • Brand: Cisco Systems, Inc
  • Series: Business
  • Part Number: CBS220-48FP-4X-NA
  • Switch Type: managed
  • Model #: CBS220-48FP-4X
  • $1,446.13
  •  
  • $1,309.99 –
  • Save: 9%
  • Free Shipping
Cisco Catalyst C1200-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1200-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Part Number: C1200-24FP-4G
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.11ac IEEE 802.1x IEEE 802.3az IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3ad IEEE 802.1Q IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Model #: C1200-24FP-4G
  •  
  • $832.99 –
  • Free Shipping
Cisco Catalyst C1200-24P-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1200-24P-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1200-24P-4X
  • Switch Type: Manageable
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Model #: C1200-24P-4X
  •  
  • $577.81 –
  • $22.95 Shipping
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst C1300 Series
  • Part Number: C1300-24MGP-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
  • Model #: C1300-24MGP-4X
  •  
  • $1,340.99 –
  • Free Shipping
Cisco C9350-24T Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - Twisted Pair
Quick View
in 30 days
Cisco C9350-24T Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - Twisted Pair
  • Brand: Cisco
  • Series: Catalyst 9350
  • Part Number: C9350-24T
  • Switch Type: Managed
  • Model #: C9350-24T
  • $7,735.99
  •  
  • $4,744.99 –
  • Save: 38%
  • Free Shipping
Cisco Catalyst C1200-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1200-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1200-48P-4X
  • Switch Type: Manageable
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Model #: C1200-48P-4X
  • $1,028.60
  •  
  • $994.13 –
Cisco Catalyst 9200L48-port Partial PoE+ 4x1G Uplink Switch, Network Essentials - 48 Ports - Manageable - 3 Layer Supported - 4 SFP Slots - 600 W Power Cons - 370 W PoE Budget - C9200L-48PL-4G-E
Quick View
  •  
  • $7,260.42 –
  • Free Shipping
Cisco Catalyst C1300-48T-4G Ethernet Switch, 54 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48T-4G Ethernet Switch, 54 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48T-4G
  • Format: Rack-mountable
  • Model #: C1300-48T-4G
  •  
  • $959.99 –
  • Free Shipping
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-16FP-2G
  • Format: Rack-mountable
  • Model #: C1300-16FP-2G
  •  
  • $1,029.99 –
  • Free Shipping
Cisco Catalyst C1300-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1300-48P-4X
  • Format: Rackmount
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 10GBase-X
  • Model #: C1300-48P-4X
  • $2,043.92
  •  
  • $1,782.99 –
  • Save: 12%
  • Free Shipping
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
Quick View
in 30 days
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48P-4G
  • Format: Rackmount
  • Model #: C1300-48P-4G
  • $2,136.51
  •  
  • $1,549.99 –
  • Save: 27%
  • Free Shipping
Cisco Business CBS220-16T-2G Ethernet Switch, 16 Ports - Manageable - 2 Layer Supported
Quick View
Cisco Business CBS220-16T-2G Ethernet Switch, 16 Ports - Manageable - 2 Layer Supported
  • Part Number: CBS220-16T-2G-NA
  • Format: Rack-mountable
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 1000Base-T 1000Base-X
  • Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Number of SFP Slots: 2
  • Model #: CBS22016T2GNA
  •  
  • $241.99 –
  • $5.99 Shipping
Cisco Catalyst C1300-16XTS Layer 3 Switch, 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16XTS Layer 3 Switch, 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1300-16XTS
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1x IEEE 802.3af IEEE 802.3at IEEE 802.1ab IEEE 802.3az
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-16XTS
  •  
  • $2,522.99 –
  • Free Shipping
Cisco Catalyst C1300-48FP-4G Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48FP-4G Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48FP-4G
  • Format: Rackmount
  • Model #: C1300-48FP-4G
  •  
  • $2,069.99 –
  • Free Shipping
Cisco Catalyst C1300-48MGP-4X, 48-port Layer 3 Managed Switch | C1300-48MGP-4X
Quick View
Cisco Catalyst C1300-48MGP-4X, 48-port Layer 3 Managed Switch | C1300-48MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst 1300 Series
  • Part Number: C1300-48MGP-4X
  • Format: Rackmount
  • Model #: C1300-48MGP-4X
  •  
  • $2,408.99 –
  • Free Shipping
Cisco Catalyst C1300-48FP-4X Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - Layer 3 Supported
Quick View
Cisco Catalyst C1300-48FP-4X Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - Layer 3 Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: 1300-48FP-4X
  • Format: Rack-mountable
  • Model #: C1300-48FP-4X
  •  
  • $2,132.99 –
  • Free Shipping
Cisco Catalyst 9300 48-port 1G copper with fixed 4x10G/1G SFP+ uplinks, PoE+, Network Essentials | C9300L-48P-4X-E
Quick View
Cisco Catalyst 9300 48-port 1G copper with fixed 4x10G/1G SFP+ uplinks, PoE+, Network Essentials | C9300L-48P-4X-E
  • Brand: CISCO
  • Series: 9300
  • Part Number: C9300L-48P-4X-E
  • Format: Rackmount
  • Model #: C9300L-48P-4X-E
  •  
  • $8,108.92 –
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
Quick View
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
  • Brand: CISCO
  • Switch Type: ethernet
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP+
  • Model #: CBS220-24T-4X
  •  
  • $606.28 –
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48T-4X
  • Format: Rack-mountable
  • Model #: C1300-48T-4X
  •  
  • $1,496.19 –
Cisco Catalyst C9300-48UXM-E Ethernet Switch
Quick View
Cisco Catalyst C9300-48UXM-E Ethernet Switch
  • Format: Rack-mountable
  • Primary Port Speed: 10/100/1000Base-T
  • Weight: 17.03 lb
  • Model #: C9300-48UXM-E
  •  
  • $13,774.18 –
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24P-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RFC 951,...
  • Model #: C1300X-24P-4X
  •  
  • $1,624.25 –
Cisco Catalyst 9200L 48-port Data 4x1G uplink Switch, Network Essentials | C9200L-48T-4G-E
Quick View
Cisco Catalyst 9200L 48-port Data 4x1G uplink Switch, Network Essentials | C9200L-48T-4G-E
  • Brand: CISCO
  • Series: 9200
  • Part Number: C9200L-48T-4G
  • Format: Rackmount
  • Model #: C9200L-48T-4G-E
  •  
  • $2,184.82 –
  • $30.87 Shipping
Cisco Catalyst C1300-24FP-4X Ethernet Switch, 24 Ports, Manageable, 10 Gigabit Ethernet, 10/100/1000Base-T, 10GBase-X, 3 Layer Supported, 370 W PoE Budget
Quick View
Cisco Catalyst C1300-24FP-4X Ethernet Switch, 24 Ports, Manageable, 10 Gigabit Ethernet, 10/100/1000Base-T, 10GBase-X, 3 Layer Supported, 370 W PoE Budget
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C130024FP4X
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Model #: C1300-24FP-4X
  •  
  • $1,601.38 –
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
Quick View
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24NGU-4X
  • Format: Rackmount
  • Model #: C1300X-24NGU-4X
  •  
  • $1,688.76 –