Skip to main content
  • Shop All PLANET Products At Newegg

All Products
Sort By
235 Items
View
  1. 378 / 4
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
  • Return Policy: View Return Policy
$402.60
Free Shipping
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature
  • MAC Address Table: 8K entries, automatic source address learning and ageing
  • Buffer Memory: 4Mbits
  • QoS: Traffic classification based, Strict priority and WRR 8-Level priority for switching - Port Number - 802.1p priority - 802.1Q VLAN tag - DSCP/TOS field in IP Packet
  • Model #: IGS-10020HPT
  • Return Policy: View Return Policy
$596.00
$8.00 Shipping
Planet POE-171 Single-Port 10/100/1000 Mbps Ultra PoE Injector (60 Watts)
Planet POE-171 Single-Port 10/100/1000 Mbps Ultra PoE Injector (60 Watts)
  • Type: PoE Injector
  • Color: Black
  • Specifications: Interface: Input Port 1 x RJ-45 STP Data In Output Port 1 x RJ-45 STP PoE (Data + Power) Out DC socket 56V DC Input LED Indicator: System: Power x 1 (Green) PoE Port: PoE in Use x 1 (Green) Network Cable: Ultra PoE (60W): 10/100/1000Base-T: 4-Pair UTP Cat. 5e, 6 up to 100m (328 ft.) 802.3af/at PoE(15W / 30W): 10/100/1000Base-T: 2-Pair UTP Cat. 3, 5, 5e, 6 up to 100m (328 ft.) Data Rate: 10/100/1000 Mbps Unit Input Voltage: DC 56V Power Requirements: External AC-to-DC adapter 100-240V AC, 50/60 Hz, 1.5A Power Consumption: 65 watts max. PoE Standard: IEEE 802.3at High Power over Ethernet End-span / Mid-span PSE Power Output: DC 56V / 60-watt PoE via 4-pairs DC 56V / 30-watt PoE via 2-pairs PoE Power Supply Type: End-Span + Mid-Span Power Pin Assignment: Pair 1: 1/2 (-), 3/6 (+) Pair 2: 4/5 (+), ...
  • Model #: POE-171
  • Item #: 9SIA8WVKCX0842
  • Return Policy: View Return Policy
$69.99
$9.00 Shipping
PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
  • Device Type: Converter
  • Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
  • Wavelength: 1310nm
  • Ports: 1 x 10/100/1000Base-T port 1 x 1000Base-SX/LX port
  • Model #: GT-802S
  • Return Policy: View Return Policy
$85.99
Free Shipping
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
  • Return Policy: View Return Policy
$399.00
Free Shipping
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
PLANET IGS-4215-8P2T2S 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 10/100/1000T 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: IGS-4215-8P2T2S
  • Return Policy: View Return Policy
$651.20
$8.00 Shipping
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
PLANET GS-4210-16P2S 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
  • Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
  • MAC Address...
  • Model #: GS-4210-16P2S
  • Return Policy: View Return Policy
$325.00
$14.00 Shipping
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-804HPT
  • Return Policy: View Return Policy
$259.60
Free Shipping
PLANET XT-705A 10G/5G/2.5G/1G/100M Copper to 10GBASE-X SFP+ Media Converter
Planet IGS-12040MT Industrial 8-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
Planet IGS-12040MT Industrial 8-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
  • Format: DIN Rail Mount
  • Uplink Ports: 4
  • Primary Port Speed: 10/100/1000Mbps
  • VLAN Support: Yes
  • Model #: IGS-12040MT
  • Return Policy: View Return Policy
$519.00
$520.00
$8.00 Shipping
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
  • Format: DIN Rail Mount
  • VLAN Support: Yes
  • Jumbo Frames: 9000 bytes
  • SNMP: Yes
  • Model #: IGS-5225-4T2S
  • Return Policy: View Return Policy
$343.20
$352.00
Free Shipping
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
PLANET IVC-234GT Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet ITU-T G.993.1 VDSL ITU-T G.997.1 ITU-T G.993.2 VDSL2 (Profile 17a/30a Support) ITU-T G.993.5 G.Vectoring and G.INP ITU-T G.998
  • Primary Ports: 4 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IVC-234GT
  • Return Policy: View Return Policy
$252.00
Free Shipping
PLANET GT-805A 10/100/1000Base-T to 1000FX (SFP) Media Converter
PLANET GT-805A 10/100/1000Base-T to 1000FX (SFP) Media Converter
  • Device Type: Converter
  • Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
  • Ports: 1 x 10/100/1000Base-T port 1 x 1000Base-SX/LX port
  • LEDs: PWR TP LINK / ACT, 1000 Fiber LINK / ACT
  • Model #: GT-805A
  • Return Policy: View Return Policy
$69.00
Free Shipping
Planet ISW-500T IP30 Compact Size 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
Planet ISW-500T IP30 Compact Size 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
Save 6%
$81.40
$87.00
$8.00 Shipping
Planet IGS-20040MT L2+ Industrial 16-Port 10/100/1000T + 4 100/1000X SFP Managed Switch (-40 ~ 75 degrees C)
Planet IGS-20040MT L2+ Industrial 16-Port 10/100/1000T + 4 100/1000X SFP Managed Switch (-40 ~ 75 degrees C)
  • Format: DIN Rail Mount
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100Mbps + 1000Mbps
  • VLAN Support: Yes
  • Model #: IGS-20040MT
  • Return Policy: View Return Policy
Save 30%
$712.00
$1,026.00
Free Shipping
Planet GS-4210-16T2S 16-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces
Planet GS-4210-16T2S 16-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces
  • Format: Rackmount
  • Primary Port Speed: 10/100/1000Mbps
  • VLAN Support: Yes
  • Jumbo Frames: 9000 bytes
  • Model #: GS-4210-16T2S
  • Return Policy: View Return Policy
$164.00
Free Shipping
Planet POE-173 60-Watt Ultra Power Over Ethernet Injector
Planet POE-173 60-Watt Ultra Power Over Ethernet Injector
  • Type: PoE Injector
  • Color: Black
  • Specifications: Interface: LAN: 1 x RJ-45 STP, "Data" Input Port POE: 1 x RJ-45 STP, "Data + Power" Output Port AC Connector: 1 x AC Input power socket, IEC-320 C6 Network Cable: Ultra PoE (60W): 4-pair UTP Cat. 5, 5e, 6 up to 100m (328 ft.) 802.3af / at PoE(15W / 30W): 2-pair UTP Cat. 3, 4, 5, up to 100m (328 ft.) LED Indicator: System: Power x 1 (Green) PoE Port: Active, PoE ready / In Use x 1 (Green) Data Rate: 10/100/1000 Mbps Unit Output Voltage: DC 50-57V, 1.2A Power Requirements: 100-240V AC @ 50/60 Hz, 1.5A max. Power Consumption: 60 watts max. PoE Standard: Ultra PoE over 4-pairs UTP, High Power over Ethernet End-Span / Mid-Span PSE PoE Power Supply Type: End-Span + Mid-Span Power Pin Assignment: Pair 1 End-Span: 1/2 (+), 3/6 (-) Pair 2 Mid-Span: 4/5 (+), 7/8 (-) PoE Power Output: DC 50-57V/60-w...
  • Model #: POE-173
  • Return Policy: View Return Policy
$64.00
$8.00 Shipping
Planet MGB-SX SFP-Port 1000BASE-SX mini-GBIC module - 550m
Planet MGB-SX SFP-Port 1000BASE-SX mini-GBIC module - 550m
  • Device Type: Transceiver
  • Ports: 1000Base-SX
  • Transfer Rate: 1 Gbps
  • Model #: MGB-SX
  • Return Policy: View Return Policy
$27.60
$28.99
$8.00 Shipping
Planet POE-151 IEEE 802.3af Power Over Ethernet Injector (Mid-Span)
Planet POE-151 IEEE 802.3af Power Over Ethernet Injector (Mid-Span)
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3af Power over Ethernet
  • Ports: 2 x RJ-45 (1 for data + DC out, 1 for Data in)
  • LEDs: 1 x power, 1 x POE ready / in-use
  • Cabling: TIA/EIA-568, Category 5/5e cable
  • Model #: POE-151
  • Item #: 9SIA513KPB8985
  • Return Policy: View Return Policy
$29.99
Free Shipping
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
  • Format: DIN Rail Mount
  • MAC Address Table: 8K MAC address table with auto learning function
  • Jumbo Frames: 9000 bytes
  • Buffer Memory: 1MB
  • Model #: WGS-804HP
  • Return Policy: View Return Policy
$172.00
Free Shipping
PLANET HPOE-460 4-Port IEEE 802.3at High Power Over Ethernet Injector Hub
PLANET HPOE-460 4-Port IEEE 802.3at High Power Over Ethernet Injector Hub
  • Type: PoE Injector
  • Color: Black
  • Specifications: Hardware Version: 2 Interface: "Data" Input Ports: 4 x RJ-45 "Data+Power" Output Ports: 4 x RJ-45 Data Rate: 10/100/1000 Mbps LED: System: Power x 1 (Green) Per PoE Port: PoE ready / in-use x 4 (Green) Network Cable: 10Base-T: 4-Pair UTP Cat. 5 up to 100m (328 ft.) 100Base-TX: 4-Pair UTP Cat. 5 up to 100m (328 ft.) 1000Base-T: 4-Pair UTP Cat. 5e, 6, up to 100m (328 ft.) EIA/TIA- 568 100-ohm STP (100m, 328 ft.) Power Requirements: DC 52V~56V PoE Power Supply Type: Mid-Span PoE Power Output: Per Port DC 52V 30.8 watts / 15.4 watts Power Pin Assignment: 4/5(+), 7/8(-) PoE Power Budget: 120 watts Number of 802.3af PD Class 0, 1, 2, 3 can be powered: 4 Number of 802.3at PD Class 1, 2, 3 can be powered: 4 Number of 802.3at PD Class 0, 4 can be powered: 4 Standards Compliance: IEEE 802.3 10Bas...
  • Model #: HPOE-460
  • Return Policy: View Return Policy
Save 6%
$112.00
$120.00
$8.00 Shipping
PLANET FT-905A 10/100Base-TX to 100Base-FX Web Smart Media Converter (SFP)
PLANET FT-905A 10/100Base-TX to 100Base-FX Web Smart Media Converter (SFP)
  • Device Type: Converter
  • Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX, 100Base-FX IEEE 802.3x, Flow Control IEEE 802.1p, Class of Service
  • Ports: 1 x 10/100Base-TX RJ-45 port Auto-negotiation, Auto-MDI/MDI-x
  • LEDs: PWR TP LINK / ACT, TP FDX, TP SPEED Fiber LINK / ACT, Fiber FDX
  • Model #: FT-905A
  • Item #: 9SIA29J8HC5164
  • Return Policy: View Return Policy
$56.00
$8.00 Shipping
Planet POE-172S Single Port 10/100/1000Mbps 95W Ultra PoE Splitter (12V/19V/24V)
Planet POE-172S Single Port 10/100/1000Mbps 95W Ultra PoE Splitter (12V/19V/24V)
$80.00
Free Shipping
Planet WGS-818HP Industrial 8-Port 10/100/1000T Wall-mounted Gigabit PoE+ Switch
Planet WGS-818HP Industrial 8-Port 10/100/1000T Wall-mounted Gigabit PoE+ Switch
  • Switch Type: managed
  • Model #: PLA-WGS-818HP
  • Item #: 9SIA29JG342648
  • Return Policy: View Return Policy
$236.00
Free Shipping
Planet SGS-6340-24T4S Layer 3 24-Port 10/100/1000T + 4-Port 1000X SFP Stackable Managed Switch
Planet SGS-6340-24T4S Layer 3 24-Port 10/100/1000T + 4-Port 1000X SFP Stackable Managed Switch
  • Format: Rackmount
  • Primary Ports: 24 10/100/1000BASE-T RJ45 auto-MDI/MDI-X ports
  • Primary Port Speed: 4 1000BASE-X SFP interfaces
  • MAC Address Table: 16K MAC address table with auto learning function
  • Model #: SGS-6340-24T4S
  • Item #: 9SIA29J3V31565
  • Return Policy: View Return Policy
$299.00
Free Shipping
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
  • Format: Rail-mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-duplex flow control
  • Primary Ports: 8x 10/100/1000Base-T Ports
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: IGS-801T
  • Item #: 9SIA29J0SZ9062
  • Return Policy: View Return Policy
$164.00
Free Shipping
PLANET IPOE-162 Industrial IEEE 802.3at Gigabit High Power over Ethernet Injector (Mid-Span)
PLANET IPOE-162 Industrial IEEE 802.3at Gigabit High Power over Ethernet Injector (Mid-Span)
$104.00
Free Shipping
PLANET POE-164 IEEE 802.3at High Power Over Ethernet Injector (10/100 Mbps, Mid-span, 30 Watts)
PLANET POE-164 IEEE 802.3at High Power Over Ethernet Injector (10/100 Mbps, Mid-span, 30 Watts)
  • Type: PoE Injector
  • Color: Black
  • Specifications: Interface: "Data" Input Port: 1 x RJ45 STP "PoE (Data + Power) Output Port: 1 x RJ45 STP AC Input Power Socket: 1 LED Indicator: System: Power x 1 (Green) PoE Port: Active, PoE ready-in-use x 1 (Green) Network Cable: 10BASE-T: 2-pair UTP Cat. 3, 4, 5, up to 100m (328 ft.) 100BASE-TX: 2-pair UTP Cat. 3, 4, 5, up to 100m (328 ft.) EIA/TIA-568 100-ohm STP (100m) Data Rate: 10/100 Mbps Unit Output Voltage: DC 53V, 0.6A Power Requirements: 100-240V AC, 50/60 Hz, 0.75A Power Consumption: 30 watts (max.) Number of Devices that can be powered: 1 PoE Standard: IEEE 802.3at Power over Ethernet Plus / PSE PoE Power Output: DC 53V / 30 watts PoE Power Supply Type: Mid-span Power Pin Assignment: 4/5 (+), 7/8 (-) Standards Compliance: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE ...
  • Model #: POE-164
  • Item #: 9SIA29J1995964
  • Return Policy: View Return Policy
$32.00
$8.00 Shipping
PLANET GS-5220-24P4X L2+ 24-Port 10/100/1000T 802.3at PoE+ 4-Port 10G SFP+ Managed Switch
PLANET GS-5220-24P4X L2+ 24-Port 10/100/1000T 802.3at PoE+ 4-Port 10G SFP+ Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN tagging IEEE 802.1x port authentication network control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 24 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ injector 4 x 100/1000BASE-X mini-GBIC/SFP combo interface with Port-21 to Port-24 4 x 10GBASE-SR/LR ...
  • Model #: GS-5220-24P4X
  • Item #: 9SIA29J9AG3778
  • Return Policy: View Return Policy
$575.00
$14.00 Shipping
Planet IPOE-E174 1-Port Ultra PoE to 4-Port 802.3af/at Gigabit PoE Extender
Planet IPOE-E174 1-Port Ultra PoE to 4-Port 802.3af/at Gigabit PoE Extender
OUT OF STOCK
Sold Price: $178.99
Free Shipping
PLANET IPOE-171-95W Industrial Single-Port 10/100/1000 Mbps 802.3bt PoE Injector (95 Watts, -40~75 degrees C, 12~48V DC)
PLANET IPOE-171-95W Industrial Single-Port 10/100/1000 Mbps 802.3bt PoE Injector (95 Watts, -40~75 degrees C, 12~48V DC)
  • Type: PoE Injector
  • Specifications: Interface: Input Port: 1 x RJ45 STP Data In Output Port: 1 x RJ45 STP PoE (Data + Power) Out Input power terminal block: 1 Network Cable: Twisted-pair cable up to 100 meters (328 ft.) 10BASE-T: 4-pair UTP Cat. 3, 4, 5, 5e, 6 100BASE-TX: 4-pair UTP Cat. 5, 5e, 6 1000BASE-T: 4-pair UTP Cat. 5e, 6 Data Rate: 10/100/1000 Mbps Dimensions: 1.26" x 5.31" x 3.46" Weight: 1.04 lbs. Power Requirements: DC 12~48V, 5A max. Unit Output Voltage: DC 54V Power Consumption: 120 watts max. Standards Compliance: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3bt 4-pair Power over Ethernet Type 4 IEEE 802.3at Power over Ethernet Plus Package Contents: IPOE-171-95W User's manual Wall-mount kit Dust cap
  • Model #: IPOE-171-95W
  • Item #: N82E16833962006
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $255.99
Free Shipping
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
PLANET GSD-1008HP 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  • Item #: N82E16833322083
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $125.99
Free Shipping
PLANET IGT-805AT Industrial 10/100/1000BASE-T to 100/1000BASE-X SFP Media Converter
PLANET IGT-805AT Industrial 10/100/1000BASE-T to 100/1000BASE-X SFP Media Converter
  • Device Type: Converter
  • Media Conversion: RJ45 - SFP
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Ports: 1 x 10/100/1000BASE-T RJ45 with auto MDI / MDI-X function 1 x SFP interface, 100/1000BASE-X dual mode (auto detection)
  • Model #: IGT-805AT
  • Item #: N82E16833322135
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $122.99
Free Shipping
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
Planet FT-802 10/100BASE-TX to 100BASE-FX (SC, MM) Bridge Media Converter - 2 km
Planet FT-802 10/100BASE-TX to 100BASE-FX (SC, MM) Bridge Media Converter - 2 km
  • Device Type: Converter
  • Standards: IEEE 802.3, 10BASE-T IEEE 802.3u, 100BASE-TX IEEE 802.3u, 100BASE-FX IEEE 802.3x, Flow Control
  • Wavelength: 1310nm
  • Fiber Cable: SC / Multi-mode / 2 km
  • Model #: FT-802
  • Item #: N82E16833322094
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $64.99
Free Shipping
Planet FTP-802S15 100Base-FX to 10/100Base-TX PoE Media Converter (SC,SM) - 15 km
Planet FTP-802S15 100Base-FX to 10/100Base-TX PoE Media Converter (SC,SM) - 15 km
  • Device Type: Converter
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet
  • Wavelength: 1310nm
  • Fiber Cable: SC / Single-mode / 15 km
  • Model #: FTP-802S15
  • Item #: N82E16833322098
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $100.99
Free Shipping
Planet GT-806A15 10/100/1000Base-T to 1000Base-LX (WDM) Media Converter TX:1310nm - 15km
Planet GT-806A15 10/100/1000Base-T to 1000Base-LX (WDM) Media Converter TX:1310nm - 15km
  • Device Type: Converter
  • Media Conversion: RJ45 - SX/LX
  • Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
  • Wavelength: TX:1310nm RX:1550nm
  • Model #: GT-806A15
  • Item #: N82E16833322119
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
Planet GS-4210-8P2S 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
Planet GS-4210-8P2S 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
  • Format: Desktop
  • MAC Address Table: 8K entries
  • VLAN Support: Yes
  • Jumbo Frames: 10K bytes
  • Model #: GS-4210-8P2S
  • Item #: 0XP-005D-00048
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
  • MAC Address Table: 4K
  • Switching Method: Store and Forward
  • Model #: FGSD-1008HPS
  • Item #: N82E16833322084
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
PLANET FSD-604HP 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 4-Port 10/100TX 802.3af/at PoE 2-Port 10/100TX
  • Primary Port Speed: 10/100Mbps
  • Model #: FSD-604HP
  • Item #: N82E16833322197
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $50.99
Free Shipping
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
  • Brand: PLANET
  • Format: 19-inch Desktop size, 1U Height, Rack Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Network Management Type: Unmanaged
  • Model #: GSW-2620VHP
  • Item #: N82E16833322118
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
  • Model #: GS-4210-16P4C
  • Item #: N82E16833322100
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
  • Primary Ports: 4 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-620TF
  • Item #: N82E16833322133
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P4S
  • Item #: N82E16833322130
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
Planet IPOE-162 Industrial IEEE 802.3at Gigabit High Power Over Ethernet Injector (Mid-Span)
Planet IPOE-162 Industrial IEEE 802.3at Gigabit High Power Over Ethernet Injector (Mid-Span)
  • Type: PoE Injector
  • Specifications: Interface: "Data" Input Port: 1 x RJ-45 STP "PoE (Data+Power)" Output Port: 1 x RJ-45 STP Input power terminal block: 1 LED Indicator: System: Power 1, Power 2, Fault (Green) PoE Port: PoE in Use x 1 (Green) Network Cable: 10Base-T: UTP Cat. 3, 4, 5, up to 100m (328 ft.) 100Base-TX: UTP Cat. 3, 4, 5, up to 100m (328 ft.) 1000Base-T: UTP Cat. 5, 5e, 6 up to 100m (328 ft.) EIA/TIA- 568 100-ohm STP (100m) Data Rate: 10/100/1000Mbps Dimension: 1.26" x 5.31" x 3.46" Weight: 1.05 lbs. Unit Input Voltage: 24 - 48V DC; 24V AC Power Consumption: 30 watts max. Number of device can be powered: 1 Installation: DIN rail kit and wall mount ear Alarm: Provides one relay output for power failure, Alarm relay current carry ability: 3A at DC 30V Enclosure: IP30 slim type metal case Power over Ethernet PoE Standard: IEEE 802.3at High ...
  • Model #: IPOE-162
  • Item #: 0YH-00JP-00012
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
Planet ISW-800T IP30 Compact Size 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
Planet ISW-800T IP30 Compact Size 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
OUT OF STOCK
Sold Price: $95.99
Free Shipping
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 6-Port IEEE 802.3at / af / Ultra PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatible with 100BASE-FX SFP...
  • Model #: GS-4210-16UP4C
  • Item #: N82E16833322103
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
PLANET FT-801 10/100Base-TX to 100Base-FX Media Converter (MM, ST, 2 Km, LFPT)
PLANET FT-801 10/100Base-TX to 100Base-FX Media Converter (MM, ST, 2 Km, LFPT)
  • Device Type: Converter
  • Standards: IEEE 802.3, 10BASE-T IEEE 802.3u, 100BASE-TX IEEE 802.3u, 100BASE-FX
  • Wavelength: 1310nm
  • Power Adapter: Power Input: 5V DC, 2A, max Power Supply: AC Adapter 100-240V AC, Frequency: 50-60 Hz
  • Model #: FT-801
  • Item #: 0EP-0060-00009
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $65.99
Free Shipping
PLANET GT-1205A 1-Port 10/100/1000Base-T - 2-Port 1000FX (SFP) Switch Media Converter
PLANET GT-1205A 1-Port 10/100/1000Base-T - 2-Port 1000FX (SFP) Switch Media Converter
  • Device Type: Converter
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX IEEE 802.3ab 1000Base-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3x Flow Control
  • Ports: Copper: 1 x 10/100/1000Base-T port Fiber: 2 x 1000Base-X SFP slots
  • Power Adapter: Power Requirements: 5V DC, 2A max Power Consumption: 5.4 watts / 18.5 BTU per hour max
  • Model #: GT-1205A
  • Item #: 0EP-0060-00029
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $119.99
Free Shipping
PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
  • Device Type: Converter
  • Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX IEEE 802.3ah OAM
  • Wavelength: 1310nm
  • Ports: 1 x 10/100/1000Base-T port 1 x 1000Base-SX/LX port
  • Model #: GST-802S
  • Item #: 0EP-0060-00011
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
Planet IGS-5225-8T2S2X Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 ~ 75 degrees C)
Planet IGS-5225-8T2S2X Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 ~ 75 degrees C)
  • Format: DIN Rail Mount
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Model #: IGS-5225-8T2S2X
  • Item #: 0XP-005D-00066
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
PLANET FT-806B20 10/100TX - 100Base-FX (WDM) Bi-directional Fiber Converter (SM, SC, 1550nm, 20 Km, LFPT)
PLANET FT-806B20 10/100TX - 100Base-FX (WDM) Bi-directional Fiber Converter (SM, SC, 1550nm, 20 Km, LFPT)
  • Device Type: Converter
  • Standards: IEEE 802.3, 10BASE-T IEEE 802.3u, 100BASE-TX IEEE 802.3u, 100BASE-FX
  • Wavelength: TX: 1550nm; RX: 1310nm
  • Power Adapter: Power Input: 5V DC, 2A, max Power Supply: AC Adapter 100-240V AC, Frequency: 50-60 Hz
  • Model #: FT-806B20
  • Item #: 0EP-0060-00016
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $78.99
Free Shipping
PLANET IGT-1205AT Industrial 10/100/1000T to 2-port 100/1000X SFP Media Converter
PLANET IGT-1205AT Industrial 10/100/1000T to 2-port 100/1000X SFP Media Converter
  • Device Type: Converter
  • Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
  • Ports: 1-port 10/100/1000Base-T RJ-45 with auto MDI / MDI-X function 2-port SFP slot interface, SFP supports 1000Base-X and 100Base-FX transceiver via DIP switch configured
  • LEDs: 3 x LED for System and Power: Green: DC Power 1 Green: DC Power 2 Green: Power Fault 2 x LED for Per Copper Port: Green: 1000 LNK / ACT Orange:100 LNK / ACT 1 x LED for Per mini-GBIC interface (Port-1 and Port-2): Green: LNK / ACT
  • Model #: IGT-1205AT
  • Item #: 0YH-00JP-000C9
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
PLANET IGTP-805AT 1000Base-SX / LX to 10/100/1000Base-T 802.3at PoE Industrial Media Converter (Mini-GBIC, SFP)
PLANET IGTP-805AT 1000Base-SX / LX to 10/100/1000Base-T 802.3at PoE Industrial Media Converter (Mini-GBIC, SFP)
  • Device Type: Converter
  • Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX/FX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3z 1000Base-SX/LX Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet
  • Fiber Cable: Vary on SFP Module
  • Ports: LC Fiber Interface
  • Model #: IGTP-805AT
  • Item #: 0YH-00JP-00009
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
Planet IGS-10020PT Industrial 8-Port 10/100/1000T 802.3af PoE + 2 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
Planet IGS-10020PT Industrial 8-Port 10/100/1000T 802.3af PoE + 2 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
  • Primary Ports: 8 10/100/1000Base-T RJ-45 Auto-MDI/MDI-X ports / 2 1000Base-SX/LX/BX SFP interfaces (Port-9 and Port-10)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-10020PT
  • Item #: 0XP-005D-00041
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Free Shipping
PLANET POE-E201 IEEE802.3at High Power PoE Repeater (Extender)
PLANET POE-E201 IEEE802.3at High Power PoE Repeater (Extender)
  • Type: PoE Extender
  • Specifications: PoE Standard: IEEE 802.3af (Power over Ethernet) IEEE 802.3at (High Power over Ethernet) PoE Power Supply Type: Mid-Span / Type B PoE Power Output: 52V DC, 510 mA, Max. 26 watts Power Pin Assignment: 4/5 (+), 7/8 (-) Maximum Distance: 4 units, daisy-chain installation with 500m support Data Rate: 10/100/1000 Mbps Switch Architecture: Store-and-Forward Maximum Frame Size: 1552 Bytes Flow Control: Back pressure for half-duplex IEEE 802.3x pause frame for full-duplex LED Indicators: 1 x PoE IN (Green) 1 x LAN Data (Green) 1 x PoE OUT (Green) Power Requirements: IEEE 802.3at compliant with voltage within 52V-56V DC Power Consumption: 3.2 watts (system maximum)
  • Model #: POE-E201
  • Item #: 0EP-002Z-00002
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $74.99
Free Shipping
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-501T
  • Item #: 0EP-0060-00063
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $114.99
Free Shipping
PLANET HPOE-2400G 24-Port Gigabit IEEE 802.3at PoE+ Managed Injector Hub (720 Watts)
PLANET HPOE-2400G 24-Port Gigabit IEEE 802.3at PoE+ Managed Injector Hub (720 Watts)
  • Type: PoE Injector
  • Color: Black
  • Specifications: Hardware Version: 4 Interface: Data Input Ports: 24 x RJ45 Data + Power Output Ports: 24 x RJ45 Management Port: 1 x RJ45; 10/100/1000BASE-T, auto-negotiation, auto-MDI/MDIX Data Rate: 10/100/1000 Mbps LED: System: 1 x SYS PWR (Green) 1 x PoE1 Fail (Red) 1 x PoE2 Fail (Red) 1 x Fan1 Fail (Red) 1 x Fan2 Fail (Red) Per PoE Port: 1 x PoE-in-Use (Green) 2 x Management port: 1000 (Green), 10/100 (Orange) Network Cable: 10BASE-T: 4-pair UTP Cat5 up to 100m (328 ft.) 100BASE-TX: 4-pair UTP Cat5 up to 100m (328 ft.) 1000BASE-T: 4-pair UTP Cat5e, 6, up to 100m (328 ft.) EIA/TIA- 568 100-ohm STP (100m) Power Requirements: 100-240V AC, 50/60 Hz, 8A Power Consumption: 800 watts max. Cooling: 3 x Fan PoE Power Supply Type: Mid-span PoE Power Output: Per port DC 50-57V 30.8 / 15.4 watts Power Pin Assignment...
  • Model #: HPOE-2400G
  • Item #: N82E16833962013
  • Return Policy: 15-Day Return Policy
OUT OF STOCK
Sold Price: $608.99
Free Shipping

Leading the Way in Networking Solutions

Welcome to PLANET, a trailblazer in the realm of networking solutions. Renowned for our cutting-edge technologies, we offer an extensive array of products designed to enhance connectivity and facilitate seamless communication. Our portfolio spans advanced Switches and versatile Network Transceivers, catering to both enterprise and residential needs. PLANET products are engineered to support reliable and efficient data transmission, empowering users to stay connected anytime, anywhere.

Innovative Product Range

With PLANET, you gain access to a diverse product lineup including state-of-the-art Switch Modules and intuitive Wired & Wireless Accessories. Our offerings ensure that all your networking essentials are covered, from Modems / Gateways that provide robust internet access, to Home Safety & Security products that safeguard your connected spaces. At PLANET, innovation meets practicality in every solution we deliver.

Integration and Flexibility

PLANET excels in delivering integration capabilities with our dynamic Powerline Networking and Data Converters, allowing for seamless assimilation into existing setups. Our Network Connectors/Adapters offer unparalleled flexibility, ensuring compatibility and ease of use across various platforms and devices. The adaptability of PLANET products makes them a perfect match for customized networking environments.

Ensuring Top-Notch Connectivity

Stay ahead in the networking world with PLANET's cutting-edge technologies. From versatile 2 in 1 Accessories to reliable Hub devices, each product is designed to improve your connectivity experience. Our commitment to quality and durability ensures that PLANET is the go-to brand for anyone seeking exceptional and reliable networking products. Experience the power of superior connectivity, only with PLANET.