Your Browsing History
Get Educated
Make informed decisions with expert advice. Learn More
Engenius EGS7228P Gigabit Ethernet switch with PoE
- A Full-Featured Layer 2 PoE+ Switch
- 802.3at / af PoE on its 24 Ports , up to 30 Watts per port
- Total PoE Budget of 185 Watts
- Included 4 Dual-Speed SFP Ports
- 24 Gigabit Ethernet Port
Overview
Specs
Reviews
See all Q & A
Any questions? Ask CelesteSM will help you find out quickly.
Try me now
Engenius EGS7228P
Brand NewIncludes One Year Warranty
The Engenius EGS7228P is a 24-Port PoE smart switch with 4 gigabit SFP slots. The switch features comprehensive layer 2 switching capabilities, the switch helps to connect and power VoIP phone systems, IP cameras and wireless access points throughout the facility. The switch offers IEEE802.3at/af PoE support on all its ports and fiber uplinks through the four SFP slots.
The EGS7228P delivers up to 30 watts over connected ethernet cables to powered devices, with a total PoE budget of 185 watts. The switch supports VLAN, QoS, spanning tree protocols, MLD snooping, IGMP snooping features for priority based applications, like IP surveillance or video/voice transitions.
EGS7228P Features:
Brand NewIncludes One Year Warranty
The Engenius EGS7228P is a 24-Port PoE smart switch with 4 gigabit SFP slots. The switch features comprehensive layer 2 switching capabilities, the switch helps to connect and power VoIP phone systems, IP cameras and wireless access points throughout the facility. The switch offers IEEE802.3at/af PoE support on all its ports and fiber uplinks through the four SFP slots.
The EGS7228P delivers up to 30 watts over connected ethernet cables to powered devices, with a total PoE budget of 185 watts. The switch supports VLAN, QoS, spanning tree protocols, MLD snooping, IGMP snooping features for priority based applications, like IP surveillance or video/voice transitions.
EGS7228P Features:
- Smart PoE Gigabit Switch
- 24 Gigabit Ethernet Ports
- 4 100/1000Mbps SFP Slots
- IEEE 802.3at/af PoE Support on all Ports
- 56 Gbps Switching Capacity
- Total 185W PoE Budget
- Delivers Up To 30 Watts Over Connected Ethernet Cables to Powered Devices - PoE Management
- Power On/Off Per Port
- Power Class Configuration
- Power Feeding w/ Priority
- User-defined Power Limit - IGMP Snooping v1/v2/v3
- Bandwidth Control
- IEEE802.1 VLAN
- IEEE802.1 Port-based VLAN
- IEEE802.1p QoS
- IEEE 802.3ad Link Aggregation
- LED Indicators:
- Power LED
- Fault LED
- PoE Max LED
- LAN Mode LED
- PoE Mode LED
- SFP/Copper Ports: LAN/PoE Mode, Link/Act - Forwarding Mode: Store & Forward
- Storm Control
- Port Trunking
- Port Mirroring - One to One & Many to One
- Spanning Tree Protocols: STP/RSTP/MSTP
- TFTP/BootP/DHCP Client
- Web-Based Support
- Command Line Interface (CLI)
- MIB Support: RFC1213, RFC1493, RFC1757, RFC2674
- Cable Diagnostic
- CoS
Warranty & Returns
Warranty, Returns, And Additional Information
Return Policies
- Return for refund within: 30 days
- Return for replacement within: 30 days
- This item is covered by Newegg.com's 30-Day Return Policy.
- Read full return policy for details.
Manufacturer Contact Info
- Manufacturer Website
- Support Phone: 1-888-735-7888
- Support Website
- View other products from EnGenius Technologies
LOADING...
LOADING...






