Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
Sort By:
View:
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EP-100NAS
  •  
  • AUD$701.80 –
  • AUD$106.39 Shipping
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
Quick View
Netgear Inc.
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
  • Brand: NETGEAR
  • Part Number: GS748-100NAS
  • Format: Rack-mountable, Desktop, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS748-100NAS
  •  
  • AUD$1,102.20 –
  • AUD$156.62 Shipping
QNAP, Optical Transceiver 10GbE SFP+ 850nm SR up to 300m industrial-temperature (-40 ~85)
Quick View
  •  
  • AUD$122.10 –
  • AUD$81.21 Shipping
Gigabit PoE+ Media Converter, 10/100/1000BASE-T to SFP
Quick View
  •  
  • AUD$820.60 –
  • AUD$85.83 Shipping
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
  •  
  • AUD$1,560.90 –
  • AUD$147.55 Shipping
Zyxel 48-port GbE PoE Lite-L3 Smart Managed Switch with 4 10G Uplink - 48 Ports - Manageable - 10 Gigabit Ethernet - 470.10 W Power Consumption - 375 W PoE Budget (XGS1935-52HP)
Quick View
Zyxel 48-port GbE PoE Lite-L3 Smart Managed Switch with 4 10G Uplink - 48 Ports - Manageable - 10 Gigabit Ethernet - 470.10 W Power Consumption - 375 W PoE Budget (XGS1935-52HP)
  • Brand: ZyXEL
  • Model: XGS1935-52HP
  • Part Number: XGS1935-52HP
  • Primary Ports: 48 x 100/1000BASE-T Gigbit Ethernet PoE+ RJ-45 Network Port 4 x 10 Gigbit Ethernet SFP+ Expansion Slot
  • Model #: XGS1935-52HP
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EPP-100NAS
  •  
  • AUD$797.50 –
  • AUD$105.39 Shipping
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.35
  • Model #: SW-104
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
Quick View
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
  • Brand: Juniper Networks, Inc.
  • Series: EX4400
  • Part Number: EX4400-24P
  • Format: Rackmount
  • Model #: EX4400-24P
Ruckus Wireless ICX 7650 Intake Airflow Fan Back To Front Airflow ICXFAN12I
Quick View
  •  
  • AUD$526.90 –
  • AUD$63.12 Shipping
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
Quick View
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
  • Brand: HPE
  • Series: Networking CW 2050
  • Part Number: S6X70A#ABA
  • Switch Type: 48-Port Gigabit Managed Switch
  • Model #: S6X70A#ABA
  •  
  • AUD$1,447.60 –
  • AUD$141.53 Shipping
Adder - X50-US - AdderLink X50. Transparent USB & VGA KVMA CATx Extender 50 Mtr
Quick View
  •  
  • AUD$1,087.90 –
  • AUD$77.94 Shipping
HPE Juniper Networking, Compact, fanless switch offering 12 x 1GbE, PoE+ (30W) access ports, 2 x 1/10G SFP+ uplink ports, and 2 x 10G SFP+ VC ports with a total PoE budget of 240W | EX4000-12P
Quick View
  •  
  • AUD$1,951.40 –
  • AUD$143.68 Shipping
RUCKUS ICX 7550, 24-port 10/100/1000 Mbps 802.3at POE+, 2x 40 Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-24P-E2
Quick View
RUCKUS ICX 7550, 24-port 10/100/1000 Mbps 802.3at POE+, 2x 40 Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-24P-E2
  • Brand: Ruckus
  • Part Number: ICX7550-24P-E2
  • Format: Stackable
  • Standards: 802.1AB LLDP 802.1D MAC Bridging 802.1p Mapping to Priority Queue 802.1s Multiple Spanning Tree (MST) 802.1w Rapid Reconfiguration of Spanning Tree 802.1x Port-based Network Access Control (PNAC) 802.3 Carrier Sense Multiple Access/Collision Detection (CSMA/CD) 802.3ab 1000BASE-T 802.1 AX-2008 Link Aggregation 802.3ae 10 Gigabit Ethernet 802.3af Power over Ethernet 802.3at Power over Ethernet Plus 802.3bt 4-Pair Power over Ethernet 802.3u 100Base-TX 802.3x Full duplex and Flow Control 802.3z 1000Base-SX/LX 802.3bz Multi-gigabit Ethernet 802.3 MAU MIB (RFC 2239) 802.3ba 40 and 100 Gbps Ethernet 802.1AE-MACsec (with license) 802.3az Energy Efficient Ethernet 802.1Q VLAN Tagging
  • Model #: ICX7550-24P-E2
  •  
  • AUD$12,244.10 –
  • AUD$256.50 Shipping
SMART MGD POE+ SWITCH 24PORT
Quick View
SMART MGD POE+ SWITCH 24PORT
  • Switch Type: managed
  • Model #: SM24TAT2SA-NA
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.4
  • Model #: SW-108
  •  
  • AUD$234.30 –
  • AUD$57.02 Shipping
SonicWall 100GBase-SR4 QSFP28 850nm 100m Module  - For Firewall - 1x 100GBase-SR4 Network - Optical Fiber - Multi-mode - 100 Gigabit Ethernet - 100GBase-SR4 - TAA - 02-SSC-5806
Quick View
SonicWall
SonicWall 100GBase-SR4 QSFP28 850nm 100m Module - For Firewall - 1x 100GBase-SR4 Network - Optical Fiber - Multi-mode - 100 Gigabit Ethernet - 100GBase-SR4 - TAA - 02-SSC-5806
  • Brand: SonicWall
  • Part Number: 02-SSC-5806
  • Switch Type: 100GBase-SR4 QSFP28 Transceiver Module
  • Format: QSFP28
  • Model #: 02-SSC-5806
  •  
  • AUD$1,140.70 –
  • AUD$104.39 Shipping
Black Box Gigabit Managed Ethernet Switch - 10-Ports
Quick View
Black Box Gigabit Managed Ethernet Switch - 10-Ports
  • Switch Type: Others
  • Model #: LGB1110A
D-Link DMS-1250-28P Ethernet Switch - 24 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 3 Layer Supported - 592.19 W Consumption - 475 W PoE Budget
Quick View
  •  
  • AUD$1,955.80 –
  • AUD$143.53 Shipping
BRAINBOXES SW-105 EMBEDDED 5PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-105 EMBEDDED 5PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.35
  • Model #: SW-105
  •  
  • AUD$158.40 –
  • AUD$57.03 Shipping
Netgear Business GS748PP 48-Port Gigabit Unmanaged PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS748PP 48-Port Gigabit Unmanaged PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS748PP-100NAS
  • Format: Rack-mountable, Desktop, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS748PP-100NAS
  •  
  • AUD$1,854.60 –
  • AUD$173.60 Shipping
Black Box LPB3000 Ethernet Switch LPB3028A
Quick View
HPE Aruba JL259A#ABA 2930F 24G 4 SFP Switch
Quick View
HPE Aruba JL259A#ABA 2930F 24G 4 SFP Switch
  • Primary Ports: (24) RJ-45 autosensing 10/100/1000 ports (4) SFP
  • Dimensions: 1.73" x 17.42" x 7.88"
  • Weight: 5.31 lbs.
  • Package Contents: (1) Aruba 2930F 24G 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4) bumper feet, (1) cable tie
  • Model #: JL259A#ABA
Schneider Electric NetBotz 125kHz Rack Access Control
Quick View
D-Link DES-1016D
Quick View
D-Link DES-1016D
  • Brand: D-Link
  • Model #:
OM5 LC/LC MULTIMODE FIBRE CABLE
Quick View
OM5 LC/LC MULTIMODE FIBRE CABLE
  • Weight: 2.0000
  • Model #: LCLCL-20M-OM5-FIBER
Planet IGS-10020PT Industrial 8-Port 10/100/1000T 802.3af PoE + 2 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
Quick View
Planet IGS-10020PT Industrial 8-Port 10/100/1000T 802.3af PoE + 2 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
  • Primary Ports: 8 10/100/1000Base-T RJ-45 Auto-MDI/MDI-X ports / 2 1000Base-SX/LX/BX SFP interfaces (Port-9 and Port-10)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-10020PT
  •  
  • AUD$1,009.80 –
  • AUD$97.95 Shipping
10GBASE-SR SFP+, 1310-nm Single-Mode, 10 km, LC
Quick View
  •  
  • AUD$537.90 –
  • AUD$57.61 Shipping
Aten RM Kit For CS1182XX/CS1184XX
Quick View
  •  
  • AUD$75.90 –
  • AUD$61.96 Shipping
Ubiquiti UniFi WAN Switch RJ45 (USW-WAN-RJ45)
Quick View

Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.

Network Switches Are Versatile Networking Solutions

Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.

Switches Accommodate Shifts in Business and IT Trends

Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.

Multiple Network Management Options Provide a Positive User Experience

There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.

Switches Provide the Highest Levels of Security

Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.

Network Switches Provide Comprehensive and Advanced Networking Features

Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.