Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
Sort By:
View:
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
Quick View
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
  • Format: Wall-mount and DIN Rail Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az EEE (Energy Efficient Ethernet) RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2 ITU-T G.8032 ERPS (Ethernet Ring Protection Switching)
  • Primary Ports: 6 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5226-4P2T
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
Quick View
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
  • Brand: Allied Telesis
  • Series: GS910
  • Part Number: AT-GS910/8E-10
  • Format: Wall Mountable
  • Model #: AT-GS910/8E-10
QNAP QSW-M408S 6-port layer 2 managed switch. 6 x 2.5GbE (1G/100M) ports and 4 x 10G SFP+ ports. Easy management with web browser.
Quick View
  •  
  • AUD$616.00 –
  • AUD$106.39 Shipping
HPE Aruba Networking CX 6200F 24G Class-4 PoE 4SFP 370W Switch | S0M82A
Quick View
HPE Aruba Networking CX 6200F 24G Class-4 PoE 4SFP 370W Switch | S0M82A
  • Brand: HPE
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • PoE Power Budget: 370W
  • Power: 100V-120V/200V-240V
  • Model #: S0M82AABA
  •  
  • AUD$6,207.30 –
  • AUD$266.73 Shipping
ZyXEL 5 Port Gigabit Ethernet Unmanaged POE+ Switch, 4 x PoE+ @ 60W, GS1005HP
Quick View
ZyXEL 5 Port Gigabit Ethernet Unmanaged POE+ Switch, 4 x PoE+ @ 60W, GS1005HP
  • Brand: ZyXEL
  • Part Number: GS1005HP
  • Switch Type: Manageable: Yes
  • Format: Desktop, Wall-Mount
  • Model #: GS1005HP
D-Link 52-Port 10-Gigabit Smart Managed PoE Switch DGS125052XMP6KV
Quick View
D-Link 52-Port 10-Gigabit Smart Managed PoE Switch DGS125052XMP6KV
  • Switch Type: managed
  • Model #: DGS125052XMP6KV
Black Box LIG1014A 14-Port Industrial Gigabit Ethe Rnet Switch Managed Extreme Temp.
Quick View
  •  
  • AUD$1,256.20 –
  • AUD$85.83 Shipping
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511S15
  •  
  • AUD$177.10 –
  • AUD$70.95 Shipping
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
  • Format: DIN Rail and Wall Mount Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-20160HPT
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P2S2X
Adder - CATX-USB - Computer Access Module RJ45 Socket - USB & VGA
Quick View
  •  
  • AUD$194.70 –
  • AUD$82.24 Shipping
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EP-100NAS
  •  
  • AUD$701.80 –
  • AUD$106.39 Shipping
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
Quick View
Netgear Inc.
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
  • Brand: NETGEAR
  • Part Number: GS748-100NAS
  • Format: Rack-mountable, Desktop, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS748-100NAS
  •  
  • AUD$1,102.20 –
  • AUD$156.62 Shipping
QNAP, Optical Transceiver 10GbE SFP+ 850nm SR up to 300m industrial-temperature (-40 ~85)
Quick View
  •  
  • AUD$122.10 –
  • AUD$81.21 Shipping
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2.0 Mb
  • PoE: Yes
  • Model #: R8R46A#ABA
  •  
  • AUD$166.10 –
  • AUD$113.30 Shipping
Gigabit PoE+ Media Converter, 10/100/1000BASE-T to SFP
Quick View
  •  
  • AUD$820.60 –
  • AUD$85.83 Shipping
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
  •  
  • AUD$1,560.90 –
  • AUD$147.55 Shipping
Zyxel 48-port GbE PoE Lite-L3 Smart Managed Switch with 4 10G Uplink - 48 Ports - Manageable - 10 Gigabit Ethernet - 470.10 W Power Consumption - 375 W PoE Budget (XGS1935-52HP)
Quick View
Zyxel 48-port GbE PoE Lite-L3 Smart Managed Switch with 4 10G Uplink - 48 Ports - Manageable - 10 Gigabit Ethernet - 470.10 W Power Consumption - 375 W PoE Budget (XGS1935-52HP)
  • Brand: ZyXEL
  • Model: XGS1935-52HP
  • Part Number: XGS1935-52HP
  • Primary Ports: 48 x 100/1000BASE-T Gigbit Ethernet PoE+ RJ-45 Network Port 4 x 10 Gigbit Ethernet SFP+ Expansion Slot
  • Model #: XGS1935-52HP
TP-Link 5 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Desktop/Wall-Mount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP and Link Aggregation (TL-SG105E)
Quick View
TP-Link 5 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Desktop/Wall-Mount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP and Link Aggregation (TL-SG105E)
  • Brand: TP-Link
  • Format: Desktop
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
  • Network Management Type: Unmanaged
  • Model #: TL-SG105E
  •  
  • AUD$79.20 –
  • AUD$106.47 Shipping
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EPP-100NAS
  •  
  • AUD$797.50 –
  • AUD$105.39 Shipping
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.35
  • Model #: SW-104
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • PoE: Yes
  • SNMP: Yes
  • Model #: JL811A#ABA
  •  
  • AUD$326.70 –
  • AUD$104.52 Shipping
HPE Networking Instant On Switch 24p Gigabit CL4 PoE 2p SFP 195W 1830 (JL813A#ABA)
Quick View
HPE Networking Instant On Switch 24p Gigabit CL4 PoE 2p SFP 195W 1830 (JL813A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • PoE: Yes
  • Model #: JL813A#ABA
  •  
  • AUD$633.60 –
  • AUD$193.66 Shipping
HPE Networking Instant On Switch 48p Gigabit CL4 PoE 4p SFP 370W 1830 (JL815A#ABA)
Quick View
HPE Networking Instant On Switch 48p Gigabit CL4 PoE 4p SFP 370W 1830 (JL815A#ABA)
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • PoE: Yes
  • Model #: JL815A#ABA
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
  • Primary Ports: 12 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • SNMP: Yes
  • Power: 100 - 240 VAC
  • Model #: JL805A#ABA
  •  
  • AUD$2,534.40 –
  • AUD$170.62 Shipping
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
Quick View
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
  • Brand: Juniper Networks, Inc.
  • Series: EX4400
  • Part Number: EX4400-24P
  • Format: Rackmount
  • Model #: EX4400-24P
TRENDnet 10-Port Gigabit PoE++ Switch, TPE-BG102g, 8 x Gigabit  PoE++ Ports, 2 x Gigabit SFP Ports, 240W PoE Power Budget, 20Gbps,  Internal Power Supply, Lifetime Protection, Black
Quick View
TRENDnet 10-Port Gigabit PoE++ Switch, TPE-BG102g, 8 x Gigabit PoE++ Ports, 2 x Gigabit SFP Ports, 240W PoE Power Budget, 20Gbps, Internal Power Supply, Lifetime Protection, Black
  • Brand: TRENDnet
  • Standards: IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3af IEEE 802.3at IEEE 802.3bt
  • Primary Ports: 4 x Gigabit PoE++ ports 4 x Gigabit PoE+ ports 2 x Gigabit SFP Slots LED indicators
  • Primary Port Speed: Ethernet: 10Mbps (half duplex), 20Mbps (full duplex) Fast Ethernet: 100Mbps (half duplex), 200Mbps (full duplex) Gigabit: 2000Mbps (full duplex) Fiber: 2000Mbps (full duplex)
  • Model #: TPEBG102g
TRENDnet 7-Port Multi-Gig PoE+ Switch, 5 x 1G RJ-45 PoE+ BASE-T Ports, 2 x 2.5G RJ-45 PoE+ Ports, 20Gbps Switching Capacity, Network Ethernet Switch, Lifetime Protection, Black, TPE-TG3
Quick View
TRENDnet 7-Port Multi-Gig PoE+ Switch, 5 x 1G RJ-45 PoE+ BASE-T Ports, 2 x 2.5G RJ-45 PoE+ Ports, 20Gbps Switching Capacity, Network Ethernet Switch, Lifetime Protection, Black, TPE-TG3
  • Brand: TRENDnet
  • Model: TPE-TG327
  • Standards: Networking Standards: IEEE 802.3af IEEE 802.3at IEEE 802.3bz IEEE 802.3w IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: 5 Gigabit Ethernet 2.5 Gigabit Ethernet Network Technology: 5GBase-T 2.5GBase-T Maximum Data Transfer Rate: 640 MB/s
  • Model #: TPE-TG327
  •  
  • AUD$138.60 –
  • AUD$151.45 Shipping
TRENDnet  TI-PG160, 16-Port Hardened Industrial Gigabit PoE+ DIN-Rail Network Switch
Quick View
TRENDnet TI-PG160, 16-Port Hardened Industrial Gigabit PoE+ DIN-Rail Network Switch
  • Features: • 16 x Gigabit PoE+ ports • 240W PoE power budget • 32Gbps switching capacity • Power supply sold separately (models: TI-S24052, TI-S24048, TI-S48048) • Hardened IP30 rated metal switch • Includes DIN-rail and wall mounts • Operating temperature range of -40° – 75° C (-40° – 167° F) • Dual redundant power inputs with overload current
  • Weight: 2.3100
  • Model #: TIPG160
  •  
  • AUD$730.40 –
  • AUD$90.18 Shipping
Ruckus Wireless ICX 7650 Intake Airflow Fan Back To Front Airflow ICXFAN12I
Quick View
  •  
  • AUD$526.90 –
  • AUD$63.12 Shipping

Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.

Network Switches Are Versatile Networking Solutions

Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.

Switches Accommodate Shifts in Business and IT Trends

Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.

Multiple Network Management Options Provide a Positive User Experience

There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.

Switches Provide the Highest Levels of Security

Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.

Network Switches Provide Comprehensive and Advanced Networking Features

Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.