Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
Sort By:
View:
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
  • Format: DIN-rail and Wall-mount Ear
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-4215-4P4T
TRENDnet 10-Port Industrial Gigabit L2 Managed PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 24-57V DC Power Input, IP30, VLAN, Black, TI-PG102i
Quick View
TRENDnet 10-Port Industrial Gigabit L2 Managed PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 24-57V DC Power Input, IP30, VLAN, Black, TI-PG102i
  • Switch Type: Switches
  • Format: DIN Rail Mount
  • Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.1ax IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az IEEE 802.3af IEEE 802.3at
  • Primary Ports: 8 x Gigabit PoE+ ports 2 x 100/1000 Mbps SFP slots
  • Model #: TI-PG102i
TRENDnet 8-Port Hardened Industrial Gigabit DIN-Rail Switch, TI-G80, 16 Gbps Switching Capacity, IP30 Rated, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
Quick View
TRENDnet 8-Port Hardened Industrial Gigabit DIN-Rail Switch, TI-G80, 16 Gbps Switching Capacity, IP30 Rated, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
  • Format: Includes DIN-rail and wall mounts Wall Mountable
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x
  • Primary Ports: 8 x Gigabit ports
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
  • Model #: TI-G80
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
  • Brand: PLANET
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGSW-24040R
TRENDnet TPE-082WS 10-Port Gigabit Web Smart PoE+ Switch
Quick View
TRENDnet TPE-082WS 10-Port Gigabit Web Smart PoE+ Switch
  • Format: Rackmount
  • Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
  • Model #: TPE-082WS
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
Quick View
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
  • Brand: Allied Telesis
  • Series: GS910
  • Part Number: AT-GS910/8E-10
  • Format: Wall Mountable
  • Model #: AT-GS910/8E-10
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511S15
Black Box LIG1014A 14-Port Industrial Gigabit Ethe Rnet Switch Managed Extreme Temp.
Quick View
  •  
  • MXN$16,284.07 –
  • MXN$931.66 Shipping
Adder - CATX-USB - Computer Access Module RJ45 Socket - USB & VGA
Quick View
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EP-100NAS
  •  
  • MXN$8,854.27 –
  • MXN$1,074.31 Shipping
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
Quick View
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
  • Brand: Ubiquiti Networks
  • Part Number: USW-24-POE
  • Format: Rackmount
  • Network Management Type: Managed
  • Model #: USW-24-POE
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
Quick View
Netgear Inc.
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
  • Brand: NETGEAR
  • Part Number: GS748-100NAS
  • Format: Rack-mountable, Desktop, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS748-100NAS
  •  
  • MXN$13,886.35 –
  • MXN$1,344.37 Shipping
TRENDnet 24-Port Gigabit Switch, TEG-S25, 24 x Gigabit RJ-45 Ports, 48Gbps Switching Capacity, Fanless Design, Metal Enclosure, Internal Power Supply, Lifetime Protection, Black
Quick View
TRENDnet 24-Port Gigabit Switch, TEG-S25, 24 x Gigabit RJ-45 Ports, 48Gbps Switching Capacity, Fanless Design, Metal Enclosure, Internal Power Supply, Lifetime Protection, Black
  • Brand: TRENDnet
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab
  • Network Management Type: Unmanaged
  • Primary Ports: 24x Gigabit ports LED indicators
  • Model #: TEG-S25
TRENDnet TI-PGM541, 5-port Industrial Gigabit PoE+ DIN-Rail Switch
-20°  65°C (-4°  149°F)
Quick View
TRENDnet TI-PGM541, 5-port Industrial Gigabit PoE+ DIN-Rail Switch -20° 65°C (-4° 149°F)
  • Features: • 4 x Gigabit PoE+ ports • 1 x Gigabit SFP slot • 120W PoE power budget • 10Gbps switching capacity • Hardened IP30 rated metal switch • Includes DIN-Rail and wall mounts • Operating temperature range of -20° – 65°C (-4° – 149°F) • Redundant power inputs with overload current protection • Alarm output triggered by power
  • Weight: 2.3700
  • Model #: MBVB09VYGSCJ6
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EPP-100NAS
  •  
  • MXN$10,394.75 –
  • MXN$1,103.81 Shipping
TRENDnet 8-Port 2.5G Switch, TEG-S381, 8 x 2.5G RJ45 Ports, 40Gps, NDAA + TAA Compliant, Ethernet Splitter
Quick View
TRENDnet 8-Port 2.5G Switch, TEG-S381, 8 x 2.5G RJ45 Ports, 40Gps, NDAA + TAA Compliant, Ethernet Splitter
  • Brand: TRENDnet
  • Series: ProSafe
  • Model: TEG-S381
  • Part Number: TEG-S381
  • Model #: TEG-S381
  •  
  • MXN$1,671.64 –
  • MXN$775.48 Shipping
TP-Link 24 Port Gigabit Ethernet Switch | Desktop or Rackmount | Lifetime Protection | Plug & Play | Shielded Ports | Sturdy Metal | Fanless Quiet | Traffic Optimization | Unmanaged (TL-SG1024S)
Quick View
TP-Link 24 Port Gigabit Ethernet Switch | Desktop or Rackmount | Lifetime Protection | Plug & Play | Shielded Ports | Sturdy Metal | Fanless Quiet | Traffic Optimization | Unmanaged (TL-SG1024S)
  • Switch Type: desktop
  • Format: Desktop / Rackmount
  • Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab , IEEE 802.3x
  • Primary Ports: 24 x 10/100/1000 Mbps RJ45 Ports (Auto Negotiation / Auto MDI / MDIX)
  • Model #: TL-SG1024S
  •  
  • MXN$2,326.32 –
  • MXN$1,750.33 Shipping
SMART MGD POE+ SWITCH 24PORT
Quick View
SMART MGD POE+ SWITCH 24PORT
  • Switch Type: managed
  • Model #: SM24TAT2SA-NA
Manhattan 153201 4K @ 60 Hz DisplayPort to HDMI Cable (6-Foot)
Quick View
  •  
  • MXN$698.31 –
  • MXN$681.42 Shipping
Ruckus Wireless ICX 7650 Intake Airflow Fan Back To Front Airflow ICXFAN12I
Quick View
  •  
  • MXN$6,601.55 –
  • MXN$746.71 Shipping
TRENDnet 10-Port Industrial Gigabit PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 240W PoE Power Budget, Network Switch, IP30, QoS, Black, TI-PG102
Quick View
TRENDnet 10-Port Industrial Gigabit PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 240W PoE Power Budget, Network Switch, IP30, QoS, Black, TI-PG102
  • Format: Includes DIN-rail and wall mounts
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at
  • Primary Ports: 8 x Gigabit PoE+ ports 2 x Gigabit RJ-45 / SFP shared ports
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
  • Model #: TI-PG102
  •  
  • MXN$8,394.06 –
  • MXN$971.80 Shipping
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.35
  • Model #: SW-104
Adder - X50-US - AdderLink X50. Transparent USB & VGA KVMA CATx Extender 50 Mtr
Quick View
  •  
  • MXN$14,171.71 –
  • MXN$848.32 Shipping
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.4
  • Model #: SW-108

Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.

Network Switches Are Versatile Networking Solutions

Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.

Switches Accommodate Shifts in Business and IT Trends

Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.

Multiple Network Management Options Provide a Positive User Experience

There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.

Switches Provide the Highest Levels of Security

Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.

Network Switches Provide Comprehensive and Advanced Networking Features

Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.