SHOP BY Primary Ports

Quick View
TP-Link JetStream 6-Port 10GE L2+ Managed Switch with 4-Port PoE++
- Format: • Rack Mountable • Desktop
- Standards: 802.3bt/at/af compliant
- Primary Ports: 4× 10 Gbps RJ45 ports and 2× 10 Gbps SFP+ slots
- Jumbo Frames: 9 KB
- Model #: SX3206HPP
- MXN$10,869.19 –
- MXN$938.56 Shipping

Quick View
Planet FGSW-2624HPS 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 220W PoE budget
- Model #: FGSW-2624HPS
- MXN$9,326.99
- See price in cart
- MXN$1,912.85 Shipping

Quick View
D-Link DGS-105GL 5-Port Gigabit Unmanaged Desktop Switch - Fanless, Silent & Energy Efficient
- Brand: D-Link
- Part Number: DGS-105GL
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Model #: DGS-105GL
- MXN$425.71 –
- More options from MXN$425.71 - MXN$719.71
- MXN$893.89 Shipping

Quick View
TP-Link 8 Port Gigabit PoE Switch | 8 PoE+ Ports @63W, w/ 1 Gigabit Port and 1 SFP Slot | Desktop | Plug & Play | Support QoS and IGMP (TL-SG1210P)
- Format: Desktop
- Primary Ports: 9 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 4K, Auto-learning, Auto-aging
- Model #: TL-SG1210P
- MXN$2,380.31 –
- More options from MXN$2,267.86 - MXN$2,380.31
- MXN$1,108.03 Shipping

Quick View
Planet GS-4210-24P2S 24-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
- Format: Rackmount
- MAC Address Table: 8K entries
- VLAN Support: Yes
- Jumbo Frames: 9216 bytes
- Model #: GS-4210-24P2S
- MXN$9,909.87 –
- MXN$1,410.79 Shipping

Quick View
10GBASE-SR SFP+, 1310-nm Single-Mode, 10 km, LC
- Model #: LSP422
- MXN$7,004.07 –
- MXN$683.75 Shipping

Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
- Format: DIN Rail Mount
- MAC Address Table: 8K MAC address table with auto learning function
- Jumbo Frames: 9000 bytes
- Buffer Memory: 1MB
- Model #: WGS-804HP
- MXN$3,863.99
- See price in cart
- MXN$880.16 Shipping

Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch 30W - Power Over Ethernet Switch - GbE POE+ Network Switch - Unmanaged
- Format: Desktop
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Jumbo Frames: 9KB
- Model #: IESC1G80UP
- MXN$9,395.23 –
- More options from MXN$9,395.23 - MXN$9,698.75
- MXN$1,065.48 Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- PoE: Yes
- Model #: R8R46A#ABA
- MXN$3,678.38 –
- MXN$1,006.39 Shipping

Quick View
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-801T
- MXN$3,743.31 –
- MXN$880.16 Shipping

Quick View
Planet IGS-10020PT Industrial 8-Port 10/100/1000T 802.3af PoE + 2 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
- Format: DIN Rail Mount
- Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
- Primary Ports: 8 10/100/1000Base-T RJ-45 Auto-MDI/MDI-X ports / 2 1000Base-SX/LX/BX SFP interfaces (Port-9 and Port-10)
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-10020PT
- MXN$11,394.99
- See price in cart
- MXN$966.61 Shipping

Quick View
TP-Link 9 Port Fast Ethernet 10/100Mbps PoE Switch | 8 PoE+ Ports @65W | Sturdy Metal w/Shielded Ports | Limited Lifetime Protection | Extend Mode | Priority Mode | Isolation Mode (TL-SF1009P)
- Switch Type: desktop
- Format: Desktop
- Primary Ports: 9 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: TL-SF1009P
- MXN$1,362.28 –
- More options from MXN$1,362.28 - MXN$1,536.99
- MXN$755.59 Shipping

Quick View
- MXN$2,293.51 –
- More options from MXN$2,293.51 - MXN$2,382.92
- MXN$963.56 Shipping

Quick View
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
- MAC Address Table: 2K
- Switching Method: Store and Forward
- Model #: ISW-621TF
- MXN$2,284.03 –
- MXN$769.07 Shipping

Quick View
Ubiquiti Pro Max 16, 16-Port Layer 3 (USW-Pro-Max-16)
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-Pro-Max-16
- Format: Rackmount
- Model #: USW-Pro-Max-16
- MXN$8,312.55 –
- More options from MXN$6,569.07 - MXN$10,974.75
- MXN$4,273.32 Shipping

Quick View
TP-Link 16 Port 10/100Mbps Fast Ethernet Switch | Desktop or Wall-Mounting | Plastic Case Ethernet Splitter | Unshielded Network Switch | Plug and Play | Fanless Quiet | Unmanaged (TL-SF1016D)
- Format: Desktop
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100Mbps
- MAC Address Table: 1K
- Model #: TL-SF1016D
- MXN$976.71 –
- MXN$1,709.22 Shipping

Quick View
TP-Link TL-SG108S | 8 Port Gigabit Ethernet Switch | Desktop/Wall-Mount | Plug & Play | Fanless | Sturdy Metal | Limited Lifetime Protection | 802.1p/DSCP QoS & IGMP Snooping | Compact Design
- Format: Desktop
- Standards: IEEE 802.3i / 802.3u / 802.3ab/ 802.3x /802.1p
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG108S
- MXN$784.15 –
- More options from MXN$784.15 - MXN$859.58
- MXN$1,129.97 Shipping

Quick View
Opengear DC Adapter 450041
- Model #: 450041
- MXN$2,647.10 –
- More options from MXN$2,647.10 - MXN$2,858.23
- MXN$984.54 Shipping

Quick View
Planet POE-1200G 12-Port Gigabit IEEE 802.3at PoE+ Managed Injector Hub (220 watts)
- Primary Ports: 12-Port 'Data input' 12-Port 'PoE (Data + Power) output'
- Primary Port Speed: 24-Port 10/100/1000Base-T Gigabit RJ-45 STP
- Jumbo Frames: Complies with IEEE 802.3af Power over Ethernet Mid-Span PSE
- PoE: Supports PoE power up to 15.4 Watts for each PoE ports
- Model #: POE-1200G
- MXN$8,969.11 –
- MXN$1,398.09 Shipping

Quick View
D-Link DGS-108GL 8-Port Gigabit Unmanaged Switch for Home & Small Business - Plug & Play | DGS-108GL
- Brand: D-Link
- Part Number: DGS-108GL
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Model #: DGS-108GL
- MXN$810.61 –
- More options from MXN$610.15 - MXN$810.61
- MXN$640.81 Shipping

Quick View
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3af Power over Ethernet
- Primary Ports: "Data" Input Ports: 24x RJ-45 STP "PoE (Data+Power)" Output Ports: 24x RJ-45 STP Management Port: 1 x RJ-45; 10/100Base-TX, auto-negotiation, auto-MDI / MDIX
- Primary Port Speed: 10/100/1000Mbps
- Model #: POE-2400G
- MXN$11,558.23 –
- MXN$1,410.79 Shipping

Quick View
Amer 5 Port 10/100/1000 Mbps Gigabit Ethernet Desktop Metal Switch
- Format: Desktop
- Primary Port Speed: 1000Base-T
- Weight: 0.65
- Parts: 3 Year
- Model #: SG5D V2
- MXN$950.03 –
- More options from MXN$495.31 - MXN$950.03
- Free Shipping

Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 12.0 Mb
- Layer: 2
- Model #: R8R50A#ABA
- MXN$5,289.62 –
- MXN$1,130.03 Shipping

Quick View
TP-Link TL-SG1210PP 8-Port Gigabit and 1x Combo SFP Slot PoE Switch with 6 PoE+ and 2 PoE++ Ports
- Format: Desktop
- Primary Ports: 9 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 9 x 10/100/1000Mbps RJ45 Ports 1 x 1000Mbps Combo SFP/RJ45 Port
- Model #: TL-SG1210PP
- MXN$3,769.27 –
- More options from MXN$3,769.27 - MXN$4,026.56
- MXN$1,711.21 Shipping

Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-501T
- MXN$2,684.23 –
- MXN$880.16 Shipping

Quick View
Amer SG8D 8 Port 10/100/1000 Mbps Gigabit Ethernet Desktop Switch
- Switch Type: Others
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab
- Primary Ports: 8 x RJ45
- Model #: SG8D
- MXN$55,588.99
- See price in cart
- More options from MXN$767.90 - MXN$800.39
- MXN$966.61 Shipping

Quick View
D-Link 28-Port Web Smart Gigabit Ethernet PoE Switch (DGS-1210-28P)
- Format: Rack-mountable Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode IEEE 802.3af compliance (DGS-1210-28P only) Auto-negotiation
- Primary Ports: 24 x 10/100/1000BASE-T PoE 4 x 4 SFP
- Primary Port Speed: 10/100/1000Base-T
- Model #: DGS-1210-28P
- MXN$8,774.94 –
- More options from MXN$8,593.44 - MXN$10,332.11
- MXN$3,149.05 Shipping

Quick View
BLACK BOX NETWORK SERVICES - INDUSTRIAL 10/100-MBPS ETHERNET SWITCH-UNMANAGED, EXTREME TEMPERATURE, 5-PORT
- Switch Type: ethernet
- Model #: LBH3050A
- MXN$2,647.11 –
- MXN$961.89 Shipping

Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
- MAC Address Table: 2K
- Model #: ISW-621TS15
- MXN$2,965.99
- See price in cart
- MXN$769.07 Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 2p 10GBT 2p SFP+ 1960 (JL806A#ABA)
- Primary Ports: 26 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- SNMP: Yes
- Layer: 2
- Model #: JL806A#ABA
- MXN$17,056.52 –
- MXN$1,504.88 Shipping

Quick View
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
- Model #: IGS-624HPT
- MXN$7,258.99
- See price in cart
- MXN$1,593.58 Shipping

Quick View
TRENDnet 24-Port Unmanaged Gigabit GREENnet Desktop Switch, Ethernet Network Switch, 24 x 10-100-1000 Gigabit Ethernet RJ-45 Ports, 48Gbps Switching Capacity, Lifetime Protection, Black, TEG-S24DG
- Brand: TRENDnet
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX IEEE 802.3ab 1000Base-T IEEE 802.3x Flow Control IEEE 802.3az (draft 2.0)
- Network Management Type: Unmanaged
- Model #: TEG-S24DG
- MXN$1,699.06 –
- MXN$776.38 Shipping

Quick View
- MXN$9,377.43 –
- MXN$1,034.71 Shipping

Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
- Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
- Model #: WGSW-24040
- MXN$6,477.99
- See price in cart
- MXN$1,651.84 Shipping
Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.
Network Switches Are Versatile Networking Solutions
Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.
Switches Accommodate Shifts in Business and IT Trends
Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.
Multiple Network Management Options Provide a Positive User Experience
There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.
Switches Provide the Highest Levels of Security
Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.
Network Switches Provide Comprehensive and Advanced Networking Features
Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.



