Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
Sort By:
View:
Ubiquiti Pro Max 24 PoE, 24-Port Layer 3 PoE Switch (USW-Pro-Max-24-PoE (400W))
Quick View
Ubiquiti Pro Max 24 PoE, 24-Port Layer 3 PoE Switch (USW-Pro-Max-24-PoE (400W))
  • Brand: Ubiquiti Networks
  • Part Number: USW-Pro-Max-24-PoE
  • Format: Rackmount
  • Network Management Type: Managed
  • Model #: USW-Pro-Max-24-PoE
  •  
  • S$1,453.67 –
  • S$581.79 Shipping
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511S15
  •  
  • S$151.19 –
  • S$47.38 Shipping
TRENDnet 10-Port Gigabit PoE++ Switch, TPE-BG102g, 8 x Gigabit  PoE++ Ports, 2 x Gigabit SFP Ports, 240W PoE Power Budget, 20Gbps,  Internal Power Supply, Lifetime Protection, Black
Quick View
TRENDnet 10-Port Gigabit PoE++ Switch, TPE-BG102g, 8 x Gigabit PoE++ Ports, 2 x Gigabit SFP Ports, 240W PoE Power Budget, 20Gbps, Internal Power Supply, Lifetime Protection, Black
  • Brand: TRENDnet
  • Standards: IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3af IEEE 802.3at IEEE 802.3bt
  • Primary Ports: 4 x Gigabit PoE++ ports 4 x Gigabit PoE+ ports 2 x Gigabit SFP Slots LED indicators
  • Primary Port Speed: Ethernet: 10Mbps (half duplex), 20Mbps (full duplex) Fast Ethernet: 100Mbps (half duplex), 200Mbps (full duplex) Gigabit: 2000Mbps (full duplex) Fiber: 2000Mbps (full duplex)
  • Model #: TPEBG102g
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
  • Format: DIN Rail and Wall Mount Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-20160HPT
NETGEAR 24x1G PoE+ 300W 2x1G and 4xSFP Managed Switch | AV Line M4250-26G4F-PoE+, GSM4230P
Quick View
  •  
  • S$2,348.99 –
  • S$109.46 Shipping
SMART MGD POE+ SWITCH 24PORT
Quick View
SMART MGD POE+ SWITCH 24PORT
  • Switch Type: managed
  • Model #: SM24TAT2SA-NA
BLACK BOX LGB710A GIGABIT ETHERNET (1000-MBPS) WEB SMART SWITCH - (8) 10/100/1000-MBPS COPPER RJ45
Quick View
  •  
  • S$278.63 –
  • S$86.61 Shipping
Adder - CATX-USB - Computer Access Module RJ45 Socket - USB & VGA
Quick View
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EP-100NAS
  •  
  • S$575.63 –
  • S$78.11 Shipping
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
Quick View
Netgear Inc.
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
  • Brand: NETGEAR
  • Part Number: GS748-100NAS
  • Format: Rack-mountable, Desktop, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS748-100NAS
  •  
  • S$895.31 –
  • S$104.39 Shipping
QNAP, Optical Transceiver 10GbE SFP+ 850nm SR up to 300m industrial-temperature (-40 ~85)
Quick View
  •  
  • S$99.35 –
  • S$63.68 Shipping
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
Quick View
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
  • Brand: Juniper Networks, Inc.
  • Series: EX4400
  • Part Number: EX4400-24P
  • Format: Rackmount
  • Model #: EX4400-24P
HPE SN3600B 32Gb 24/8 8-port 16Gb Short Wave SFP+ Fibre Channel Switch R4G55B
Quick View
  •  
  • S$7,399.07 –
  • S$348.36 Shipping
Manhattan 153201 4K @ 60 Hz DisplayPort to HDMI Cable (6-Foot)
Quick View
  •  
  • S$44.27 –
  • S$41.73 Shipping
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EPP-100NAS
  •  
  • S$496.79 –
  • S$87.17 Shipping
10 PORT GIGABIT MANAGED POE+ SWITCH
Quick View
10 PORT GIGABIT MANAGED POE+ SWITCH
  • Switch Type: ethernet
  • Model #: LPB3010A
SonicWall 100GBase-SR4 QSFP28 850nm 100m Module  - For Firewall - 1x 100GBase-SR4 Network - Optical Fiber - Multi-mode - 100 Gigabit Ethernet - 100GBase-SR4 - TAA - 02-SSC-5806
Quick View
SonicWall
SonicWall 100GBase-SR4 QSFP28 850nm 100m Module - For Firewall - 1x 100GBase-SR4 Network - Optical Fiber - Multi-mode - 100 Gigabit Ethernet - 100GBase-SR4 - TAA - 02-SSC-5806
  • Brand: SonicWall
  • Part Number: 02-SSC-5806
  • Switch Type: 100GBase-SR4 QSFP28 Transceiver Module
  • Format: QSFP28
  • Model #: 02-SSC-5806
  •  
  • S$944.99 –
  • S$77.29 Shipping
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
Quick View
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
  • Brand: HPE
  • Series: Networking CW 2050
  • Part Number: S6X70A#ABA
  • Switch Type: 48-Port Gigabit Managed Switch
  • Model #: S6X70A#ABA
  •  
  • S$1,207.43 –
  • S$108.55 Shipping
TRENDnet 10-Port Multi-Gig Web Smart Switch, TEG-3102WS, 8 x 2.5GBASE-T Ports, 2 x 10G SFP+ Slots, Ethernet Splitter, Metal Housing, NDAA & TAA Compliant, Lifetime Protection, Black
Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.4
  • Model #: SW-108
HPE Networking Instant On 1930 24-port PoE Switch, 4 SFP+ ports 370W | JL684B#ABA
Quick View
HPE Networking Instant On 1930 24-port PoE Switch, 4 SFP+ ports 370W | JL684B#ABA
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Buffer Memory: 1.5 MB
  • PoE: Yes
  • Model #: JL684B#ABA
Black Box Gigabit Managed Ethernet Switch - 10-Ports
Quick View
Black Box Gigabit Managed Ethernet Switch - 10-Ports
  • Switch Type: Others
  • Model #: LGB1110A
ZyXEL 5 Port Gigabit Ethernet Unmanaged POE+ Switch, 4 x PoE+ @ 60W, GS1005HP
Quick View
ZyXEL 5 Port Gigabit Ethernet Unmanaged POE+ Switch, 4 x PoE+ @ 60W, GS1005HP
  • Brand: ZyXEL
  • Part Number: GS1005HP
  • Switch Type: Manageable: Yes
  • Format: Desktop, Wall-Mount
  • Model #: GS1005HP
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.35
  • Model #: SW-104
D-Link DMS-1250-28P Ethernet Switch - 24 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 3 Layer Supported - 592.19 W Consumption - 475 W PoE Budget
Quick View
  •  
  • S$1,616.75 –
  • S$109.42 Shipping
HPE Broadcom BCM5719 Ethernet 1Gb 4-port BASE-T OCP3 Adapter P51181B21
Quick View
  •  
  • S$251.63 –
  • S$54.57 Shipping
TP-Link TL-SG2008P | Jetstream 8 Port Gigabit Smart Managed PoE Switch | 4 PoE+ Port @ 62W | Omada SDN Integrated | PoE Recovery | IPv6 | Static Routing | L2/L3/L4 QoS |Limited Lifetime Protection
Quick View
TP-Link TL-SG2008P | Jetstream 8 Port Gigabit Smart Managed PoE Switch | 4 PoE+ Port @ 62W | Omada SDN Integrated | PoE Recovery | IPv6 | Static Routing | L2/L3/L4 QoS |Limited Lifetime Protection
  • Switch Type: ethernet
  • Format: Desktop
  • Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3x, IEEE 802.1d, IEEE 802.1s, IEEE 802.1w, IEEE 802.1q, IEEE 802.1p, IEEE 802.1x
  • Primary Ports: 8 x RJ45
  • Model #: SG2008P
TP-Link TL-SG1218MPE | 16 Port Gigabit PoE Switch | Easy Smart Managed | 16 PoE+ Ports @250W, 2 Non-PoE Ports, 2 Combo SFP Slots | QoS, Vlan, IGMP & LAG | Limited Lifetime Protection | Port Priority
Quick View
TP-Link TL-SG1218MPE | 16 Port Gigabit PoE Switch | Easy Smart Managed | 16 PoE+ Ports @250W, 2 Non-PoE Ports, 2 Combo SFP Slots | QoS, Vlan, IGMP & LAG | Limited Lifetime Protection | Port Priority
  • Switch Type: other
  • Format: Rackmount
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at, IEEE 802.1q, IEEE 802.1p
  • Primary Ports: 16 x RJ45 + 2 x SFP
  • Model #: TL-SG1218MPE
TRENDnet 24-Port Unmanaged Gigabit GREENnet Desktop Switch, Ethernet Network Switch, 24 x 10-100-1000 Gigabit Ethernet RJ-45 Ports, 48Gbps Switching Capacity, Lifetime Protection, Black, TEG-S24DG
Quick View
TRENDnet 24-Port Unmanaged Gigabit GREENnet Desktop Switch, Ethernet Network Switch, 24 x 10-100-1000 Gigabit Ethernet RJ-45 Ports, 48Gbps Switching Capacity, Lifetime Protection, Black, TEG-S24DG
  • Brand: TRENDnet
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX IEEE 802.3ab 1000Base-T IEEE 802.3x Flow Control IEEE 802.3az (draft 2.0)
  • Network Management Type: Unmanaged
  • Model #: TEG-S24DG
  •  
  • S$118.34 –
  • S$67.02 Shipping

Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.

Network Switches Are Versatile Networking Solutions

Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.

Switches Accommodate Shifts in Business and IT Trends

Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.

Multiple Network Management Options Provide a Positive User Experience

There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.

Switches Provide the Highest Levels of Security

Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.

Network Switches Provide Comprehensive and Advanced Networking Features

Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.