SHOP BY Primary Ports

Quick View
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3af Power over Ethernet
- Primary Ports: "Data" Input Ports: 24x RJ-45 STP "PoE (Data+Power)" Output Ports: 24x RJ-45 STP Management Port: 1 x RJ-45; 10/100Base-TX, auto-negotiation, auto-MDI / MDIX
- Primary Port Speed: 10/100/1000Mbps
- Model #: POE-2400G
- S$714.95 –
- S$105.72 Shipping

Quick View
Opengear DC Adapter 450041
- Model #: 450041
- S$179.27 –
- More options from S$179.27
- S$60.37 Shipping

Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-501T
- S$167.40 –
- S$60.58 Shipping

Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
- MAC Address Table: 2K
- Model #: ISW-621TS15
- S$200.99
- See price in cart
- S$47.38 Shipping

Quick View
HPE 5406R 44GT PoE+/4SFP+ (No PSU) v3 zl2 Switch
- Format: Rack-mountable
- Primary Port Speed: 10GBase-X 10/100Base-TX 10/100/ 1000Base-T
- Weight: 28.11 lb
- Package Contents: Package Contents: 5406R 44GT PoE+/4SFP+ (No PSU) v3 zl2 Switch 1 x HP 5400R zl2 Management Module (J9827A) 1 x HP 5412R zl2 Switch Fan Tray (J9831A) 1 x HP 24-port 10/100/1000BASE-T PoE+ MACsec v3 zl2 Module (J9986A) 1 x HP 20-port 10/100/1000BASE-T PoE+ / 4-port 1G/10GbE SFP+ MACsec v3 zl2 Module (J9990A) Mounting Hardware
- Model #: JL003A
- S$18,838.43 –
- S$213.21 Shipping

Quick View
TP-Link TL-SG1210PP 8-Port Gigabit and 1x Combo SFP Slot PoE Switch with 6 PoE+ and 2 PoE++ Ports
- Format: Desktop
- Primary Ports: 9 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 9 x 10/100/1000Mbps RJ45 Ports 1 x 1000Mbps Combo SFP/RJ45 Port
- Model #: TL-SG1210PP
- S$257.28 –
- More options from S$257.28 - S$263.44
- S$62.96 Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 2p 10GBT 2p SFP+ 1960 (JL806A#ABA)
- Primary Ports: 26 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- SNMP: Yes
- Layer: 2
- Model #: JL806A#ABA
- S$1,078.84 –
- S$123.45 Shipping

Quick View
TRENDnet 8-Port 2.5G PoE++ Switch, TPE-BG380, 8 x 2.5GB PoE++ Ports, 230W Poe Power Budget, 40Gbps Switching Capacity, NDAA + TAA Compliant, Lifetime TRENDnet Protection
- Brand: TRENDnet
- Series: ProSafe
- Part Number: TPE-BG380
- Format: Desktop
- Model #: TPE-BG380
- S$328.43 –
- More options from S$328.43 - S$447.57
- S$74.71 Shipping

Quick View
- S$595.50 –
- S$78.12 Shipping

Quick View
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
- Model #: IGS-624HPT
- S$489.99
- See price in cart
- S$124.86 Shipping

Quick View
Fortinet FortiSwitch 248E-POE, Layer 2/3 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 SFP ports, 24 port PoE w/ maximum 370 W limit | FS-248E-POE
- Brand: Fortinet
- Series: 200 Series
- Part Number: FS-248E-POE
- Format: Rackmount
- Model #: FS-248E-POE
- S$3,222.71 –
- S$140.49 Shipping

Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
- Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
- Model #: WGSW-24040
- S$437.99
- See price in cart
- S$133.02 Shipping

Quick View
RUCKUS ICX 8200 Switch, 24x10/100/1000 Mbps PoE+ ports, 4x25 GbE SFP28 stacking/uplink-ports, 370 W PoE budget, three-year remote TAC support. Power cord not included - OEM
- Part Number: ICX8200-24P
- Primary Ports: Interfaces: 24x10/100/1000 Mbps RJ45 ; 4x1/10/25 Gbps SFP/SFP+/SFP28 uplinks; USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 24
- Power: Max Power Consumption: 525 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
- Model #: ICX8200-24P
- S$5,139.71 –
- S$93.66 Shipping

Quick View
TRENDnet 10-Port Hardened Industrial Unmanaged Gigabit PoE ++ DIN-Rail Switch, 4 Gigabit PoE++ Ports, 4 Gigabit PoE+, 2 Gigabit Share Ports SFP or RJ-45, 360W Power Budget, Black, TI-BG104
- Brand: TRENDnet
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.1ax IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az IEEE 802.3af IEEE 802.3at IEEE 802.3bt
- Network Management Type: HTTP web-based GUI CLI: Telnet / SSHv2 SNMP v1, v2c, v3 SNMP trap (up to 5 receivers) RMON groups 1/2/3/9 Device configuration backup & restore, upgrade firmware, reboot, and reset to default Multiple administrative or read-only user accounts Enable or disable power saving mode per port Static MAC entries LLDP (Link layer discovery protocol) Netlite device map ONVIF device discovery SNTP SMTP alert Syslog Port statistics/utilization Traffic monitor Port mirror: one to one, many to one Storm control: Broadcast, multicast, destination lookup failure (Min. limit: 1pps) Loop...
- Model #: TI-BG62i
- S$832.89 –
- More options from S$832.89 - S$1,042.37
- S$53.08 Shipping

Quick View
RUCKUS ICX 8200 Compact Switch, 8x10/100/1000 Mbps PoE+ ports, 2x10 GbE SFP+ stacking/uplink-ports, 124 W PoE budget, three-year remote TAC support. Power cord not included | ICX8200-C08PF - OEM
- Brand: Ruckus Wireless
- Series: RUCKUS ICX 8200
- Part Number: ICX8200-C08PF
- Format: Desktop
- Model #: ICX8200-C08PF
- S$2,854.43 –
- S$87.16 Shipping

Quick View
TP-Link TL-SG1005P| 5 Port Fast Ethernet PoE Switch | 4 PoE+ Ports @67W | Desktop | Plug & Play | Sturdy Metal w/ Shielded Ports | Fanless | Limited Lifetime Protection | Extend & Priority Mode
- Brand: TP-Link
- Switch Type: desktop
- Format: Desktop
- Network Management Type: Unmanaged
- Model #: TL-SG1005P
- S$127.43 –
- More options from S$101.82 - S$127.43
- Free Shipping

Quick View
TRENDnet 5-Port 10G Switch, TEG-S750, 5 x 10G RJ-45 Ports, 100Gbps Switching Capacity, Supports 2.5G and 5G-Base-T Connections, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
- Weight: 3.5200
- Model #: TEG-S750
- S$359.47 –
- More options from S$359.47 - S$424.15
- S$81.85 Shipping

Quick View
Schneider Electric NetBotz 125kHz Rack Access Control
- Model #: 731304332077
- S$1,234.43 –
- More options from S$1,234.43 - S$1,357.21
- S$67.11 Shipping

Quick View
TP-Link TL-SG1210MPE 10-Port Gigabit Easy Smart Switch with 8-Port PoE+
- Format: Desktop
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p, IEEE 802.3at, IEEE 802.3z
- Primary Ports: 9 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1210MPE
- S$228.60 –
- More options from S$228.60 - S$341.49
- S$62.99 Shipping

Quick View
TRENDnet 16-Port Gigabit Switch, TEG-S17, 16 x Gigabit RJ-45 Ports, 32Gbps Switching Capacity, Fanless Design, Metal Enclosure, Internal Power Supply, Lifetime Protection, Black
- Weight: 6.3800
- Model #: TEG-S17
- S$140.52 –
- S$67.51 Shipping

Quick View
GIGABIT ETHERNET (1000-MBPS) MANAGED SWITCH - (20) SFP, (4) 100/1000-MBPS DUAL-M
- Model #: LGB5124A-R2
- S$1,175.03 –
- More options from S$1,175.03 - S$1,287.45
- S$93.72 Shipping

Quick View
TP-Link Omada 6-Port 10/100Mbps Unmanaged Desktop Switch with 4-Port PoE+ - 10 Ports - Gigabit Ethernet - 10/100/1000Base-T, 10/100Base-T - 2 Layer Supported - 2.52 W Power Consumption - DS106P
- Brand: TP LINK
- Model: DS106P
- Part Number: DS106P
- Model #: DS106P
- S$127.43 –
- More options from S$72.21 - S$132.92
- Free Shipping

Quick View
RUCKUS ICX 8200 Compact Switch, 4x100/1000/2500 Mbps PoE++ ports, 4x 1/2.5/5/10Gbps PoE++ ports, 2x25 GbE SFP28 stacking/uplinkports, 240 W PoE budget, 3-Y remote TAC support | ICX8200-C08ZP - OEM
- Part Number: ICX8200-C08ZP
- Uplink Interface: 4× 100/1000/2500 Mbps RJ-45 PoE++ 90W ports; 4× 1/2.5/5/10 Gbps RJ-45 PoE++ 90W ports; 2× 1/10/25 GbE uplink/stacking SFP28 ports; USB Type-C port;RJ45 serial port;USB Type-A port;RJ45 Ethernet port (For console manag
- Power: Power Over Ethernet (PoE) Support: Yes PoE Power Consumption: 240W
- Max Power Consumption: Power / Device Type: Power Supply Max Power Consumption: 305 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Model #: ICX8200-C08ZP
- S$5,016.59 –
- S$90.92 Shipping

Quick View
Micro Mini Media Converter, 10-/100-/1000-Mbps Copper to 1000-Mbps Duplex Fiber, Multimode, 850-nm, 0.5 km, SC
- Model #: LMC4002A
- S$612.35 –
- S$56.84 Shipping

Quick View
Netgear AV Line M4350-8M2V 8-Port Managed Switch, 2.5G/10G/25G Multi-Gigabit Ethernet
- Brand: NETGEAR
- Part Number: MSM4310-100NES
- Format: Rack-mountable
- Standards: 2.5GBase-T, 25GBase-X, 1000Base-T, 10GBase-X
- Model #: MSM4310-100NES
- S$5,873.03 –
- S$119.57 Shipping

Quick View
Ruckus ICX8200-24 24 Ports 1G PoE Enterprise-Class Stackable Access Switch with Future-Proof Expandability - OEM
- Part Number: ICX8200-24
- Uplink Interface: Interfaces: 24x10/100/1000 Mbps RJ45 ; 4x1/10/25 Gbps SFP/SFP+/SFP28 uplinks; USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 24
- Max Power Consumption: Max Power Consumption: 65 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
- Model #: ICX8200-24
- S$3,910.67 –
- S$104.52 Shipping

Quick View
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: ISW-801T
- S$963.35 –
- S$47.38 Shipping

Quick View
TRENDnet 52-Port Gigabit Web Smart PoE+ Switch with 10G SFP+ Ports, TPE-3524S, 48 x Gigabit PoE+ Ports, 4 x 10G SFP+ Ports, 410W PoE Power Budget, Lifetime Protection, Black
- Weight: 17.0500
- Model #: TPE-3524S
- S$992.42 –
- More options from S$992.42 - S$1,223.62
- S$108.01 Shipping

Quick View
TRENDnet 10-Port Industrial Gigabit L2 Managed PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 24-57V DC Power Input, IP30, VLAN, Black, TI-PG102i
- Switch Type: Switches
- Format: DIN Rail Mount
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.1ax IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az IEEE 802.3af IEEE 802.3at
- Primary Ports: 8 x Gigabit PoE+ ports 2 x 100/1000 Mbps SFP slots
- Model #: TI-PG102i
- S$656.92 –
- More options from S$656.92 - S$865.34
- S$74.72 Shipping

Quick View
TRENDnet TI-PGM541, 5-port Industrial Gigabit PoE+ DIN-Rail Switch
-20° 65°C (-4° 149°F)
- Features: • 4 x Gigabit PoE+ ports • 1 x Gigabit SFP slot • 120W PoE power budget • 10Gbps switching capacity • Hardened IP30 rated metal switch • Includes DIN-Rail and wall mounts • Operating temperature range of -20° – 65°C (-4° – 149°F) • Redundant power inputs with overload current protection • Alarm output triggered by power
- Weight: 2.3700
- Model #: MBVB09VYGSCJ6
- S$177.31 –
- More options from S$177.31 - S$221.32
- S$47.56 Shipping

Quick View
- S$829.95 –
- More options from S$718.19 - S$829.95
- S$75.40 Shipping

Quick View
HPE CW 2150 48p 10M/100M/1G PoE+ 4p SFP+ 1G/10G 770W Switch - 48 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 969 W Power - S6X54A#ABA
- Brand: HPE
- Model: S6X54A#ABA
- Part Number: S6X54A#ABA
- Dimensions: 17.3 in x 10.2 in x 1.7 in
- Model #: S6X54A#ABA
- S$2,667.59 –
- S$109.21 Shipping

Quick View
TP-Link Omada 5-Port Gigabit Easy Managed Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 2 Layer Supported - 65 W PoE Budget - Twisted Pair - PoE Ports - Desktop, Wall Mountabl
- Brand: TP-Link
- Uplink Interface: RJ45
- Primary Ports: RJ45
- Primary Port Speed: 5000 megabits_per_second
- Model #: ES205GP
- S$92.49 –
- More options from S$92.49 - S$99.79
- S$81.41 Shipping
Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.
Network Switches Are Versatile Networking Solutions
Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.
Switches Accommodate Shifts in Business and IT Trends
Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.
Multiple Network Management Options Provide a Positive User Experience
There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.
Switches Provide the Highest Levels of Security
Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.
Network Switches Provide Comprehensive and Advanced Networking Features
Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.






