Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Show More
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
VLAN Support
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
MokerLink 8 Port Gigabit PoE Switch, 8 PoE+ Ports 1000Mbps, 802.3af/at 120W, Metal Fanless Unmanaged Plug and Play
Quick View
  •  
  • $82.45 –
  • Free Shipping
Direct from TAURKENAM Direct from TAURKENAM
MokerLink 8 Port PoE Switch with 2 Gigabit Uplink, 802.3af/at PoE+ 100Mbps, 120W Built-in Power, Extend to 250Meter, Metal Plug & Play
Quick View
  •  
  • $104.45 –
  • Free Shipping
Direct from TAURKENAM Direct from TAURKENAM
10 Port Gigabit PoE Switch, 8 GE PoE+, 2 GE Uplink, 10/100/1000Mbps, 120W 802.3af/at PoE, Fanless Plug & Play Ethernet Switch
Quick View
  •  
  • $79.99 –
  • Free Shipping
Direct from BFKK Direct from BFKK
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 120W Built-in Power, 802.3af/at Compliant, Managed PoE+ Switch Support VLAN, QoS, Fanless Metal, Plug and Play(Desktop/Wall Mount)
Quick View
  •  
  • $74.99 –
  • Free Shipping
8 Port Gigabit PoE Switch, 8 PoE+ Ports 1000Mbps, 120W 802.3af/at, Metal Fanless Unmanaged Plug and Play
Quick View
  •  
  • $79.99 –
  • Free Shipping
Direct from BFKK Direct from BFKK
MokerLink 8 Port Outdoor Gigabit PoE Switch, 8 PoE+ Ports 1000Mbps, 802.3af/at 120W, Weatherproof Fanless Unmanaged Plug and Play
Quick View
  •  
  • $113.45 –
  • Free Shipping
Direct from TAURKENAM Direct from TAURKENAM
Intellinet 8-Port Gigabit PoE+ Switch, PoE Passthrough, 85W Budget | IEEE 802.3bt PD input, 8 Gigabit RJ45 ports, 85W PoE passthrough, fanless metal housing, up to 656 ft reach
Quick View
Intellinet 8-Port Gigabit PoE+ Switch, PoE Passthrough, 85W Budget | IEEE 802.3bt PD input, 8 Gigabit RJ45 ports, 85W PoE passthrough, fanless metal housing, up to 656 ft reach
  • Brand: Intellinet Network Solutions
  • Model: Unmanaged Gigabit Ethernet PoE Switch
  • Part Number: 8
  • Format: Desktop
  • Model #: RNAB08M6FG7VP
  • $141.99
  •  
  • $112.99 –
  • Save: $29.00 (20%)
  • Free Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
8 Port Outdoor Gigabit PoE Switch, 8 PoE+ Ports 1000Mbps, 802.3af/at 120W, Weatherproof Fanless Unmanaged Plug and Play
Quick View
  •  
  • $129.99 –
  • Free Shipping
Direct from BFKK Direct from BFKK