Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Department
Show More
Brands
Show More
Price
Show More
Thunderbolt
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
Sort By:
View:
Enlabs USB 3.0 Motherboard 20-Pin Header to 2x USB 3.0 A Female Adapter Cable w/ Full Profile PCI Slot Bracket ,2 Ports USB 3.0 Back Panel Expansion Bracket to 20Pin - Black,1.64ft
Quick View
Enlabs USB 3.0 Motherboard 20-Pin Header to 2x USB 3.0 A Female Adapter Cable w/ Full Profile PCI Slot Bracket ,2 Ports USB 3.0 Back Panel Expansion Bracket to 20Pin - Black,1.64ft

Limited time offer, ends 10/30

  • Type: USB 3.0
  • Connector Type: USB to 20 pins
  • Cable Length: 1.64 ft. (0.50m)
  • Connector Number: 3
  • Model #: PCIU320P2AFBK
  •  
  • $10.59 –
  • Free Shipping
Available Direct from EN-Labs Available Direct from EN-Labs
Enlabs MB20P22U310IN 2 Port Internal USB 3.0 Motherboard  20-Pin Header to 2x USB 3.0 A 10-Inch Female Adapter Cable,USB 20pin to 2 x USB 3.0 Splitter Cable -Black
Quick View
Enlabs MB20P22U310IN 2 Port Internal USB 3.0 Motherboard 20-Pin Header to 2x USB 3.0 A 10-Inch Female Adapter Cable,USB 20pin to 2 x USB 3.0 Splitter Cable -Black

Limited time offer, ends 10/30

  • Cable Length: 10 in.
  • Type: USB Cable
  • Connector Type: Internal 20pin to USB 3.0
  • Connector Number: 3
  • Model #: MB20P22U310IN
  •  
  • $11.19 –
  • Free Shipping
Available Direct from EN-Labs Available Direct from EN-Labs
Gold-plated USB 3.0 A to A Male Cable [3 Pack 10ft],USB3.0 to USB3.0 Cable USB Male to Male Cable USB Cord with Gold-Plated Connector for Hard Drive Enclosures, DVD Player, Laptop Cooler
Quick View
Gold-plated USB 3.0 A to A Male Cable [3 Pack 10ft],USB3.0 to USB3.0 Cable USB Male to Male Cable USB Cord with Gold-Plated Connector for Hard Drive Enclosures, DVD Player, Laptop Cooler

Limited time offer, ends 10/14

  • Type: Extension Cables
  • Connector Type: USB A to USB A
  • Terminal Gender: Male to Male
  • Speed: Up to 5Gbps Transfer Rate
  • Model #: A-UAB3.0M2M-2m3P
  •  
  • $18.97 –
  • Free Shipping
Available Direct from AUBEAMTO Available Direct from AUBEAMTO
Nippon Labs 50USB2-CM-AM-10 10 ft. USB-C Male to USB A Male Charge and Data Transfer Cable - Black
Quick View
Nippon Labs 50USB2-CM-AM-10 10 ft. USB-C Male to USB A Male Charge and Data Transfer Cable - Black
  • Cable Length: 10 ft.
  • Type: USB 2.0
  • Connector Type: USB C to USB A
  • Connector Number: 2
  • Model #: 50USB2-CM-AM-10
Available Direct from Nippon Labs Available Direct from Nippon Labs
EnLabs USB10GCMF20CM 8 inches USB-C Type C Male to Female USB 3.1 Gen 2(10Gbps) Port Saver Adapter Cable - Black
Quick View
EnLabs USB10GCMF20CM 8 inches USB-C Type C Male to Female USB 3.1 Gen 2(10Gbps) Port Saver Adapter Cable - Black

Limited time offer, ends 10/30

  • Cable Length: 8 in.
  • Type: USB Cable
  • Connector Type: USB type-c male to female
  • Connector Number: 2
  • Model #: USB10GCMF20CM
  •  
  • $9.69 –
  • Free Shipping
Direct from EN-Labs Direct from EN-Labs
SMA [2 PACK] USB C to C Charging Cable 10ft/3M, 60W Fast Type C to C Charger Cord Long for i-Phone 16/16 Pro Max/15 Plus/15 Pro Max, MacBook Pro 2021/2020/2019/2018,iPad 12.9/11 inch/Mini/Air 5/4 etc.
Quick View
SMA [2 PACK] USB C to C Charging Cable 10ft/3M, 60W Fast Type C to C Charger Cord Long for i-Phone 16/16 Pro Max/15 Plus/15 Pro Max, MacBook Pro 2021/2020/2019/2018,iPad 12.9/11 inch/Mini/Air 5/4 etc.

Limited time offer, ends 10/10

  • Cable Length: 10ft / 3M
  • Type: USB Cable
  • Connector Type: USB C to USB C
  • Connector Detail: 1 x USB C to 1 x USB C
  • Model #: Z2#Q2846_W_3M_2PCS
Low Profile Header USB 3.0 19/20 Pin Internal Extension Male to Female Adapter Flat Cable for Motherboard -Solve the problem that the USB port is blocked by graphics card  - 6 inches
Quick View
  •  
  • $10.89 –
  • Free Shipping
Direct from EN-Labs Direct from EN-Labs
9 Pin 2 in 1 Internal USB Splitter Cable, 9 pin USB Header Male 1 to 2 Female Extension Connector Adapter, USB 2.0 HUB Connector Port Multiplier PWM Fan Splitter Cable (30cm/0.98ft)
Quick View
  •  
  • $13.29 –
  • Free Shipping
Direct from BUCIER Direct from BUCIER
EnLabs 2 Port USB 2.0 Bracket Cable,Motherboard USB 2.0 9pin to 2 x Female Adapter Splitter Cable w/ Full-Profile PCI Slot Cover - (1ft/30CM, Gray)
Quick View
EnLabs 2 Port USB 2.0 Bracket Cable,Motherboard USB 2.0 9pin to 2 x Female Adapter Splitter Cable w/ Full-Profile PCI Slot Cover - (1ft/30CM, Gray)

Limited time offer, ends 10/30

  • Cable Length: 1 ft.
  • Type: Adapter
  • Connector Type: USB 2.0 10pin to 2 x Type A female
  • Model #: PCIU210P2AGY
  •  
  • $7.69 –
  • Free Shipping
Available Direct from EN-Labs Available Direct from EN-Labs
Cablecc Type-C USB-C to HDMI 4K@120hz USB 3.0 OTG Converter HDTV Multiport Adapter with Female PD 100W Power Port UC-027-Y005
Quick View
  •  
  • $11.99 –
  • $39.99 Shipping
Available Direct from Cablecc Available Direct from Cablecc
USB 3.0 Header Extension Cable 19/20 Pin 1 to 2 Y Splitter Internal Extension Adapter DIY(5.9 inch)
Quick View
USB 3.0 Header Extension Cable 19/20 Pin 1 to 2 Y Splitter Internal Extension Adapter DIY(5.9 inch)

Limited time offer, ends 11/04

  • Connector Type: Lighting Connector to USB A
  • Model #: 1654979464
  •  
  • $16.29 –
  • Free Shipping
Direct from BUCIER Direct from BUCIER
2 Pack Mini Flashlight USB C LED Light Brightness 210 Lumens Get Power from Phone/Power Bank Small Size & Easy to Carry with Hook Hole
Quick View
  •  
  • $10.54 –
  • Free Shipping
Direct from ZFBASCENTGO Direct from ZFBASCENTGO
Nippon Labs 50USB2-CM-AM-6 6 ft. USB-C Male to USB A Male Charge and Data Transfer Cable - Black
Quick View
Nippon Labs 50USB2-CM-AM-6 6 ft. USB-C Male to USB A Male Charge and Data Transfer Cable - Black

Limited time offer, ends 10/14

  • Cable Length: 6 ft.
  • Type: USB 2.0
  • Connector Type: USB C to USB A
  • Connector Number: 2
  • Model #: 50USB2-CM-AM-6
Available Direct from Nippon Labs Available Direct from Nippon Labs
Enlabs INU29P1X2 Motherboard USB 2.0 9pin Header 1 to 2 Extension Hub Splitter Adapter - Converter MB USB 2.0 Male to 2 Male - 30CM USB 9-pin Internal Cable
Quick View
Enlabs INU29P1X2 Motherboard USB 2.0 9pin Header 1 to 2 Extension Hub Splitter Adapter - Converter MB USB 2.0 Male to 2 Male - 30CM USB 9-pin Internal Cable

Limited time offer, ends 10/30

  • Cable Length: 1 ft.
  • Type: Adapter
  • Connector Type: USB 2.0 9pin 1 to 2 splitter hub
  • Specifications: Internal USB 2.0 9pin 1 to 2 ports Hub Duplicate motherboard USB 2.0 header to two Convert motherboard USB 2.0 Male to 2 Male 1ft USB 2.0 internal cable for motherboard and hub connecting Self-Stick for easy installation
  • Model #: INU29P1X2
  •  
  • $9.09 –
  • Free Shipping
Direct from EN-Labs Direct from EN-Labs
USB C to USB C Fast Charging Cable 15Ft, RIITOP USB 3.1 Gen 2 10Gbps Type C Cable with E-Marker Chipset, PD Charging 96W(20V 5A),Compatible with Gaming Box, Digital Camera, Oculus Quest 2 Link
Quick View
  •  
  • $39.99 –
  • $17.76 Shipping
  • $24.50 - $39.99
AUTYUE 2PCS Short USB A to USB C Cable, USB 3.2 to USB C Cable, Flat Type C Cable 3A 60W Fast Charging USB Type C Charging Short Cord for Power Bank,iPad Pro,i-Phone 15/16,Car-Play (0.65FT/0.2M)
Quick View
AUTYUE 2PCS Short USB A to USB C Cable, USB 3.2 to USB C Cable, Flat Type C Cable 3A 60W Fast Charging USB Type C Charging Short Cord for Power Bank,iPad Pro,i-Phone 15/16,Car-Play (0.65FT/0.2M)

Limited time offer, ends 10/10

  • Cable Length: 7.87 in. (20cm)
  • Color: Black
  • Connector Detail: 1 x USB 3.2 to 1 x USB C
  • Specifications: USB A to USB C Cable
  • Model #: Q3295_0.2M_2PCS
  •  
  • $10.99 –
  • Free Shipping
Available Direct from AUTYUE Available Direct from AUTYUE
Cablecc USB 3.1 Type-C USB-C Source to HDMI HDTV Displays Male 4K Monitor Cable for Laptop 1.8m UC-018-HDF
Quick View
  •  
  • $11.88 –
  • $39.99 Shipping
Available Direct from Cablecc Available Direct from Cablecc
Tripp Lite 3 ft. USB 3.1 Gen 2 USB-C to USB-A Cable (M/M), 10 Gbps, 3' USB Type-C to Type-A, Fast Charging (U428-003-G2)
Quick View
Tripp Lite 3 ft. USB 3.1 Gen 2 USB-C to USB-A Cable (M/M), 10 Gbps, 3' USB Type-C to Type-A, Fast Charging (U428-003-G2)
  • Type: USB 3.1
  • Connector Type: USB C to USB A
  • Connector Number: 2
  • Connector Detail: 1 x USB Type-C (USB-C) 1 x USB-A
  • Model #: U428-003-G2
Lian Li PW-U2HB ,Interal USB 2.0 1 to 3 HUB,Black Color --------- PW-U2TPAB
Quick View
Available Direct from Lian Li Available Direct from Lian Li
Plugable USB4 Cable with 240W Charging, 3.3 Feet (1M), USB-IF Certified, 1x 8K Display, 40 Gbps, Compatible with USB 4, Thunderbolt 4, Thunderbolt 3, USB-C
Quick View
  •  
  • $25.95 –
  • Free Shipping
Direct from Plugable Technologies Direct from Plugable Technologies
3 Pack USB3.0 Extension Cable [1.5FT+1.5FT+1.5FT], USB 3.0 to USB 3.0 Cable USB Male to Female USB3.0 Extension Cord Compatible with Xbox, Keyboard, Mouse, USB Flash Drive, Printer, Camera and More
Quick View
3 Pack USB3.0 Extension Cable [1.5FT+1.5FT+1.5FT], USB 3.0 to USB 3.0 Cable USB Male to Female USB3.0 Extension Cord Compatible with Xbox, Keyboard, Mouse, USB Flash Drive, Printer, Camera and More

Limited time offer, ends 10/14

  • Type: USB 3.0
  • Connector Type: USB A to USB A
  • Terminal Gender: Male to Female
  • Speed: Up to 5Gbps Transfer Rate
  • Model #: A-USBAM2F-3P0.5M
  •  
  • $13.97 –
  • Free Shipping
Available Direct from AUBEAMTO Available Direct from AUBEAMTO
Tripp Lite USB 3.1 Gen 1 (5 Gbps) Cable, USB Type-C (USB-C) to USB 3.0 Micro-B M/M, 3-ft. (U426-003)
Quick View
Tripp Lite USB 3.1 Gen 1 (5 Gbps) Cable, USB Type-C (USB-C) to USB 3.0 Micro-B M/M, 3-ft. (U426-003)
  • Brand: Tripp Lite
  • Model: U426-003
  • Type: Cables - USB Cables
  • Color: Black
  • Model #: U426-003
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
Quick View
HP
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
  • Brand: HP
  • Type: Gateway
  • Protocols: LLDP-MED for VLAN discovery; IPv4; TCP (RFC 793) in SSL/TLS; Domain Name System (DNS): A records (RFC 1706), SRV records (RFC 2782), RTP (RFC 1889, 1890), RFC 5966
  • Security: HTTPS secure provisioning; Local Access Interface: IVR password
  • Model #: 8F3H4AA#ABA
CY USB 3.1 Type-C USB-C Source to HDMI HDTV Displays Male 4K Monitor Cable for Laptop 1.8m
Quick View
  •  
  • $11.88 –
  • $39.99 Shipping
Available Direct from CY Available Direct from CY
Cablecc 90 Degree Up Down Angled Type-C USB-C Male to Male USB3.1 10Gbps 100W Data Cable for Laptop  Phone UC-064-UP-1.0M
Quick View
  •  
  • $9.99 –
  • $39.99 Shipping
Direct from Cablecc Direct from Cablecc
3 Pack USB-C to USB Adapter, Type-C Male to USB-A Female Converter, Fast Transfer Connector for Phones & Laptops
Quick View
Direct from AJMRTC Direct from AJMRTC
USB-A to USB-C 3.1 Gen 2 Adapter Charger Cable, Fast Charger, 10Gbps High-Speed, USB-IF Certified, for Apple iPhone 15, iPad, Samsung Galaxy, Tablets, Laptops, 10 Foot, 2Pack, Black
Quick View
USB-A to USB-C 3.1 Gen 2 Adapter Charger Cable, Fast Charger, 10Gbps High-Speed, USB-IF Certified, for Apple iPhone 15, iPad, Samsung Galaxy, Tablets, Laptops, 10 Foot, 2Pack, Black

Limited time offer, ends 10/25

  • Type: USB 3.2
  • Connector Type: USB A to USB C
  • Terminal Gender: Male to Male
  • Apple Compatible: USB-C port
  • Model #: W-PQ108-2P3M-3
  •  
  • $17.48 –
  • Free Shipping
Available Direct from Jansicotek Available Direct from Jansicotek
Cablecc 5pcs/lot DIY 24pin USB Type-C USB-C Male OTG Host Type 5.1k Resistor with Black Housing Cover UC-107-BK
Quick View
  •  
  • $7.99 –
  • $39.99 Shipping
Available Direct from Cablecc Available Direct from Cablecc
USB 3.2 Type C to USB C Cable 20Gbps 100W 1ft, 2-in-1 USB-A/C to USB-C Fast Charger Charging Cable Cord and Data Sync for Apple MacBook Pro/Air 2020,iPad Pro 2020,Samsung Galaxy S21,Type-C Laptops
Quick View
  •  
  • $19.95 –
  • Free Shipping
  • $13.50 - $19.95
EnLabs USB10GCMF1M USB Type C Extension Cable - USB-C USB 3.1 Gen 2(10Gbps) Male to Female Extending Port Saver Adapter Cable Cord - 3.3FT- Black
Quick View
EnLabs USB10GCMF1M USB Type C Extension Cable - USB-C USB 3.1 Gen 2(10Gbps) Male to Female Extending Port Saver Adapter Cable Cord - 3.3FT- Black

Limited time offer, ends 10/30

  • Cable Length: 3.28 ft. (1m)
  • Type: USB Extension Cable
  • Connector Type: USB-C Male to Female
  • Connector Number: 2
  • Model #: USB10GCMF1M
  •  
  • $12.49 –
  • Free Shipping
Direct from EN-Labs Direct from EN-Labs
avatar

Any questions? Our AI mode will help you find out quickly.

Did You Find It?