Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Sharp 86" Ultra High Definition Professional Display Model PN-M862
Quick View
Sharp 98" Ultra High Definition Professional Display Model PN-M982
Quick View
Sharp 43" UHD 4K HDR Commercial Monitor Model  PN-P436
Quick View
  • $1,839.99 - $1,849.99
Sharp 75" UHD 4K HDR Commercial Monitor  Model  PN-ME752
Quick View
Sharp 75" UHD 4K HDR Commercial Monitor Model PN-ME752
  • Brand: Sharp/NEC
  • Part Number: PN-ME752
  • Screen Size: 75"
  • Native Resolution: 3840 x 2160
  • Model #: PN-ME752
usb c 3.1 cable,usb c 10gbps type c data transfer cable 4K Video Output 100W Power Delivery Compatible with Thunderbolt 3 Tpye C CordMatebook, Chromebook and More Type-C Devices/Laptops/Hub,6.6FT2m
Quick View
usb c 3.1 cable,usb c 10gbps type c data transfer cable 4K Video Output 100W Power Delivery Compatible with Thunderbolt 3 Tpye C CordMatebook, Chromebook and More Type-C Devices/Laptops/Hub,6.6FT2m

Limited time offer, ends 10/25

  • Cable Length: 6.6
  • Brand: HOTUTUKI
  • Type: USB C to USB C Cable
  • Connector Type: USB Type C
  • Model #: USB-C 3.1
  •  
  • $20.99 –
  • Free Shipping
Yealink SIP-T44U SIP Phone for Workers of Co-working Space
Quick View
Yealink SIP-T44U SIP Phone for Workers of Co-working Space
  • Brand: Yealink
  • Part Number: SIP-T44U
  • Type: VoIP Phones
  • Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV(RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication: MD5/SHA1/SHA224/-SHA256/SHA384/ SHA512 OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
  • Model #: SIP-T44U
Yealink MP45 USB Phone Compatible with Microsoft Teams
Quick View
Yealink MP45 USB Phone Compatible with Microsoft Teams
  • Brand: Yealink
  • Part Number: MP45
  • Type: VoIP Phones
  • Ports: RJ9 handset port RJ9 headset port
  • Model #: MP 45
Cable Leader 1.6ft (0.5m) USB C to USB C Cable 10Gbps, USB 3.2 Gen 2 Type-C Data Cable, 60W PD Fast Charging, E-Marker, 4K Video, Black - for MacBook, iPhone, iPad, Samsung Galaxy & SSD
Quick View
  •  
  • $15.99 –
  • Free Shipping
UGREEN 100W Retractable USB C Cable, Fast Charging, White, 3.3FT
Quick View
  •  
  • $26.28 –
  • Free Shipping
Polaroid Hi-Print - Bluetooth Connected 3x3 Photo Dye-Sub Printer - 10 Photo Sheets Included (9196)
Quick View
  •  
  • $120.99 –
  • Free Shipping
Cable Leader 3.3ft (1m) USB C to USB C Cable 10Gbps, USB 3.2 Gen 2 Type-C Data Cable, 60W PD Fast Charging, E-Marker, 4K Video, White - for MacBook, iPhone, iPad, Samsung Galaxy & SSD
Quick View
  •  
  • $14.99 –
  • Free Shipping
USB C to C Cable, 3.2 Gen 2 USB-C Cable 10ft - 4K UHD 20Gbps 100W PD Fast Charging Cable for MacBook Pro, for iPad Pro, Nylon Braided, Black.
Quick View
USB C to C Cable, 3.2 Gen 2 USB-C Cable 10ft - 4K UHD 20Gbps 100W PD Fast Charging Cable for MacBook Pro, for iPad Pro, Nylon Braided, Black.
  • Brand: Elfesoul
  • Type: USB C to USB C
  • Connector Type: Usb 3.2 Type C
  • Color: Black
  • Model #: 234930397008
  •  
  • $31.49 –
  • Free Shipping
YEALINK T5 Series Expansion Module (YEA-EXP50)
Quick View
YEALINK T5 Series Expansion Module (YEA-EXP50)
  • Specifications: Display: 4.3" 272 x 480-pixel color display with backlight 16 bit depth color Three page views are possible Different color icons for each function shown on the LCD Features Keys and Indicator: 20 physical keys each with a dual-color LED 40 additional keys through page switch 3 independent control keys with illuminated LED are used for fast switching pages Programmable for shared line, BLF List, call park,conference, forward, group pickup, group listening, LDAP, XML Browser Features: Wallpaper Screensaver Power saving Avatar Display on SFB and UC platform (pending) Stand with 2 adjustable angles For support of two or three Expansion Modules, an external Yealink power adapter (5V / 2A) is required. Up to three EXP50 can be attached on any Yealink T5 Series IP phones: USB port (2.0 compliant) for data in and out USB port (2.0 compliant) for: wired / wirele...
  • Model #: YEA-EXP50
Yealink T54W IP Phone POE - Bluetooth and Wi-Fi Standard
Quick View
Yealink T54W IP Phone POE - Bluetooth and Wi-Fi Standard
  • Brand: Yealink
  • Type: Wireless VoIP
  • Features: Mid-level phone, ideal for professionals and managers with moderate call load 4.3" 480x272-pixel color display, fully adjustable HD Voice with Yealink Acoustic Shield technology 10 line keys, 16 SIP accounts, 27 memory keys Built-in Bluetooth, Wi-Fi Dual-port Gigabit Ethernet 1xUSB port for call recording and wireless USB headset Power supply not included
  • Model #: SIP-T54W
USB A to USBC Adapter Cable Type A 30 Male to Type C Female Data amp Charging Converter for Laptop and PCOculus Quest Link
Quick View
  •  
  • $19.17 –
  • Free Shipping
USB C Cable, USB-C Male to Male Coiled Spring Spiral Cable, 3A 10Gbps Fast Charging, Data Extension, 3FT/1M (M/M Left & Right)
Quick View
  •  
  • $22.98 –
  • Free Shipping
Coiled USB 3.1 Type C Cable, USB-C Male to Male Spring Spiral, 3A 10Gbps Fast Charging, Data Extension, Stretched 1.2M (M/M)
Quick View
  •  
  • $21.98 –
  • Free Shipping
USB C Female to Female Adapter 100W, Type C Couple Support 20Gbps Data Transfer for iPad Pro, Laptop, Phones and More Devices (2 Pack)
Quick View
  •  
  • $19.98 –
  • Free Shipping