Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Useful Links
Show More
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
W59R Cordless Ruggedized DECT IP Phone, Base Station Not Included, 1.8-Inch Color Display, Power Adapter Included
Quick View
  •  
  • $329.24 –
  • Free Shipping
Logitech Rally Plus with White Mic Pods - Video Conferencing Kit | 960-001398
Quick View
Logitech Rally Plus with White Mic Pods - Video Conferencing Kit | 960-001398
  • Brand: Logitech
  • Part Number: 960-001398
  • Type: Video Conference Device
  • Camera: Rally Camera Zoom: 15x HD zoom (5x optical + 3x digital) Pan: 180° (±90°) Tilt: 140° (+50° / -90°) Field of View Diagonal: 90° Horizontal: 82° Vertical: 52° Total Room Coverage: 262° wide x 192° tall (field of view + pan and tilt) Resolutions @ 30fps: 4K Ultra HD, 1440p, 1080p, 900p, 720p, and SD Resolutions @ 60fps: 1080p, 720p RightLight Technologies: Wide Dynamic Range (WDR), low-light compensation, video noise reduction, low-light saturation optimization Privacy: Lens parks at -90° in sleep mode for assured privacy
  • Model #: 960-001398
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
Quick View
HP
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
  • Brand: HP
  • Type: Gateway
  • Protocols: LLDP-MED for VLAN discovery; IPv4; TCP (RFC 793) in SSL/TLS; Domain Name System (DNS): A records (RFC 1706), SRV records (RFC 2782), RTP (RFC 1889, 1890), RFC 5966
  • Security: HTTPS secure provisioning; Local Access Interface: IVR password
  • Model #: 8F3H4AA#ABA
Magnasonic All-in-One 25MP Film Scanner with Large 5" Display & HDMI, Converts 35mm/126/110/Super 8 Film & 135/126/110 Slides into Digital Photos, Built-in Memory (FS70)
Quick View
  •  
  • $110.97 –
  • Free Shipping
Direct from MAGNASONIC Direct from MAGNASONIC
Lenovo ThinkSmart One Pro for Microsoft Team Rooms  12BS0008US
Quick View
Lenovo
Lenovo ThinkSmart One Pro for Microsoft Team Rooms 12BS0008US
  • Brand: Lenovo
  • Part Number: 12BS0008US
  • Type: Video Conference Device
  • Parts: 3 Year
  • Model #: 12BS0008US
Attendance Punch Time Clock Employee Payroll Recorder LCD Display w/ 100 Cards
Quick View
Attendance Punch Time Clock Employee Payroll Recorder LCD Display w/ 100 Cards
  • Brand: Yescom
  • Model: 16ATC002-S1SET-07
  • Features: Down Lighting
  • Selling Unit: Each
  • Model #: 16ATC002-S1SET-07
  •  
  • $119.90 –
  • Free Shipping
Direct from Yescom USA, Inc. Direct from Yescom USA, Inc.
  • $112.71 - $119.90
Digium D65 Executive-level HD Phone - Includes Power Supply
Quick View
  •  
  • $299.99 –
  • Free Shipping
Digium D62 Mid-level HD phone - Includes Power Supply
Quick View
  •  
  • $269.99 –
  • Free Shipping
Rally Conf Solution Spker Set
Quick View
Logitech
Rally Conf Solution Spker Set
  • Camera: Ultra-HD imaging system supports: 4K, 1440p, 1080p, 900p, 720p, and SD at 30fps 1080p, 720p at 30fps and 60 fps
  • Additional Features: Studio-Quality Video With an Ultra-HD imaging system, Rally delivers brilliantly sharp video, outstanding color, and exceptional optical accuracy at resolutions up to 4K. Logitech RightLight technology optimizes light balance to emphasize faces and render natural-looking skin tones, even in dim or backlit conditions. Advanced Modular Audio Crystal-clear audio is essential for world-class video
  • Weight: 20.2
  • Model #: 960-001217
IP CONFERENCE PHONE ANDROID
Quick View
IP CONFERENCE PHONE ANDROID
  • Additional Features: 6 lines, 6 SIP accounts, 7-way voice conferencing Runs Android 4.4 and offers full access to the Google Play Store and all Android apps, such as Skype, Google Hangouts and more Bluetooth to support syncing of headsets and mobile devices Built-in 7-way conference bridge 4.3" (800 x 480) capacitive touch screen for easy use Auto-sensing Gigabit port, built-in PoE support Built-in Wi-Fi support offers mobility and network flexibility Full HD audio support to maximize voice quality Daisy-chain support to combine two GAC2500 together TLS and SRTP security encryption
  • Display: 4.3" IPS LCD with 800x480 resolution
  • Power: Universal Power Supply: Input:100-240V AC, 50-60 Hz Output:12V DC, 2A (24W)
  • Dimensions: 2.36" x 11.02" x 11.22"
  • Model #: GAC2500
VideoSecu CCTV Surveillance PC VGA to AV TV RCA Video Converter Switch Box Adapter MAC 1L7
Quick View
VideoSecu CCTV Surveillance PC VGA to AV TV RCA Video Converter Switch Box Adapter MAC 1L7
  • Type: Other
  • Specifications: • Input port: DB15 (VGA) • Output ports: Composite video (RCA), S-video and HD15 (VGA)
  • Package Contents: PC TV Converter; RCA video cable; USB Power Adapter Cable; VGA cable
  • Model #: QVGA2TV-N1
  •  
  • $218.50 –
  • $6.50 Shipping
Polycom VVX 250 Business IP Desk Phone with Color Display - Four Lines
Quick View
  •  
  • $64.99 –
  • Free Shipping
HP Poly VVX 250 4-Line IP Corded Phone and PoE-Enabled GSA/TAA-US | 89B64AA#ABA
Quick View
HP Poly VVX 250 4-Line IP Corded Phone and PoE-Enabled GSA/TAA-US | 89B64AA#ABA
  • Brand: HP
  • Part Number: 89B64AA#ABA
  • Type: VoIP Phones
  • Protocols: Network protocols, supported 10/100/1000 Base-TX across LAN and PC ports; Conforms to IEEE802.3- 2005 (Clause 40) for physical media attachment; Conforms to IEEE802.3- 2002 (Clause 28) for link partner auto-negotiation; Manual or dynamic host configuration protocol (DHCP) network setup
  • Model #: 89B64AA#ABA
  •  
  • $119.99 –
  • Free Shipping
CLNR CP920 IP CONFERENCE PHONE (CP920) Silver
Quick View
  •  
  • $99.98 –
  • Free Shipping
NEC ASPIRE 0890045 34-BUTTON HANDS-FREE SPEAKER DISPLAY PHONE (BLACK)
Quick View
  •  
  • $65.55 –
  • Free Shipping
Polycom Poly VVX 250 - 2200-48822-025
Quick View
Refurbished Polycom Poly VVX 250 - 2200-48822-025
  • Part Number: VVX 250
  • Model #: 610807887454
Samsung Galaxy A15 5G, 128GB, Blue Black - Locked to Verizon (Very Good)
Quick View
SAMSUNG
Refurbished Samsung Galaxy A15 5G, 128GB, Blue Black - Locked to Verizon (Very Good)
  • Brand: SAMSUNG
  • Series: A
  • Part Number: A156V
  • Features: Fingerprint Recognition, not_water_resistant, True, [Incomplete: CDMA (2G/3G) and 5G are supported], CDMA
  • Model #: A156V FAC BLA 128 Very Good
  •  
  • $144.98 –
  • Free Shipping
Polycom 2200-48820-025-R IP Phone
Quick View
  •  
  • $69.99 –
Polycom VVX350 2200-48830-025-R IP Phone
Quick View
  •  
  • $74.99 –