Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
StarTech.com Cisco SFP-GE-S Compatible SFP Module - 1000BASE-SX - 1GE Gigabit Ethernet SFP 1GbE Multimode Fiber MMF Optic Transceiver
Quick View
StarTech.com Cisco SFP-GE-S Compatible SFP Module - 1000BASE-SX - 1GE Gigabit Ethernet SFP 1GbE Multimode Fiber MMF Optic Transceiver
  • Standards: IEEE 802.3z 1000BASE-SX
  • Wavelength: 850nm
  • Fiber Cable: MMF
  • Ports: 1 - Fiber Optic LC Female
  • Model #: SFPGESST
  • $38.99
  •  
  • $36.99 –
  • Save: $2.00 (5%)
  • $3.99 Shipping
Canon ImageFORMULA R10 4861C001 Duplex Portable Document Scanner White
Quick View
Canon ImageFORMULA R10 4861C001 Duplex Portable Document Scanner White
  • Weight: 2.20
  • Features: Sold as 1 Each.
  • Model #: 4861C001
Tripp Lite Cat6a Snagless Shielded STP Patch Cable 10G, PoE, Blue M/M 20 ft. (N262-020-BL)
Quick View
Tripp Lite Cat6a Snagless Shielded STP Patch Cable 10G, PoE, Blue M/M 20 ft. (N262-020-BL)
  • Brand: TRIPP LITE
  • Type: Consumer Electronics
  • Length: 20 ft.
  • Color: Blue
  • Model #: N262-020-BL
  •  
  • $41.91 –
  • Free Shipping
Ubiquiti Networks Wave Long-Range (Wave-LR)
Quick View
Ubiquiti Networks Wave Long-Range (Wave-LR)
  • Frequency Band: RF Operating frequency* 57–71 GHz *Depends on regulatory region. Channel bandwidth 2160, 1080, 540* MHz *FW version 3.3.0 and later. Operating channels* 58320, 59400, 60480, 61560, 62640, 63720, 64800, 65880, 66960, 68040, 69120, 70200 MHz *Depends on regulatory region. Modulation 16QAM, QPSK Antenna gain 46 dBi Polarization Vertically linear Beamwidth Azimuth: 3 dB 1° Elevation: 3 dB 1° Back-Up RF WiFi standard 802.11ax (WiFi 6) Operating frequency* US/ CA Worldwide U-NII-1 5150 - 5250 MHz U-NII-2A 5250 - 5350 MHz U-NII-2C 5470 - 5725 MHz U-NII-3 5725 - 5850 MHz 5150 - 5875 MHz *Depends on regulatory region. Channel bandwidth 20, 40, 80 MHz Modulation BPSK (1/2), QPSK (1/2), QPSK (3/4), 16QAM (1/2), 16QAM (3/4), 64QAM (2/3), 64QAM (3/4), 64QAM (5/6), 256QAM (3/4), 256QAM (5/6), 1024QAM (3/4), 1024QAM (5/6) Antenna gain 2...
  • Model #: WAVE-LR-US
Belkin A3L980-20-ORG-S 20 ft. Cat 6 Orange Snagless Network Cable
Quick View
Belkin A3L980-20-ORG-S 20 ft. Cat 6 Orange Snagless Network Cable
  • Brand: Belkin
  • Type: Consumer Electronics
  • Cat: 6
  • Connector A: RJ45
  • Model #: A3L980-20-ORG-S
TP-Link RE380D AC1200 Wi-Fi Range Extender
Quick View
TP-Link RE380D AC1200 Wi-Fi Range Extender
  • Standards: IEEE 802.11a/b/g/n/ac
  • Frequency Band: 2.4 GHz / 5.0 GHz
  • Wireless Data Rates: 5 GHz: Up to 867 Mbps 2.4 GHz: Up to 300 Mpbs
  • Antenna: 2 dual band detachable antennas
  • Model #: RE380D
  •  
  • $87.52 –
  • Free Shipping
Tripp Lite N262-020-AQ Cat.6a STP Patch Network Cable
Quick View
Tripp Lite N262-020-AQ Cat.6a STP Patch Network Cable
  • Brand: TRIPP LITE
  • Type: Category 6a
  • Cat: Category 6a
  • Connector A: 1 x RJ-45 Male Network RJ-45 Male Network
  • Model #: N262-020-AQ
  •  
  • $39.86 –
  • $26.71 - $39.86
TRENDnet 5-Port Gigabit PoE+ Powered EdgeSmart Switch With PoE Pass Through, 18W PoE Budget, 10Gbps Switching Capacity, Managed Switch, Wall-Mountable, Black, TPE-P521ES
Quick View
TRENDnet 5-Port Gigabit PoE+ Powered EdgeSmart Switch With PoE Pass Through, 18W PoE Budget, 10Gbps Switching Capacity, Managed Switch, Wall-Mountable, Black, TPE-P521ES
  • Standards: IEEE 802.1d IEEE 802.1w IEEE 802.1p IEEE 802.1Q IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
  • Primary Ports: 1 x Gigabit PoE+ input port 2 x Gigabit PoE output ports 2 x Gigabit ports
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
  • MAC Address Table: 2K
  • Model #: TPE-P521ES (V1.0R)
Black Box CAT5EPC-020-BL CAT5e 100-MHz Stranded Ethernet Patch Cable - Unshielded, PVC, Snagless Boot, Blue, 20 ft.
Quick View
Black Box CAT5EPC-020-BL CAT5e 100-MHz Stranded Ethernet Patch Cable - Unshielded, PVC, Snagless Boot, Blue, 20 ft.
  • Brand: Black Box
  • Type: Network Ethernet Cables
  • Cat: 5E
  • Connector A: RJ45
  • Model #: CAT5EPC-020-BL
TRENDnet 7-Port Industrial Gigabit DIN-Rail Switch, TI-G62, 5 x Gigabit Ports, 2 x Gigabit SFP Ports, IP50 Weather Rated, 14Gbps, NDAA TAA Compliant, Lifetime Protection
Quick View
TRENDnet 7-Port Industrial Gigabit DIN-Rail Switch, TI-G62, 5 x Gigabit Ports, 2 x Gigabit SFP Ports, IP50 Weather Rated, 14Gbps, NDAA TAA Compliant, Lifetime Protection
  • Format: Includes DIN-rail and wall mounts Wall Mountable
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x
  • Primary Ports: 5 x Gigabit ports 1 x Shared SFP slot (port F5) 1 x Gigabit SFP slot (port F6)
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
  • Model #: TI-G62
AddOn Cisco GLC-T Compatible 10 Pack 1000Base-TX SFP Transceiver (Copper, 100m, RJ-45)
Quick View
AddOn Cisco GLC-T Compatible 10 Pack 1000Base-TX SFP Transceiver (Copper, 100m, RJ-45)
  • Network Media: 1 x RJ45
  • Ports: RJ-45
  • Max Distance: 100M
  • Transfer Rate: 1 Gbps
  • Model #: GLC-T-AO-10PK
  • $756.00
  •  
  • $288.99 –
  • Save: $467.01 (61%)
  • $1.99 Shipping
PLANET FT-806B20 10/100TX - 100Base-FX (WDM) Bi-directional Fiber Converter (SM, SC, 1550nm, 20 Km, LFPT)
Quick View
PLANET FT-806B20 10/100TX - 100Base-FX (WDM) Bi-directional Fiber Converter (SM, SC, 1550nm, 20 Km, LFPT)
  • Device Type: Converter
  • Standards: IEEE 802.3, 10BASE-T IEEE 802.3u, 100BASE-TX IEEE 802.3u, 100BASE-FX
  • Wavelength: TX: 1550nm; RX: 1310nm
  • Power Adapter: Power Input: 5V DC, 2A, max Power Supply: AC Adapter 100-240V AC, Frequency: 50-60 Hz
  • Model #: FT-806B20
  •  
  • $80.99 –
  • Free Shipping
TRENDnet 6-Port Hardened Industrial Gigabit Poe+ Layer 2 Managed DIN-Rail Switch, 4 x Gigabit PoE+ 802.3at Ports, 1 x Gigabit Port, 1 x Gigabit SFP Slot, 120W Power Budget, Black, TI-PG541i
Quick View
TRENDnet 6-Port Hardened Industrial Gigabit Poe+ Layer 2 Managed DIN-Rail Switch, 4 x Gigabit PoE+ 802.3at Ports, 1 x Gigabit Port, 1 x Gigabit SFP Slot, 120W Power Budget, Black, TI-PG541i
  • Switch Type: Switches
  • Format: DIN Rail Mount
  • Standards: IEEE 802.1p IEEE 802.1Q IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3af IEEE 802.3at IEEE 802.3az
  • Primary Ports: 4 x Gigabit PoE+ ports 1 x Gigabit port 1 x Gigabit SFP slot
  • Model #: TI-PG541i
TRENDnet 8-Port Industrial Gigabit PoE+ DIN-Rail Switch, TI-PG80, 8 x Gigabit PoE+ Ports, 200W PoE Power Budget, 16Gbps Switching Capacity, NDAA TAA Compliant, Lifetime Protection
Quick View
TRENDnet 8-Port Industrial Gigabit PoE+ DIN-Rail Switch, TI-PG80, 8 x Gigabit PoE+ Ports, 200W PoE Power Budget, 16Gbps Switching Capacity, NDAA TAA Compliant, Lifetime Protection
  • Switch Type: Switches
  • Format: Includes DIN-rail and wall mounts Wall Mountable
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x IEEE 802.3af PoE IEEE 802.3at PoE+
  • Primary Ports: 8 x Gigabit PoE+ ports
  • Model #: TI-PG80
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
  • Model #: GS-4210-16P4C
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
  • Brand: PLANET
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGSW-24040R
Belkin Cat.5e UTP Patch Cable
Quick View
Belkin Cat.5e UTP Patch Cable
  • Brand: Belkin
  • Type: Consumer Electronics
  • Cat: 5E
  • Length: 20 ft
  • Model #: TAA791-20-BLK-S
  • $19.99
  •  
  • $17.02 –
  • Save: $2.97 (14%)
  • Free Shipping
Ubiquiti Networks AM-5G19-120 4.9-5.9Ghz AirmaXBase Station 19DBI- 120 Deg with Rocket Kit
Quick View
Ubiquiti Networks AM-5G19-120 4.9-5.9Ghz AirmaXBase Station 19DBI- 120 Deg with Rocket Kit
  • Type: Antenna
  • Color: Grey
  • Specifications: Dimensions (mm): 700 x 135 x 73 mm (27.6" x 5.3" x 2.9") Weight: 5.9 kg (13 lb) Frequency Range: 5.15 - 5.85 GHz Gain: 18.6 - 19.1 dBi HPOL Beamwidth: 123° (6 dB) VPOL Beamwidth: 123° (6 dB) Electrical Beamwidth: 4° Electrical Downtilt: 2° Max. VSWR: 1.5:1 Wind Survivability: 200 km/h (125 mph) Wind Loading: 89 N @ 160 km/h (20 lbf @ 100 mph) Polarization: Dual-Linear Cross-pol Isolation: 28 dB Min. ETSI Specification: EN 302 326 DN2 Mounting: Universal Pole Mount, RocketM Bracket, and Weatherproof RF Jumpers Included
  • Model #: AM-5G19-120
Ubiquiti Networks WiFi BaseStation XG (UWB-XG) Access Point
Quick View
Ubiquiti Networks WiFi BaseStation XG (UWB-XG) Access Point
  • Wireless Data Rates: 802.11a 6, 9, 12, 18, 24, 36, 48, 54 Mbps 802.11n 6.5 Mbps to 600 Mbps (MCS0 - MCS23, HT 20/40) 802.11ac 6.5 Mbps to 1.7 Gbps (MCS0 - MCS9 NSS1/2/3/4, VHT 20/40/80)
  • Interface: (1) GbE RJ45 port (1) 1/10 GbE ICM Ethernet port
  • Standards: 802.11 a/b/g/n/ac
  • Security: WEP, WPA-PSK, WPA-Enterprise (WPA/WPA2, TKIP/AES), 802.11w/PMF
  • Model #: UWB-XG-US
Belkin A3L980-20-GRN-S 20 ft. Cat 6 Green UTP Patch Cable
Quick View
Belkin A3L980-20-GRN-S 20 ft. Cat 6 Green UTP Patch Cable
  • Brand: Belkin
  • Type: Consumer Electronics
  • Cat: 6
  • Connector A: RJ45
  • Model #: A3L980-20-GRN-S
Belkin A3L980-20-PUR-S 20 ft. Cat 6 Purple UTP Patch Cable
Quick View
Belkin A3L980-20-PUR-S 20 ft. Cat 6 Purple UTP Patch Cable
  • Brand: Belkin
  • Type: Consumer Electronics
  • Cat: 6
  • Connector A: RJ45
  • Model #: A3L980-20-PUR-S
C2G 03971 20 ft. Cat 6 Grey Snagless Patch Cable
Quick View
C2G 03971 20 ft. Cat 6 Grey Snagless Patch Cable
  • Brand: C2G
  • Type: Banker Box
  • Cat: 6
  • Connector A: RJ-45 Male
  • Model #: 03971
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 6-Port IEEE 802.3at / af / Ultra PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatible with 100BASE-FX SFP...
  • Model #: GS-4210-16UP4C
SonicWall NSa 4800 Network Security/Firewall - Centralized Management - 24 Port - 10 Gigabit Ethernet - 3000 VPN - 24x RJ-45 - 8 Total Expansion Slots - 50 Hz, 60 Hz - 1U - Rack-mountable  03-SSC-1845
Quick View
  • $9,020.00
  •  
  • $7,216.00 –
  • Save: $1,804.00 (20%)
  • Free Shipping
PLANET PWR-480-48 DC Single Output Industrial DIN Rail Power Supply Units
Quick View
PLANET PWR-480-48 DC Single Output Industrial DIN Rail Power Supply Units
  • Type: Power Supply
  • Specifications: Hardware Version: 2 Dimensions: 5.04" x 3.35" x 4.92" Weight: 3.31 lbs. Input Voltage: 100-240V AC, 50/60 Hz, 4.8A Power Output: 480 watts, 48V, 10A Temperature: Operating: -20 ~ 70 degrees C Storage: -40 ~ 85 degrees C Humidity: Operating: 20 ~ 95% Storage: 10 ~ 95% (non-condensing) Installation: DIN rail TS-35/7.5 or 15
  • Model #: PWR-480-48
  •  
  • $159.99 –
  • Free Shipping
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
Quick View
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
  • Primary Ports: (4) 10/100 MbE fast ports
  • PoE: Yes
  • Power: Power method PV panel (H4 connectors) Max. power consumption 2W Supported voltage range 10–60V (Reverse protection, surge protection) Max. open circuit voltage: 60V
  • Dimensions: 202 x 190 x 50 mm (8 x 7.5 x 2")
  • Model #: SM-SP-40
  •  
  • $199.00 –
  • Free Shipping
yealink w70b - dect ip base station
Quick View
yealink w70b - dect ip base station
  • Brand: Yealink
  • Part Number: 1302017
  • Type: Telephone
  • Dimensions: 2.51 L x 10 W x 13 H centimeters
  • Model #: RNAB09BFXNK65