Your Browsing History
- Sold by Newegg
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
PoE Texas GPOE-6AB-48v60w | Gigabit 6 Port Passive Power Over Ethernet Injector for 802.3af Devices | with 48 Volt 60 Watt Power Supply
- Model #: RCCWB00FYEY6SY
- $122.99 –
- Free Shipping

Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
- Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
- Model #: WGSW-24040
- $332.00
- See price in cart
- Free Shipping

Quick View
High Power GigE Passive PoE Injector 320W 48-57V 6A Ethernet Adapter for Demanding Applications
- Model #: RCCWB0DTYW7QGS
- $98.99 –
- Free Shipping

Quick View
TP-POE-48G - 100-240VAC Input, 48V Gigabit Passive PoE Injector, 24W, with US Power Cord
- Model #: RCCWB0C1D7MQ69
- $89.99 –
- Free Shipping

Quick View
RB-GES401-POE Gigabit Ethernet 4+1 Ports high Power POE Switch
- Model #: CLOLB07Y6CJ4TF
- $78.99 –
- Free Shipping