Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
Sort By:
View:
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
Quick View
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3af Power over Ethernet
  • Primary Ports: "Data" Input Ports: 24x RJ-45 STP "PoE (Data+Power)" Output Ports: 24x RJ-45 STP Management Port: 1 x RJ-45; 10/100Base-TX, auto-negotiation, auto-MDI / MDIX
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: POE-2400G
  •  
  • $498.99 –
  • Free Shipping
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-621TF
  •  
  • $96.99 –
  • Free Shipping
SLC8000 ADV CONSOLE MANAGER
Quick View
SLC8000 ADV CONSOLE MANAGER
  • Model #: SLC80162401S
Black Box FMT335-R2 GigaStation2 Snap Fitting - Blank, Ivory, 10-Pack
Quick View
Black Box FMT335-R2 GigaStation2 Snap Fitting - Blank, Ivory, 10-Pack
  • Type: Keystone Jack
  • Color: Blank, Ivory
  • Specifications: Works with GigaStation2 Wallplates. Convenient snap-in jack installs easily. Available in office white, ivory, or white.
  • Model #: FMT335-R2
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-24XTS
  • Format: Rack-mountable
  • Model #: C1300-24XTS
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
  • Part Number: C1300-24XS
  • Format: Rackmount
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-X 1000Base-T Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-24XS
Cisco Catalyst 9200L 48-port Data 4x1G uplink Switch, Network Essentials | C9200L-48T-4G-E
Quick View
Cisco Catalyst 9200L 48-port Data 4x1G uplink Switch, Network Essentials | C9200L-48T-4G-E
  • Brand: CISCO
  • Series: 9200
  • Part Number: C9200L-48T-4G
  • Format: Rackmount
  • Model #: C9200L-48T-4G-E
Cisco Business CBS220-16T-2G Ethernet Switch, 16 Ports - Manageable - 2 Layer Supported
Quick View
Cisco Business CBS220-16T-2G Ethernet Switch, 16 Ports - Manageable - 2 Layer Supported
  • Part Number: CBS220-16T-2G-NA
  • Format: Rack-mountable
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 1000Base-T 1000Base-X
  • Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Number of SFP Slots: 2
  • Model #: CBS22016T2GNA
Aruba CX 5420 Switch Chassis - Manageable - 3 Layer Supported - 1000 W Power Consumption - Optical Fiber - PoE Ports - 4U - Compact  - S0U59A
Quick View
Planet IGS-10080MFT Industrial 8 100/1000X SFP + 2-Port 10/100/1000T Managed Switch (-40 ~ 75 degrees C)
Quick View
Planet IGS-10080MFT Industrial 8 100/1000X SFP + 2-Port 10/100/1000T Managed Switch (-40 ~ 75 degrees C)
  • Format: DIN Rail Mount
  • Primary Ports: 8 100/1000Base-SX/LX mini-GBIC SFP slots
  • MAC Address Table: 8K entries, automatic source address learning and ageing
  • VLAN Support: Yes
  • Model #: IGS-10080MFT
Netgear AV Line M4350-16V4C Managed Switch, 100 Gigabit Ethernet
Quick View
Netgear Inc.
Netgear AV Line M4350-16V4C Managed Switch, 100 Gigabit Ethernet
  • Brand: NETGEAR
  • Part Number: VSM4320C-100NES
  • Format: Rack-mountable, Table Top
  • Standards: 100GBase-X, 25GBase-X
  • Model #: VSM4320C-100NES
  •  
  • $12,258.60 –
  • $13.55 Shipping
Panduit CJ688TGBL-24 Mini-Com UTP RJ45 Cat 6 TG Jack Module, Black, 24-pack
Quick View
Panduit CJ688TGBL-24 Mini-Com UTP RJ45 Cat 6 TG Jack Module, Black, 24-pack
  • Color: Black
  • Type: Jack Module
  • Specifications: Performance Level: Category 6 Termination Style: TG Style Body Material : ABS Contact Material: Plated Phosphor Bronze Module Type: Mini-Com Wiring Scheme: T568A/T568B Shield Type: Unshielded (UTP) Sub Brand: Pan-Net Maximum Operating Temperature (°C): 65 Maximum Operating Temperature (°F): 149 Minimum Operating Temperature (°C): -10 Minimum Operating Temperature (°F): 14 Maximum Storage Temperature (°C): 70 Maximum Storage Temperature (°F): 158 Minimum Storage Temperature (°C): -40 Minimum Storage Temperature (°F): -40 Resistance Properties: Heat-Resistant Standards Met: Exceeds Channel Requirements of ANSI/TIA-568-C.2 Category 6A and ISO 11801 Class EA Standards for Supporting 10GBASE-T Transmission Over Twisted Pair Cabling Systems in a 4-Connector Configuration up to 100 meters at Swe...
  • Model #: CJ688TGBL-24
FortiSwitch-124G-FPOE Layer 2 FortiGate Switch Controller Compatible PoE Switch with 24x 2.5G/1G/100M RJ45 ports (FS-124G-FPOE)
Quick View
FortiSwitch-124G-FPOE Layer 2 FortiGate Switch Controller Compatible PoE Switch with 24x 2.5G/1G/100M RJ45 ports (FS-124G-FPOE)
  • Brand: Fortinet
  • Series: FortiGate
  • Part Number: FS-124G-FPOE
  • Format: Rackmount
  • Model #: FS-124G-FPOE
  •  
  • $1,732.99 –
  • Free Shipping
Patch Panel, Mini-Com, Rack Mt, 24 Port
Quick View
Patch Panel, Mini-Com, Rack Mt, 24 Port
  • Color: Black
  • Model #: CPPL24WBLY
  •  
  • $38.99 –
  • $7.24 Shipping
Panduit Network Connector
Quick View
Panduit Network Connector
  • Model #: CJS6X88TGY
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
  • MAC Address Table: 2K
  • Model #: ISW-621TS15
Transition Networks SISTG1040-242-LRT Ethernet Switch SISTG1040242LRT
Quick View
Transition Networks SISTG1040-242-LRT Ethernet Switch SISTG1040242LRT
  • Format: Wall Mountable
  • Uplink Ports: Yes
  • Uplink Interface: SFP
  • Primary Ports: 4 x Gigabit Ethernet Network 2 x Gigabit Ethernet Expansion Slot
  • Model #: SISTG1040-242-LRT
RUCKUS ICX 8200 Switch, 24x10/100/1000 Mbps PoE+ ports, 4x25 GbE SFP28 stacking/uplink-ports, 370 W PoE budget, three-year remote TAC support. Power cord not included - OEM
Quick View
RUCKUS ICX 8200 Switch, 24x10/100/1000 Mbps PoE+ ports, 4x25 GbE SFP28 stacking/uplink-ports, 370 W PoE budget, three-year remote TAC support. Power cord not included - OEM
  • Part Number: ICX8200-24P
  • Primary Ports: Interfaces: 24x10/100/1000 Mbps RJ45 ; 4x1/10/25 Gbps SFP/SFP+/SFP28 uplinks; USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 24
  • Power: Max Power Consumption: 525 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
  • Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
  • Model #: ICX8200-24P
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
  • Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
  • Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
  • Model #: WGSW-24040
Netgear AV Line M4350-8M2V 8-Port Managed Switch, 2.5G/10G/25G Multi-Gigabit Ethernet
Quick View
Netgear Inc.
Netgear AV Line M4350-8M2V 8-Port Managed Switch, 2.5G/10G/25G Multi-Gigabit Ethernet
  • Brand: NETGEAR
  • Part Number: MSM4310-100NES
  • Format: Rack-mountable
  • Standards: 2.5GBase-T, 25GBase-X, 1000Base-T, 10GBase-X
  • Model #: MSM4310-100NES
  •  
  • $3,988.54 –
  • $12.69 Shipping
Cisco Catalyst C1300-16XTS Layer 3 Switch, 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16XTS Layer 3 Switch, 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1300-16XTS
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1x IEEE 802.3af IEEE 802.3at IEEE 802.1ab IEEE 802.3az
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-16XTS
Netgear AV Line M4350-24M4X4V 28-Port Managed Switch, Multi-Gigabit Ethernet up to 25G
Quick View
Netgear Inc.
Netgear AV Line M4350-24M4X4V 28-Port Managed Switch, Multi-Gigabit Ethernet up to 25G
  • Brand: NETGEAR
  • Part Number: MSM4332-100NES
  • Format: Rack-mountable
  • Standards: 2.5GBase-T, 1000Base-T, 5GBase-T, 10GBase-T, 10GBase-X, 25GBase-X
  • Model #: MSM4332-100NES
  •  
  • $5,908.95 –
  • $13.87 Shipping
Lantronix Managed Hardened Multi-Gigabit Ethernet PoE++ Switch - 10G Uplink - 8 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - SISPM1242-582-LRT
Quick View
Lantronix Managed Hardened Multi-Gigabit Ethernet PoE++ Switch - 10G Uplink - 8 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - SISPM1242-582-LRT
  • Brand: Lantronix
  • Part Number: SISPM1242-582-LRT
  • Switch Type: managed
  • Standards: 802.1w, 802.1s, 802.1p
  • Model #: SISPM1242-582-LRT
Panduit CJ688TGYL Mini-Com Cat.6 UTP Jack Module
Quick View
Panduit CJ688TGYL Mini-Com Cat.6 UTP Jack Module
  • Color: Yellow
  • Specifications: Connector Details: 1 x RJ-45 Female Network
  • Model #: CJ688TGYL
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24P-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RFC 951,...
  • Model #: C1300X-24P-4X
Cisco Catalyst C1300-48MGP-4X, 48-port Layer 3 Managed Switch | C1300-48MGP-4X
Quick View
Cisco Catalyst C1300-48MGP-4X, 48-port Layer 3 Managed Switch | C1300-48MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst 1300 Series
  • Part Number: C1300-48MGP-4X
  • Format: Rackmount
  • Model #: C1300-48MGP-4X
avatar

Any questions? Our AI mode will help you find out quickly.

Did You Find It?