Your Browsing History
- In Stock
- Sold by Newegg
- New

Quick View
Netgear GS108T 8-Port Gigabit Ethernet Smart Switch with Cloud Management, GS108T-300NAS
OUT OF STOCK
- Brand: NETGEAR
- Part Number: GS108T-300NAS
- Switch Type: Non rack mountable
- Network Management Type: Smart
- Model #: GS108T-300NAS
- $83.99 –
- Free Shipping

Quick View
Zyxel XMG1915-18EP 16-Port 2.5G Multi-Gigabit Smart Nebula Cloud Managed PoE Switch with 2x 10G SFP+ Uplinks, 8 PoE+ / PoE++ Ports at 180W, Fanless
OUT OF STOCK
- Part Number: XMG1915-18EP
- Switch Type: Manageable
- Format: Compact Standalone Rack-mountable Desktop
- Standards: IEEE 802.3bt IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.3ae IEEE 802.3af IEEE 802.3at IEEE 802.3x IEEE 802.3az IEEE 802.1p IEEE 802.1Q IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3ad
- Model #: XMG1915-18EP
- $369.99 –
- More options from $369.99 - $462.34
- Free Shipping

Quick View
QNAP QSW-3205-5T Ethernet Switch - 5 Ports - 10 Gigabit Ethernet - 10GBase-T - 2 Layer Supported - 36 W Power Consumption - Twisted Pair - Desktop, Compact - 2 Year Limited Warranty
OUT OF STOCK
- Brand: Qnap
- Model #: QSW-3205-5T-US
- $276.99 –
- $26.75 Shipping

Quick View
TP-Link 5 Port Gigabit PoE Switch | 4 PoE+ Port @65W | Easy Smart | Plug & Play | Limited Lifetime Protection | Shielded Ports | Support QoS, VLAN, IGMP and Link Aggregation (TL-SG105PE)
OUT OF STOCK
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p, IEEE 802.3at
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 2K
- Model #: TL-SG105PE
- $59.99 –
- More options from $59.99 - $101.24
- Free Shipping

Quick View
in 30 days
Netgear MS305E 5-Port Multi-Gigabit (2.5G) Ethernet Easy Smart Managed Essentials Switch, MS305E-100NASOUT OF STOCK
- Brand: NETGEAR
- Part Number: MS305E-100NAS
- Standards: Networking Standards: IEEE 802.3 IEEE 802.3ab IEEE 802.3u IEEE 802.1p IEEE 802.1Q IEEE 802.3x IEEE 802.3bz IEEE 802.3az IEEE 802.3ad
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: 2.5 Gigabit Ethernet Network Technology: 2.5GBase-T
- Model #: MS305E-100NAS
- $159.99
- $89.99 –
- Save: $70.00 (43%)
- Free Shipping

Quick View
D-Link Ethernet Switch, 16 Port Easy Smart Managed Gigabit Network Internet Desktop or Rack Mountable (DGS-1100-16V2), Black
OUT OF STOCK
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- VLAN Support: Yes
- Model #: DGS-1100-16V2
- $129.99 –
- Free Shipping

Quick View
Cisco Business 220 Gigabit Ethernet Switch, 8 x 10/100/1000 ports w/ 130W power budget, 2 x Gigabit SFP | CBS220-8FP-E-2G-NA
OUT OF STOCK
- Part Number: CBS220-8FP-E-2G
- Format: Rack-mountable
- Standards: Layer Supported: 2 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.1x IEEE 802.3af IEEE 802.3at
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Model #: CBS2208FPE2GNA
- $245.99 –
- More options from $245.99 - $270.81
- Free Shipping

Quick View
NETGEAR 24x1G PoE+ 480W 2x1G and 4xSFP+ Managed Switch | AV Line M4250-26G4XF-PoE+, GSM4230PX
OUT OF STOCK
- Model #: GSM4230PX100NAS
- $1,941.00 –
- Free Shipping

Quick View
Aruba CX 6000 12p 10M/100M/1G Class4 PoE 2p SFP 1G 139W Switch - 14 Ports - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported - 2 SFP Slots - 165 W Power Consumption - R8N89B#ABA
OUT OF STOCK
- Brand: Aruba
- Series: CX 6000
- Part Number: R8N89B#ABA
- Switch Type: Managed
- Model #: R8N89B#ABA
- $1,388.00
- $837.99 –
- Save: $550.01 (39%)
- More options from $714.20 - $1,182.93
- Free Shipping

Quick View
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W with 2 SFP Uplinks, Fanless, GS1900-10HP
OUT OF STOCK
- Format: Desktop
- Standards: IEEE 802.3at, IEEE 802.3az
- Uplink Ports: 2
- Uplink Interface: SFP
- Model #: GS1900-10HP
- $199.99
- More options from $120.99 - $146.21
- Free Shipping

Quick View
Netgear Smart S3600-XS516TM 16-Port Manageable 10 Gigabit Ethernet Smart Switch, XS516TM-100NAS
OUT OF STOCK
- Brand: NETGEAR
- Part Number: XS516TM100NAS
- Network Management Type: Smart
- Primary Ports: 16 x RJ45 + 2 x SFP+
- Model #: XS516TM-100NAS
- $1,499.99 –
- Free Shipping

Quick View
Hardened Mini Industrial Switch, 5-Port (4-to-1); (4) 10-/100-Mbps Copper + (1)
OUT OF STOCK
- Model #: LBH120A-H-ST
- $217.99 –
- More options from $217.99 - $303.00
- Free Shipping

Quick View
D-Link 5-Port Gigabit Smart Managed Switch | Web Managed | Cable Diagnostics | Fanless | Compact Metal Desktop | NDAA Compliant - (DGS-1100-05V2)
OUT OF STOCK
- Switch Type: Others
- Model #: DGS110005V2
- $44.99 –
- More options from $28.99 - $55.18
- Free Shipping

Quick View
HPE Networking Instant On Switch 16p Gigabit CL4 PoE 124W 1430 (R8R48A#ABA)
OUT OF STOCK
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- PoE: Yes
- Model #: R8R48A#ABA
- $219.99 –
- Free Shipping

Quick View
Luxul AMS-1208P Managed AV Series 12-Port/8 PoE+ Gigabit Managed Switch
OUT OF STOCK
- Brand: Luxul
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3z, IEEE 802.3ab, IEEE 802.3af, IEEE 802.1D, IEEE 802.3x
- Network Management Type: Managed
- Primary Ports: 10 x RJ45 + 2 x SFP
- Model #: AMS-1208P
- $213.99 –
- Free Shipping

Quick View
Cisco Catalyst C1300-24P-4G Ethernet Switch, 24 Ports, Manageable, Gigabit Ethernet, 10/100/1000Base-T, 1000Base-X , 3 Layer Supported
OUT OF STOCK
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C130024P4G
- Switch Type: Manageable
- Model #: C1300-24P-4G
- $928.99 –
- More options from $921.81 - $928.99
- Free Shipping

Quick View
NETGEAR 8-Port 10G/Multi-Gigabit Ethernet Smart Switch with 2 10G SFP+ Ports | XS508TM
OUT OF STOCK
- Brand: NETGEAR
- Part Number: XS508TM100NAS
- Network Management Type: Smart
- Primary Ports: 8 x RJ45 + 2 x SFP+
- Model #: XS508TM-100NAS
- $919.99 –
- Free Shipping

Quick View
HPE Networking Instant On 1960, 40-port Gigabit CL4, 8-port Gigabit CL6, PoE 2-port 10GBT, 2-port SFP+ 600W | JL809A#ABA
OUT OF STOCK
- Primary Ports: 50 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- PoE: Yes
- SNMP: Yes
- Model #: JL809A#ABA
- $1,799.99 –
- More options from $1,299.31 - $2,899.00
- Free Shipping

Quick View
PLANET IGS-5225-8P2T2S L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T+ 2-Port 100/1000X SFP Managed Ethernet Switch
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1ad Q-in-Q VLAN stacking IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 1588 PTPv2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 ITU G.8032 ERPS Ring
- Primary Ports: 8 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports 2 x 100/1000BASE-X mini-GBIC/SFP slots for SFP ty...
- Model #: IGS-5225-8P2T2S
- $604.99 –
- Free Shipping

Quick View
D-Link DGS-1018P Ethernet Switch - 16 Ports - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported - 2 SFP Slots - 280.21 W Power Consumption - 240 W PoE Budget
OUT OF STOCK
- Brand: D-Link
- Model: DGS-1018P
- Part Number: DGS-1018P
- Primary Port Speed: 1000 megabits_per_second
- Model #: DGS-1018P
- $219.99 –
- More options from $219.99 - $235.74
- Free Shipping

Quick View
(3-Pack) Ubiquiti Flexible 5-Port, Layer 2 PoE Switch (USW-Flex-3 (46W))
OUT OF STOCK
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-Flex (46W)
- Format: Desktop
- Model #: USW-Flex-3 (46W)
- $302.00 –
- More options from $302.00 - $372.99
- Free Shipping

Quick View
QNAP Desktop QSW-2104-2S-US, Unmanaged Switch, 4 port 2.5Gbps auto negotiation (2.5G/1G/100M), 2 10GbE SFP+ port
OUT OF STOCK
- Series: Desktop QSW-2104-2S-US
- Part Number: QSW-2104-2S-A-US
- Model #: QSW-2104-2S-A-US
- $143.99 –
- More options from $143.99 - $183.30
- Free Shipping

Quick View
Netgear GS308EPP 8-Port PoE+ Gigabit Ethernet Plus Switch 123W, GS308EPP-100NAS
OUT OF STOCK
- Brand: NETGEAR
- Part Number: GS308EPP-100NAS
- Format: Wall Mountable Desktop Rack-mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3ab 1000BASE-T IEEE 802.3u 100BASE-T IEEE 802.3ab 1000BASE-T EEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.3x Full-duplex Flow Control IEEE 802.3af PoE IEEE 802.3at PoE+
- Model #: GS308EPP-100NAS
- $139.99
- $129.99 –
- Save: $10.00 (7%)
- Free Shipping

Quick View
Netgear AV Line M4250-26G4F-PoE++ 24-Port Managed Switch, GSM4230UP-100NAS
OUT OF STOCK
- Brand: NETGEAR
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Network Management Type: Managed
- Uplink Interface: Total Number of Network Ports: 24 Uplink Port: Yes Modular: Yes Port/ Expansion Slot Details: 24 x Gigabit Ethernet PoE++ 2 x Gigabit Ethernet Network 4 x Gigabit Ethernet Expansion Slot
- Model #: GSM4230UP-100NAS
- $2,825.99 –
- Free Shipping

Quick View
Ubiquiti Pro XG Aggregation, Professional-grade 32-port, Layer 3 Etherlighting switch (USW-Pro-XG-Aggregation)
OUT OF STOCK
- Brand: Ubiquiti
- Series: Switching
- Part Number: USW-Pro-XG-Aggregation
- Format: Rackmount
- Model #: USW-PRO-XG-AGGREGATION
- $2,696.00 –
- More options from $2,696.00 - $4,351.99
- Free Shipping

Quick View
ZyXEL 24-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 24 PoE+ Ports at 375W with 4 SFP Uplinks, TAA Compliant, GS1920-24HPv2
OUT OF STOCK
- Brand: ZyXEL
- Part Number: GS1920-24HPv2
- Switch Type: Manageable: Yes
- Format: Rack-mountable
- Model #: GS1920-24HPV2
- $299.99
- Free Shipping

Quick View
TP-Link 48 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Lifetime Protection | Traffic Optimization | Unmanaged (TL-SG1048)
OUT OF STOCK
- Brand: TP-Link
- Format: Rackmount
- Network Management Type: Unmanaged
- Primary Ports: 48 x RJ45
- Model #: TL-SG1048
- $239.99 –
- Free Shipping

Quick View
D-Link DGS-105GL 5-Port Gigabit Unmanaged Desktop Switch - Fanless, Silent & Energy Efficient
OUT OF STOCK
- Brand: D-Link
- Part Number: DGS-105GL
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Model #: DGS-105GL
- $19.99
- $17.99 –
- Save: $2.00 (10%)
- More options from $17.99 - $45.67
- $5.99 Shipping

Quick View
Yealink 1303228 24 Port L2+ Gigabit Managed Switched - Web-based Management - 370 PoE Power Budget - Designed for AV Networking
OUT OF STOCK
- Brand: Yealink
- Part Number: 1303228
- Network Management Type: Managed
- Primary Ports: 24× Gigabit PoE, 4× SFP fiber uplinks
- Model #: 1303228
- $759.00
- More options from $650.60 - $759.00
- Free Shipping

Quick View
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature
OUT OF STOCK
- MAC Address Table: 8K entries, automatic source address learning and ageing
- Buffer Memory: 4Mbits
- QoS: Traffic classification based, Strict priority and WRR 8-Level priority for switching - Port Number - 802.1p priority - 802.1Q VLAN tag - DSCP/TOS field in IP Packet
- Model #: IGS-10020HPT
- $650.00
- Free Shipping

Quick View
PLANET IGS-10020MT Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40~75 Degrees C)
OUT OF STOCK
- Format: Wall Mountable
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX / 100Base-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 8 x 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports 2 x 1000Base-SX/LX/BX SFP interfaces (Port-9 and Port-10)
- MAC Address Table: 8K entries, automatic source address learning and ageing...
- Model #: IGS-10020MT
- $370.00
- Free Shipping

Quick View
ZyXEL 24-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 12 PoE+ Ports at 130W, GS1915-24EP
OUT OF STOCK
- Brand: ZyXEL
- Part Number: GS1915-24EP
- Switch Type: Manageable: Yes
- Format: Wall Mountable Rack-mountable
- Model #: GS191524EP
- $280.99
- $199.99 –
- Save: $81.00 (28%)
- More options from $199.99 - $305.10
- Free Shipping

Quick View
Cisco Business CBS110-24T Unmanaged Switch | 24 Port GE | 2x1G SFP Shared | Limited Lifetime Protection (CBS110-24T-NA)
OUT OF STOCK
- Part Number: CBS110-24T
- Format: Desktop Wall Mountable Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
- Model #: CBS11024TNA
- $238.00
- $188.99 –
- Save: $49.01 (20%)
- More options from $188.99 - $207.82
- $3.99 Shipping

Quick View
PLANET Technology - GS-4210-24T2S - Planet 24-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces - 24 Ports - Manageable - 4 Layer Supported - Modular - Twisted Pair, Optical Fiber - 1U
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 24-port 10/100/1000BASE-T Gigabit RJ45 copper 2 x 100/1000BASE-X mini-GBIC / SFP slots
- MAC Address Table: 8K
- Switching Method: Store and Forward
- Model #: GS-4210-24T2S
- $197.99 –
- Free Shipping

Quick View
NETGEAR 8-port, 5-speed Unmanaged Switch 10-Gigabit/Multi-Gigabit | XS508M
OUT OF STOCK
- Brand: NETGEAR
- Format: Rackmount / Desktop
- Standards: IEEE 802.3 Ethernet IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Full-Duplex Flow Control IEEE 802.1p Class of Service IEEE 802.3az Energy Efficient Ethernet IEEE 802.3an 10GBASE-T IEEE 802.3bz 5 Gbps and 2.5 Gbps Ethernet Over Copper Twisted Pair Cable IEEE 802.3ae 10-Gigabit Ethernet Over Fiber IEEE 802.3aq 10-Gigabit over Fiber (10GBASE-LRM) IEEE 802.3z Gigabit Ethernet 1000BASE-SX/LX
- Network Management Type: Unmanaged
- Model #: XS508M-100NAS
- $629.99 –
- Free Shipping

Quick View
- $1,208.99 –
- More options from $1,208.99 - $1,758.25
- Free Shipping



