Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Intellinet 16-Port Gigabit Ethernet PoE+ Switch, 16 x PoE ports, IEEE 802.3at/af Power-over-Ethernet (PoE+/PoE), Endspan, Rackmount
Quick View
Available Direct from Intellinet Available Direct from Intellinet
D-Link DGS-1100-08V2 Managed 8-Port Gigabit Smart Managed Switch
Quick View
D-Link DGS-1100-08V2 Managed 8-Port Gigabit Smart Managed Switch
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5MB
  • Power: Maximum Power Consumption: 4.94 W Power Input AC: 100 ~ 240 V (5V/1A power adapter)
  • Model #: DGS-1100-08V2
  •  
  • $41.99 –
  • Free Shipping
Intellinet 16-Port Gigabit Ethernet Switch, 16-Port RJ45 10/100/1000 Mbps, IEEE 802.3az Energy Efficient Ethernet, Desktop, 10" and 19" Rackmount
Quick View
Intellinet 16-Port Gigabit Ethernet Switch, 16-Port RJ45 10/100/1000 Mbps, IEEE 802.3az Energy Efficient Ethernet, Desktop, 10" and 19" Rackmount
  • Format: Rack-mountable Desktop
  • Primary Port Speed: 10/100/1000Base-TX
  • Weight: 2.07 lb
  • Package Contents: Package Contents: 16-Port Gigabit Ethernet Switch 19" Rackmount Brackets Power Cable Instructions
  • Model #: 561068
  • $81.99
  •  
  • $74.99 –
  • Save: $7.00 (8%)
  • Free Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
Mikrotik S+RJ10 6-speed RJ-45 Module for up to 10 Gbps
Quick View
Blink Video Doorbell - Wired/Wireless - White
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
GL.iNet GL-XE300 Puli 4G LTE Industrial Router, OpenWrt, 5000mAh Battery
Quick View
  •  
  • $238.45 –
  • Free Shipping
Direct from TAURKENAM Direct from TAURKENAM
Intellinet Network Solutions 5-Port Gigabit Ethernet PoE+ Switch (561228)
Quick View
Intellinet Network Solutions 5-Port Gigabit Ethernet PoE+ Switch (561228)
  • Format: Desktop
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (1000Base-T Gigabit Ethernet) IEEE 802.3af (Power over Ethernet 802.3at Type 1) IEEE 802.3at (Power over Ethernet 802.3at Type 2) IEEE 802.3az (Energy Efficient Ethernet EEE)
  • Primary Ports: 5 x RJ45
  • MAC Address Table: 2K
  • Model #: 561228
Available Direct from Intellinet Available Direct from Intellinet
D-Link 28-Port Layer 2 Smart Managed Gigabit Poe Switch
Quick View
D-Link 28-Port Layer 2 Smart Managed Gigabit Poe Switch
  • Brand: D-LINK BUSINESS PRODUCTS SOLUTIONS
  • Part Number: DGS-1210-28MP
  • Switch Type: Others
  • Format: 28 Port Gigabit 370W PoE
  • Model #: DGS-1210-28MP
Cudy AP3000 AX3000 2.5G Wi-Fi 6 Access Point
Quick View
TRENDnet 5-Port Gigabit Long Range PoE+ Switch, 4 x Gigabit PoE+ Ports, 1 x Gigabit Port, 32W PoE Budget, 10Gbps Switching Capacity, Extends PoE+ 200m (656 ft), Lifetime Protection, Black, TPE-LG50
Quick View
TRENDnet 5-Port Gigabit Long Range PoE+ Switch, 4 x Gigabit PoE+ Ports, 1 x Gigabit Port, 32W PoE Budget, 10Gbps Switching Capacity, Extends PoE+ 200m (656 ft), Lifetime Protection, Black, TPE-LG50

Limited time offer, ends 09/30

  • Switch Type: Switches
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x IEEE 802.3p IEEE 802.3af IEEE 802.3at
  • Primary Ports: 4 x RJ45
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
  • Model #: TPE-LG50 (v1.0R)
Available Direct from TRENDnet Available Direct from TRENDnet
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
  • Format: DIN Rail and Wall Mount Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-20160HPT
Intellinet 8-Port Fast Ethernet PoE+ Switch, 8 x PoE ports, IEEE 802.3at/af Power-over-Ethernet (PoE+/PoE), Endspan, Desktop
Quick View
Intellinet 8-Port Fast Ethernet PoE+ Switch, 8 x PoE ports, IEEE 802.3at/af Power-over-Ethernet (PoE+/PoE), Endspan, Desktop
  • Brand: Intellinet
  • Format: Desktop
  • Standards: IEEE 802.3/3u, IEEE 802.3af/at
  • Primary Ports: 8 x RJ45
  • Model #: 560764
  • $84.99
  •  
  • $59.99 –
  • Save: $25.00 (29%)
  • Free Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
Intellinet 24-Port Gigabit Ethernet Switch with 2 SFP Ports, 24 x 10/100/1000 Mbps RJ45 Ports + 2 x SFP, IEEE 802.3az (Energy Efficient Ethernet), 19" Rackmount, Metal
Quick View
Intellinet 24-Port Gigabit Ethernet Switch with 2 SFP Ports, 24 x 10/100/1000 Mbps RJ45 Ports + 2 x SFP, IEEE 802.3az (Energy Efficient Ethernet), 19" Rackmount, Metal
  • Format: Rack-mountable
  • Primary Port Speed: 10/100/1000Base-TX 1000Base-X
  • Weight: 6.61 lb
  • Package Contents: Package Contents: 24-Port Gigabit Ethernet Switch with 2 SFP Ports Power Cable 19" Rackmount Brackets User Manual
  • Model #: 561044
  • $129.99
  •  
  • $99.99 –
  • Save: $30.00 (23%)
  • Free Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
Mikrotik OmniTIK 5 PoE ac 7. 5dBi Gb Ethernet Ports Access Point Omni
Quick View
  •  
  • $329.99 –
  • Free Shipping
Direct from BFKK Direct from BFKK
LR-LINK 1019PF-2QSFP28 PCIe x16 Single-port 100G QSFP28 Ethernet Network Adapter Intel E810 Chip Based
Quick View
LR-LINK 1019PF-2QSFP28 PCIe x16 Single-port 100G QSFP28 Ethernet Network Adapter Intel E810 Chip Based
  • Connectors: 1*QSFP28
  • Temperature: 0 ℃ to +55 ℃
  • Humidity: 0 % ~ 90 % (Non-condensing)
  • Model #: LRES1019PF-QSFP28
  •  
  • $659.00 –
  • $10.00 Shipping
Available Direct from LR-LINK Available Direct from LR-LINK
MikroTik Wireless Wire Dish 2 Gb/s aggregate link up to 1500m RBLHGG-60ad kit
Quick View
  •  
  • $579.00 –
  • Free Shipping
Direct from BFKK Direct from BFKK
Intellinet 8-Port Fast Ethernet Office Switch, Desktop Size, Metal, IEEE 802.3az (Energy Efficient Ethernet)
Quick View
Intellinet 8-Port Fast Ethernet Office Switch, Desktop Size, Metal, IEEE 802.3az (Energy Efficient Ethernet)
  • Format: Desktop
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Switching Method: Store and Forward
  • Model #: 523318
Intellinet 8-Port Ethernet Network Switch - Plug-and-Play, Eco-Friendly, 100 Mbps Speed, Ideal for Home & Small Business Networking - 561730
Quick View
  •  
  • $12.99 –
  • $15.87 Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
  • $11.69 - $12.99
Xiiaozet LK301E Gigabit USB3.0 Device Server, 3-Port USB Hub
Quick View
  •  
  • $138.99 –
Juniper Networks SRX320 Firewall w/ Junos Software Base (firewall, NAT, IPSec, routing, MPLS and switching), RMK not included | SRX320-SYS-JB
Quick View
Juniper Networks SRX320 Firewall w/ Junos Software Base (firewall, NAT, IPSec, routing, MPLS and switching), RMK not included | SRX320-SYS-JB
  • Protocols: ROUTING PROTOCOLS IPv4, IPv6, ISO, Connectionless Network Service (CLNS) Static routes RIP v1/v2 OSPF/OSPF v3 BGP with Route Reflector IS-IS Multicast: Internet Group Management Protocol (IGMP) v1/v2, Protocol Independent Multicast (PIM) sparse mode (SM)/dense mode (DM)/source-specific multicast (SSM), Session Description Protocol (SDP), Distance Vector Multicast Routing Protocol (DVMRP), Multicast Source Discovery Protocol (MSDP), Reverse Path Forwarding (RPF) Encapsulation: VLAN, Point-to-Point Protocol (PPP), Frame Relay, High-Level Data Link Control (HDLC), serial, Multilink Point-to-Point Protocol (MLPPP), Multilink Frame Relay (MLFR), and Point-to-Point Protocol over Ethernet (PPPoE) Virtual routers Policy-based routing, source-based routing Equal-cost multipath (ECMP)
  • Brand: Juniper Networks
  • Series: SRX3000...
  • Model #: SRX320-SYS-JB
D-Link Network DES-1005E Switch DES-1005E 5 Port 10/100 Desktop Unmanaged Switch
Quick View
D-Link Network DES-1005E Switch DES-1005E 5 Port 10/100 Desktop Unmanaged Switch
  • Format: Desktop
  • Standards: IEEE 802.3 10BaSE-t Ethernet (twisted-pair copper) IEEE 802.3u 100BaSE-tX Fast Ethernet (twisted-pair copper) ANSI / IEEE 802.3 Nway autonegotiation IEEE 802.3x flow control IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/20/100/200 Mbps
  • Model #: DES-1005E
  •  
  • $19.94 –
  • $7.85 Shipping
GL.iNet GL-MT1300 (Beryl) VPN Secure Travel Gigabit Wireless Router, AC1300 400Mbps (2.4GHz) + 867Mbps (5GHz) Wi-Fi, Pocket-Sized Hotspot, IPv6, Tor, MicroSD Slot, USB3.0 for Wi-Fi Repeater
Quick View
  •  
  • $135.00 –
  • Free Shipping