Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1005P
- $71.99 –
- More options from $53.99 - $101.00
- Free Shipping

Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch 30W - Power Over Ethernet Switch - GbE POE+ Network Switch - Unmanaged
- Format: Desktop
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Jumbo Frames: 9KB
- Model #: IESC1G80UP
- $438.99
- $413.99 –
- Save: $25.00 (5%)
- More options from $413.99 - $529.10
- Free Shipping

Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 12.0 Mb
- Layer: 2
- Model #: R8R50A#ABA
- $189.99 –
- More options from $189.99 - $294.00
- Free Shipping

Quick View
Cisco Catalyst 9200L 48-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-48P-4X-E
- Brand: Cisco
- Series: 9200
- Part Number: C9200L-48P-4X
- Network Management Type: Managed
- Model #: C9200L-48P-4X-E
- $10,638.88 –
- More options from $7,001.99 - $10,638.88
- Free Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- PoE: Yes
- Model #: R8R46A#ABA
- $99.99 –
- More options from $99.99 - $229.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 1430 (R8R49A#ABA)
- Part Number: R8R49A#ABA
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- Model #: R8R49A#ABA
- $129.99 –
- More options from $129.99 - $268.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- SNMP: Yes
- Model #: JL812A#ABA
- $204.99 –
- More options from $159.20 - $311.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 2p SFP 124W 1930 (JL681A#ABA)
- Part Number: JL681A#ABA
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- Model #: JL681A#ABA
- $294.99 –
- More options from $253.06 - $415.00
- Free Shipping

Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES101GP2SFW
- $451.99 –
- More options from $451.99 - $574.84
- Free Shipping

Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: WGS-5225-8T2SV
- $341.99 –
- More options from $327.20 - $341.99
- Free Shipping

Quick View
SonicWall Managed PoE Switch SWS14-24FPOE | 02-SSC-2468 28 Ports - Manageable - 2 Layer Supported - Modular - 500.40 W Power Consumption - 410 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports
- Format: Desktop
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- MAC Address Table: 32K
- Model #: 02-SSC-2468
- $899.96
- See price in cart
- Free Shipping

Quick View
in 30 days
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE- Part Number: FS-124F-FPOE
- Format: Rackmount
- Management Interface: 24x GE RJ45 and 4x 10GE SFP+
- Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
- Model #: FS-124F-FPOE
- $1,662.99
- $1,328.99 –
- Save: $334.00 (20%)
- Free Shipping

Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
- Format: DIN Rail and Wall Mount Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 18 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-20160HPT
- $1,301.80
- See price in cart
- Free Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- $435.60
- See price in cart
- More options from $399.00 - $405.99
- Free Shipping

Quick View
SONICWALL 02-SSC-2466 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 530 W Power Consumption - 740 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - 1U - Rack-mountable
- Format: Desktop
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- MAC Address Table: 32K
- Model #: 02-SSC-2466
- $1,466.99 –
- Free Shipping

Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
- Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES81GPOEW
- $390.99
- $292.99 –
- Save: $98.00 (25%)
- More options from $292.99 - $370.61
- $1.99 Shipping

Quick View
SonicWall Switch SWS12-8POE 10 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 73.30 W Power Consumption - 55 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: 02-SSC-2463
- $314.99 –
- Free Shipping

Quick View
CSE-PT813-PD5I2 1U Power Distributor
- Model #: tmgalaxy-CSE-PT813-PD5I2
- $548.60 –
- Free Shipping

Quick View
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
- Format: External
- Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
- Primary Ports: 5 x RJ45
- MAC Address Table: 1K
- Model #: 530378
- $61.99
- $21.99 –
- Save: $40.00 (64%)
- $11.20 Shipping

Quick View
Netgear ProSafe GS752TP 48-Port Manageable Gigabit Ethernet Switch, GS752TP-300NAS
- Brand: NETGEAR
- Part Number: GS752TP-300NAS
- Network Management Type: Smart
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: GS752TP-300NAS
- $679.99 –
- Free Shipping

Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: CBS110-8PP-D-NA
- $150.46
- See price in cart
- More options from $123.99 - $139.36
- Free Shipping

Quick View
NETGEAR 8x1G PoE+ 240W 2x1G and 2xSFP+ Managed Switch | AV Line M4250-10G2XF-PoE, GSM4212PX
- Format: Rackmount
- Primary Ports: 8 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 8 x 10/100/1000BASE-T (RJ45) PoE+ with 240W PoE budget 2 x 10/100/1000BASE-T (RJ45) 2 x 1000/10GBASE-X (SFP+)
- Model #: GSM4212PX-100NAS
- $1,079.99 –
- Free Shipping

Quick View
SonicWall 100GBase-SR4 QSFP28 850nm 100m Module - For Firewall - 1x 100GBase-SR4 Network - Optical Fiber - Multi-mode - 100 Gigabit Ethernet - 100GBase-SR4 - TAA - 02-SSC-5806
- Brand: SonicWall
- Part Number: 02-SSC-5806
- Switch Type: 100GBase-SR4 QSFP28 Transceiver Module
- Format: QSFP28
- Model #: 02-SSC-5806
- $650.00 –
- Free Shipping

Quick View
H14SSL-NT Motherboard - EPYC 9005 series, SoC, DDR5 12 DIMM slots
- Model #: tmgalaxy-H14SSL-NT
- $3,749.98 –
- Free Shipping

Quick View
SonicWall TZ580 Firewall (Gen 8), w/ Secure Upgrade Plus (3-Year Advanced Protection Security Suite) and 1 Year CSE (3 & Free Program) | 03-SSC-7462
- Brand: SONICWALL
- Part Number: 03-SSC-7462
- Type: Wired
- Form Factor: Desktop
- Model #: 03-SSC-7462
- $5,065.00
- $4,457.20 –
- Save: $607.80 (12%)
- Free Shipping

Quick View
Cisco Catalyst 9200L 24-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-24P-4X-E
- Brand: Cisco
- Series: 9200
- Network Management Type: Managed
- Primary Port Speed: 10GBase-X 10/100/1000Base-T
- Model #: C9200L-24P-4X-E
- $2,527.99 –
- More options from $2,527.99 - $2,754.53
- Free Shipping

Quick View
Netgear ProSafe M4300-24X 24-Port Manageable 10GBase-T, 10GBase-X - 4 Layer Switch, XSM4324CS-100NES
- Brand: NETGEAR
- Series: ProSafe
- Format: Stackable
- Network Management Type: Managed
- Model #: XSM4324CS-100NES
- $3,699.99 –
- Free Shipping

Quick View
HPE Networking Instant On Switch 48p Gigabit 4p SFP 1830 (JL814A#ABA)
- Primary Ports: 48 x RJ45 + 4 x SFP
- Buffer Memory: 1.5 MB
- Layer: 2
- Power: 100 - 240 VAC
- Model #: JL814A#ABA
- $394.99 –
- More options from $394.99 - $578.00
- Free Shipping

Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-500T
- $117.99 –
- Free Shipping

Quick View
SonicWall Managed Switch SWS12-10FPOE w/ 3-Year Network Management Essential and Support | 02-SSC-8371
- Brand: SONICWALL
- Part Number: SWS12-10FPOE
- Format: Desktop
- Network Management Type: Managed
- Model #: 02-SSC-8371
- $418.80 –
- Free Shipping

Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T2S
- $245.99 –
- Free Shipping

Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-621T
- $132.00
- See price in cart
- Free Shipping

Quick View
Planet ISW-511T 4+1 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511T for up to 2 km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511T
- $112.99 –
- Free Shipping

Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T
- $201.60
- See price in cart
- Free Shipping

Quick View
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
- Format: Rack-mountable Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Base-T
- Model #: DGS-1210-52
- $395.29 –
- Free Shipping

Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P4S
- $767.80
- See price in cart
- Free Shipping


