Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
RUCKUS ICX 7550, 48-port 10/100/1000 Mbps 802.3at POE+, 2x 40Gbps QSFP+ dual-mode uplink/stacking ports, modular slot, 3-Y remote support included | ICX7550-48P-E2-R3
Quick View
RUCKUS ICX 7550, 48-port 10/100/1000 Mbps 802.3at POE+, 2x 40Gbps QSFP+ dual-mode uplink/stacking ports, modular slot, 3-Y remote support included | ICX7550-48P-E2-R3
  • Part Number: ICX7550-48P-E2-R3
  • Primary Ports: Interfaces: 48-port 10/100/1000 Mbps 802.3at POE+ with 2-ports 40 Gbps Uplink/Stack QSFP+ 10/100/1000BASE-T Ports: 48
  • Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
  • Power: Power / Device Type: Power Supply Power / Installed Qty: 2 Power / Provided (W): 1200 Watt Max Power Consumption: 1131.6 Watt Power / Voltage Required: 180-240V
  • Model #: ICX7550-48P-E2-R3
  •  
  • $10,074.99 –
  • Free Shipping
FortiSwitch-424E Layer 2/3 FortiGate switch controller compatible switch with 24 x GE RJ45 ports, 4 x 10 GE SFP+ uplinks
Quick View
FortiSwitch-424E Layer 2/3 FortiGate switch controller compatible switch with 24 x GE RJ45 ports, 4 x 10 GE SFP+ uplinks
  • Format: Rackmount
  • Primary Ports: 24x GE RJ45 and 4x10 GE SFP+ ports Note: SFP+ ports are compatlble with 1 GE SFP
  • VLAN Support: 4K
  • Packet Forwarding Rate: 190 Mpps
  • Model #: FS-424E
  •  
  • $1,615.99 –
  • Free Shipping
Ruckus ICX7550-24-E2 24 Ports 1G Mid-Range Enterprise-Class Stackable Access/Aggregation Switch, 2 AC Power Supplies with Exhaust Airflow Installed
Quick View
Ruckus ICX7550-24-E2 24 Ports 1G Mid-Range Enterprise-Class Stackable Access/Aggregation Switch, 2 AC Power Supplies with Exhaust Airflow Installed
  • Part Number: ICX7550-24-E2
  • Format: 1RU
  • Primary Ports: Interfaces: 24-port 10/100/1000 Mbps; 2-port 40 Gbps Uplink/Stack QSFP+, expansion module slot 10/100/1000BASE-T Ports: 24
  • Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
  • Model #: ICX7550-24-E2
  • $8,690.00
  •  
  • $6,107.99 –
  • Save: $2,582.01 (29%)
  • Free Shipping
D-Link 28-Port Layer 2 Smart Managed Gigabit Poe Switch
Quick View
D-Link 28-Port Layer 2 Smart Managed Gigabit Poe Switch
  • Brand: D-LINK BUSINESS PRODUCTS SOLUTIONS
  • Part Number: DGS-1210-28MP
  • Switch Type: Others
  • Format: 28 Port Gigabit 370W PoE
  • Model #: DGS-1210-28MP
Fortinet FortiSwitch Secure Campus 448E, 48-port managed ethernet switch, L3, rack-mountable, FS-448E
Quick View
Fortinet FortiSwitch Secure Campus 448E, 48-port managed ethernet switch, L3, rack-mountable, FS-448E
  • Format: Rackmount
  • Management Interface: 48x GE RJ45 and 4x 10GE SFP+ ports
  • Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
  • VLAN Support: 4K
  • Model #: FS-448E
  • $2,725.00
  •  
  • $2,027.99 –
  • Save: $697.01 (25%)
  • Free Shipping
ZyXEL 8-Port GbE Web Managed PoE Switch, GS1200-8HPv2
Quick View
ZyXEL 8-Port GbE Web Managed PoE Switch, GS1200-8HPv2
  • Standards: EEE 802.3u 100BASE-TX Ethernet: Yes IEEE 802.3ab 1000BASE-T Ethernet: Yes IEEE 802.3az EEE support: Yes IEEE 802.3x flow control: Yes IEEE 802.3z 1000BASE-X: Yes IEEE 802.1p CoS:Yes IEEE 802.3af PoE: Yes IEEE 802.3at PoE Plus: Yes (30W per port) Auto MDI/MDI-X: Yes IEEE802.1Q VLAN tagging: Yes
  • Primary Ports: 4 x 1000BASE-T 4 x 1000BASE-T PoE
  • MAC Address Table: 4K
  • VLAN Support: Yes
  • Model #: GS1200-8HP
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
  • Format: DIN Rail Mount
  • MAC Address Table: 8K MAC address table with auto learning function
  • Jumbo Frames: 9000 bytes
  • Buffer Memory: 1MB
  • Model #: WGS-804HP
Cisco Catalyst 9200L 24-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-24P-4X-E
Quick View
Cisco Catalyst 9200L 24-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-24P-4X-E
  • Brand: Cisco
  • Series: 9200
  • Network Management Type: Managed
  • Primary Port Speed: 10GBase-X 10/100/1000Base-T
  • Model #: C9200L-24P-4X-E
Fortinet FortiSwitch 248E-POE, Layer 2/3 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 SFP ports, 24 port PoE w/ maximum 370 W limit | FS-248E-POE
Quick View
  •  
  • $2,470.99 –
  • Free Shipping
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
Quick View
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
  • Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
  • Primary Port Speed: 20Gbps / non-blocking
  • Model #: MGSD-10080F
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-801T
  •  
  • $657.00 –
  • Free Shipping
Sophos SD-RED 60 Rev.1 Remote Ethernet Device (R60ZTCHUS)
Quick View
  •  
  • $1,149.99 –
  • $5.99 Shipping
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-801T
  •  
  • $160.99 –
  • Free Shipping
Cisco Catalyst 9200L 24-port PoE+ 4x1G uplink Switch, Network Essentials | C9200L-24P-4G-E
Quick View
Cisco Catalyst 9200L 24-port PoE+ 4x1G uplink Switch, Network Essentials | C9200L-24P-4G-E
  • Brand: CISCO
  • Series: 9200
  • Network Management Type: Managed
  • Primary Port Speed: 1000Base-X 10/100/1000Base-T
  • Model #: C9200L-24P-4G-E
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
  • Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
  • Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
  • Model #: WGSW-24040
Allied Telesis SPTX-90 SFP (mini-GBIC) Module
Quick View
  •  
  • $29.99 –
  • $5.99 Shipping
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-501T
  •  
  • $114.99 –
  • Free Shipping
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
Quick View
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
  • Format: Wall-mount and DIN Rail Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az EEE (Energy Efficient Ethernet) RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2 ITU-T G.8032 ERPS (Ethernet Ring Protection Switching)
  • Primary Ports: 6 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5226-4P2T
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
  • MAC Address Table: 2K
  • Model #: ISW-621TS15
CSE-113AC2-R706WB2 1U Chassis with Redundant 750W PWS
Quick View
CSE-113AC2-R706WB2 1U Chassis with Redundant 750W PWS
  • Model #: tmgalaxy-CSE-113AC2-R706WB2
  •  
  • $3,749.98 –
  • Free Shipping
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-621TF
  •  
  • $96.99 –
  • Free Shipping
CSE-825TQC-R802WB 2U SAS3 WIO Chassis with Redundant 800W PWS
Quick View
  •  
  • $3,249.98 –
  • Free Shipping
IoT SuperServer SYS-510D-10C-FN6P CSE-505-203B + X12SDV-10C-SP6F
Quick View
  •  
  • $7,699.98 –
  • Free Shipping
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511S15
4U Lockable Rackmount Drawer, SPCC
EIA 19" Racks/Cabinets
Quick View
  •  
  • $747.00 –
  • Free Shipping
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P2S2X
CSE-825TQC-R802LPB 2U Rackmount 800W Power Supply
Quick View
  •  
  • $2,793.00 –
  • Free Shipping
Planet IGS-10020PT Industrial 8-Port 10/100/1000T 802.3af PoE + 2 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
Quick View
Planet IGS-10020PT Industrial 8-Port 10/100/1000T 802.3af PoE + 2 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
  • Primary Ports: 8 10/100/1000Base-T RJ-45 Auto-MDI/MDI-X ports / 2 1000Base-SX/LX/BX SFP interfaces (Port-9 and Port-10)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-10020PT
CSE-846BE2C-R1K03JBOD 4U SAS3 24 Drive JBOD w/ Dual Expander, 1000W
Quick View
  •  
  • $10,999.98 –
  • Free Shipping
CSE-826BE1C4-R1K23WB1 2U WIO Chassis-Single SAS3, Redundant 1200W PWS
Quick View
  •  
  • $6,599.98 –
  • Free Shipping
CSE-PT20 4U Power Backplane
Quick View
CSE-PT20 4U Power Backplane
  • Model #: tmgalaxy-CSE-PT20
  •  
  • $822.93 –
  • Free Shipping
X12SDV-4C-SP6F MB - Embedded FlexATX, Xeon ICX-D, Dual 25GSFP28
Quick View
  •  
  • $3,249.98 –
  • Free Shipping
Opengear CM8132-10G Console Server - 32 selectable serial ports - 2x 10GbE SFP+, 2x 1GbE - ARM 1.6GHz 2-core - 2GB  - 32GB Flash Memory - TPM 2.0 - Docker support - C14 power cord
Quick View