Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
- Brand: CISCO
- Part Number: CBS220-24FP-4G-NA
- Switch Type: managed
- Format: 24-port GE / PoE + / 382W / 4 x GE uplinks
- Model #: CBS22024FP4GNA
- $764.99
- $698.99 –
- Save: $66.00 (8%)
- More options from $698.99 - $765.23
- Free Shipping

Quick View
D-LINK DIS-100G-5PSW 5-Port Unmanaged Industrial Switch - 120W
- Standards: IEEE 802.3 for Ethernet IEEE 802.3u for Fast Ethernet IEEE 802.3ab for Gigabit Ethernet IEEE 802.3z for Gigabit fiber IEEE 802.3x Flow Control IEEE 802.3af/at Power over Ethernet (DIS-100G-5PSW) IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 4 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 2K
- Model #: DIS-100G-5PSW
- $427.99 –
- More options from $342.96 - $427.99

Quick View
D-Link DGS-1008P Switches 4 to 10 Ports 8-port Gigabit Ethernet POE Switch
- Format: External
- Standards: IEEE 802.3/3u, IEEE 802.3af
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1008P
- $69.03 –
- More options from $69.03 - $94.99
- Free Shipping

Quick View
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
- Uplink Ports: None
- Primary Ports: 16 x RJ45
- Model #: TL-SG1016DE
- $106.88 –
- More options from $106.88 - $152.63

Quick View
UBIQUITI ER-6P EdgeRouter 6P, 6-Port Gigabit Router with 1 SFP Port
- Primary Ports: 1 x RJ45 Serial Port 5 x 10/100/1000 Ethernet Router Ports 1 x 1 Gbps SFP Ethernet Router Port 1 x USB 3.0 reserved for future
- LEDs: Data Ports: Speed / Link / Activity, PoE SFP Data Port: Link / Activity
- Power: Max. Power Consumption: 16W (Excludes PoE Output) Power Method: 24V, 2.5A Power Adapter (Included) Power Supply: External AC Power Adapter, 60W (24V, 2.5A) Supported Voltage Range: 100-240V AC, 50/60 Hz Universal Adapter 30-16V
- Dimensions: 9.02" x 5.37" x 1.22"
- Model #: ER-6P
- $269.13 –
- More options from $269.13 - $399.63
- Free Shipping

Quick View
Ubiquiti (UXG-Pro-US) Next-Generation Gateway Pro
- LAN Ports: LAN: (1) 1 GbE RJ45 port (1) 10G SFP+ port WAN: (1) 1 GbE RJ45 port (1) 10G SFP+ port
- Brand: Ubiquiti Networks
- Series: Gateway
- LEDs: Ethernet Green/amber SFP+ White/ green AC outlet/ RPS Blue
- Model #: UXG-Pro-US
- $897.02 –
- More options from $479.00 - $897.02
- Free Shipping

Quick View
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
- Brand: PLANET
- Format: 19-inch Desktop size, 1U Height, Rack Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Network Management Type: Unmanaged
- Model #: GSW-2620VHP
- $432.00
- See price in cart
- Free Shipping

Quick View
D-Link Network DES-1005E Switch DES-1005E 5 Port 10/100 Desktop Unmanaged Switch
- Format: Desktop
- Standards: IEEE 802.3 10BaSE-t Ethernet (twisted-pair copper) IEEE 802.3u 100BaSE-tX Fast Ethernet (twisted-pair copper) ANSI / IEEE 802.3 Nway autonegotiation IEEE 802.3x flow control IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/20/100/200 Mbps
- Model #: DES-1005E
- $19.94 –
- $7.85 Shipping

Quick View
D-Link 8-Port EasySmart Gigabit PoE Ethernet Switch - Lifetime Warranty (DGS-1100-08P)
- Brand: D-Link
- Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
- Network Management Type: Smart
- Primary Ports: 8 x RJ45
- Model #: DGS-1100-08P
- $122.23 –
- Free Shipping

Quick View
D-Link 28-Port Web Smart Gigabit Ethernet PoE Switch (DGS-1210-28P)
- Format: Rack-mountable Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode IEEE 802.3af compliance (DGS-1210-28P only) Auto-negotiation
- Primary Ports: 24 x 10/100/1000BASE-T PoE 4 x 4 SFP
- Primary Port Speed: 10/100/1000Base-T
- Model #: DGS-1210-28P
- $378.99 –
- More options from $378.99 - $514.00

Quick View
D-Link WebSmart DES-1210-28 Smart Switch
- Format: Rackmount
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted-pair copper) IEEE 802.3z Gigabit Ethernet (fiber) ANSI/IEEE 802.3 Auto-negotiation IEEE 802.3x Flow Control
- Primary Ports: 26 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100Mbps + 1000Mbps
- Model #: DES-1210-28
- $151.90 –
- Free Shipping

Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES101GP2SFW
- $451.99 –
- More options from $451.99 - $574.84
- Free Shipping

Quick View
Juniper Networks EX4000Switch, 24-Port 10/100/1000BaseT, 4x 1G/10G SFP/SFP+ (optics sold separately) with Standard SW | EX4000-24T
- Brand: Juniper Networks, Inc.
- Series: EX4000
- Part Number: EX4000-24T
- Network Management Type: Managed
- Model #: EX4000-24T
- $1,753.40 –
- More options from $904.99 - $1,812.33
- Free Shipping

Quick View
TP-Link Omada 16-Port Gigabit Easy Managed Switch - 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 2 Layer Supported - 8.40 W Power Consumption - Twisted Pair - 1U - Desktop, Rack-moun
- Brand: TP-Link
- Format: Desktop / Rackmountable
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: ES216G

Quick View
Planet ISW-511T 4+1 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511T for up to 2 km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511T
- $112.99 –
- Free Shipping

Quick View
TRENDnet 8-Port Gigabit GREENnet PoE+ Switch, TPE-TG81g, 8 x Gigabit PoE+ Ports, Rack Mountable, Up to 30 W Per Port with 110 W Total Power Budget, Ethernet Network Switch, Metal, Lifetime Protection
- Brand: TRENDnet
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX IEEE 802.3ab 1000Base-T IEEE 802.3at Power over Ethernet (PoE+) IEEE 802.3af Power over Ethernet (PoE) IEEE 802.3x Flow Control IEEE 802.3az Energy Efficient Ethernet
- Network Management Type: Network - Switches
- Model #: TPE-TG81g
- $110.33 –
- More options from $110.33 - $212.00

Quick View
D-Link DGS-1024C 24-Port 10/100/1000 Mbps Gigabit Unmanaged Desktop Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: DGS-1024C
- $89.00 –
- More options from $89.00 - $116.87
- Free Shipping

Quick View
PLANET IGS-4215-4P4T2S Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40~75 degrees C)
- Primary Ports: 8-port 10/100/1000BASE-T Gigabit RJ45 copper with 4-port IEEE 802.3at/af PoE Injector (Port-1 to Port-4) 2 x 100/1000BASE-X mini-GBIC / SFP slots, SFP type auto detection
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Switching Method: Store and Forward
- Model #: IGS-4215-4P4T2S
- $549.99 –
- Free Shipping

Quick View
TP-Link TL-SG105PP-M2 Unmanaged Desktop Switch with 4-Port PoE++
- Format: Desktop
- Primary Ports: 5 x RJ45
- Primary Port Speed: 2.5 Gbps
- Primary Port Type: 5 x 10 Mbps/100 Mbps/1 Gbps/2.5 Gbps RJ45 ports
- Model #: TL-SG105PP-M2
- $170.39 –
- More options from $170.39 - $373.45

Quick View
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
- Format: Desktop
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 4-Port 10/100TX 802.3af/at PoE 2-Port 10/100TX
- Primary Port Speed: 10/100Mbps
- Model #: FSD-604HP
- $49.99 –
- Free Shipping

Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
- Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES81GPOEW
- $390.99
- $292.99 –
- Save: $98.00 (25%)
- More options from $292.99 - $370.61
- $1.99 Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- $435.60
- See price in cart
- More options from $399.00 - $405.99
- Free Shipping

Quick View
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSD-1008HPS
- $236.00
- See price in cart
- Free Shipping

Quick View
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port 10/100TX
- MAC Address Table: 8K
- Model #: FSD-1008HP
- $88.99 –
- Free Shipping

Quick View
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 10/100/1000T 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: IGS-4215-8P2T2S
- $530.99 –
- More options from $530.99 - $651.20
- Free Shipping

Quick View
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
- Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
- MAC Address Table: 2K
- Switching Method: Store and Forward
- Model #: ISW-514PTF
- $215.99 –
- Free Shipping

Quick View
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
- Primary Ports: 4 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-620TF
- $198.00
- See price in cart
- Free Shipping

Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-500T
- $117.99 –
- Free Shipping

Quick View
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
- Primary Ports: (4) 10/100 MbE fast ports
- PoE: Yes
- Power: Power method PV panel (H4 connectors) Max. power consumption 2W Supported voltage range 10–60V (Reverse protection, surge protection) Max. open circuit voltage: 60V
- Dimensions: 202 x 190 x 50 mm (8 x 7.5 x 2")
- Model #: SM-SP-40
- $199.00 –
- Free Shipping

Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-621T
- $132.00
- See price in cart
- Free Shipping

Quick View
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet over Fiber-Optic IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 24 x 10/100BASE-TX RJ45 copper with 24-port IEEE 802.3at / af PoE injector 2 x 10/100/1000BASE-T Gigabit RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots, shared with port-25 to port-26
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSW-2624HPS4
- $556.00
- See price in cart
- Free Shipping

Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T2S
- $245.99 –
- Free Shipping

Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P4S
- $767.80
- See price in cart
- Free Shipping

Quick View
TP-Link TL-SL1311MP | 8 Port 10/100Mbps Fast Ethernet PoE Switch | 8 PoE+ Ports @124W, w/ 2 Uplink Gigabit Ports + 1 SFP Port | Limited Lifetime Protection | PoE Recovery | Extend & Isolation Mode
- Format: Desktop
- Primary Ports: 8x 10/100 Mbps 802.3af/at PoE+ Ports, 2x Gigabit RJ45 Ports, 1x Gigabit SFP Port
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 2K
- Model #: TL-SL1311MP
- $151.95 –
- More options from $79.99 - $151.95

Quick View
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511TS15
- $121.99 –
- Free Shipping

Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
- Brand: PLANET
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGSW-24040R
- $376.00
- See price in cart
- Free Shipping
