Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1005P
- $71.99 –
- More options from $53.99 - $101.00
- Free Shipping

Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch 30W - Power Over Ethernet Switch - GbE POE+ Network Switch - Unmanaged
- Format: Desktop
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Jumbo Frames: 9KB
- Model #: IESC1G80UP
- $438.99
- $413.99 –
- Save: $25.00 (5%)
- More options from $413.99 - $529.10
- Free Shipping

Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 12.0 Mb
- Layer: 2
- Model #: R8R50A#ABA
- $189.99 –
- More options from $189.99 - $294.00
- Free Shipping

Quick View
Ubiquiti Dream Machine Beast (UDM-Beast)
- Security: Stateful Firewall Application-Aware Layer 7 Firewall DPI & Traffic Identification Zone-Based Firewall Advanced Filtering (Regions, Domains, Apps) Content Filtering Intrusion Prevention (IPS/IDS) Ad Blocking IDS/IPS Signatures: 55,000+ with CyberSecure
- Brand: Ubiquiti Networks
- Series: Dream Machine
- Part Number: UDM-Beast
- Model #: UDM-Beast
- $1,629.00 –
- More options from $1,629.00 - $1,699.00
- Free Shipping

Quick View
Cisco Catalyst 9200L 48-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-48P-4X-E
- Brand: Cisco
- Series: 9200
- Part Number: C9200L-48P-4X
- Network Management Type: Managed
- Model #: C9200L-48P-4X-E
- $10,638.88 –
- More options from $7,001.99 - $10,638.88
- Free Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- PoE: Yes
- Model #: R8R46A#ABA
- $99.99 –
- More options from $99.99 - $229.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 1430 (R8R49A#ABA)
- Part Number: R8R49A#ABA
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- Model #: R8R49A#ABA
- $129.99 –
- More options from $129.99 - $268.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- SNMP: Yes
- Model #: JL812A#ABA
- $204.99 –
- More options from $159.20 - $311.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit 2p SFP 1930 (JL680A#ABA)
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- SNMP: Yes
- Model #: JL680A#ABA
- $144.99 –
- More options from $144.99 - $218.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 4p SFP+ 1930 - JL682A
- Part Number: JL682A#ABA
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- Model #: JL682A#ABA
- $314.99 –
- More options from $314.99 - $538.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 2p SFP 124W 1930 (JL681A#ABA)
- Part Number: JL681A#ABA
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- Model #: JL681A#ABA
- $294.99 –
- More options from $253.06 - $415.00
- Free Shipping

Quick View
HPE Networking Instant On 1930 24-port PoE Switch, 4 SFP+ ports 370W | JL684B#ABA
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Buffer Memory: 1.5 MB
- PoE: Yes
- Model #: JL684B#ABA
- $689.99 –
- More options from $472.99 - $846.00
- Free Shipping

Quick View
CSE-M28SAB Black SAS/SATA Mobile Rack for 8x 2
- Model #: tmgalaxy-CSE-M28SAB
- $749.88 –
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit CL4 PoE 2p SFP 195W 1830 (JL813A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- PoE: Yes
- Model #: JL813A#ABA
- $399.99 –
- More options from $399.99 - $588.00
- Free Shipping

Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES101GP2SFW
- $451.99 –
- More options from $451.99 - $574.84
- Free Shipping

Quick View
Netgear 5-Port Multi-Gigabit (2.5G) Ethernet Unmanaged Switch, MS105-100NAS
- Brand: NETGEAR
- Standards: IEEE 802.3az
- Network Management Type: Unmanaged
- Primary Ports: 5 x RJ45
- Model #: MS105-100NAS
- $159.99 –
- Free Shipping

Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: WGS-5225-8T2SV
- $341.99 –
- More options from $327.20 - $341.99
- Free Shipping

Quick View
HPE Networking Instant On 8-Port Gigabit Managed Switch 1830 (JL810A#ABA)
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5MB
- SNMP: Yes
- Model #: JL810A#ABA
- $104.99 –
- More options from $104.99 - $218.00
- Free Shipping

Quick View
in 30 days
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE- Part Number: FS-124F-FPOE
- Format: Rackmount
- Management Interface: 24x GE RJ45 and 4x 10GE SFP+
- Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
- Model #: FS-124F-FPOE
- $1,662.99
- $1,328.99 –
- Save: $334.00 (20%)
- Free Shipping

Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
- Format: DIN Rail and Wall Mount Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 18 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-20160HPT
- $1,301.80
- See price in cart
- Free Shipping

Quick View
SonicWall Switch SWS12-8POE 10 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 73.30 W Power Consumption - 55 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: 02-SSC-2463
- $314.99 –
- Free Shipping

Quick View
Netgear GS524PP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (300W), GS524PP-100NAS
- Brand: NETGEAR
- Format: Desktop / Rackmount
- Network Management Type: Unmanaged
- Primary Ports: 24 x RJ45
- Model #: GS524PP-100NAS
- $389.99 –
- Free Shipping

Quick View
Netgear ProSafe GS752TP 48-Port Manageable Gigabit Ethernet Switch, GS752TP-300NAS
- Brand: NETGEAR
- Part Number: GS752TP-300NAS
- Network Management Type: Smart
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: GS752TP-300NAS
- $679.99 –
- Free Shipping

Quick View
HPE Networking Instant On Switch 48p Gigabit CL4 PoE 4p SFP 370W 1830 (JL815A#ABA)
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- PoE: Yes
- Model #: JL815A#ABA
- $679.99 –
- More options from $658.46 - $1,059.00
- Free Shipping

Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: CBS110-8PP-D-NA
- $150.46
- See price in cart
- More options from $123.99 - $139.36
- Free Shipping

Quick View
NETGEAR 8x1G PoE+ 240W 2x1G and 2xSFP+ Managed Switch | AV Line M4250-10G2XF-PoE, GSM4212PX
- Format: Rackmount
- Primary Ports: 8 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 8 x 10/100/1000BASE-T (RJ45) PoE+ with 240W PoE budget 2 x 10/100/1000BASE-T (RJ45) 2 x 1000/10GBASE-X (SFP+)
- Model #: GSM4212PX-100NAS
- $1,079.99 –
- Free Shipping

Quick View
Intel Ethernet Converged Network Adapter X550, Backward compatible 10GBASE-T network adapter | X550T2
- Brand: Intel
- Part Number: X550-T2
- Speed: Dual-port 100Mb/s: 3.9 W (Typical Power) 4.9 W (Maximum Power) Dual-port 1GbE 5.5 W (Typical Power) 6.4 W (Maximum Power) Dual-port 10GbE 11.2 W (Typical Power) 13.0 W (Maximum Power)
- Connectors: 2 x RJ45
- Model #: X550T2
- $115.79 –
- More options from $115.79 - $169.73
- Free Shipping

Quick View
TP-Link TL-SG1008MP - switch - 8 ports - unmanaged - rack-mountabl (TL-SG1008MP)
- Brand: TP-Link
- Series: ProSafe
- Part Number: TL-SG1008MP
- Switch Type: Others
- Model #: TL-SG1008MP
- $122.29 –
- More options from $99.44 - $276.99
- Free Shipping

Quick View
Netgear ProSafe M4300-24X 24-Port Manageable 10GBase-T, 10GBase-X - 4 Layer Switch, XSM4324CS-100NES
- Brand: NETGEAR
- Series: ProSafe
- Format: Stackable
- Network Management Type: Managed
- Model #: XSM4324CS-100NES
- $3,699.99 –
- Free Shipping

Quick View
HPE Networking Instant On Switch 48p Gigabit 4p SFP 1830 (JL814A#ABA)
- Primary Ports: 48 x RJ45 + 4 x SFP
- Buffer Memory: 1.5 MB
- Layer: 2
- Power: 100 - 240 VAC
- Model #: JL814A#ABA
- $394.99 –
- More options from $394.99 - $578.00
- Free Shipping

Quick View
Planet ISW-511T 4+1 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511T for up to 2 km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511T
- $112.99 –
- Free Shipping

Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T
- $201.60
- See price in cart
- Free Shipping

Quick View
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
- Format: Rack-mountable Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Base-T
- Model #: DGS-1210-52
- $395.29 –
- Free Shipping

Quick View
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
- Brand: NETGEAR
- Format: Desktop / Rackmount
- Network Management Type: Unmanaged
- Primary Ports: 16 x RJ45
- Model #: GS516UP-100NAS
- $369.99 –
- Free Shipping

Quick View
SuperMicr MCP-220-00188-0B 2.5in Tool-Less Hard Drive Tray CSE-LB16TS-R804AMP
- Model #: tmgalaxy-MCP-220-00188-0B
- $259.00
- Request Price
- More options from $199.00 - $374.98
- Free Shipping

Quick View
Axiom Memory Solutionlc 1000Base-SX SFP Transceiver for Allied Telesis - At-Spsx-90
- Model #: 694782013800
- $100.18 –
- More options from $94.99 - $100.18
- Free Shipping




