Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
X12SDV-8C-SPT4F MB - Embedded mini ITX, Xeon D-1736NT, Dual 25G SFP28
- Model #: tmgalaxy-X12SDV-8C-SPT4F
- $4,998.18 –
- Free Shipping

Quick View
RUCKUS ICX 7550, 48-port 10/100/1000 Mbps 802.3at POE+, 2x 40Gbps QSFP+ dual-mode uplink/stacking ports, modular slot, 3-Y remote support included | ICX7550-48P-E2-R3
- Part Number: ICX7550-48P-E2-R3
- Primary Ports: Interfaces: 48-port 10/100/1000 Mbps 802.3at POE+ with 2-ports 40 Gbps Uplink/Stack QSFP+ 10/100/1000BASE-T Ports: 48
- Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
- Power: Power / Device Type: Power Supply Power / Installed Qty: 2 Power / Provided (W): 1200 Watt Max Power Consumption: 1131.6 Watt Power / Voltage Required: 180-240V
- Model #: ICX7550-48P-E2-R3
- $10,074.99 –
- Free Shipping

Quick View
SonicWall Managed PoE Switch SWS14-24FPOE | 02-SSC-2468 28 Ports - Manageable - 2 Layer Supported - Modular - 500.40 W Power Consumption - 410 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports
- Format: Desktop
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- MAC Address Table: 32K
- Model #: 02-SSC-2468
- $899.96
- See price in cart
- Free Shipping

Quick View
FortiSwitch-424E Layer 2/3 FortiGate switch controller compatible switch with 24 x GE RJ45 ports, 4 x 10 GE SFP+ uplinks
- Format: Rackmount
- Primary Ports: 24x GE RJ45 and 4x10 GE SFP+ ports Note: SFP+ ports are compatlble with 1 GE SFP
- VLAN Support: 4K
- Packet Forwarding Rate: 190 Mpps
- Model #: FS-424E
- $1,615.99 –
- Free Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- $435.60
- See price in cart
- More options from $399.00 - $405.99
- Free Shipping

Quick View
SONICWALL 02-SSC-2466 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 530 W Power Consumption - 740 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - 1U - Rack-mountable
- Format: Desktop
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- MAC Address Table: 32K
- Model #: 02-SSC-2466
- $1,466.99 –
- Free Shipping

Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
- Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES81GPOEW
- $390.99
- $292.99 –
- Save: $98.00 (25%)
- More options from $292.99 - $370.61
- $1.99 Shipping

Quick View
Ruckus ICX7550-24-E2 24 Ports 1G Mid-Range Enterprise-Class Stackable Access/Aggregation Switch, 2 AC Power Supplies with Exhaust Airflow Installed
- Part Number: ICX7550-24-E2
- Format: 1RU
- Primary Ports: Interfaces: 24-port 10/100/1000 Mbps; 2-port 40 Gbps Uplink/Stack QSFP+, expansion module slot 10/100/1000BASE-T Ports: 24
- Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
- Model #: ICX7550-24-E2
- $8,690.00
- $6,107.99 –
- Save: $2,582.01 (29%)
- Free Shipping

Quick View
Fortinet FortiSwitch Secure Campus 448E, 48-port managed ethernet switch, L3, rack-mountable, FS-448E
- Format: Rackmount
- Management Interface: 48x GE RJ45 and 4x 10GE SFP+ ports
- Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
- VLAN Support: 4K
- Model #: FS-448E
- $2,725.00
- $2,027.99 –
- Save: $697.01 (25%)
- Free Shipping

Quick View
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
- Format: External
- Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
- Primary Ports: 5 x RJ45
- MAC Address Table: 1K
- Model #: 530378
- $61.99
- $21.99 –
- Save: $40.00 (64%)
- $11.20 Shipping

Quick View
ZyXEL 8-Port GbE Web Managed PoE Switch, GS1200-8HPv2
- Standards: EEE 802.3u 100BASE-TX Ethernet: Yes IEEE 802.3ab 1000BASE-T Ethernet: Yes IEEE 802.3az EEE support: Yes IEEE 802.3x flow control: Yes IEEE 802.3z 1000BASE-X: Yes IEEE 802.1p CoS:Yes IEEE 802.3af PoE: Yes IEEE 802.3at PoE Plus: Yes (30W per port) Auto MDI/MDI-X: Yes IEEE802.1Q VLAN tagging: Yes
- Primary Ports: 4 x 1000BASE-T 4 x 1000BASE-T PoE
- MAC Address Table: 4K
- VLAN Support: Yes
- Model #: GS1200-8HP
- $59.99
- See price in cart
- More options from $54.99 - $93.90
- $10.99 Shipping

Quick View
SonicWall TZ580 Firewall (Gen 8), w/ Secure Upgrade Plus (3-Year Advanced Protection Security Suite) and 1 Year CSE (3 & Free Program) | 03-SSC-7462
- Brand: SONICWALL
- Part Number: 03-SSC-7462
- Type: Wired
- Form Factor: Desktop
- Model #: 03-SSC-7462
- $5,065.00
- $4,457.20 –
- Save: $607.80 (12%)
- Free Shipping

Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
- Format: DIN Rail Mount
- MAC Address Table: 8K MAC address table with auto learning function
- Jumbo Frames: 9000 bytes
- Buffer Memory: 1MB
- Model #: WGS-804HP
- $198.00
- See price in cart
- More options from $163.99 - $172.00
- Free Shipping

Quick View
Cisco Catalyst 9200L 24-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-24P-4X-E
- Brand: Cisco
- Series: 9200
- Network Management Type: Managed
- Primary Port Speed: 10GBase-X 10/100/1000Base-T
- Model #: C9200L-24P-4X-E
- $2,527.99 –
- More options from $2,527.99 - $2,754.53
- Free Shipping

Quick View
Fortinet FortiSwitch 248E-POE, Layer 2/3 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 SFP ports, 24 port PoE w/ maximum 370 W limit | FS-248E-POE
- Brand: Fortinet
- Series: 200 Series
- Part Number: FS-248E-POE
- Format: Rackmount
- Model #: FS-248E-POE
- $2,470.99 –
- Free Shipping

Quick View
H14SSL-NT Motherboard - EPYC 9005 series, SoC, DDR5 12 DIMM slots
- Model #: tmgalaxy-H14SSL-NT
- $3,749.98 –
- Free Shipping

Quick View
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
- Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
- Primary Port Speed: 20Gbps / non-blocking
- Model #: MGSD-10080F
- $376.00
- See price in cart
- Free Shipping

Quick View
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: ISW-801T
- $657.00 –
- Free Shipping

Quick View
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-801T
- $160.99 –
- Free Shipping

Quick View
Cisco Catalyst 9200L 24-port PoE+ 4x1G uplink Switch, Network Essentials | C9200L-24P-4G-E
- Brand: CISCO
- Series: 9200
- Network Management Type: Managed
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Model #: C9200L-24P-4G-E
- $1,687.99 –
- More options from $1,687.99 - $1,910.24
- Free Shipping

Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: 19-inch Rack-mountable Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 16 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-16T4S
- $872.50
- See price in cart
- More options from $871.99
- Free Shipping

Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
- Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
- Model #: WGSW-24040
- $332.00
- See price in cart
- Free Shipping

Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-501T
- $114.99 –
- Free Shipping

Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-500T
- $117.99 –
- Free Shipping

Quick View
SonicWall Managed Switch SWS12-10FPOE w/ 3-Year Network Management Essential and Support | 02-SSC-8371
- Brand: SONICWALL
- Part Number: SWS12-10FPOE
- Format: Desktop
- Network Management Type: Managed
- Model #: 02-SSC-8371
- $418.80 –
- Free Shipping

Quick View
H12SSL-CT Motherboard Socket SP3/ Single AMD EPYC
- Model #: tmgalaxy-H12SSL-CT
- $5,499.98 –
- Free Shipping

Quick View
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
- Format: Wall-mount and DIN Rail Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az EEE (Energy Efficient Ethernet) RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2 ITU-T G.8032 ERPS (Ethernet Ring Protection Switching)
- Primary Ports: 6 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5226-4P2T
- $607.20
- See price in cart
- Free Shipping

Quick View
Axiom Memory Solutionlc 10gbs Dual Port Sfp+ Pcie X8 Nic Card
- Model #: TOLDB01A33OA7C
- $417.99 –
- Free Shipping

Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
- MAC Address Table: 2K
- Model #: ISW-621TS15
- $152.00
- See price in cart
- Free Shipping

Quick View
X14SBM-TP4F Motherboard MicroATX Single Socket E2 (LGA-4710) Xeon 6700/6500 Series Processors With P-Cores Or 6700 Series Processors With E-Cores
- Model #: TGM3-X14SBM-TP4F
- $2,506.50 –
- Free Shipping

Quick View
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
- MAC Address Table: 2K
- Switching Method: Store and Forward
- Model #: ISW-621TF
- $96.99 –
- Free Shipping

Quick View
HYNIXHynix Hmt325U7Efr8C-Pb Hynix 2Gb (1X2Gb) Pc312800 Ddr31600Mhz Sdram 1Rx8 Ecc Unbuffered Cl11 240Pin Dimm Memory Module
- Model #: HMT325U7EFR8C-PB
- $29.99 –
- Free Shipping

Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T2S
- $245.99 –
- Free Shipping

Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-621T
- $132.00
- See price in cart
- Free Shipping

Quick View
Axiom Memory Solutionlc 10gbs Dual Port Sfp+ Pcie X8 Nic Card
- Model #: TOLDB01A33OEFK
- $628.99 –
- Free Shipping

Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511S15
- $104.00
- See price in cart
- Free Shipping

