Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
Sort By:
View:
Sophos XGS 4500 Network Security/Firewall Appliance - 1-year Standard Protection  - 8 Port - 10/100/1000Base-T, 2.5GBase-T, 10GBase-X - 10 Gigabit Ethernet - 8 x RJ-45 - 6 Total Expansion Slots
Quick View
  •  
  • $25,214.99 –
  • Free Shipping
Sophos XGS 108w Network Security/Firewall Appliance 3 Year XSTREAM Protection - 6 Port - 2.5GBase-T, 1000Base-X - 2.5 Gigabit Ethernet - 12.21 Gbit/s Firewall Throughput - Wireless LAN IEEE 802.11ax
Quick View
  •  
  • $1,967.99 –
  • Free Shipping
Sophos XGS 4300 Network Security/Firewall Appliance - 1 Year Standard Protection - 8 Port - 10/100/1000Base-T, 2.5GBase-T, 10GBase-X - 10 Gigabit Ethernet - 8 x RJ-45 - 6 Total Expansion Slots
Quick View
  •  
  • $18,395.99 –
  • Free Shipping
HPE Aruba Networking 2930F 24G 4SFP+ Switch | JL253A
Quick View
HPE Aruba Networking 2930F 24G 4SFP+ Switch | JL253A
  • Primary Ports: (24) RJ-45 autosensing 10/100/1000 ports (4) SFP+ 1/10GbE ports
  • Dimensions: 1.73" x 17.42" x 7.88"
  • Weight: 5.31 lbs.
  • Package Contents: (1) Aruba 2930F 24G 4SFP+ Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4) bumper feet, (1) cable tie
  • Model #: JL253A#ABA
  •  
  • $3,652.99 –
  • Free Shipping
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
Quick View
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
  • Part Number: C12CTCHUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: C12CTCHUS
  • $1,243.20
  •  
  • $1,126.99 –
  • Save: $116.21 (9%)
  • Free Shipping
Juniper EX4000-24P Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - Modular - 51W Power Consumption - 370 W PoE Budget (EX4000-24P)
Quick View
Juniper EX4000-24P Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - Modular - 51W Power Consumption - 370 W PoE Budget (EX4000-24P)
  • Brand: Juniper Networks, Inc.
  • Part Number: EX4000-24P
  • Switch Type: managed
  • Network Management Type: Managed
  • Model #: EX4000-24P
  • $2,678.85 - $2,682.53
Sophos XGS 116 Network Security/Firewall Appliance - 3 Year Xstream Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
Quick View
  •  
  • $2,701.99 –
  • Free Shipping
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24P-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RFC 951,...
  • Model #: C1300X-24P-4X
NP Type-C to Gigabit PoE Converter, POE Ethernet Adapter gigabit RJ45 to Type C 1000Mbps Converter
Quick View
  •  
  • $137.99 –
  • Free Shipping
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
Quick View
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24NGU-4X
  • Format: Rackmount
  • Model #: C1300X-24NGU-4X
Sophos XGS 116 Network Security/Firewall Appliance - 3 Year Standard Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
Quick View
  •  
  • $2,296.99 –
  • Free Shipping
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
Quick View
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-48P-4X
  • Format: Rackmount
  • Model #: C1300X-48P-4X
Alcatel-Lucent OmniSwitch OS2360-24 24-Port Gigabit Managed Switch 10G SFP+
Quick View
  •  
  • $472.90 –
  • Free Shipping
5 Port Gigabit PoE Switch with 4 Port PoE+ 1000Mbps, 802.3af/at 78W Built-in Power, Fanless Metal Unmanaged Plug & Play
Quick View
5 Port Gigabit PoE Switch with 4 Port PoE+ 1000Mbps, 802.3af/at 78W Built-in Power, Fanless Metal Unmanaged Plug & Play
  • Brand: NETGEAR
  • Series: ProSafe
  • Part Number: YS2041G-P
  • Standards: Passive PoE
  • Model #: 723975703890
  •  
  • $59.99 –
  • Free Shipping
5 Port PoE+ Switch | Easy Smart Managed Ethernet Switch | Support VLAN, QoS | 52W Total PoE Budget | Fanless Metal | Plug & Play (Desktop/Wall Mount)
Quick View
  •  
  • $46.99 –
  • Free Shipping
Cisco Catalyst 8300 Router, 1RU w/ 10G WAN (1 SM slot and 1 NIM slot, 2 x 10-Gigabit Ethernet and 4 x 1-Gigabit Ethernet ports) | C8300-1N1S-4T2X
Quick View
Cisco Catalyst 8300 Router, 1RU w/ 10G WAN (1 SM slot and 1 NIM slot, 2 x 10-Gigabit Ethernet and 4 x 1-Gigabit Ethernet ports) | C8300-1N1S-4T2X
  • Brand: CISCO
  • Part Number: C8300-1N1S-4T2X
  • Form Factor: Rack Mountable
  • System Memory: Memory (DRAM) default: 8 GB
  • Model #: C8300-1N1S-4T2X
10 Port Gigabit Switch, 8 x 100/1000Mbps Ports, 1 Gigabit Uplink, 1 Gigabit SFP, Support Vlan, Metal Fanless Unmanaged Plug and Play Ethernet Switch
Quick View
  •  
  • $51.79 –
  • Free Shipping
Cisco Business CBS110-16T Unmanaged Switch, 16 Port GE, Limited Lifetime Protection (CBS110-16T-NA)
Quick View
Cisco Business CBS110-16T Unmanaged Switch, 16 Port GE, Limited Lifetime Protection (CBS110-16T-NA)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
  • Primary Ports: 16 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: CBS110-16T
  •  
  • $204.99 –
8-Port Gigabit Unmanaged PoE+ Ethernet Switch, with 4 PoE Ports up to 60W PoE Budget, QoS, Fanless, Sturdy Metal with Shielded Ports, Compact Desktop, Follows NDAA/TAA (DGS-1008P)
Quick View
  •  
  • $91.99 –
  • Free Shipping
Mitel MiVoice 6930 IP Phone VoIP phone with Bluetooth Interface
Quick View
  •  
  • $409.00 –
  • Free Shipping
16 Port Gigabit Switch, 16 x 100/1000Mbps Ports, Metal Unmanaged Fanless Pluy and Play Network Switch
Quick View
16 Port Gigabit Switch, 16 x 100/1000Mbps Ports, Metal Unmanaged Fanless Pluy and Play Network Switch
  • Brand: NETGEAR
  • Series: ProSafe
  • Part Number: UMG16
  • Standards: Passive PoE
  • Model #: 648360249095
  •  
  • $74.99 –
  • Free Shipping
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - with 5-year Support
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - with 5-year Support
  • Part Number: LS28FZ60ZZPCUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: LS28FZ60ZZPCUS
  • $1,678.00
  •  
  • $1,587.99 –
  • Save: $90.01 (5%)
  • Free Shipping
5-Port Ethernet PoE Switch (4 PoE Ports, 1 Uplink) with Extend Function, Easy Smart Managed Ethernet Switch, Plug & Play, Fanless Metal Design, VLAN, Qos,Desktop/Wall Mount
Quick View
  •  
  • $46.99 –
  • Free Shipping
mikrotik crs310-1g-5s-4s+in 5 x sfp ports 4 x sfp+ ports and 1 x gigabit ethernet port
Quick View
  •  
  • $299.99 –
  • Free Shipping
Grandstream Gxp2130 Ip Phone - Wall Mountable
Quick View
Grandstream Gxp2130 Ip Phone - Wall Mountable
  • Brand: Grandstream
  • Type: Office Products
  • Weight: 2.7
  • Model #: GXP2130
16 Port Fast Ethernet Switch Unmanaged 10/100 Mbps Desktop Rackmount Plug and Play Metal Housing Fanless Design EEE (DES-1016D)
Quick View
16 Port Fast Ethernet Switch Unmanaged 10/100 Mbps Desktop Rackmount Plug and Play Metal Housing Fanless Design EEE (DES-1016D)
  • Brand: NETGEAR
  • Series: ProSafe
  • Part Number: DES-1016D
  • Format: Desktop
  • Model #: 635446996806
  •  
  • $88.99 –
  • Free Shipping
HP OEM Poly VVX 250 4-Line VoIP Phone, Color LCD, HD Voice, Acoustic Fence Noise Reduction, Dual Gigabit Ethernet, USB Port, PoE, SIP Support, ENERGY STAR, Antimicrobial Surface
Quick View
  •  
  • $99.99 –
  • Free Shipping
avatar

Any questions? Our AI mode will help you find out quickly.

Did You Find It?