Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Real HD 16 Port PoE Switch, High Power 300W, 16 PoE+ 100Mbps Ports with 2 Gigabit Uplink Ethernet Ports, Unmanaged Plug and Play, Each Port Up to 30W, 802.3af/at Compliant, Rack Mount
- Model #: EQWER412012375128
- $130.49 –
- Free Shipping

Quick View
Ubiquiti 10G 16-Port Managed Aggregation Switch US-16-XG
- Model #: 8de-402493000332785
- $3,414.99 –
- Free Shipping

Quick View
Extreme Networks 5420F 24-port Switch with 8 ports 90W and 16 ports 30W PoE, 4 x 1/10Gb SFP+ ports, Base software included | 5420F-8W-16P-4XE
- Brand: Extreme Networks
- Series: 5420 Series
- Part Number: 5420F-8W-16P-4XE
- Network Management Type: Managed
- Model #: 5420F8W16P4XE
- $7,780.00
- $5,162.99 –
- Save: $2,617.01 (33%)
- Free Shipping

Quick View
- $119.31 –
- Free Shipping

Quick View
Extreme Networks 5420F 48-port Switch with 16 ports 90W multi-rate and 32 ports 30W PoE, 4x 1/10Gb SFP+ ports | 5420F-16MW-32P-4XE
- Brand: Extreme Networks
- Series: 5420 Series
- Part Number: 5420F-16MW-32P-4XE
- Management Interface: Interfaces: 16 x 100M/1G/2.5GBASE-T 802.3bt (90W) ports MACsec-capable 32 x 10/100/1000BASE-T 802.3at (30W) ports Full / Half-Duplex(autosensing) MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420F16MW32P4XE
- $15,432.00
- $10,424.99 –
- Save: $5,007.01 (32%)
- Free Shipping

Quick View
Extreme Networks 5320 16-port 30W PoE Switch w/AC Power, 2 x 1/10Gb SFP+ ports | 5320-16P-2MXT-2X
- Brand: Extreme Networks
- Series: 5320 Series
- Part Number: 5320-16P-2MXT-2X
- Format: Rackmount
- Model #: 5320-16P-2MXT-2X
- $3,738.00
- $2,394.99 –
- Save: $1,343.01 (35%)
- Free Shipping

Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: 19-inch Rack-mountable Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 16 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-16T4S
- $872.50
- See price in cart
- More options from $871.99
- Free Shipping

Quick View
Cudy 16-Port Gigabit Unmanaged Switch GS1016
- Model #: GS1016
- $56.99 –
- More options from $56.99 - $82.79
- $4.99 Shipping

Quick View
- $850.90 –
- Free Shipping

Quick View
Linksys LGS116 16 Port Gigabit Unmanaged Network Switch - Home / Office Ethernet Switch Hub with Metal Housing - Wall Mount or Desktop Ethernet Splitter, Easy Plug & Play Connection
- Model #: EQWER412012372455
- $148.49 –
- Free Shipping

Quick View
16 Port Gig Rackmount Switch
- Switch Type: unmanaged
- Format: Wall Mountable
- Primary Ports: 16 x Gigabit Ethernet Network
- Primary Port Speed: 10/100/1000Base-T
- Model #: DHGS110016

Quick View
YuanLey 16 Port Gigabit PoE Switch with 2 Gigabit Uplink, 16 PoE+ Port 1000Mbps, 250W 802.3af/at, Metal Desktop/Rackmount, Unmanaged Plug and Play Network Switch
- Model #: 9391048897877
- $178.99 –
- $5.00 Shipping

Quick View
TRENDnet 16-Port Hardened Industrial Unmanaged Gigabit DIN-Rail Switch, TI-G162, 14 x Gigabit Ports, 2 x Gigabit SFP Slots,32Gbps Switching Capacity, IP30 Ethernet Network Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3z
- Primary Ports: 14 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: TI-G162
- $458.32 –
- Free Shipping

Quick View
Zyxel 16 Port Network Switch | Unmanaged Gigabit Ethernet Splitter | 16x GbE Ports | Fanless Design | Plug and Play Easy Installation | Wall and Rack Mounting Kits Included | GS1100-16v3
- Model #: EQWER412012371700
- $136.49 –
- Free Shipping

Quick View
TRENDnet TPE-TG160G 16-Port Gigabit PoE+ Switch
- Brand: TRENDnet
- Format: Rackmount
- Standards: IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3af (15.4 Watts / port) IEEE 802.3at (30 Watts / port) IEEE 802.3az
- Primary Ports: 16 x Gigabit PoE/PoE+ ports
- Model #: TPE-TG160G
- $417.99 –

Quick View
YuanLey 16 Port Gigabit PoE Switch with 2 Gigabit Uplink, 16 PoE+ Port 1000Mbps, 250W 802.3af/at, Metal Desktop/Rackmount, Unmanaged Plug and Play Network Switch
- Model #: EQWER412012371038
- $227.49 –
- Free Shipping

Quick View
- $119.31 –
- Free Shipping

Quick View
TP-Link TL-SG116E 16 Port Gigabit Unmnged Pro Switch
- Model #: TL-SG116E
- $89.99 –
- More options from $89.99 - $119.31
- Free Shipping

Quick View
YuanLey 16 Port PoE Switch with 2 Gigabit Uplink, 16 PoE+ Port 10/100Mbps Network Switch, 802.3af/at Compliant, Durable Metal with 250W High Power, Unmanaged Plug and Play
- Model #: EQWER412012371021
- $155.49 –
- Free Shipping

Quick View
TP-Link 16 Port Gigabit Ethernet Network Switch, Desktop/ Wall-Mount, Fanless, Sturdy Metal w/ Shielded Ports, Traffic Optimization, Unmanaged (TL-SG116) Black
- Model #: 9391048906531
- $104.99 –
- $5.00 Shipping

Quick View
Cudy GS1016E 16 Port Light Smart Managed Gigabit Switch Plug & Play, Sturdy Metal w/Shielded Ports QoS, VLAN, IGMP LAG, Rack-Mountable Steel Case
- Model #: EQWER412012371403
- $138.49 –
- Free Shipping

Quick View
Grandstream GWN7812P | 16-Port Gigabit Ethernet Layer 3 Managed PoE Switch
- Brand: Grandstream
- Part Number: PRO0457861
- Power: ,
- Temperature: ,
- Model #: PRO0457861
- $299.00 –
- Free Shipping

Quick View
Intellinet 560993 16-Port Gigabit Ethernet PoE+ Switch
- Brand: Intellinet
- Format: Rackmount
- Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3ab (Twisted Pair Gigabit Ethernet) IEEE 802.3af (Power over Ethernet 802.3at Type 1) IEEE 802.3at (Power over Ethernet 802.3at Type 2) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3x (flow control, for full duplex mode)
- Primary Ports: 16 x PoE ports
- Model #: 560993
- $315.99
- See price in cart

Quick View
16 Ports 2.5Gb Unmanaged Ethernet Switch, 16*2.5G Base-T Ports. GiGaPlus 2.5Gbps Network Switch for 2.5Gbps NAS/PC, Wireless AP, WiFi6 Router. Plug and Play, Fanless Design.
- Model #: EQWER412012372547
- $331.49 –
- Free Shipping

Quick View
10-Port Ethernet PoE Switch (8 PoE Ports, 2 Uplink) with Extend Function, Easy Smart Managed Ethernet Switch, Plug & Play, Fanless Metal Design, VLAN, Qos,Desktop/Wall Mount
- Model #: STARWELL977971759766Lan
- $64.33 –
- Free Shipping

Quick View
9-Port 2.5Gb Switch Unmanaged,8 x 2.5GBASE-T Ports,1X10G SFP+ | Aluminum Alloy Cooling & Magnetic Mounting, Fanless,Plug & Play 2.5G Ethernet Switch
- Brand: Sodola
- Series: 8X2.5G RJ45+1X10G SFP+(Unmanaged), SL902-SWTG018AS
- Part Number: SL902-SWTG018AS
- Format: Access Point
- Model #: 034064145305
- $85.99 –
- Free Shipping

Quick View
8 Ports 10/100M Industrial Ethernet Enhance Switch 8 Port RJ45 VLAN Signal increased to 250 meters
Limited time offer, ends 10/07
- Model #: C6WV-0804-OYJ-211
- $49.73 –
- Free Shipping

Quick View
PoE Switch, 6 Port PoE Switch, and 5 Port Gigabit PoE Switch, 78W High Power, Support IEEE802.3af/at, Fanless Metal Plug & Play
- Model #: C750-HALCEN-GS717-43
- $178.70 –
- Free Shipping









