Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Allied Telesis AT-2711FX/ST-901 100Mbps PCI-Express Network adapter
- Connectors: 1 x ST
- BUS: 32-bit PCI
- Weight: 20
- Parts: Lifetime limited
- Model #: AT-2711FX/ST-901
- $179.69 –
- More options from $150.28 - $239.29
- Free Shipping

Quick View
StarTech.com Mini PCI Express Gigabit Ethernet Network Adapter NIC Card
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab
- Connectors: 1 x RJ45
- LEDs: 1 - Activity 1 - Link
- Wake On LAN: Yes
- Model #: ST1000SMPEX
- $30.99 –
- Free Shipping

Quick View
TRENDnet 20-Port Gigabit PoE+ Web Smart PoE+ Switch, 16 x Gigabit PoE+ Ports, 4 x Shared Gigabit Ports, Up To 30W Per Port, 185W Total Power Budget, Rack Mountable, Black, TPE-1620WS
- Brand: TRENDnet
- Format: Rackmount
- Standards: IEEE 802.3/3u/3ab, IEEE 802.3af/at
- Network Management Type: Smart
- Model #: TPE-1620WS
- $345.58 –
- More options from $337.55 - $504.88
- Free Shipping

Quick View
AddOn Linksys MGBSX1 Compatible 1000Base-SX SFP Transceiver (MMF, 850nm, 550m, LC)
- Device Type: Other
- Protocols: TCP/IP
- Ports: 1 x LC 1000Base-SX Network
- Max Distance: 850NM 550M
- Model #: MGBSX1-AO
- $47.20 –
- More options from $46.01 - $59.30
- Free Shipping

Quick View
D-Link Network DES-1005E Switch DES-1005E 5 Port 10/100 Desktop Unmanaged Switch
- Format: Desktop
- Standards: IEEE 802.3 10BaSE-t Ethernet (twisted-pair copper) IEEE 802.3u 100BaSE-tX Fast Ethernet (twisted-pair copper) ANSI / IEEE 802.3 Nway autonegotiation IEEE 802.3x flow control IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/20/100/200 Mbps
- Model #: DES-1005E
- $19.94 –
- $7.85 Shipping

Quick View
(20-Pack) Ubiquiti Networks 1G Bidirectional Single-Mode Optical Module, UACC-OM-SM-1G-S-20
- Model #: UACC-OM-SM-1G-S-20
- $211.99 –
- More options from $211.99 - $329.94
- Free Shipping

Quick View
Black Box Gigabit Managed Ethernet SFP Fiber Switch - 28-Port
- Brand: Black Box
- Part Number: LGB5128A-R2
- Format: Rackmount
- Network Management Type: Ethernet Switch
- Model #: LGB5128A-R2
- $1,374.83 –
- More options from $1,367.12 - $1,413.27
- Free Shipping

Quick View
StarTech.com SFPSXMM 10GBASE-SR SFP+ Transceiver Module, 10 Gbps, 550m
- Wavelength: 850nm
- Protocols: TCP/IP
- Ports: 1 x Fiber Optic LC Female
- Max Distance: 550 Meters - 1805 Feet
- Model #: SFPSXMM
- $49.99 –
- Free Shipping

Quick View
TRENDnet 6-Port Fast Ethernet PoE+ Switch, 4 x Fast Ethernet PoE Ports, 2 x Fast Ethernet Ports, 60W PoE Budget, 1.2 Gbps Switch Capacity, Metal, Limited Lifetime Protection, Black, TPE-S50
- Brand: TRENDnet
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3af (15.4 Watts / port) IEEE 802.3az
- Uplink Interface: 4 x Fast Ethernet PoE+ ports 2 x Fast Ethernet ports LED indicators Wall mountable
- Primary Ports: 4 x 10/100 Mbps PoE ports 1 x 10/100 Mbps port
- Model #: TPE-S50
- $48.65 –
- More options from $39.99 - $62.76
- Free Shipping

Quick View
StarTech.com Gigabit Ethernet Copper-to-Fiber Media Converter - SM LC - 20 km - Ethernet Media Converter - GbE Converter
- Device Type: Converter
- Wavelength: 1310nm
- Protocols: TCP/IP
- LEDs: 1 - PWR 1 - RPF 1 - LFP 1 - LNK 1 - LINK - RJ45 1 - FULL - RJ45
- Model #: ET91000SM20
- $242.91
- $235.17 –
- More options from $231.99 - $282.38

Quick View
AddOn - Network Upgrades JD089B-AO H3C (now HP) compatible SFP Transceiver
- Ports: RJ45
- Max Distance: 100m
- Transfer Rate: 1 Gbps
- Weight: 20
- Model #: JD089B-AO
- $84.00
- $47.99 –
- Save: $36.01 (42%)
- Free Shipping

Quick View
Juniper Networks EX4000 24-Port Multi-Gig with 4x 100M/1G/2.5GBaseT, 20x 10/100/1000BaseT, PoE++, 4x 1G/10G SFP/SFP+ (optics sold separately) with Standard SW | EX4000-24MP
- Brand: Juniper
- Model #: EX4000-24MP
- $5,295.00
- $2,699.99 –
- Save: $2,595.01 (49%)
- More options from $2,699.99 - $5,064.18
- Free Shipping

Quick View
Intel® Ethernet Converged Network Adapter X540-T2 X540T2
- Brand: Intel
- Model: X540-T2
- Part Number: X540-T2
- Standards: IEEE 802.3 – Original Ethernet standard (10 Mbps) IEEE 802.3u – Fast Ethernet (100 Mbps) IEEE 802.3ab – Gigabit Ethernet over copper (1000BASE-T) IEEE 802.3an – 10 Gigabit Ethernet over copper (10GBASE-T) IEEE 802.3x – Flow control (full-duplex) IEEE 802.3ad – Link aggregation / LACP (teaming multiple ports) IEEE 802.1Q – VLAN tagging IEEE 802.1p – Quality
- Model #: 553-327826000331651

Quick View
StarTech.com Cisco SFP-10G-SR Compatible SFP+ Module - 10GBASE-SR - 10GE Gigabit Ethernet SFP+ 10GbE Multimode Fiber MMF Optic Transceiver
- Standards: IEEE 802.3ae 10GBASE-SR
- Wavelength: 850nm
- Fiber Cable: Multi Mode
- Protocols: TCP/IP
- Model #: SFP10GSRST
- $58.04 –
- More options from $57.69 - $169.99
- Free Shipping

Quick View
StarTech ET90110WDM2 10/100 Mbps Ethernet Single Mode WDM Fiber Media Converter Kit with SC 20km
- Device Type: others
- Weight: 3.75
- Package Contents: 1 x Local Media Converter Unit 1 x Remote Media Converter Unit 2 x Universal Power Adapters 1 x Instruction Manual
- Parts: 2 Year Limited
- Model #: ET90110WDM2
- $133.06 –
- More options from $133.06 - $393.99

Quick View
HPE JD092B X130 10G SFP+ LC SR Transceiver
- Device Type: Transceiver
- Fiber Cable: 1 x LC 10GBase-SR Network
- Protocols: TCP/IP
- Transfer Rate: 10 Gbps Gigabit Ethernet
- Model #: JD092B
- $796.42
- See price in cart
- Free Shipping

Quick View
StarTech.com SFPG1320C Cisco GLC-LH-SMD Compatible SFP Module -1000BASE-LH Fiber Optical Transceiver - SFPG1320C
- Part Number: SFPG1320C
- Compatible Brand: Cisco Firepower Switches: IE2000 IE4000 C9300 IE3000
- Device Type: Transceiver
- Form Factor: Hot-pluggable Hot-swappable
- Model #: SFPG1320C
- $56.99 –
- Free Shipping

Quick View
Planet GST-805A 10/100/1000Base-T to 1000Base-LX/SX(mini-GBIC, SFP) Smart Media Converter-distance depends on SFP module
- Device Type: Converter
- Media Conversion: RJ45 - SX/LX
- Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX IEEE 802.3ah OAM
- Fiber Cable: 50/125µm or 62.5/125µm multi-mode fiber cable, up to 220 / 550m. 9/125µm single-mode cable, provides long distance for 10 / 20 / 30 / 40 / 50 / 70 / 120km (vary on fiber transceiver or SFP module)
- Model #: GST-805A
- $80.99 –
- Free Shipping

Quick View
Planet GT-806A15 10/100/1000Base-T to 1000Base-LX (WDM) Media Converter TX:1310nm - 15km
- Device Type: Converter
- Media Conversion: RJ45 - SX/LX
- Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
- Wavelength: TX:1310nm RX:1550nm
- Model #: GT-806A15
- $124.00
- See price in cart
- Free Shipping

Quick View
StarTech.com Dual Port 10G PCIe Network Adapter Card, Intel-X550AT 10GBASE-T PCI Express 10GbE Multi Gigabit Ethernet 5 Speed NIC 2 Port
- Standards: IEEE 802.3an (10GBASE-T), IEEE 802.3ab (1GBASE-T), IEEE 802.3u (100BASE-T) PCI Express Rev 3.0
- Temperature: Operating Temperature:5 ~ 50 degree Celsius (41 ~ 122 degree Fahrenheit) Storage Temperature: -20 ~ 60 degree Celsius (-4 ~ 140 degree Fahrenheit)
- Humidity: 20% ~ 80% RH
- Dimensions: 0.70" x 4.70" x 5.90"
- Model #: ST10GPEXNDPI
- $475.48 –
- More options from $460.99 - $523.93

Quick View
PLANET GT-806B15 10/100/1000Base-TX to 1000FX WDM Bi-directional Media Converter (SM, WDM, 1550nm, 15 km)
- Device Type: Converter
- Media Conversion: RJ45 - SX/LX
- Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
- Wavelength: TX:1550nm RX:1310nm
- Model #: GT-806B15
- $152.00
- See price in cart
- Free Shipping

Quick View
2.5G PCIe Network Adapter RTL8125B 2500/1000/100Mbps, RIITOP PCI Express Gigabit Ethernet Card RJ45 LAN Controller Support PXE for Windows/Linux/MAC with Low Profile
Limited time offer, ends 10/07
- Model #: PCET25G-UT-RT
- $15.99 –
- Free Shipping

Quick View
StarTech VS424HD4K60 4x4 HDMI Matrix Switch w/ Audio & Ethernet Control, 4K 60Hz
- Network Media: 10 - USB 3.2 Type-A (9 pin, Gen 1, 5Gbps) 1 - USB 3.2 Type-B (9 pin, Gen 1, 5Gbps) 1 - Terminal Block (2 Wire)
- Uplink Ports: 4
- Power: 100 - 240 AC Power / Voltage Required
- Dimensions: Width: 17.2 Inch Depth: 6.3 Inch Height: 1.7 Inch
- Model #: VS424HD4K60
- $595.99 –
- More options from $595.99 - $675.75
- Free Shipping

Quick View
yealink w70b - dect ip base station
- Brand: Yealink
- Part Number: 1302017
- Type: Telephone
- Dimensions: 2.51 L x 10 W x 13 H centimeters
- Model #: RNAB09BFXNK65

Quick View
SonicWall NSa 4800 Network Security/Firewall - Centralized Management - 24 Port - 10 Gigabit Ethernet - 20 Gbit/s Firewall Throughput - 3000 VPN - 24x RJ-45 - 8 Total Expansion Slots - 50 Hz, 60 Hz -
- Brand: SONICWALL
- Series: NSa
- Part Number: 03-SSC-7039
- Form Factor: Rack Mountable
- Model #: 03-SSC-7039
- $7,667.00
- See price in cart
- Free Shipping

Quick View
TRENDnet 5-Port Hardened Industrial Gigabit PoE+ DIN-Rail Unmanaged Switch, TI-PG541
- Brand: TRENDnet
- Part Number: TI-PG541
- Format: DIN Rail Mount
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3at IEEE 802.3af IEEE 802.3x
- Model #: TI-PG541
- $185.10 –
- More options from $179.41 - $267.68
- Free Shipping

Quick View
StarTech.com Cisco SFP-GE-S Compatible SFP Module - 1000BASE-SX - 1GE Gigabit Ethernet SFP 1GbE Multimode Fiber MMF Optic Transceiver
- Standards: IEEE 802.3z 1000BASE-SX
- Wavelength: 850nm
- Fiber Cable: MMF
- Ports: 1 - Fiber Optic LC Female
- Model #: SFPGESST
- $38.99
- $36.99 –
- Save: $2.00 (5%)
- $3.99 Shipping

Quick View
TRENDnet 26-Port Gigabit PoE+ Switch, 24 x 30W PoE+ Ports, 2 Gigabit SFP Slots, 380W PoE Budget, 52Gbps Switching Capacity, 1U 19" Rack Mountable, Lifetime Protection, Black, TPE-TG262
- Type: Cable Modem
- Model #: 923477590440
- $499.99 –
- More options from $499.99 - $537.99
- Free Shipping

Quick View
AddOn Cisco GLC-T Compatible 10 Pack 1000Base-TX SFP Transceiver (Copper, 100m, RJ-45)
- Network Media: 1 x RJ45
- Ports: RJ-45
- Max Distance: 100M
- Transfer Rate: 1 Gbps
- Model #: GLC-T-AO-10PK
- $756.00
- $288.99 –
- Save: $467.01 (61%)
- $1.99 Shipping

Quick View
TRENDnet 5-Port Gigabit PoE+ Powered EdgeSmart Switch With PoE Pass Through, 18W PoE Budget, 10Gbps Switching Capacity, Managed Switch, Wall-Mountable, Black, TPE-P521ES
- Standards: IEEE 802.1d IEEE 802.1w IEEE 802.1p IEEE 802.1Q IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
- Primary Ports: 1 x Gigabit PoE+ input port 2 x Gigabit PoE output ports 2 x Gigabit ports
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
- MAC Address Table: 2K
- Model #: TPE-P521ES (V1.0R)
- $79.99 –
- More options from $79.99 - $128.62
- Free Shipping

Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
- Model #: GS-4210-16P4C
- $458.00
- See price in cart
- Free Shipping

Quick View
PLANET FT-806B20 10/100TX - 100Base-FX (WDM) Bi-directional Fiber Converter (SM, SC, 1550nm, 20 Km, LFPT)
- Device Type: Converter
- Standards: IEEE 802.3, 10BASE-T IEEE 802.3u, 100BASE-TX IEEE 802.3u, 100BASE-FX
- Wavelength: TX: 1550nm; RX: 1310nm
- Power Adapter: Power Input: 5V DC, 2A, max Power Supply: AC Adapter 100-240V AC, Frequency: 50-60 Hz
- Model #: FT-806B20
- $80.99 –
- Free Shipping

Quick View
TRENDnet 7-Port Industrial Gigabit DIN-Rail Switch, TI-G62, 5 x Gigabit Ports, 2 x Gigabit SFP Ports, IP50 Weather Rated, 14Gbps, NDAA TAA Compliant, Lifetime Protection
- Format: Includes DIN-rail and wall mounts Wall Mountable
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x
- Primary Ports: 5 x Gigabit ports 1 x Shared SFP slot (port F5) 1 x Gigabit SFP slot (port F6)
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
- Model #: TI-G62
- $161.98 –
- More options from $161.98 - $186.17
- Free Shipping





