Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
Alcatel-Lucent OmniSwitch OS2360-24 24-Port Gigabit Managed Switch 10G SFP+
Quick View
  •  
  • $472.90 –
  • Free Shipping
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24P-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RFC 951,...
  • Model #: C1300X-24P-4X
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
Quick View
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24NGU-4X
  • Format: Rackmount
  • Model #: C1300X-24NGU-4X
Grandstream GXP2170 IP Phone Wired/Wireless Bluetooth Wall Mountable
Quick View
Grandstream GXP2170 IP Phone Wired/Wireless Bluetooth Wall Mountable
  • Brand: Grandstream Networks, Inc
  • Model: GXP2170
  • Type: Office Products
  • Protocols: TCP/IP
  • Model #: GXP2170
8 Port PoE+ Switch 120W 30W/Port, 2 Uplink Ports, 250M Transmission, AI Smart Detection, Unmanaged PoE Switch for IP Cameras, Home Office, Small Business  Plug & Play, Wall Mountable
Quick View
  •  
  • $53.99 –
  • Free Shipping
Sophos XGS 116 Network Security/Firewall Appliance - 3 Year Standard Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
Quick View
  •  
  • $2,296.99 –
  • Free Shipping
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
Quick View
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-48P-4X
  • Format: Rackmount
  • Model #: C1300X-48P-4X
Black Box FMT1001 Office White Snap Fitting Hdmi Female/Female
Quick View
  • $14.99
  •  
  • $10.99 –
  • Save: $4.00 (26%)
  • $7.12 Shipping
5 Port Gigabit PoE Switch with 4 Port PoE+ 1000Mbps, 802.3af/at 78W Built-in Power, Fanless Metal Unmanaged Plug & Play
Quick View
5 Port Gigabit PoE Switch with 4 Port PoE+ 1000Mbps, 802.3af/at 78W Built-in Power, Fanless Metal Unmanaged Plug & Play
  • Brand: NETGEAR
  • Series: ProSafe
  • Part Number: YS2041G-P
  • Standards: Passive PoE
  • Model #: 723975703890
  •  
  • $59.99 –
  • Free Shipping
Audiocodes 405HD VoIP Phone Black UC405HDEPSG
Quick View
  • $123.99
  •  
  • $115.99 –
  • Save: $8.00 (6%)
  • $10.99 Shipping
5 Port PoE+ Switch | Easy Smart Managed Ethernet Switch | Support VLAN, QoS | 52W Total PoE Budget | Fanless Metal | Plug & Play (Desktop/Wall Mount)
Quick View
  •  
  • $46.99 –
  • Free Shipping
Grandstream Gxp2130 Ip Phone - Wall Mountable
Quick View
Grandstream Gxp2130 Ip Phone - Wall Mountable
  • Brand: Grandstream
  • Type: Office Products
  • Weight: 2.7
  • Model #: GXP2130
10 Port Gigabit Switch, 8 x 100/1000Mbps Ports, 1 Gigabit Uplink, 1 Gigabit SFP, Support Vlan, Metal Fanless Unmanaged Plug and Play Ethernet Switch
Quick View
  •  
  • $51.79 –
  • Free Shipping
Cisco Catalyst 8300 Router, 1RU w/ 10G WAN (1 SM slot and 1 NIM slot, 2 x 10-Gigabit Ethernet and 4 x 1-Gigabit Ethernet ports) | C8300-1N1S-4T2X
Quick View
Cisco Catalyst 8300 Router, 1RU w/ 10G WAN (1 SM slot and 1 NIM slot, 2 x 10-Gigabit Ethernet and 4 x 1-Gigabit Ethernet ports) | C8300-1N1S-4T2X
  • Brand: CISCO
  • Part Number: C8300-1N1S-4T2X
  • Form Factor: Rack Mountable
  • System Memory: Memory (DRAM) default: 8 GB
  • Model #: C8300-1N1S-4T2X
Intellinet 5-Port Gigabit Ethernet Switch - Fast & Reliable Network Hub for Home/Office, Plug-and-Play Installation, Eco-Friendly, Compact Design - 561747
Quick View
Intellinet 5-Port Gigabit Ethernet Switch - Fast & Reliable Network Hub for Home/Office, Plug-and-Play Installation, Eco-Friendly, Compact Design - 561747
  • Format: Desktop
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Switching Method: Store and Forward
  • Model #: 561747
  •  
  • $34.09 –
  • $25.49 - $34.09
8-Port Gigabit Ethernet Easy Smart Managed Essentials Switch (GS308E) - Desktop or Wall Mount, Home Network Hub, Office Ethernet Splitter, Silent Operation
Quick View
  •  
  • $55.99 –
  • Free Shipping
Cisco Business CBS110-16T Unmanaged Switch, 16 Port GE, Limited Lifetime Protection (CBS110-16T-NA)
Quick View
Cisco Business CBS110-16T Unmanaged Switch, 16 Port GE, Limited Lifetime Protection (CBS110-16T-NA)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
  • Primary Ports: 16 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: CBS110-16T
  •  
  • $204.99 –
8-Port Gigabit Unmanaged PoE+ Ethernet Switch, with 4 PoE Ports up to 60W PoE Budget, QoS, Fanless, Sturdy Metal with Shielded Ports, Compact Desktop, Follows NDAA/TAA (DGS-1008P)
Quick View
  •  
  • $91.99 –
  • Free Shipping
5-Port Gigabit Ethernet Unmanaged Essentials Switch (GS305) - Home Network Hub, Office Ethernet Splitter, Plug-and-Play, Silent Operation, Desktop or Wall Mount
Quick View
  •  
  • $31.99 –
  • Free Shipping
8-Port Gigabit Ethernet Unmanaged Essentials Switch (GS308) - Home Network Hub, Office Ethernet Splitter, Plug-and-Play, Silent Operation, Desktop or Wall Mount
Quick View
  •  
  • $44.99 –
  • Free Shipping
Mitel MiVoice 6930 IP Phone VoIP phone with Bluetooth Interface
Quick View
  •  
  • $409.00 –
  • Free Shipping
16 Port Gigabit Switch, 16 x 100/1000Mbps Ports, Metal Unmanaged Fanless Pluy and Play Network Switch
Quick View
16 Port Gigabit Switch, 16 x 100/1000Mbps Ports, Metal Unmanaged Fanless Pluy and Play Network Switch
  • Brand: NETGEAR
  • Series: ProSafe
  • Part Number: UMG16
  • Standards: Passive PoE
  • Model #: 648360249095
  •  
  • $74.99 –
  • Free Shipping
mikrotik crs310-1g-5s-4s+in 5 x sfp ports 4 x sfp+ ports and 1 x gigabit ethernet port
Quick View
  •  
  • $299.99 –
  • Free Shipping
avatar

Any questions? Our AI mode will help you find out quickly.

Did You Find It?