Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Lot of 10 - 36W Power Supply 12V 3A Charger 100-240V ADP-36PH AC Adapter
- Model #: AT#325065774899
- $102.99 –
- Free Shipping

Quick View
Unew 9.8FT 3 in 1 Starlink Mini DC Power Cable, Cigarette Lighter Car Charger Cord with PD Type-C Port
- Model #: XL-Mini three-in-one connection cable

Quick View
OEM Laptop Charger 19V 6.32A 120W AC Adapter ADP-120ZB BB Yellow Tip
- Model #: KC#325353560084
- $54.99 –
- Free Shipping

Quick View
Transformer 4-Bay Battery Charger for Vocera B3000 batteries. Power Supply included
- Brand: Artisan Power
- Type: Voip Telephone Products
- Model #: CH-TFB3000
- $149.00 –
- $9.99 Shipping

Quick View
TransFormer DCD100 Dual Charger for BPL Batteries: Charges phone and spare battery
- Brand: Artisan Power
- Type: Voip Telephone Products
- Model #: CH-DCD100
- $62.00 –
- $9.99 Shipping

Quick View
Transformer 8-Bay Battery Charger for Vocera B3000 batteries. Power Supply included
- Brand: Artisan Power
- Type: Voip Telephone Products
- Model #: CH-TFB3000-8H
- $279.00 –
- More options from $279.00 - $386.00
- $9.99 Shipping

Quick View
Baseus 4G LTE Mobile Hotspot & 20000mAh 67W Power Bank 2-in-1 PD3.1 140W USB C Charger, PPS Fast Charger Type C, Fast Charging Block
- Model #: RCCWB0FWJXY1GZ
- $252.99 –
- Free Shipping

Quick View
Transformer Dual Charger for Polycom / SpectraLink 8400 & 8440 Series Batteries. Power Supply Included
- Brand: Artisan Power
- Type: Voip Telephone Products
- Model #: CH-TF8400-2
- $75.95
- $73.50 –
- More options from $69.00 - $114.00

Quick View
Baseus 4G LTE Mobile Hotspot & 20000mAh 67W Power Bank 2-in-1 Picogo 100W USB C Laptop Charger with Smart Display
- Model #: RCCWB0FWJV65W2
- $243.99 –
- Free Shipping

Quick View
Baseus 4G WiFi Hotspot Power Bank & 67W 3 Ports USB C Charger
- Model #: RCCWB0FWB2D678
- $198.99 –
- Free Shipping

Quick View
TP4056 Micro USB Lithium Battery Charging Protection Board, 5V 1A TE585 Lipo Charger Module
Limited time offer, ends 10/09
- Model #: C472-L5613
- $23.34 –
- Free Shipping

Quick View
ENGENIUS DURAFON-SIP-HC DURAFON-SIP HANDSET AND CHARGER
- Body Color: Black
- Battery Type: 3.7V, 1700 mAh Li-ion Battery
- Power Consumption: RF Power: Peak: 708 mW Average: 88.5 mW TX Power Control Range: 100-708 mW
- Connections: Earphone DC
- Model #: DURAFON-SIP-HC
- $497.11 –
- More options from $490.00 - $633.00
- Free Shipping

Quick View
Converter 110V AC to 12V DC Power Supply Transformer Adapter Charger Max 600W 50A
- Device Type: Converter
- Model #: BE901C6Q3C
- $109.00 –
- Free Shipping

Quick View
TP4056 Micro USB 5V 1A Lithium Battery Charging Protection Board TE585 Lipo Charger Module
Limited time offer, ends 10/06
- Model #: 786575436435
- $28.29 –
- Free Shipping

Quick View
Cisco 860 WW Phone, Battery, Cable, Charger Refresh - CP-860-BUN-K9
- Model #: CP-860-BUN-K9-RF
- $2,373.04 –
- Free Shipping

Quick View
TransFormer Quad Charger for BPL Batteries: Replaces SpectraLink GCQ100
- Brand: Artisan Power
- Type: Voip Telephone Products
- Model #: CH-TF4-BPL
- $155.00 –
- $9.99 Shipping

Quick View
Duo 4-bay Battery Charger compatible with Cisco 8821 and 7925 batteries. Power Supply included
- Brand: Artisan Power
- Type: Voip Telephone Products
- Model #: CH-DUO-CIS
- $139.00 –
- $9.99 Shipping

Quick View
StarTech.com US1GC30W USB C to Gigabit Ethernet Adapter - White - USB 3.1 to RJ45 LAN Network Adapter - USB Type C to Ethernet (US1GC30W)
- Weight: 0.2
- Parts: 2 Year
- Model #: US1GC30W
- $35.99 –
- More options from $35.99 - $41.15
- Free Shipping

Quick View
2.5 Gigabit PoE+ Injector 90W, 802.3af/at/bt Power Over Ethernet PoE Adapter, 100/1000/2500Mbps, Non-PoE to PoE Adapter, Plug & Play, Distance Up to 100 Meters (328 ft.)
- Model #: TauR453906522617
- $62.45 –
- Free Shipping

Quick View
Portable Router, 4G LTE Travel Router with SIM Card Slot, 300Mbps Unlocked 5G Hotspot Router for Game Party Travel, Support FDD LTE TDD LTE WCDMA
- Model #: RCCWB0CDPYLBDY
- $88.99 –
- Free Shipping

Quick View
Pocket 5G 300Mbps Router, Mobile Router with SIM Card Slot, Mini Smart Router for Europe Home, Network Router, Support Multiple Encryption, Plug and Play
- Model #: RCCWB0BVRG118Q
- $114.99 –
- Free Shipping

Quick View
Yealink W76P High-performance DECT IP phone system with user-centric design
- Brand: Yealink
- Part Number: W76P
- Type: IP DECT Phone Kit
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) SNTP/NTP VLAN (802.1Q and 802.1P) 802.1x, LLDP STUN Client (NAT Traversal) UDP/TCP/TLS IP assignment: Static/DHCP Support outbound proxy server backup Open VPN Transport Layer Security (TLS) HTTPS (server/client), SRTP (RFC3711) Digest authentication Secure configuration file via AES encryption Support SHA256/SHA512/SHA384 Three-level configuration mode: Admin/Var/User
- Model #: W76P
- $169.99 –
- More options from $169.99 - $309.00

Quick View
GRANDSTREAM DP720 DECT CORDLESS IP PHONE RANGE OF
- Brand: Grandstream
- Model: DP720
- Type: Office Products
- Weight: 0.85
- Model #: DP720

Quick View
Portable Passive 24v PoE Injector Compatible with Bosch/Makita Battery Feed | Battery Powered | 1 Gigabit Full Duplex passthrough | 25 watt Power Supply | Ethernet
- Model #: RCCWB0CFJJ4SXW
- $238.99 –
- Free Shipping

Quick View
Gigabit PoE+ Injector Adapter Converts Non-PoE to PoE
- Model #: TauR453906521214
- $40.45 –
- Free Shipping

Quick View
Ceptics Australia, New Zealand, China Travel Adapter Plug with Dual USB Input - Ultra Compact - USA to Type I - Perfect for Cell Phones, Chargers, Cameras and More (CTU-16-2PK)
- Model #: TauR453906523225
- $38.45 –
- Free Shipping

Quick View
Ceptics 20W European Travel Plug Adapter, 2 USA Outlets, USB-C & USB-A
- Model #: TauR453906523232
- $38.45 –
- Free Shipping

Quick View
Gigabit PoE+ Injector 30W, IEEE802.3at/af Compliant PoE Injector Adapter
- Model #: TauR453906520996
- $50.45 –
- Free Shipping

Quick View
2.5G USB3.1 Ethernet Adapter, 2-in-1 USB-A/USB-C to 2.5Gbps Ethernet Adapter RJ45 Network Converter for PC Laptop Windows Mac OS Linux
Limited time offer, ends 10/16
- Model #: LHXC6W1JU14L-032
- $82.58 –
- More options from $82.58
- Free Shipping






