Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Refurbished TRENDnet TEG-S50G Unmanaged Gigabit GREENnet Switch
- Brand: TRENDnet
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
- Network Management Type: Unmanaged
- Primary Ports: 5 x RJ45
- Model #: TEG-S50G
- $19.99 –
- Free Shipping

Quick View
Refurbished LINKSYS EZXS55W-RM EtherFast 5-Port Workgroup Switch
- Format: External
- Standards: IEEE802.3, IEEE802.3u
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: EZXS55W-RM
- $29.99 –
- Free Shipping

Quick View
Refurbished D-Link DSS-16+/RE Unmanaged 16-Port Desktop/Rackmount Switch
- Brand: D-Link
- Format: Desktop/Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x, IEEE 802.3 Nway Auto-negotiation, IEEE 802.1p Qos Prioritization
- Network Management Type: Unmanaged
- Model #: DSS-16+/RE
- $49.99 –
- Free Shipping

Quick View
- $301.00 –
- More options from $301.00 - $392.65
- $12.99 Shipping

Quick View
- $1,163.00 –
- Free Shipping

Quick View
Netgear GS305E 5-Port Gigabit Ethernet SOHO Plus Easy Smart Managed Essentials Switch, GS305E-100NAS
OUT OF STOCK
- Brand: NETGEAR
- Part Number: GS305E-100NAS
- Standards: IEEE 802.3 Ethernet IEEE 802.3ab 1000BASE-T IEEE 802.3u 100BASE-T IEEE 802.3ab 1000BASE-T IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.3x Full-duplex Flow Control
- Network Management Type: Smart
- Model #: GS305E-100NAS
- $29.99
- $24.99 –
- Save: $5.00 (16%)
- Free Shipping

Quick View
Netgear ProSafe GS105 5-Port Gigabit Ethernet Unmanaged Switch, GS105NA
OUT OF STOCK
- Brand: NETGEAR
- Series: ProSafe
- Standards: IEEE 802.3i 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3z 1000BASE-T Gigabit Ethernet
- Network Management Type: Unmanaged
- Model #: GS105NA
- $39.99
- $32.99 –
- Save: $7.00 (17%)
- Free Shipping

Quick View
PLANET Technology - GS-4210-24T2S - Planet 24-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces - 24 Ports - Manageable - 4 Layer Supported - Modular - Twisted Pair, Optical Fiber - 1U
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 24-port 10/100/1000BASE-T Gigabit RJ45 copper 2 x 100/1000BASE-X mini-GBIC / SFP slots
- MAC Address Table: 8K
- Switching Method: Store and Forward
- Model #: GS-4210-24T2S
- $197.99 –
- Free Shipping

Quick View
TP-Link 5 Port Fast Ethernet 10/100Mbps PoE Switch | 4 PoE Ports @58W | Desktop | Plug & Play | Sturdy Metal w/ Shielded Ports | Fanless | Limited Lifetime Protection | Unmanaged (TL-SF1005P)
OUT OF STOCK
- Brand: TP-Link
- Switch Type: Others
- Format: Desktop
- Network Management Type: Managed
- Model #: TL-SF1005P
- $39.99 –
- More options from $39.99
- Free Shipping

Quick View
NETGEAR 8-port, 5-speed Unmanaged Switch 10-Gigabit/Multi-Gigabit | XS508M
OUT OF STOCK
- Brand: NETGEAR
- Format: Rackmount / Desktop
- Standards: IEEE 802.3 Ethernet IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Full-Duplex Flow Control IEEE 802.1p Class of Service IEEE 802.3az Energy Efficient Ethernet IEEE 802.3an 10GBASE-T IEEE 802.3bz 5 Gbps and 2.5 Gbps Ethernet Over Copper Twisted Pair Cable IEEE 802.3ae 10-Gigabit Ethernet Over Fiber IEEE 802.3aq 10-Gigabit over Fiber (10GBASE-LRM) IEEE 802.3z Gigabit Ethernet 1000BASE-SX/LX
- Network Management Type: Unmanaged
- Model #: XS508M-100NAS
- $629.99 –
- Free Shipping

Quick View
Ubiquiti CloudKey+ (UCK-G2-PLUS)
OUT OF STOCK
- LAN Ports: (1) GbE RJ45 port
- Brand: Ubiquity Networks
- Series: Gateway
- LEDs: (1) Power: white/blue
- Model #: UCK-G2-PLUS
- $199.00 –
- More options from $199.00 - $217.33
- Free Shipping

Quick View
Intellinet 8-Port Gigabit Ethernet Switch, Desktop size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
OUT OF STOCK
- Brand: Intellinet
- Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
- Network Management Type: Unmanaged
- Primary Ports: 8 x RJ45
- Model #: 530347
- $71.99
- $58.18 –
- Save: $13.81 (19%)
- Free Shipping

Quick View
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
OUT OF STOCK
- Format: Wall Mountable
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Switching Method: Store and Forward
- Model #: WGS-5225-8P2SV
- $444.99 –
- Free Shipping

Quick View
PLANET IFGS-1022HPT Unmanaged Industrial 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP Combo Ethernet Switch
OUT OF STOCK
- Format: DIN Rail Mount
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x Flow Control and Back Pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port Gigabit TP/SFP
- MAC Address Table: 16K
- Model #: IFGS-1022HPT
- $315.99 –
- Free Shipping

Quick View
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
OUT OF STOCK
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3bt Power over Ethernet ready RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 5 x RJ45 + 2 SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-4UP1T2S
- $563.99 –
- Free Shipping

Quick View
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch
OUT OF STOCK
- Format: Wall Mountable
- Standards: IEEE 802.3: Ethernet IEEE 802.3u: Fast Ethernet IEEE 802.3ab: Gigabit Ethernet IEEE 802.3x: Flow Control
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-803
- $159.60
- Free Shipping

Quick View
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
OUT OF STOCK
- Brand: PLANET
- Format: 19-inch Desktop size, 1U Height, Rack Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Network Management Type: Unmanaged
- Model #: GSW-1820VHP
- $384.00
- Free Shipping

Quick View
PLANET FGSD-1011HP 8-Port 10/100TX 802.3at/af PoE + 1-Port 10/100/1000T + 1-Port 100/1000X SFP Desktop Switch
OUT OF STOCK
- Format: Desktop
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX / LX IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8 x 10/100 Mbps Fast Ethernet ports 1 x 10/100/1000BASE-T Gigabit Ethernet port 1 x 1000BASE-X mini-GBIC SFP interface
- MAC Address Table: 4K
- Model #: FGSD-1011HP
- $122.99 –
- Free Shipping

Quick View
PLANET IGS-1020TF Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch (-40~75 Degrees C)
OUT OF STOCK
- Format: DIN Rail and Wall Mount Design
- Standards: IEEE 802.3 Ethernet/10BASE-T IEEE 802.3u Fast Ethernet/100BASE-TX IEEE 802.3ab Gigabit Ethernet/1000BASE-T IEEE 802.3z Gigabit Ethernet/1000BASE-SX/LX IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.1p Cos
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-1020TF
- $294.40
- Free Shipping

Quick View
Ubquiti Power Distribution Hi-Density, support large, rack-mounted UniFi hardware deployments | USP-PDU-HD
OUT OF STOCK
- Brand: Ubiquiti Networks
- Part Number: USP-PDU-HD
- Primary Ports: (1) 10/100 MbE RJ45 port (3) GbE RJ45 ports for network redundancy
- Button: (1) Factory-reset (1) Circuit breaker
- Model #: USP-PDU-HD
- $999.00 –
- Free Shipping

Quick View
ZyXEL GS2220-28HP GS2220-28HP 24-Port Gigabit L2+ Managed and Nebula Pro Cloud Managed Switch, 24 PoE+ Ports at 375W with 4 SFP Uplinks
OUT OF STOCK
- Brand: ZyXEL
- Part Number: GS2220-28HP
- Switch Type: Others
- Format: 24-port PoE+ / 4-port GbE combo
- Model #: GS222028HP
- $839.99 –
- Free Shipping

Quick View
PLANET GSD-1002M 8-Port 10/100/1000Mbps + 2-Port 100/1000X SFP Managed Desktop Switch
OUT OF STOCK
- Primary Ports: 8 x 10/100/1000Base-T RJ45 Auto-MDI/MDI-X port / 2 100/1000Base-X SFP interfaces
- MAC Address Table: 8K entries
- Switching Method: Store and Forward
- VLAN Support: Yes
- Model #: GSD-1002M
- $135.99 –
- Free Shipping

Quick View
PLANET GS-4210-48P4S Managed 48-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000BASE-X SFP Managed Switch
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 48 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 48-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots
- MAC Address Table: 16K
- Switching Method: Store and ...
- Model #: GS-4210-48P4S
- $1,025.99 –
- Free Shipping

Quick View
PLANET ISW-501T 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
OUT OF STOCK
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: ISW-501T
- $76.00
- Free Shipping

Quick View
Juniper Networks EX4000 Switch, 48-Port Multi-Gig switch with 8x 100M/1G/2.5GBaseT, 40x 10/100/1000BaseT, PoE++, 4x 1G/10G SFP/SFP+ (optics sold separately) | EX4000-48MP
OUT OF STOCK
- Brand: Juniper Networks, Inc.
- Series: EX4000
- Part Number: EX4000-48MP
- Network Management Type: Managed
- Model #: EX4000-48MP
- $7,895.00
- $4,067.99 –
- Save: $3,827.01 (48%)
- Free Shipping

