Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
4U Lockable Rackmount Drawer, SPCC
EIA 19" Racks/Cabinets
Quick View
  •  
  • $747.00 –
  • Free Shipping
CSE-113AC2-R706WB2 1U Chassis with Redundant 750W PWS
Quick View
CSE-113AC2-R706WB2 1U Chassis with Redundant 750W PWS
  • Model #: tmgalaxy-CSE-113AC2-R706WB2
  •  
  • $3,749.98 –
  • Free Shipping
CSE-825TQC-R802WB 2U SAS3 WIO Chassis with Redundant 800W PWS
Quick View
  •  
  • $3,249.98 –
  • Free Shipping
SYS-E200-12D-8C  Xeon ICX-D, X12SDV-8C-SPT4F, 101F
Quick View
SYS-E200-12D-8C Xeon ICX-D, X12SDV-8C-SPT4F, 101F
  • Model #: tmgalaxy-SYS-E200-12D-8C
  •  
  • $5,499.98 –
  • Free Shipping
IoT SuperServer SYS-510D-10C-FN6P CSE-505-203B + X12SDV-10C-SP6F
Quick View
  •  
  • $7,699.98 –
  • Free Shipping
X12SDV-8C-SP6F MB - Embedded FlexATX, Xeon ICX-D, Dual 25GSFP28
Quick View
  •  
  • $5,035.58 –
  • Free Shipping
CSE-826BE1C-R920LPB 2U Chassis w/ 1 Expander, Redundant 920W
Quick View
  •  
  • $4,499.98 –
  • Free Shipping
H11SSL-C MB-supports single EPYC 7001/7002-Series CPU
Quick View
  •  
  • $3,999.98 –
  • Free Shipping
Brocade 5120 24-Port Active 8GB SAN Switch (BR-5120-0008-A)
Quick View
  •  
  • $2,055.00 –
  • Free Shipping
Intel CM8064601467102 Xeon E3-1240 v3 Quad-core (4 Core) 3.40 GHz Processor - OEM Pack
Quick View
  •  
  • $145.10 –
  • Free Shipping
Ruckus ICX7550-48F-E2  Entry-Level Aggregation 48 Ports 1G/10G SFP/SFP+ Managed Rack-Mountable Switch, 2 AC Power Supplies, 3 Fans Exhaust Airflow Installed
Quick View
Ruckus ICX7550-48F-E2 Entry-Level Aggregation 48 Ports 1G/10G SFP/SFP+ Managed Rack-Mountable Switch, 2 AC Power Supplies, 3 Fans Exhaust Airflow Installed

OUT OF STOCK

  • Part Number: ICX7550-48F-E2
  • Primary Ports: Interfaces: 36-port 100/1000 Mbps SFP, 12-port 1/10 Gbps SFP+, 2x 40/100Gbps QSFP+, USB Type-C SFP Ports: 36 SFP+ Ports: 12
  • Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
  • Power: Power / Device Type: Power Supply Power / Installed Qty: 2 Power / Provided (W): 400 Watt Max Power Consumption: 166.8 Watt Power / Voltage Required: 100 to 240 VAC
  • Model #: ICX7550-48F-E2
  •  
  • $10,020.99 –
  • Free Shipping
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports
Quick View
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports

OUT OF STOCK

  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE, IEEE 802.3x Flow Control for Full-Duplex Mode, Auto-negotiation
  • Primary Ports: 24* 10/100/1000Mbps Port PoE (370w) 4*10G SFP+ Ports
  • MAC Address Table: 16K
  • Switching Method: Store and Forward
  • Model #: DGS-1510-28XMP
Juniper Networks QFX5120-48T, 48x10GbE+6x100GbE, 1 U, AC airflow in | QFX5120-48T-AFI
Quick View
Juniper Networks 32X100G 1U AC AIRFLOW OUT | QFX5120-32C-AFO
Quick View
Juniper Networks 32X100G 1U AC AIRFLOW OUT | QFX5120-32C-AFO

OUT OF STOCK

  • Brand: Juniper Networks, Inc.
  • Series: QFX5120
  • Part Number: QFX5120-32C-AFO
  • Switch Type: managed
  • Model #: QFX5120-32C-AFO
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch

OUT OF STOCK

  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3bt Power over Ethernet ready RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 5 x RJ45 + 2 SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-4UP1T2S
  •  
  • $563.99 –
  • Free Shipping
Luxul 1Gb L2/L3 Managed Switch - 24 PoE+, 2 Combo RJ45/SFP Rear-Facing Ports - Manageable - Gigabit Ethernet - 1000Base-T, 1000Base-X - 3 Layer Supported - Modular -  TAA - SW-505-24P-R
Quick View
Vivotek AW-IHT-0502 Industrial Switch (4 FE PoE Ports & 1 FE SC Single-Mode 18.6 mi Port)
Quick View
Vivotek AW-IHT-0502 Industrial Switch (4 FE PoE Ports & 1 FE SC Single-Mode 18.6 mi Port)

OUT OF STOCK

  • Brand: Vivotek
  • Standards: IEEE 802.3 10-BASE-T (Ethernet) IEEE 802.3u 100-BASE-TX (Fast Ethernet) IEEE 802.3z 1000-BASE-X (Gigabit Ethernet) IEEE 802.3x Flow Control (Full-Duplex Flow Control) IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 4 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: AW-IHT-0502
  •  
  • $249.99 –
  • Free Shipping
SonicWall Switch SWS12-10FPOE 12 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 152.80 W Power Consumption - 130 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
Quick View
SonicWall
SonicWall Switch SWS12-10FPOE 12 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 152.80 W Power Consumption - 130 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop

OUT OF STOCK

  • Format: Desktop
  • Primary Ports: 10 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 8K
  • Model #: 02-SSC-2464
Planet GS-4210-24P2S 24-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet GS-4210-24P2S 24-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch

OUT OF STOCK

  • Format: Rackmount
  • MAC Address Table: 8K entries
  • VLAN Support: Yes
  • Jumbo Frames: 9216 bytes
  • Model #: GS-4210-24P2S
  •  
  • $440.99 –
  • Free Shipping
HPE Networking Instant On 1830 8G Switch, 8 ports JL810AABA
Quick View
HPE Networking Instant On 1830 8G Switch, 8 ports JL810AABA

OUT OF STOCK

  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5MB
  • Power: 100~240VAC, 50/60Hz
  • Model #: JL810AABA
  • $137.00
  •  
  • $92.99 –
  • Save: $44.01 (32%)
  • Free Shipping
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch
Quick View
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3: Ethernet IEEE 802.3u: Fast Ethernet IEEE 802.3ab: Gigabit Ethernet IEEE 802.3x: Flow Control
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-803
HPE Aruba Networking CX 6000 48G 4SFP Switch, Layer 2 Managed | R8N86A
Quick View
HPE Aruba Networking CX 6000 48G 4SFP Switch, Layer 2 Managed | R8N86A

OUT OF STOCK

  • Brand: HPE
  • Series: CX 6000 Series
  • Part Number: R8N86A
  • Format: Desktop
  • Model #: R8N86A#ABA
  •  
  • $792.99 –
  • Free Shipping
PLANET GSD-1002M 8-Port 10/100/1000Mbps + 2-Port 100/1000X SFP Managed Desktop Switch
Quick View
PLANET GSD-1002M 8-Port 10/100/1000Mbps + 2-Port 100/1000X SFP Managed Desktop Switch

OUT OF STOCK

  • Primary Ports: 8 x 10/100/1000Base-T RJ45 Auto-MDI/MDI-X port / 2 100/1000Base-X SFP interfaces
  • MAC Address Table: 8K entries
  • Switching Method: Store and Forward
  • VLAN Support: Yes
  • Model #: GSD-1002M
  •  
  • $135.99 –
  • Free Shipping
NVIDIA Quantum 200Gb/s InfiniBand switch, 40 QSFP56 ports, two power supplies (AC), unmanaged, x86 dual core, standard depth, C2P airflow, rail kit | MQM8700-HS2R
Quick View
NVIDIA
NVIDIA Quantum 200Gb/s InfiniBand switch, 40 QSFP56 ports, two power supplies (AC), unmanaged, x86 dual core, standard depth, C2P airflow, rail kit | MQM8700-HS2R

OUT OF STOCK

  • Brand: NVIDIA
  • Series: QUANTUM QM8700 SERIES
  • Part Number: MQM8700-HS2R
  • Format: Rackmount
  • Model #: MQM8700-HS2R
D-Link DGS-3630-28SC 28-Port Layer 3 Stackable Managed Gigabit Fiber Switch w/ Standard Image | DGS-3630-28SC/SI
Quick View
D-Link DGS-3630-28SC 28-Port Layer 3 Stackable Managed Gigabit Fiber Switch w/ Standard Image | DGS-3630-28SC/SI

OUT OF STOCK

  • Brand: D-Link
  • Series: DGS-3630 Series
  • Part Number: DGS-3630-28SC/SI
  • Format: Rackmount
  • Model #: DGS-3630-28SC/SI
  •  
  • $2,264.99 –
  • Free Shipping
HPE Aruba Networking CX 6400 Ethernet Switch, 24-port manageable ethernet switch, Smart Rate 1G/2.5G/5G/10G Class8 PoE 4p SFP56 50G Module | S1T83A
Quick View
HPE Aruba Networking CX 6400 Ethernet Switch, 24-port manageable ethernet switch, Smart Rate 1G/2.5G/5G/10G Class8 PoE 4p SFP56 50G Module | S1T83A

OUT OF STOCK

  • Brand: HPE
  • Network Management Type: Managed
  • Buffer Memory: 16MB
  • Power: 110-127 / 200-240 VAC
  • Model #: S1T83A
  • $16,679.00
  •  
  • $13,034.99 –
  • Save: $3,644.01 (21%)
  • Free Shipping
Vivotek Industrial 8XGE Poe + 2XGE SFP Switch, 48-56 VDC Input, -40°C to 75°C
Quick View
Vivotek Industrial 8XGE Poe + 2XGE SFP Switch, 48-56 VDC Input, -40°C to 75°C

OUT OF STOCK

  • Brand: Vivotek
  • Standards: IEEE 802.3 10-BASE-T (Ethernet) IEEE 802.3u 100-BASE-TX (Fast Ethernet) IEEE 802.3ab 1000-BASE-T (Gigabit Ethernet) IEEE 802.3z 1000-BASE-X (Gigabit Ethernet) IEEE 802.3x Flow Control (Full-Duplex Flow Control) IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 2 x SFP / 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: AW-IHT-1000
  •  
  • $264.99 –
  • Free Shipping
Ruckus ICX7550-24ZP-E2 ICX755-Series 24-Ports Managed Rack-Mountable Switch
Quick View
Ruckus ICX7550-24ZP-E2 ICX755-Series 24-Ports Managed Rack-Mountable Switch

OUT OF STOCK

  • Part Number: ICX7550-24ZP-E2
  • Primary Ports: RJ45, 1/10 Gbps SFP/SFP+ uplinks, QSFP28, USB type C
  • Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
  • Power: Power / Device Type: Power Supply Power / Installed Qty: 2 Power / Provided (W): 1.2 KW Max Power Consumption: 1152 Watt Power / Voltage Required: 100 to 240 VAC
  • Model #: ICX7550-24ZP-E2
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
Quick View
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch

OUT OF STOCK

  • Primary Ports: 24 1000Base-SX/LX/BX SFP interfaces, (Compatible with 100Base-FX SFP Transceiver), 4 1/10GBase-SR/LR SFP+ slots, 4 10/ 100/1000Base-T TP/SFP combo ports
  • MAC Address Table: 16K entries, automatic source address learning and ageing
  • Switching Method: Store and Forward
  • VLAN Support: Yes
  • Model #: MGSW-28240F
Fortinet FortiSwitch FS-248E-FPOE, Layer 2/3 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 SFP ports, 48 port PoE | FS-248E-FPOE
Quick View
Fortinet FortiSwitch FS-248E-FPOE, Layer 2/3 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 SFP ports, 48 port PoE | FS-248E-FPOE

OUT OF STOCK

  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 16K
  • Buffer Memory: 1.5 MB
  • Model #: FS-248E-FPOE
  •  
  • $2,100.99 –
  • Free Shipping
HPE Aruba Networking 6300L 48-port Smart Rate 100M/1G/2.5G/5G CL8 2-port SFP56 50G 2-port SFP28 25G L2 Switch | S3L76A
Quick View
HPE Aruba Networking 6300L 48-port Smart Rate 100M/1G/2.5G/5G CL8 2-port SFP56 50G 2-port SFP28 25G L2 Switch | S3L76A

OUT OF STOCK

  • Brand: HPE Aruba Networking
  • Series: CX 6300 Switch Series
  • Part Number: S3L76A
  • Standards: IEEE 802.3af, 802.3at, and 802.3bt
  • Model #: S3L76A
PLANET ISW-501T 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-501T 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-501T
SONICWALL 02-SSC-2465 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 54 W Power Consumption - Optical Fiber, Twisted Pair - 1U - Rack-mountable - 12 Month Limited Warranty
Quick View
SonicWall
SONICWALL 02-SSC-2465 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 54 W Power Consumption - Optical Fiber, Twisted Pair - 1U - Rack-mountable - 12 Month Limited Warranty

OUT OF STOCK

  • Format: Desktop
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • MAC Address Table: 32K
  • Model #: 02-SSC-2465
  • $1,034.95
  •  
  • $827.99 –
  • Save: $206.96 (19%)
  • Free Shipping
Cisco Catalyst 9200L 48-port Data 4x1G uplink Switch, Network Essentials | C9200L-48T-4G-E
Quick View
Cisco Catalyst 9200L 48-port Data 4x1G uplink Switch, Network Essentials | C9200L-48T-4G-E

OUT OF STOCK

  • Brand: CISCO
  • Series: 9200
  • Part Number: C9200L-48T-4G
  • Format: Rackmount
  • Model #: C9200L-48T-4G-E