Your Browsing History
- In Stock
- Sold by Newegg
- New

Quick View
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
- Part Number: C12CTCHUS
- Switch Type: managed
- Format: Rackmount
- Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
- Model #: C12CTCHUS
- $1,243.20
- $1,126.99 –
- Save: $116.21 (9%)
- Free Shipping

Quick View
Juniper EX4000-24P Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - Modular - 51W Power Consumption - 370 W PoE Budget (EX4000-24P)
- Brand: Juniper Networks, Inc.
- Part Number: EX4000-24P
- Switch Type: managed
- Network Management Type: Managed
- Model #: EX4000-24P
- $2,682.53 –
- More options from $1,320.99 - $2,785.85

Quick View
Sophos XGS 116 Network Security/Firewall Appliance - 3 Year Xstream Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
- Series: XGS
- Part Number: IA1B3CSUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: IA1B3CSUS
- $2,701.99 –
- Free Shipping

Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-24P-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RFC 951,...
- Model #: C1300X-24P-4X
- $1,426.99 –
- More options from $1,426.99 - $1,623.42
- Free Shipping

Quick View
Yealink VP59 Smart Video Teams Phone
- Brand: Yealink
- Type: Telephone
- Model #: VP59-TEAMS
- $449.99 –
- More options from $449.99 - $757.04

Quick View
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-24NGU-4X
- Format: Rackmount
- Model #: C1300X-24NGU-4X
- $1,701.68 –
- More options from $1,676.82 - $1,861.95

Quick View
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-48P-4X
- Format: Rackmount
- Model #: C1300X-48P-4X
- $2,209.99 –
- More options from $2,209.99 - $2,392.86
- Free Shipping

Quick View
Sophos XGS 116 Network Security/Firewall Appliance - 3 Year Standard Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
- Series: XGS
- Part Number: JA1B3CSUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: JA1B3CSUS
- $2,296.99 –
- Free Shipping

Quick View
HP OEM Poly VVX 250 4-Line VoIP Phone, Color LCD, HD Voice, Acoustic Fence Noise Reduction, Dual Gigabit Ethernet, USB Port, PoE, SIP Support, ENERGY STAR, Antimicrobial Surface
- Brand: HP
- Type: VoIP Phones
- Standards: IEEE 802.3
- Ports: 2 x RJ45, 1 USB
- Model #: 002200-48820-025
- $99.99 –
- Free Shipping

Quick View
5 Port Gigabit PoE Switch with 4 Port PoE+ 1000Mbps, 802.3af/at 78W Built-in Power, Fanless Metal Unmanaged Plug & Play
- Brand: NETGEAR
- Series: ProSafe
- Part Number: YS2041G-P
- Standards: Passive PoE
- Model #: 723975703890
- $59.99 –
- Free Shipping

Quick View
Cisco Business CBS110-16T Unmanaged Switch, 16 Port GE, Limited Lifetime Protection (CBS110-16T-NA)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: CBS110-16T
- $204.99 –

Quick View
5 Port PoE+ Switch | Easy Smart Managed Ethernet Switch | Support VLAN, QoS | 52W Total PoE Budget | Fanless Metal | Plug & Play (Desktop/Wall Mount)
- Brand: NETGEAR
- Series: ProSafe
- Part Number: 104
- Format: Desktop
- Model #: 054731808681
- $46.99 –
- Free Shipping

Quick View
PoE Switch, 10 Ports Managed PoE Ethernet Switch (8*100M PoE Ports +2*1000M Uplinks), 120W Built in Power, 250m Extend Function, VLAN, QoS, Fanless Metal, Desktop/Wall Mount, Plug and Play
- Brand: NETGEAR
- Series: ProSafe
- Part Number: PS208G
- Format: Desktop
- Model #: 253953115076
- $62.99 –
- Free Shipping

Quick View
8 Port Full Gigabit PoE+ Switch with Rack Mount Ears, with 2 Gigabit Uplink Ports Up to 30W Per Port, Total Budget 120W, 48 Volt 802.3af/at Compliant, Compatible with PoE IP Cameras VOIP Phones
- Brand: NETGEAR
- Series: ProSafe
- Format: Desktop
- Standards: Passive PoE
- Model #: 584396875348
- $72.99 –
- Free Shipping

Quick View
Cisco Catalyst 8300 Router, 1RU w/ 10G WAN (1 SM slot and 1 NIM slot, 2 x 10-Gigabit Ethernet and 4 x 1-Gigabit Ethernet ports) | C8300-1N1S-4T2X
- Brand: CISCO
- Part Number: C8300-1N1S-4T2X
- Form Factor: Rack Mountable
- System Memory: Memory (DRAM) default: 8 GB
- Model #: C8300-1N1S-4T2X
- $24,181.89
- $14,443.99 –
- Save: $9,737.90 (40%)
- More options from $14,443.99 - $16,857.82
- Free Shipping

Quick View
10 Port Gigabit Switch, 8 x 100/1000Mbps Ports, 1 Gigabit Uplink, 1 Gigabit SFP, Support Vlan, Metal Fanless Unmanaged Plug and Play Ethernet Switch
- Brand: NETGEAR
- Series: ProSafe
- Part Number: G082S
- Standards: Passive PoE
- Model #: 938297064848
- $51.79 –
- Free Shipping

Quick View
Mitel MiVoice 6930 IP Phone VoIP phone with Bluetooth Interface
- Type: Telephone
- Model #: BE50006769
- $409.00 –
- Free Shipping

Quick View
8-Port Gigabit Unmanaged PoE+ Ethernet Switch, with 4 PoE Ports up to 60W PoE Budget, QoS, Fanless, Sturdy Metal with Shielded Ports, Compact Desktop, Follows NDAA/TAA (DGS-1008P)
- Brand: NETGEAR
- Series: ProSafe
- Part Number: DGS-1008P
- Format: Desktop
- Model #: 472215504373
- $91.99 –
- Free Shipping

Quick View
16 Port Gigabit Switch, 16 x 100/1000Mbps Ports, Metal Unmanaged Fanless Pluy and Play Network Switch
- Brand: NETGEAR
- Series: ProSafe
- Part Number: UMG16
- Standards: Passive PoE
- Model #: 648360249095
- $74.99 –
- Free Shipping

Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - with 5-year Support
- Part Number: LS28FZ60ZZPCUS
- Switch Type: managed
- Format: Rackmount
- Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
- Model #: LS28FZ60ZZPCUS
- $1,678.00
- $1,587.99 –
- Save: $90.01 (5%)
- Free Shipping

Quick View
5-Port Ethernet PoE Switch (4 PoE Ports, 1 Uplink) with Extend Function, Easy Smart Managed Ethernet Switch, Plug & Play, Fanless Metal Design, VLAN, Qos,Desktop/Wall Mount
- Brand: NETGEAR
- Series: ProSafe
- Part Number: PS104G
- Format: Desktop
- Model #: 797983006804
- $46.99 –
- Free Shipping

Quick View
mikrotik crs310-1g-5s-4s+in 5 x sfp ports 4 x sfp+ ports and 1 x gigabit ethernet port
- Weight: 1.3500
- Model #: MBVB09W7WBQ77
- $299.99 –
- Free Shipping

Quick View
- $126.89 –

Quick View
16 Port Fast Ethernet Switch Unmanaged 10/100 Mbps Desktop Rackmount Plug and Play Metal Housing Fanless Design EEE (DES-1016D)
- Brand: NETGEAR
- Series: ProSafe
- Part Number: DES-1016D
- Format: Desktop
- Model #: 635446996806
- $88.99 –
- Free Shipping

Quick View
8 Port Gigabit Ethernet Switch, Desktop Ethernet Splitter, Unmanaged Network Switch Hub, Plug & Play, Wall-Mount, Fanless Quiet, for Ethernet Cable, Router, PC, NAS (SG108)
- Brand: NETGEAR
- Series: ProSafe
- Part Number: SG108-V4.0
- Format: Desktop
- Model #: 810709457457
- $31.99 –
- Free Shipping

Quick View
Nvidia MCX75510AAS-NEAT ConnectX-7 400Gigabit Ethernet Card - PCI Express 5.0 x16 - 1 Ports - Optical Fiber - Tall Bracket Bracket Height - OSFP - Plug-in Card
- Part Number: MCX75510AAS-NEAT
- Model #: MCX75510AAS-NEAT
- $1,961.99 –
- Free Shipping

Quick View
- $472.90 –
- Free Shipping

Quick View
2.5Gb Switch,4 x 2.5G Base-T Ports, 2 x 10G SFP+, Aluminum Alloy Cooling & Magnetic Mounting,2.5 Gigabit Network Switch Fanless Plug & Play, Unmanaged Multi-Gigabit Switch,Lifetime Protection
- Brand: NETGEAR
- Series: ProSafe
- Part Number: SL902-SWTG024AS-JP2
- Standards: Passive PoE
- Model #: 249912957341
- $74.99 –
- Free Shipping

Quick View
5 Port 2.5GB Switch, Unmanaged Ethernet Switch for Game Console, PC, NAS, etc. 2.5 Gigabit Network Switch Fanless Plug & Play, Multi-Gigabit Switch, Desktop / Wall Mount, Lifetime Protection
- Brand: NETGEAR
- Series: ProSafe
- Part Number: 5 Ports 2.5G Ethernet Switch
- Format: Desktop
- Model #: 499187149800
- $72.99 –
- Free Shipping

Quick View
GRANDSTREAM GXP2135 HIGH-END IP PHONE 4 SIP
- Brand: Grandstream
- Model: GXP2135
- Type: Office Products
- Parts: 2
- Model #: GS-GXP2135
- $126.74 –
- More options from $113.82 - $137.96

Quick View
6-Port 10Gb Ethernet Switch Unmanaged, 2 x 10Gb RJ45 Uplink Ports + 4 x 2.5Gb Base-T Ports, Compatible with 10G/5G/2.5G/1G, Fanless Metal , VLAN, Plug-and-Play Network Switch for NAS, AP, PC
- Brand: NETGEAR
- Series: ProSafe
- Part Number: SFP-P4810k-G2-001
- Standards: Passive PoE
- Model #: 231281450036
- $103.99 –
- Free Shipping

Quick View
Ethernet Splitter 1 to 3 High Speed LAN Splitter 1000Mbps Gigabit RJ45 Ethernet Switch with USB C Power Cable for Cat5/5e/6/7/8 Cable
- Brand: NETGEAR
- Uplink Ports: 8
- Layer: 1
- Button: touch
- Model #: 202413628535
- $39.99 –
- Free Shipping

Quick View
- $289.99 –
- Free Shipping

Quick View
2.5Gb Switch, 8 Port Network Switch 2.5 Gigabit, Unmanaged Ethernet Switch for Game Console, NAS, PC, Computer Networking Switch Plug & Play Fanless, Desktop Wall Mount, Lifetime Protection
- Brand: NETGEAR
- Series: ProSafe
- Part Number: 8 Ports 2.5G Ethernet Switch
- Format: Desktop
- Model #: 700695837031
- $83.99 –
- Free Shipping

Quick View
16 Port Network Switch | Unmanaged Gigabit Ethernet Switch | 16x GbE Ports | Slim Design | Switchable DIP | Fanless | Wall Mount Kit Included | GS1100-16ES
- Brand: NETGEAR
- Series: ProSafe
- Part Number: GS1100-16ES
- Standards: Passive PoE
- Model #: 342914237600
- $97.99 –
- Free Shipping


