Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
PLANET IFGS-1022HPT Unmanaged Industrial 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP Combo Ethernet Switch
Quick View
PLANET IFGS-1022HPT Unmanaged Industrial 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP Combo Ethernet Switch

OUT OF STOCK

  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x Flow Control and Back Pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port Gigabit TP/SFP
  • MAC Address Table: 16K
  • Model #: IFGS-1022HPT
  •  
  • $315.99 –
  • Free Shipping
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch

OUT OF STOCK

  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3bt Power over Ethernet ready RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 5 x RJ45 + 2 SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-4UP1T2S
  •  
  • $563.99 –
  • Free Shipping
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch
Quick View
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3: Ethernet IEEE 802.3u: Fast Ethernet IEEE 802.3ab: Gigabit Ethernet IEEE 802.3x: Flow Control
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-803
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
Quick View
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)

OUT OF STOCK

  • Brand: PLANET
  • Format: 19-inch Desktop size, 1U Height, Rack Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Network Management Type: Unmanaged
  • Model #: GSW-1820VHP
PLANET FGSD-1011HP 8-Port 10/100TX 802.3at/af PoE + 1-Port 10/100/1000T + 1-Port 100/1000X SFP Desktop Switch
Quick View
PLANET FGSD-1011HP 8-Port 10/100TX 802.3at/af PoE + 1-Port 10/100/1000T + 1-Port 100/1000X SFP Desktop Switch

OUT OF STOCK

  • Format: Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX / LX IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 8 x 10/100 Mbps Fast Ethernet ports 1 x 10/100/1000BASE-T Gigabit Ethernet port 1 x 1000BASE-X mini-GBIC SFP interface
  • MAC Address Table: 4K
  • Model #: FGSD-1011HP
  •  
  • $122.99 –
  • Free Shipping
PLANET IGS-1020TF Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch (-40~75 Degrees C)
Quick View
PLANET IGS-1020TF Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch (-40~75 Degrees C)

OUT OF STOCK

  • Format: DIN Rail and Wall Mount Design
  • Standards: IEEE 802.3 Ethernet/10BASE-T IEEE 802.3u Fast Ethernet/100BASE-TX IEEE 802.3ab Gigabit Ethernet/1000BASE-T IEEE 802.3z Gigabit Ethernet/1000BASE-SX/LX IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.1p Cos
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-1020TF
Ubquiti Power Distribution Hi-Density, support large, rack-mounted UniFi hardware deployments | USP-PDU-HD
Quick View
Ubquiti Power Distribution Hi-Density, support large, rack-mounted UniFi hardware deployments | USP-PDU-HD

OUT OF STOCK

  • Brand: Ubiquiti Networks
  • Part Number: USP-PDU-HD
  • Primary Ports: (1) 10/100 MbE RJ45 port (3) GbE RJ45 ports for network redundancy
  • Button: (1) Factory-reset (1) Circuit breaker
  • Model #: USP-PDU-HD
  •  
  • $999.00 –
  • Free Shipping
ZyXEL GS2220-28HP GS2220-28HP 24-Port Gigabit L2+ Managed and Nebula Pro Cloud Managed Switch, 24 PoE+ Ports at 375W with 4 SFP Uplinks
Quick View
ZyXEL GS2220-28HP GS2220-28HP 24-Port Gigabit L2+ Managed and Nebula Pro Cloud Managed Switch, 24 PoE+ Ports at 375W with 4 SFP Uplinks

OUT OF STOCK

  • Brand: ZyXEL
  • Part Number: GS2220-28HP
  • Switch Type: Others
  • Format: 24-port PoE+ / 4-port GbE combo
  • Model #: GS222028HP
  •  
  • $839.99 –
  • Free Shipping
PLANET GSD-1002M 8-Port 10/100/1000Mbps + 2-Port 100/1000X SFP Managed Desktop Switch
Quick View
PLANET GSD-1002M 8-Port 10/100/1000Mbps + 2-Port 100/1000X SFP Managed Desktop Switch

OUT OF STOCK

  • Primary Ports: 8 x 10/100/1000Base-T RJ45 Auto-MDI/MDI-X port / 2 100/1000Base-X SFP interfaces
  • MAC Address Table: 8K entries
  • Switching Method: Store and Forward
  • VLAN Support: Yes
  • Model #: GSD-1002M
  •  
  • $135.99 –
  • Free Shipping
PLANET GS-4210-48P4S Managed 48-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000BASE-X SFP Managed Switch
Quick View
PLANET GS-4210-48P4S Managed 48-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000BASE-X SFP Managed Switch

OUT OF STOCK

  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 48 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 48-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots
  • MAC Address Table: 16K
  • Switching Method: Store and ...
  • Model #: GS-4210-48P4S
  •  
  • $1,025.99 –
  • Free Shipping
PLANET ISW-501T 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-501T 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-501T
Juniper Networks EX4000 Switch, 48-Port Multi-Gig switch with 8x 100M/1G/2.5GBaseT, 40x 10/100/1000BaseT, PoE++, 4x 1G/10G SFP/SFP+ (optics sold separately) | EX4000-48MP
Quick View
Juniper Networks EX4000 Switch, 48-Port Multi-Gig switch with 8x 100M/1G/2.5GBaseT, 40x 10/100/1000BaseT, PoE++, 4x 1G/10G SFP/SFP+ (optics sold separately) | EX4000-48MP

OUT OF STOCK

  • Brand: Juniper Networks, Inc.
  • Series: EX4000
  • Part Number: EX4000-48MP
  • Network Management Type: Managed
  • Model #: EX4000-48MP
  • $7,895.00
  •  
  • $4,067.99 –
  • Save: $3,827.01 (48%)
  • Free Shipping