Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
Quick View
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
  • Brand: CISCO
  • Series: Catalyst
  • Part Number: C1300-8P-E-2G
  • Format: Rack-mountable
  • Model #: C1300-8P-E-2G
(3-Pack) Ubiquiti Flex Mini, 5-Port Layer 2 PoE Switch (USW-Flex-Mini-3)
Quick View
(3-Pack) Ubiquiti Flex Mini, 5-Port Layer 2 PoE Switch (USW-Flex-Mini-3)
  • Brand: Ubiquiti Networks
  • Series: Network Switch
  • Format: Desktop
  • Network Management Type: Managed
  • Model #: USW-Flex-Mini-3
  •  
  • $95.00 –
  • Free Shipping
GO POWER! by Valterra GP-MPPT-PRO-BT-1 Bluetooth Dongle for GP-MPPT-PRO-60, Black
Quick View
  •  
  • $117.99 –
  • Free Shipping
Cisco Refresh SG112-24 24-port Gigabit Switch 24 x 10/100/1000 + 2 x combo Gigabit SFP, create a reliable, high-speed network to connect your business office
Quick View
Cisco Refresh SG112-24 24-port Gigabit Switch 24 x 10/100/1000 + 2 x combo Gigabit SFP, create a reliable, high-speed network to connect your business office
  • Format: Rackmount
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3z, IEEE 802.3ab, IEEE 802.3az, IEEE 802.1p, IEEE 802.3x
  • Primary Ports: 22 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: SG112-24-NA-RF
  •  
  • $243.54 –
  • Free Shipping
TP-Link TL-SG1218MPE | 16 Port Gigabit PoE Switch | Easy Smart Managed | 16 PoE+ Ports @250W, 2 Non-PoE Ports, 2 Combo SFP Slots | QoS, Vlan, IGMP & LAG | Limited Lifetime Protection | Port Priority
Quick View
TP-Link TL-SG1218MPE | 16 Port Gigabit PoE Switch | Easy Smart Managed | 16 PoE+ Ports @250W, 2 Non-PoE Ports, 2 Combo SFP Slots | QoS, Vlan, IGMP & LAG | Limited Lifetime Protection | Port Priority
  • Switch Type: other
  • Format: Rackmount
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at, IEEE 802.1q, IEEE 802.1p
  • Primary Ports: 16 x RJ45 + 2 x SFP
  • Model #: TL-SG1218MPE
Ceptics 20W European Travel Plug Adapter, 2 USA Outlets, USB-C & USB-A
Quick View
  •  
  • $38.45 –
  • Free Shipping
Direct from TAURKENAM Direct from TAURKENAM
AurCore AIS2003P 8-Port PoE+ Industrial Switch, 4 Combo Ports, Layer 2+ Managed, DIN-Rail Mount, Wide Temperature Range, for IP Cameras, VLAN QoS ACL, 3-Year Warranty
Quick View
  •  
  • $358.00 –
  • Free Shipping
Luxul 1Gb L2/L3 Managed Switch - 16 PoE+, 2 Combo RJ45/SFP Rear-Facing Ports - TAA Compliant  - SW-505-16P-R
Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
  • Model #: GS-4210-16P4C
HARDENED 345 WATT ISOLATED POWER SUPPLY WITH 56VDC AND 24 VDC DUAL OUTPUT
Quick View
  •  
  • $998.84 –
  • Free Shipping
TP-Link TL-SG1210MP | 8 Port Gigabit PoE Switch | 8 PoE+ Ports @123W, w/ 2 Uplink Gigabit Ports + 1 Combo SFP Slot | Plug & Play | Extend, Priority & Isolation Mode | Limited Lifetime Protection
Quick View
TP-Link
TP-Link TL-SG1210MP | 8 Port Gigabit PoE Switch | 8 PoE+ Ports @123W, w/ 2 Uplink Gigabit Ports + 1 Combo SFP Slot | Plug & Play | Extend, Priority & Isolation Mode | Limited Lifetime Protection
  • Format: Desktop
  • Primary Ports: 9 x RJ45 + 1 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Primary Port Type: 9 x 10/100/1000 Mbps RJ45 Ports 1 x 1000 Mbps Combo SFP/RJ45 Port
  • Model #: TL-SG1210MP
  •  
  • $199.99 –