Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
Mikrotik CRS326-24G-2S+RM Cloud Router Switch 326-24G-2S+RM 24 Gigabit port switch with 2 x SFP+ cages in 1U rackmount case, Dual boot (RouterOS or SwitchOS)
Quick View
  •  
  • $423.93 –
  • Free Shipping
Direct from PISKEKAT Direct from PISKEKAT
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-804HPT
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
Quick View
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
  • Format: Rail-mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-duplex flow control
  • Primary Ports: 8x 10/100/1000Base-T Ports
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: IGS-801T
  •  
  • $164.00 –
  • Free Shipping
MikroTik hEX S Gigabit Ethernet Router with SFP Port (RB760iGS)
Quick View
  •  
  • $121.99 –
  • $5.99 Shipping
HP V1910-24G-PoE JE007A#ABA Managed V1910-24G-PoE Switch
Quick View
HP V1910-24G-PoE JE007A#ABA Managed V1910-24G-PoE Switch
  • Brand: HP
  • Series: V1910-24G-PoE
  • Format: Rackmount
  • Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
  • Model #: JE007A#ABA
  •  
  • $2,500.00 –
  • Free Shipping
HP J9049A Managed ProCurve Switch 2900-24G
Quick View
HP J9049A Managed ProCurve Switch 2900-24G
  • Brand: HP
  • Format: Rackmount
  • Standards: IEEE 802.1w Rapid Convergence Spanning Tree IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1Q VLAN tagging IEEE 802.1p Priority IEEE 802.1D Spanning Tree IEEE 802.1s Multiple Spanning Trees IEEE 802.1AB Link Layer Discovery Protocol IEEE 802.1X Network Login IEEE 802.1Q GVRP
  • Network Management Type: Managed
  • Model #: J9049A
  •  
  • $3,000.00 –
  • Free Shipping
Mikrotik CRS326-24G-2S+RM Network Switch L2 Gigabit Ethernet (10/100/1000) Grey Power Over Ethernet (PoE)
Quick View
Mikrotik Wireless Wire RBwAPG-60ad kit 60GHz PtP 1 Gbit Full Duplex Link up to 100 Meters
Quick View
Mikrotik NetMETAL 5 RB921UAGS-5SHPacD-NM US Version Dual chain 5GHz integrated 802.11ac wireless device
Quick View
Mikrotik Routerboard Metal 52 Ac Outdoor Wireless Ap 802.11ac- RBMetalG-52SHPacn
Quick View
MikroTik LHG LTE6 kit CAT6 LTE Modem for Very Remote/Rural Locations Within Cellular Network Coverage
Quick View
HPE Aruba 3810M 24 SFP+ 250W Switch
Quick View
HPE Networking Instant On
HPE Aruba 3810M 24 SFP+ 250W Switch
  • Format: Rackmount
  • Primary Ports: 48 x 10/100/1000 ports, maximum or 16 x 1/10 GbE SFP+ ports, depending on model, all supporting MACSec 8 x HPE Smart Rate Multi-Gigabit (1/2.5/5/10GBASE-T) ports, available on select model 2 x open I/O module slots, maximum, depending on model PoE / PoE+ on selected models
  • Buffer Memory: 13.5MB Internal
  • Power: 100-240V AC Depending on installed options, model and configuration
  • Model #: JL430A
  •  
  • $4,939.00 –
  • Free Shipping
MikroTik CRS418-8P-8G-2S+RM L3 Switch 16x Gigabit Ports with PoE-Out 2X 10G SFP+ Rackmount
Quick View
  •  
  • $684.99 –
  • Free Shipping
Ubiquiti US-8-150W 150 W 8 Port UniFi PoE Switch
Quick View
  •  
  • $367.99 –
  • Free Shipping
CISCO CBS250-16T-2G-NA Managed Switch
Quick View
CISCO CBS250-16T-2G-NA Managed Switch
  • Format: Desktop
  • Primary Ports: 16 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 8K
  • Model #: CBS250-16T-2G-NA
  •  
  • $285.00 –
  • Free Shipping
MikroTik MikroTik hAP ax2 US Version (C52iG-5HaxD2HaxD-TC-US)
Quick View
  •  
  • $178.99 –
  • Free Shipping
Mikrotik Rb750r2 Hex Lite Routerboard
Quick View
  •  
  • $77.99 –
  • Free Shipping
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
Quick View
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
  • Primary Ports: 24 1000Base-SX/LX/BX SFP interfaces, (Compatible with 100Base-FX SFP Transceiver), 4 1/10GBase-SR/LR SFP+ slots, 4 10/ 100/1000Base-T TP/SFP combo ports
  • MAC Address Table: 16K entries, automatic source address learning and ageing
  • Switching Method: Store and Forward
  • VLAN Support: Yes
  • Model #: MGSW-28240F
avatar

Any questions? Our AI mode will help you find out quickly.

Did You Find It?