Skip to main content
  • Sold by Newegg
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
Sold by
VLAN Support
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
Repair Clips - Fix Loose Outlets and Switches - Electrical Wall Box Repair Clips - 10 Pack
Quick View
  •  
  • $39.49 –
  • Free Shipping
TP-Link TL-SG108-M2 | 8 Port Multi-Gigabit Unmanaged Network Switch, Ethernet Splitter | 2.5G Bandwidth | Plug & Play | Desktop/Wall-Mount | Fanless Metal Design | Limited Lifetime Protection
Quick View
TP-Link TL-SG108-M2 | 8 Port Multi-Gigabit Unmanaged Network Switch, Ethernet Splitter | 2.5G Bandwidth | Plug & Play | Desktop/Wall-Mount | Fanless Metal Design | Limited Lifetime Protection
  • Format: Desktop
  • Standards: IEEE 802.3, 802.3u, 802.3ab, 802.3x, 802.1p, 802.3bz
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 2.5 Gbps
  • Model #: TL-SG108-M2
Outdoor PoE Passthrough Switch, 1 in 3 Out Extender, IEEE802.3af/at POE Powered, 100Mbps Ethernet, Wall Mount Waterproof Plug and Play
Quick View
  •  
  • $38.45 –
  • Free Shipping
Direct from TAURKENAM Direct from TAURKENAM
PoE Texas Single-Port Mode B Passive PoE Injector, 48V 15W Supply
Quick View
  •  
  • $40.45 –
  • Free Shipping
Direct from TAURKENAM Direct from TAURKENAM
Passive 24V PoE Switch and Injector, 12~24V Input 24V PoE Outpot, -40°C~75°CDin Rail
Quick View
  •  
  • $319.99 –
  • Free Shipping