Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
- Brand: PLANET
- Format: 19-inch Desktop size, 1U Height, Rack Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Network Management Type: Unmanaged
- Model #: GSW-2620VHP
- $432.00
- See price in cart
- Free Shipping

Quick View
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
- Brand: NETGEAR
- Part Number: GS116EPP-100NAS
- Format: Desktop, Wall Mountable, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS116EP-100NAS
- $390.39 –
- $11.62 Shipping

Quick View
D-Link 28-Port Web Smart Gigabit Ethernet PoE Switch (DGS-1210-28P)
- Format: Rack-mountable Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode IEEE 802.3af compliance (DGS-1210-28P only) Auto-negotiation
- Primary Ports: 24 x 10/100/1000BASE-T PoE 4 x 4 SFP
- Primary Port Speed: 10/100/1000Base-T
- Model #: DGS-1210-28P
- $379.22 –
- More options from $378.99 - $514.00

Quick View
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
- Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
- MAC Address...
- Model #: GS-4210-16P2S
- $324.99 –
- More options from $324.99
- Free Shipping

Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
- Format: DIN Rail and Wall Mount Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 18 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-20160HPT
- $1,301.80
- See price in cart
- Free Shipping

Quick View
Cisco Catalyst C1300-24P-4G Ethernet Switch, 24 Ports, Manageable, Gigabit Ethernet, 10/100/1000Base-T, 1000Base-X , 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C130024P4G
- Switch Type: Manageable
- Model #: C1300-24P-4G
- $928.99 –
- More options from $921.81 - $928.99
- Free Shipping

Quick View
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
- Brand: D-Link
- Format: Rackmount
- Standards: 802.3 Ethernet, 802.3u Fast Ethernet, 802.3x Flow Control, 802.3ab Gigabit Ethernet, 802.1p QoS
- Network Management Type: Unmanaged
- Model #: DGS-1016D

Quick View
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- SNMP: Yes
- Model #: JL812A#ABA
- $204.99
- $159.20 –
- Save: $45.79 (22%)
- More options from $99.31 - $311.00
- Free Shipping

Quick View
D-Link DGS-1024D Unmanaged 24-Port Gigabit Unmanaged Desktop or Rackmount Switch
- Format: Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
- Uplink Ports: None
- Primary Ports: 24 x RJ45
- Model #: DGS-1024D
- $83.99 –
- More options from $83.99 - $139.99
- Free Shipping

Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
- Format: Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1210-28
- $199.99
- $192.47 –
- More options from $192.47 - $399.00
- Free Shipping

Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: 19-inch Rack-mountable Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 16 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-16T4S
- $872.50
- See price in cart
- More options from $871.99
- Free Shipping

Quick View
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
- Brand: NETGEAR
- Part Number: GS116EPP-100NAS
- Format: Desktop, Wall Mountable, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS116EPP-100NAS
- $446.16 –
- $11.62 Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 1430 (R8R49A#ABA)
- Part Number: R8R49A#ABA
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- Model #: R8R49A#ABA
- $140.49
- $129.99 –
- Save: $10.50 (7%)
- More options from $129.99 - $268.00
- Free Shipping

Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
- Brand: PLANET
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGSW-24040R
- $376.00
- See price in cart
- Free Shipping

Quick View
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
- Part Number: C12CTCHUS
- Switch Type: managed
- Format: Rackmount
- Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
- Model #: C12CTCHUS
- $1,243.20
- $1,126.99 –
- Save: $116.21 (9%)
- Free Shipping

Quick View
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
- Brand: Ubiquiti Networks
- Part Number: USW-24-POE
- Format: Rackmount
- Network Management Type: Managed
- Model #: USW-24-POE
- $408.00 –
- More options from $408.00 - $518.19
- Free Shipping

Quick View
TP-Link TL-SG3428XPP-M2 JetStream 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++
- Format: Rackmount
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10 Gbps
- Primary Port Type: 24 x 2.5 Gbps RJ45 Ports 4 x 10G SFP+ Slots
- Model #: TL-SG3428XPP-M2
- $764.39 –
- More options from $764.39 - $1,098.35
- Free Shipping

Quick View
TP-Link TL-SG3428XMP | Jetstream 24 Port Gigabit Smart Managed L2+ PoE switch | 24 PoE+ Port @384W, 4 x 10GE SFP+ Slots | Omada SDN Integrated | IPv6 and Static Routing | Limited Lifetime Protection
- Format: Desktop
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 24 x 10/100/1000 Mbps RJ45 Ports 4 x 10G SFP+ Slots
- Model #: TL-SG3428XMP
- $606.48 –
- More options from $415.44 - $725.70
- Free Shipping

Quick View
HPE Networking Instant On 1930 24G Class4 PoE 4SFP/SFP+ 195W Switch (JL683B#ABA)
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Buffer Memory: 1.5 MB
- PoE: Yes
- Model #: JL683B#ABA
- $514.99 –
- More options from $441.00 - $514.99
- Free Shipping

Quick View
TP-Link 24 Port Gigabit Ethernet Switch | Desktop or Rackmount | Lifetime Protection | Plug & Play | Shielded Ports | Sturdy Metal | Fanless Quiet | Traffic Optimization | Unmanaged (TL-SG1024S)
- Switch Type: desktop
- Format: Desktop / Rackmount
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab , IEEE 802.3x
- Primary Ports: 24 x 10/100/1000 Mbps RJ45 Ports (Auto Negotiation / Auto MDI / MDIX)
- Model #: TL-SG1024S
- $113.29 –
- More options from $74.99 - $114.56

Quick View
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
- Brand: NETGEAR
- Part Number: GS524UP-100NAS
- Switch Type: unmanged
- Format: Desktop Rack-mountable
- Model #: GS524UP-100NAS
- $529.99 –
- Free Shipping

Quick View
Netgear GS724TP 24-Port Gigabit Ethernet PoE+ Smart Switch with 2x SFP Ports (190W), Optional Insight Cloud Management, GS724TP-300NAS
- Brand: NETGEAR
- Part Number: GS724TP-300NAS
- Format: Rack-mountable Desktop
- Standards: IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.3 IEEE 802.11ac IEEE 802.3at IEEE 802.3af IEEE 802.1Q IEEE 802.3ad IEEE 802.1D IEEE 802.1w IEEE 802.1s
- Model #: GS724TP-300NAS
- $369.99 –
- Free Shipping

Quick View
TP-Link 24 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1024DE)
- Format: Rackmount
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1024DE
- $119.80 –
- More options from $119.80 - $252.49

Quick View
TP-Link TL-SG3428X | 24 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG | Limited Lifetime Protection
- Format: Desktop
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 24 x 10/100/1000 Mbps RJ45 Ports 4 x 10G SFP+ Slots
- Model #: TL-SG3428X
- $334.99 –
- More options from $309.99 - $439.62

Quick View
TP-Link 16 Port 10/100Mbps Fast Ethernet PoE Switch | 16 PoE+ Ports @194W, w/ 2 Uplink Gigabit Ports + 2 Combo SFP Slots | Plug & Play | Lifetime Protection | Extend Mode | Priority Mode (TL-SL1218MP)
- Format: Desktop
- Primary Ports: 18 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100Mbps + 1000Mbps
- Protocols: TCP/IP
- Model #: TL-SL1218MP
- $171.01 –
- More options from $139.99 - $326.15

Quick View
HPE Networking Instant On 1930 24-port PoE Switch, 4 SFP+ ports 370W | JL684B#ABA
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Buffer Memory: 1.5 MB
- PoE: Yes
- Model #: JL684B#ABA
- $689.99 –
- More options from $472.99 - $846.00
- Free Shipping

Quick View
TRENDnet 8-Port Gigabit PoE+ Switch, 65W PoE Power Budget, 16Gbps Switching Capacity, IEEE 802.1p QoS, DSCP Pass-Through Support, Fanless, Wall Mountable, Lifetime Protection, Black, TPE-TG83
- Brand: TRENDnet
- Series: ProSafe
- Model: TPE-TG83
- Part Number: TPE-TG83
- Model #: TPE-TG83

Quick View
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
- Primary Ports: 12 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- SNMP: Yes
- Power: 100 - 240 VAC
- Model #: JL805A#ABA
- $1,599.99
- $1,499.99 –
- Save: $100.00 (6%)
- More options from $1,499.99 - $2,555.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 2p 10GBT 2p SFP+ 1960 (JL806A#ABA)
- Primary Ports: 26 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- SNMP: Yes
- Layer: 2
- Model #: JL806A#ABA
- $749.99 –
- More options from $745.99 - $1,406.00
- Free Shipping

Quick View
Netgear AV Line XSM4216F Fully Managed M4250 16 x 1G/10G Fiber SFP+ Switch, XSM4216F-100NAS
- Switch Type: managed
- Format: Desktop
- Primary Ports: 16 x SFP+
- Primary Port Speed: 10 Gbps
- Model #: XSM4216F-100NAS
- $1,319.99 –
- Free Shipping

Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 12.0 Mb
- Layer: 2
- Model #: R8R50A#ABA
- $189.99 –
- More options from $189.99 - $294.00
- Free Shipping

Quick View
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
- Switch Type: managed
- Format: Desktop
- Primary Ports: 12 x RJ45 + 2 x SFP+
- Primary Port Speed: 10 Gbps
- Model #: MSM4214X-100NAS
- $1,169.99
- See price in cart
- Free Shipping

Quick View
Netgear AV Line M4350-24F4V 28-Port Manageable 25 Gigabit Ethernet Switch, XSM4328FV-100NES
- Brand: NETGEAR
- Series: M4350
- Part Number: XSM4328FV-100NES
- Format: Rack-mountable Table Top
- Model #: XSM4328FV-100NES
- $3,359.99 –
- Free Shipping

Quick View
Netgear GS728TXPv3 24-Port Manageable Gigabit PoE+ Smart Switches with 4 Dedicated 10G SFP+ Ports, GS728TXP-300NAS
- Brand: NETGEAR
- Part Number: GS728TXP300NAS
- Standards: IEEE 802.1x IEEE 802.1Q IEEE 802.3ad IEEE 802.3x IEEE 802.1D IEEE 802.1s IEEE 802.1w IEEE 802.1ab IEEE 802.1p IEEE 802.1as IEEE 802.1Qat IEEE 802.3an IEEE 802.1BA IEEE 802.3i IEEE 802.1Qav IEEE 802.3z IEEE 802.3ae
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-X 10/100/ 1000Base-T
- Model #: GS728TXP-300NAS
- $489.99 –
- Free Shipping

Quick View
Netgear AV Line M4350-12X12F 12-Port Ethernet Manageable 10 Gigabit Ethernet Switch, XSM4324-100NES
- Brand: NETGEAR
- Part Number: XSM4324-100NES
- Network Management Type: Managed
- Primary Ports: 12 x RJ45 + 12 x SFP+
- Model #: XSM4324-100NES
- $2,999.99 –
- Free Shipping

Quick View
Netgear AV Line M4350-8X8F 8-Port Manageable 10 Gigabit Ethernet Switch, XSM4316-100NES
- Brand: NETGEAR
- Part Number: XSM4316100NES
- Network Management Type: Managed
- Primary Ports: 8 x RJ45 + 8 x SFP+
- Model #: XSM4316-100NES
- $2,199.99 –
- Free Shipping


