Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
  • 13Ports - 30Ports
Netgear GS116 16-Port Gigabit Ethernet Unmanaged Switch, GS116-300NAS
Quick View
Netgear Inc.
Netgear GS116 16-Port Gigabit Ethernet Unmanaged Switch, GS116-300NAS
  • Brand: NETGEAR
  • Part Number: GS116-300NAS
  • Format: Desktop Wall Mountable Compact
  • Standards: IEEE 802.3az IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x
  • Model #: GS116-300NAS
  •  
  • $99.99 –
  • Free Shipping
Cisco Catalyst C1300-16P-4X Ethernet Switch, 16 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16P-4X Ethernet Switch, 16 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-16P-4X
  • Format: Rack-mountable
  • Model #: C1300-16P-4X
Cisco Catalyst C1200-16T-2G Ethernet Switch - 16 Ports - Manageable - Gigabit Ethernet - 3 Layer Supported   C1200-16T-2G
Quick View
Cisco Catalyst C1200-16T-2G Ethernet Switch - 16 Ports - Manageable - Gigabit Ethernet - 3 Layer Supported C1200-16T-2G
  • Brand: CISCO
  • Series: 1200
  • Part Number: C120016T2G
  • Switch Type: Ethernet Switch
  • Model #: C1200-16T-2G
  • $384.80
  •  
  • $356.99 –
  • Save: $27.81 (7%)
  • Free Shipping
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
Quick View
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
  • Brand: D-Link
  • Format: Rackmount
  • Standards: 802.3 Ethernet, 802.3u Fast Ethernet, 802.3x Flow Control, 802.3ab Gigabit Ethernet, 802.1p QoS
  • Network Management Type: Unmanaged
  • Model #: DGS-1016D
Available Direct from D-Link Available Direct from D-Link
6-Port 2.5G Web Managed Ethernet Switch, VLAN/QoS/STP/IGMP/LACP Supported, Fanless Easy Smart 2.5Gb Network Switch, Aluminum Housing, Desktop/Wall-Mount
Quick View
Netgear GS116PP 16-Port PoE/PoE+ Gigabit Ethernet Unmanaged Switch with FlexPoE (183W), GS116PP-100NAS
Quick View
Netgear GS116PP 16-Port PoE/PoE+ Gigabit Ethernet Unmanaged Switch with FlexPoE (183W), GS116PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS116PP-100NAS
  • Switch Type: Desktop / Rackmount / Wall-Mount
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: GS116PP-100NAS
  •  
  • $249.99 –
  • Free Shipping
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
Quick View
Netgear Inc.
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
  • Brand: NETGEAR
  • Format: Desktop / Rackmount
  • Network Management Type: Unmanaged
  • Primary Ports: 16 x RJ45
  • Model #: GS516UP-100NAS
  •  
  • $369.99 –
  • Free Shipping
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
Quick View
Netgear Inc.
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
  • Brand: NETGEAR
  • Part Number: GS524UP-100NAS
  • Switch Type: unmanged
  • Format: Desktop Rack-mountable
  • Model #: GS524UP-100NAS
  •  
  • $529.99 –
  • Free Shipping
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
Quick View
Netgear Inc.
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS516PP-100NAS
  • Format: Desktop Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: GS516PP-100NAS
  •  
  • $309.99 –
  • Free Shipping
NETGEAR 8X10G, 8XSFP+ Managed Switch | XSM4316S
Quick View
Netgear Inc.
NETGEAR 8X10G, 8XSFP+ Managed Switch | XSM4316S
  • Brand: NETGEAR
  • Series: ProSafe
  • Network Management Type: Managed
  • Primary Ports: 8 x RJ45 + 8 x SFP+
  • Model #: XSM4316S-100NES
  •  
  • $2,159.99 –
  • Free Shipping
HPE Networking Instant On Switch 24p Gigabit 2p 10GBT 2p SFP+ 1960 (JL806A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 24p Gigabit 2p 10GBT 2p SFP+ 1960 (JL806A#ABA)
  • Primary Ports: 26 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • SNMP: Yes
  • Layer: 2
  • Model #: JL806A#ABA
Netgear AV Line XSM4216F Fully Managed M4250 16 x 1G/10G Fiber SFP+ Switch, XSM4216F-100NAS
Quick View
Netgear Inc.
Netgear AV Line XSM4216F Fully Managed M4250 16 x 1G/10G Fiber SFP+ Switch, XSM4216F-100NAS
  • Switch Type: managed
  • Format: Desktop
  • Primary Ports: 16 x SFP+
  • Primary Port Speed: 10 Gbps
  • Model #: XSM4216F-100NAS
  •  
  • $1,319.99 –
  • Free Shipping
Ubiquiti EdgePoint S16, Application-specific WISP control point (EP-S16)
Quick View
Ubiquiti EdgePoint S16, Application-specific WISP control point (EP-S16)
  • Brand: Ubiquiti Networks
  • Part Number: EP-S16
  • Network Management Type: Managed
  • Primary Ports: 16 x RJ45 + 2 x SFP
  • Model #: EP-S16
  •  
  • $634.00 –
  • Free Shipping
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
Quick View
Netgear Inc.
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
  • Switch Type: managed
  • Format: Desktop
  • Primary Ports: 12 x RJ45 + 2 x SFP+
  • Primary Port Speed: 10 Gbps
  • Model #: MSM4214X-100NAS
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 12.0 Mb
  • Layer: 2
  • Model #: R8R50A#ABA
D-Link 28-Port Web Smart Gigabit Ethernet PoE Switch (DGS-1210-28P)
Quick View
D-Link 28-Port Web Smart Gigabit Ethernet PoE Switch (DGS-1210-28P)
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode IEEE 802.3af compliance (DGS-1210-28P only) Auto-negotiation
  • Primary Ports: 24 x 10/100/1000BASE-T PoE 4 x 4 SFP
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: DGS-1210-28P
Netgear AV Line M4350-12X12F 12-Port Ethernet Manageable 10 Gigabit Ethernet Switch, XSM4324-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-12X12F 12-Port Ethernet Manageable 10 Gigabit Ethernet Switch, XSM4324-100NES
  • Brand: NETGEAR
  • Part Number: XSM4324-100NES
  • Network Management Type: Managed
  • Primary Ports: 12 x RJ45 + 12 x SFP+
  • Model #: XSM4324-100NES
  •  
  • $2,999.99 –
  • Free Shipping
Netgear AV Line M4350-8X8F 8-Port Manageable 10 Gigabit Ethernet Switch, XSM4316-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-8X8F 8-Port Manageable 10 Gigabit Ethernet Switch, XSM4316-100NES
  • Brand: NETGEAR
  • Part Number: XSM4316100NES
  • Network Management Type: Managed
  • Primary Ports: 8 x RJ45 + 8 x SFP+
  • Model #: XSM4316-100NES
  •  
  • $2,199.99 –
  • Free Shipping
TRENDnet 8-Port 2.5G PoE++ Switch, TPE-BG380, 8 x 2.5GB PoE++ Ports, 230W Poe Power Budget, 40Gbps Switching Capacity, NDAA + TAA Compliant, Lifetime TRENDnet Protection
Quick View
Available Direct from TRENDnet Available Direct from TRENDnet
Netgear AV Line M4350-24G4XF 24-Port Manageable 10 Gigabit Ethernet Switch, GSM4328-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-24G4XF 24-Port Manageable 10 Gigabit Ethernet Switch, GSM4328-100NES
  • Brand: NETGEAR
  • Part Number: GSM4328100NES
  • Standards: IEEE 802.3bt IEEE 802.3af IEEE 802.3at IEEE 802.1as IEEE 802.1Qav IEEE 802.1Qat IEEE 802.1ak IEEE 802.3az IEEE 802.3ad IEEE 802.1AX IEEE 802.1s IEEE 802.1w IEEE 802.1p IEEE 802.1Q IEEE 802.1BA
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Gigabit Ethernet Network Technology: 10GBase-X 10/100/ 1000Base-T
  • Model #: GSM4328-100NES
  •  
  • $2,579.99 –
  • Free Shipping
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-28
Cisco Catalyst C1300-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-24FP-4G
  • Format: Rackmount
  • Model #: C1300-24FP-4G
SonicWall Managed PoE Switch SWS14-24FPOE | 02-SSC-2468 28 Ports - Manageable - 2 Layer Supported - Modular - 500.40 W Power Consumption - 410 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports
Quick View
SonicWall
SonicWall Managed PoE Switch SWS14-24FPOE | 02-SSC-2468 28 Ports - Manageable - 2 Layer Supported - Modular - 500.40 W Power Consumption - 410 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports
  • Format: Desktop
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • MAC Address Table: 32K
  • Model #: 02-SSC-2468
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
Quick View
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
  • Format: Desktop
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
  • Uplink Ports: None
  • Primary Ports: 16 x RJ45
  • Model #: TL-SG1016DE
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
Quick View
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
  • Brand: PLANET
  • Format: 19-inch Desktop size, 1U Height, Rack Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Network Management Type: Unmanaged
  • Model #: GSW-2620VHP
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
Quick View
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
  • Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
  • MAC Address...
  • Model #: GS-4210-16P2S
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst C1300 Series
  • Part Number: C1300-24MGP-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
  • Model #: C1300-24MGP-4X
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-16FP-2G
  • Format: Rack-mountable
  • Model #: C1300-16FP-2G
TRENDnet 20-Port Gigabit Web Smart Switch; 16 x Gigabit Ports; 4 x shared Gigabit Ports (RJ-45/SFP); VLAN; QoS; LACP; IPv6 Support; 40 Gbps Switching Capacity; Lifetime Protection; TEG-204WS
Quick View
TRENDnet 20-Port Gigabit Web Smart Switch; 16 x Gigabit Ports; 4 x shared Gigabit Ports (RJ-45/SFP); VLAN; QoS; LACP; IPv6 Support; 40 Gbps Switching Capacity; Lifetime Protection; TEG-204WS
  • Format: Rackmount
  • Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az
  • Primary Ports: 16 x Gigabit ports 4 x shared Gigabit ports (RJ-45 / SFP)
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
  • Model #: TEG-204WS
Available Direct from TRENDnet Available Direct from TRENDnet
D-Link DGS-1024C 24-Port 10/100/1000 Mbps Gigabit Unmanaged Desktop Switch
Quick View
D-Link DGS-1024C 24-Port 10/100/1000 Mbps Gigabit Unmanaged Desktop Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Primary Ports: 24 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 8K
  • Model #: DGS-1024C
TP-Link 16 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1016)
Quick View
TP-Link 16 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1016)
  • Format: Rackmount
  • Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x
  • Primary Ports: 16 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG1016
HPE Juniper Networking EX2300-C Switch, Compact Fanless 12-port 10/100/1000BASE-T, 2 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-C-12T
Quick View
HPE Juniper Networking EX2300-C Switch, Compact Fanless 12-port 10/100/1000BASE-T, 2 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-C-12T
  • Brand: Juniper Networks, Inc.
  • Series: EX2300-C
  • Part Number: EX2300-C-12T
  • Format: Desktop
  • Model #: EX2300-C-12T
TRENDnet 5-Port Gigabit PoE+ Switch, Camera DIP Switch extends PoE+ 200m (656 ft.), 60W PoE Budget, Black, TPE-TG51G
Quick View
TRENDnet 5-Port Gigabit PoE+ Switch, Camera DIP Switch extends PoE+ 200m (656 ft.), 60W PoE Budget, Black, TPE-TG51G
  • Brand: TRENDnet
  • Series: ProSafe
  • Part Number: TPE-TG51g
  • Format: Desktop
  • Model #: TPE-TG51g
Available Direct from TRENDnet Available Direct from TRENDnet
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-24XTS
  • Format: Rack-mountable
  • Model #: C1300-24XTS