Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
  • $300 - $400
Ubiquiti UniFi Switch USW-Aggregation - switch - 8 ports - man (USW-AGGREGATION)
Quick View
Ubiquiti UniFi Switch USW-Aggregation - switch - 8 ports - man (USW-AGGREGATION)
  • Part Number: USW-AGGREGATION
  • Dimensions: 17.4 in x 4.7 in x 1.7 in
  • Weight: 5.84 lbs
  • Model #: USWAGGREGATION
TRENDnet 20-Port Gigabit Web Smart 370W PoE+ Switch, TPE-1620WSF, 16 Gigabit PoE+ Ports, 4 Shared Gigabit Ports(RJ-45 or SFP), 370W PoE Budget,Managed PoE+ Ethernet Network Switch, Lifetime Protection
Quick View
TRENDnet 20-Port Gigabit Web Smart 370W PoE+ Switch, TPE-1620WSF, 16 Gigabit PoE+ Ports, 4 Shared Gigabit Ports(RJ-45 or SFP), 370W PoE Budget,Managed PoE+ Ethernet Network Switch, Lifetime Protection
  • Brand: TRENDnet
  • Model: TPE-1620WSF
  • Format: Rackmount
  • Standards: IEEE 802.1d,IEEE 802.1p,IEEE 802.1Q,IEEE 802.1s,IEEE 802.1w,IEEE 802.1X,IEEE 802.1ab,IEEE 802.3,IEEE 802.3u,IEEE 802.3x,IEEE 802.3z,IEEE 802.3ab,IEEE 802.3ad,IEEE 802.3af,IEEE 802.3at,IEEE 802.3az
  • Model #: TPE-1620WSF
Available Direct from TRENDnet Available Direct from TRENDnet
HP 1910-8G Smart Managed 8-port Gigabit Switch (JG348A#ABA)
Quick View
HP 1910-8G Smart Managed 8-port Gigabit Switch (JG348A#ABA)
  • Format: Desktop
  • Primary Port Speed: 10/100/1000Mbps
  • Weight: 4.41 lb
  • Parts: Lifetime
  • Model #: JG348A#ABA
  •  
  • $400.00 –
  • Free Shipping
TRENDnet TEG-524WS 52-Port Gigabit Web Smart Switch
Quick View
TRENDnet TEG-524WS 52-Port Gigabit Web Smart Switch
  • Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az
  • Primary Ports: 48 x Gigabit ports 4 x shared Gigabit ports (RJ-45 / SFP)
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 16K
  • Model #: TEG-524WS
Available Direct from TRENDnet Available Direct from TRENDnet
TRENDnet6-Port Hardened Industrial Gigabit PoE+ Layer 2 Managed DIN-Rail Switch,  Layer 2, 4 802.3at PoE+ + 1 Gigabit + 1 Gigabit SFP, Wide Operating  Temperature (- 40  70 °C (- 40 - 158 °F))
Quick View
TRENDnet6-Port Hardened Industrial Gigabit PoE+ Layer 2 Managed DIN-Rail Switch, Layer 2, 4 802.3at PoE+ + 1 Gigabit + 1 Gigabit SFP, Wide Operating Temperature (- 40 70 °C (- 40 - 158 °F))
  • Weight: 2.0350
  • Features: • Hardened IP40 rated metal enclosure with integrated DIN-Rail mount • Wide operating temperature range - 40 to 70 °C (-40 to 158 °F) • 4 x Gigabit PoE+ (802.3at) ports, 1 x Gigabit port, and 1 x Gigabit SFP slot • 120W total power budget • Remote cloud management with TRENDnet Hive (Additional fee applies) • Dual redundant power inputs
  • Model #: TI-PG541i (Version v2.6R)
  •  
  • $309.99 –
  • Free Shipping
Direct from TRENDnet Direct from TRENDnet
HP J9019A ProCurve Switch 2510-24
Quick View
HP
HP J9019A ProCurve Switch 2510-24
  • Brand: HP
  • Standards: IEEE 802.3x Flow Control IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1X Network Login IEEE 802.1Q VLAN tagging IEEE 802.1s Multiple Spanning Trees IEEE 802.1AB Link Layer Discovery Protocol IEEE 802.1Q VLANs IEEE 802.1p Priority
  • Primary Ports: 24 RJ-45 10/100 ports (IEEE 802.3 Type 10Base-T, IEEE 802.3u Type 100Base-T) 1 RJ-45 serial console port 2 Dual Personality Ports each port can be used as either an RJ-45 10/100/1000 port (IEEE 802.3 Type 10Base-T; IEEE 802.3u Type 100Base-TX; IEEE 802.3ab 1000Base-T Gigabit Ethernet) or an open mini-GBIC slot (for use with mini-GBIC transceivers)
  • Primary Port Speed: 10/100Mbps + 1000Mbps
  • Model #: J9019A
  •  
  • $310.09 –
  • Free Shipping
Black Box SW1030A 10-GbE Manual Switch
Quick View
IOGEAR GCMS1922
Quick View
IOGEAR GCMS1922
  • Model #: 881317521538
HP 2530-48G-POE+ SWITCH
Quick View
HP
Used - Very Good HP 2530-48G-POE+ SWITCH
  • Switch Type: Ethernet Switch
  • Model #: J9772A
  •  
  • $320.00 –
  • Free Shipping
HP J9772A Managed Switch
Quick View
HP
Refurbished HP J9772A Managed Switch
  • Format: Desktop
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.1D, IEEE 802.1Q, IEEE 802.3ab, IEEE 802.1p, IEEE 802.3x, IEEE 802.3ad (LACP), IEEE 802.1w, IEEE 802.1x, IEEE 802.1s, IEEE 802.1ab (LLDP), IEEE 802.3at, IEEE 802.3az
  • Uplink Interface: Gigabit Ethernet
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Model #: J9772A
HPE J9728A 2920-48G Switch
Quick View
Refurbished HPE J9728A 2920-48G Switch
  • Switch Type: Ethernet Switch
  • Package Contents: HP J9728A Factory Sealed Renew - Product warranty: Lifetime (99 years), advance replacement, next business day
  • Parts: 30 DAYS WARRANTY
  • Labor: 30 DAYS WARRANTY
  • Model #: J9728A
HPE Networking Instant On 1830 24G 12p Class4 PoE 2SFP 195W Switch  (JL813A#ABA)
Quick View
HP
HPE Networking Instant On 1830 24G 12p Class4 PoE 2SFP 195W Switch (JL813A#ABA)
  • Part Number: JL813A#ABA
  • Dimensions: 17.4 in x 10 in x 1.7 in
  • Weight: 7.65 lbs
  • Model #: JL813A#ABA dup
  •  
  • $399.99 –
  • Free Shipping
TP-Link TL-SG1210PP 8-Port Gigabit and 1x Combo SFP Slot PoE Switch with 6 PoE+ and 2 PoE++ Ports
Quick View
TP-Link
TP-Link TL-SG1210PP 8-Port Gigabit and 1x Combo SFP Slot PoE Switch with 6 PoE+ and 2 PoE++ Ports
  • Format: Desktop
  • Primary Ports: 9 x RJ45 + 1 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Primary Port Type: 9 x 10/100/1000Mbps RJ45 Ports 1 x 1000Mbps Combo SFP/RJ45 Port
  • Model #: TL-SG1210PP
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
HP JG304B 3600-24-poe+ V2 Si Switch - Switch - 24 Ports - Managed - Rack-mountable
Quick View
  •  
  • $359.00 –
  • Free Shipping
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
  • Format: DIN Rail Mount
  • VLAN Support: Yes
  • Jumbo Frames: 9000 bytes
  • SNMP: Yes
  • Model #: IGS-5225-4T2S
HP ARUBA 3810M/2930M 4-PORT 100M/1G/10G SFP+ MACSEC MODULE JL083A
Quick View
  •  
  • $355.00 –
  • Free Shipping
ZyXEL GS1920-8HPv2 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
Quick View
ZyXEL GS1920-8HPv2 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
  • Brand: ZyXEL
  • Series: GS1920
  • Part Number: GS1920-8HPV2
  • Switch Type: Manageable
  • Model #: GS1920-8HPV2
TP-Link TL-SG105PP-M2 Unmanaged Desktop Switch with 4-Port PoE++
Quick View
TP-Link
TP-Link TL-SG105PP-M2 Unmanaged Desktop Switch with 4-Port PoE++
  • Format: Desktop
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 2.5 Gbps
  • Primary Port Type: 5 x 10 Mbps/100 Mbps/1 Gbps/2.5 Gbps RJ45 ports
  • Model #: TL-SG105PP-M2
HP JL083A ARUBA 3810M 4SFP+ MOD
Quick View
  •  
  • $355.00 –
  • Free Shipping
Ubiquiti UniFi Switch Lite 16-Port PoE Ethernet Switch USW-Lite-16-POE
Quick View
Ubiquiti UniFi WAN Switch RJ45 (USW-WAN-RJ45)
Quick View
Ubiquiti Networks WAN Switch (USW-WAN)
Quick View