Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now
SHOP BY Primary Ports

Quick View
Cisco C1300X-24T-4X Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 3 Layer Supported - 32.10 W Power Consumption - Twisted Pair, Optical Fiber
- Brand: CISCO
- Series: C1300X Series
- Part Number: C1300X-24T-4X
- Format: Rackmount
- Model #: C1300X-24T-4X
- $1,060.52
- $853.99 –
- Save: $206.53 (19%)
- More options from $853.99 - $979.68
- Free Shipping

Quick View
TP-Link TL-SG108S | 8 Port Gigabit Ethernet Switch | Desktop/Wall-Mount | Plug & Play | Fanless | Sturdy Metal | Limited Lifetime Protection | 802.1p/DSCP QoS & IGMP Snooping | Compact Design
- Format: Desktop
- Standards: IEEE 802.3i / 802.3u / 802.3ab/ 802.3x /802.1p
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG108S

Quick View
D-Link DGS-105GL 5-Port Gigabit Unmanaged Desktop Switch - Fanless, Silent & Energy Efficient
- Brand: D-Link
- Part Number: DGS-105GL
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Model #: DGS-105GL
- $29.61 –
- More options from $17.99 - $45.65
- Free Shipping

Quick View
- $180.00 –
- Free Shipping

Quick View
Netgear GS724T 24-Port Manageable Gigabit Ethernet Smart Switch, GS724T-600NAS
- Brand: NETGEAR
- Part Number: GS724T-600NAS
- Standards: IEEE 802.3az IEEE 802.1x IEEE 802.1Q IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1ab IEEE 802.3 IEEE 802.3ab IEEE 802.3ae IEEE 802.3ad
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Model #: GS724T-600NAS
- $289.99 –
- Free Shipping

Quick View
Netgear ProSafe GS728TP 24-Port Manageable Gigabit Ethernet Switch, GS728TP-300NAS
- Brand: NETGEAR
- Part Number: GS728TP-300NAS
- Network Management Type: Smart
- Primary Ports: 24 x RJ45 + 4 x SFP
- Model #: GS728TP-300NAS
- $399.99 –
- Free Shipping

Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
- Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
- Primary Port Speed: 10/100/1000Mbps
- Model #: GSD-1008HP
- $123.99 –
- Free Shipping

Quick View
TP-Link 8 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1008D)
- Format: Desktop
- Standards: IEEE 802.3i / 802.3u / 802.3ab / 802.3x
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1008D
- $27.98 –
- More options from $27.98 - $54.25
- Free Shipping

Quick View
HP Rack Mount for HP Z2 Mini G9 Workstation (6C1U0AA)
- Brand: HP
- Part Number: 6C1U0AA
- Switch Type: Rack Mount
- Model #: 6C1U0AA
- $519.99 –
- More options from $519.99 - $1,369.64
- Free Shipping

Quick View
10Gbe Ethernet Switch Unmanaged with 2 x 10Gb RJ45 Ports 4 x 2.5Gb Base-T Ports, Desktop/Wall Mount NICGIGA 6 Port 10Gbps Network Switch for Wireless AP, NAS, PC
- Model #: RCCWB0DS4KC7Y3
- $144.99 –
- Free Shipping

Quick View
Aruba CX 6000 48p 10M/100M/1G Class4 PoE 4p SFP 1G 370W Switch 48 Ports - Manageable - Gigabit Ethernet - 4 SFP Slots - 439 W Power Consumption - 370 W PoE Budget - R8N85B#ABA
- Brand: Aruba
- Part Number: R8N85B#ABA
- Network Management Type: Managed
- Primary Ports: 48x Gigabit Ethernet Class 4 PoE+ Ports
- Model #: R8N85B#ABA
- $1,564.74 –
- More options from $1,564.74 - $3,585.94
- Free Shipping

Quick View
TP-Link TL-SG3452X | 48 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG
- Part Number: TL-SG3452X
- Format: Rackmount
- Primary Ports: 48 x RJ45 + 4 x SFP+
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Model #: TL-SG3452X
- $599.39 –
- More options from $599.39 - $688.98

Quick View
Mikrotik CRS328-24P-4S+RM 24 port Gigabit Ethernet router/switch with four 10Gbps SFP+ ports in 1U rackmount case, Dual Boot and PoE output, 500W
- Model #: CRS328-24P-4S+RM
- $509.99 –
- More options from $509.99 - $679.00
- Free Shipping

Quick View
- $229.99 –
- Free Shipping

Quick View
Solar Powered Outdoor 4G LTE Modem Router with SIM Card Slot, WiFi Extender 50M Range, 15W Solar Panel, 25600mAh Battery Built in, Design for Camping RVs and Outdoor
- Model #: RCCWB0F94BSBDV
- $214.99 –
- Free Shipping

Quick View
Grandstream GWN7664LR Wi-Fi 6 Outdoor Long Range AP
- Model #: RCCWB0BNQLTWWD
- $359.99 –
- More options from $358.99
- Free Shipping

Quick View
MikroTik RB5009UPr+S+IN 1.4GHz 1GB 7xGb 1x2.5Gb 1xSFP+ New Sealed
- Model #: RB5009UPr+S+IN
- $309.20 –
- More options from $274.14 - $310.00
- Free Shipping

Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: WGS-5225-8T2SV
- $402.60
- See price in cart
- More options from $327.20 - $341.99
- Free Shipping

Quick View
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
- Brand: NETGEAR
- Part Number: GS748-100NAS
- Format: Rack-mountable, Desktop, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS748-100NAS
- $613.48 –
- $11.62 Shipping

Quick View
Yealink 1303228 24 Port L2+ Gigabit Managed Switched - Web-based Management - 370 PoE Power Budget - Designed for AV Networking
- Brand: Yealink
- Part Number: 1303228
- Network Management Type: Managed
- Primary Ports: 24× Gigabit PoE, 4× SFP fiber uplinks
- Model #: 1303228
- $640.31 –
- More options from $640.31 - $759.00

Quick View
HP J4812A Managed ProCurve Switch 2512
- Brand: HP
- Format: Rackmount
- Standards: IEEE 802.3x Flow Control IEEE 802.1D Spanning Tree IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1X Network Login IEEE 802.1Q GVRP IEEE 802.1w Rapid Convergence Spanning Tree IEEE 802.1Q VLANs IEEE 802.1p Priority
- Network Management Type: Managed
- Model #: J4812A
- $751.00 –
- Free Shipping

Quick View
- $299.00 –
- Free Shipping

Quick View
Cisco SG250-08HP 8-Port Gigabit PoE Smart Switch - SG250-08HP-K9-EU Refresh
- Model #: SG250-08HP-K9EU-RF
- $232.99 –
- Free Shipping

Quick View
QNAP Desktop QSW-2104-2S-US, Unmanaged Switch, 4 port 2.5Gbps auto negotiation (2.5G/1G/100M), 2 10GbE SFP+ port
- Series: Desktop QSW-2104-2S-US
- Part Number: QSW-2104-2S-A-US
- Model #: QSW-2104-2S-A-US
- $143.99 –
- More options from $143.99 - $183.20
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink,1000Mbps PoE Ethernet Unmanaged Network Switch,120W, Plug & Play, VLAN, Suitable for Access Point-AP and PoE Surveillance Camera
- Model #: C1R8482776545105
- $76.79 –
- Free Shipping

Quick View
Netgear 8-Port Multi-Gigabit/10G Ethernet Ultra60 PoE++ Smart Switch with 2 SFP+ Ports, MS510TXUP-100NAS
- Brand: NETGEAR
- Part Number: MS510TXUP-100NAS
- Format: Rack-mountable Desktop
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: 2.5 Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 1000Base-T 1000Base-X
- Model #: MS510TXUP-100NAS
- $689.99 –
- Free Shipping

Quick View
Netgear GS524 24-Port Gigabit Ethernet Unmanaged Switch, GS524-300NAS
- Brand: NETGEAR
- Series: Gigabit Unmanaged Switch
- Part Number: GS524-300NAS
- Format: Wall Mountable
- Model #: GS524-300NAS
- $205.43
- $149.99 –
- Save: $55.44 (26%)
- Free Shipping

Quick View
Cisco 110 CBS110-24PP Ethernet Switch, 24 Ports - 2 Layer Supported
- Part Number: CBS110-24PP
- Format: Desktop Wall Mountable Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
- Model #: CBS11024PPNA
- $361.08
- See price in cart
- More options from $292.99 - $349.31
- Free Shipping

Quick View
TRENDnet 12-Port 10G Layer 2 Managed SFP+ Switch, TL2-F7120, 12 x 10G SFP+ Ports, 240Gbps, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
- Features: • 12 x 10G SFP+ slots • Support 1Gbps / 10Gbps link speeds • Web-based management • CLI management • Supports IPv6, LACP, VLAN, and IGMP Snooping • 802.1Q tagged-based VLAN, GVRP, and Voice VLAN support • QoS with queue scheduling support • Supports inter-VLAN routing and IPv4/IPv6 static routing • 240Gbps switching capacity • Supports 10GBASE-X / 1000BASE-FX SFP fiber modules • Smart fan • Save rack space by mounting 2 x
- Weight: 9.3500
- Model #: TL2-F7120

Quick View
ZyXEL 24-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 12 PoE+ Ports at 130W, GS1915-24EP
- Brand: ZyXEL
- Part Number: GS1915-24EP
- Switch Type: Manageable: Yes
- Format: Wall Mountable Rack-mountable
- Model #: GS191524EP
- $253.53 –
- More options from $199.99 - $305.10
- Free Shipping









