Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now
SHOP BY Primary Ports

Quick View
ZyXEL 5 Port Gigabit Ethernet Unmanaged POE+ Switch, 4 x PoE+ @ 60W, GS1005HP
- Brand: ZyXEL
- Part Number: GS1005HP
- Switch Type: Manageable: Yes
- Format: Desktop, Wall-Mount
- Model #: GS1005HP
- $54.99
- See price in cart
- More options from $39.99 - $59.19
- $2.99 Shipping

Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16FP-2G
- Format: Rack-mountable
- Model #: C1300-16FP-2G
- $1,130.99 –
- More options from $1,104.81 - $1,164.17
- Free Shipping

Quick View
TRENDnet 8-Port Industrial Unmanaged Fast Ethernet DIN-Rail Switch; TI-E80 8 x Fast Ethernet Ports; 1.6Gbps Switching Capacity;8 Port Network Fast Ethernet Switch;IP30 Metal Switch;Lifetime Protection
- Format: DIN Rail Mountable
- Primary Port Speed: 100Base-X
- Model #: TI-E80
- $90.99 –
- Free Shipping

Quick View
- $687.99 –
- More options from $687.99 - $772.77
- Free Shipping

Quick View
HPE Aruba Networking 2930F 24G PoE+ 4SFP+ Switch | JL255A
- Brand: HPE
- Model: JL255A#ABA
- Part Number: JL255A
- Primary Ports: (24) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
- Model #: JL255A#ABA
- $5,496.00
- $1,996.00 –
- Save: $3,500.00 (63%)
- More options from $1,076.00 - $1,996.00
- Free Shipping

Quick View
D-Link 52-Port 10-Gigabit Smart Managed PoE Switch DGS125052XMP6KV
- Switch Type: managed
- Model #: DGS125052XMP6KV
- $837.22 –
- More options from $837.22 - $1,145.52
- Free Shipping

Quick View
HPE Aruba JL262A#ABA 2930F 48G PoE+ 4 SFP Switch
- Primary Ports: (48) RJ-45 autosensing 10/100/1000 ports (4) SFP
- Dimensions: 1.73" x 17.42" x 9.70"
- Weight: 9.83 lbs.
- Package Contents: (1) Aruba 2930F 48G PoE+ 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4)bumper feet, (1) cable tie
- Model #: JL262A#ABA
- $5,000.00
- $2,522.99 –
- Save: $2,477.01 (49%)
- Free Shipping

Quick View
ZyXEL GS1350-6HP 5-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 3 PoE+ / 2 PoE++ Ports at 60W with 1 SFP Uplink
- Brand: ZyXEL
- Part Number: GS1350-6HP
- Switch Type: Manageable
- Format: Wall Mountable
- Model #: GS1350-6HP
- $169.95 –
- More options from $149.99 - $215.16

Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P2S2X
- $979.80
- See price in cart
- Free Shipping

Quick View
- $95.69 –
- More options from $95.69 - $116.75
- Free Shipping

Quick View
Cisco Catalyst 1300-12XS Managed Switch, 10 Port 10G SFP+, 2x10GE SFP+ Combo, Limited Lifetime Protection (C1300-12XS)
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-12XS
- Switch Type: Manageable
- Model #: C1300-12XS
- $1,529.99 –
- More options from $1,529.99 - $1,676.71
- Free Shipping

Quick View
Adder - CATX-USB - Computer Access Module RJ45 Socket - USB & VGA
- Model #: CATX-USB
- $115.20
- See price in cart
- Free Shipping

Quick View
ZyXEL 48-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 48 PoE+ Ports at 375W with 2 SFP Uplinks, TAA Compliant, GS1920-48HPv2
- Brand: ZyXEL
- Part Number: GS1920-48HPv2
- Switch Type: Manageable
- Format: Rack-mountable
- Model #: GS1920-48HPV2
- $588.50 –
- More options from $484.99 - $825.00

Quick View
Vertiv Avocent ACS8048DAC-400 ACS8000 Serial Console - 48 port Console Server | Dual AC
- Type: Consumer Electronics
- Model #: ACS8048DAC-400
- $6,176.00
- See price in cart
- More options from $5,612.10 - $7,050.00
- Free Shipping

Quick View
ZyXEL 24-Port Gigabit Smart Managed PoE Switch, 24 PoE+ Ports at 170W with 2 SFP Uplinks, TAA Compliant, GS1900-24HPV2
- Brand: ZyXEL
- Part Number: GS1900-24HPV2
- Switch Type: Manageable: Yes
- Format: Rack-mountable Desktop
- Model #: GS1900-24HPV2
- $275.53 –
- More options from $219.99 - $327.56
- Free Shipping

Quick View
Panasonic Toughmate G2 Enhanced Rotating Hand Strap ING2ERHSTP
- Model #: ING2ERHSTP
- $75.69 –
- More options from $75.69 - $83.38
- Free Shipping

Quick View
TRENDnet 20-Port Gigabit Web Smart Switch; 16 x Gigabit Ports; 4 x shared Gigabit Ports (RJ-45/SFP); VLAN; QoS; LACP; IPv6 Support; 40 Gbps Switching Capacity; Lifetime Protection; TEG-204WS
- Format: Rackmount
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az
- Primary Ports: 16 x Gigabit ports 4 x shared Gigabit ports (RJ-45 / SFP)
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
- Model #: TEG-204WS

Quick View
ZyXEL 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 60W, GS1915-8EP
- Brand: ZyXEL
- Part Number: GS1915-8EP
- Switch Type: Manageable: Yes
- Format: Wall Mountable
- Model #: GS19158EP
- $174.27 –
- More options from $129.99 - $250.00
- Free Shipping

Quick View
Black Box KV62-CBL 2-Port 4K60 DisplayPort Cable KVM Switch
- Model #: KV62-CBL
- $160.99 –
- Free Shipping

Quick View
Aruba Instant On 1830 48-Port Gb Smart Switch - 48x 1G | 4X SFP | US Cord (JL814A#ABA)
- Switch Type: Ethernet Switch
- Model #: JL814A#ABA
- $394.99 –
- More options from $379.99 - $916.99
- Free Shipping

Quick View
D-Link DGS-1024C 24-Port 10/100/1000 Mbps Gigabit Unmanaged Desktop Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: DGS-1024C
- $89.00 –
- More options from $89.00 - $108.85
- Free Shipping

Quick View
HPE Aruba 2930F 8G PoE+ 2SFP+ Switch JL258A#ABA
- Weight: 10.85
- Parts: Lifetime
- Model #: JL258A#ABA
- $1,805.99 –
- Free Shipping

Quick View
TP-Link 16 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1016)
- Format: Rackmount
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1016

Quick View
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
- Switch Type: Others
- Weight: 0.35
- Model #: SW-104
- $69.99 –
- More options from $69.99 - $83.87
- Free Shipping

Quick View
TRANSITION NETWORKS SISPM1040-362-LRT MNGDHRDNDPOE+SW 4X10/100/1000
- Switch Type: Others
- Weight: 2.1
- Parts: 5 Year
- Model #: SISPM1040-362-LRT
- $920.95
- See price in cart
- More options from $749.99 - $858.13
- Free Shipping

Quick View
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-24XTS
- Format: Rack-mountable
- Model #: C1300-24XTS
- $3,269.99 –
- More options from $3,269.99 - $3,658.79
- Free Shipping

Quick View
Cisco Catalyst 9200L 24-port PoE+ 4x1G uplink Switch, Network Essentials | C9200L-24P-4G-E
- Brand: CISCO
- Series: 9200
- Network Management Type: Managed
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Model #: C9200L-24P-4G-E
- $1,687.99 –
- More options from $1,687.99 - $1,910.24
- Free Shipping

Quick View
SMART MGD POE+ SWITCH 24PORT
- Switch Type: managed
- Model #: SM24TAT2SA-NA
- $626.55 –
- More options from $617.99 - $858.60
- Free Shipping

Quick View
HPE Aruba Networking 2930F 24G 4SFP+ Switch | JL253A
- Primary Ports: (24) RJ-45 autosensing 10/100/1000 ports (4) SFP+ 1/10GbE ports
- Dimensions: 1.73" x 17.42" x 7.88"
- Weight: 5.31 lbs.
- Package Contents: (1) Aruba 2930F 24G 4SFP+ Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4) bumper feet, (1) cable tie
- Model #: JL253A#ABA
- $3,652.99 –
- Free Shipping

Quick View
TP-Link 9 Port Fast Ethernet 10/100Mbps PoE Switch | 8 PoE+ Ports @65W | Sturdy Metal w/Shielded Ports | Limited Lifetime Protection | Extend Mode | Priority Mode | Isolation Mode (TL-SF1009P)
- Switch Type: desktop
- Format: Desktop
- Primary Ports: 9 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: TL-SF1009P

Quick View
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
- Part Number: C1300-24XS
- Format: Rackmount
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-X 1000Base-T Maximum Data Transfer Rate: 1.25 GB/s
- Model #: C1300-24XS
- $2,504.99 –
- More options from $2,504.99 - $2,689.97
- Free Shipping

Quick View
TP-Link 8 Port Gigabit PoE Switch | 8 PoE+ Ports @63W, w/ 1 Gigabit Port and 1 SFP Slot | Desktop | Plug & Play | Support QoS and IGMP (TL-SG1210P)
- Format: Desktop
- Primary Ports: 9 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 4K, Auto-learning, Auto-aging
- Model #: TL-SG1210P
- $110.25 –
- More options from $98.20 - $147.09

Quick View
TRENDnet Hardened Industrial SFP to Gigabit UPoE Media Converter, IP30 Rated Housing, Includes DIN-rail & Wall Mounts, Operating Temp. -40 to 75 °C (-40 to 167 °F), TI-UF11SFP
- Format: DIN Rail Mount
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3bt draft
- Primary Ports: 1 x Gigabit UPoE port 1 x 100/1000Mbps SFP slot
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
- Model #: TI-UF11SFP (V1.0R)
- $101.57 –
- More options from $101.57 - $123.85

Quick View
Aruba Rack Mount for Switch Black Silver JL602A
- Model #: JL602A
- $450.00
- See price in cart
- Free Shipping

Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
- Switch Type: Others
- Weight: 0.4
- Model #: SW-108
- $132.99 –
- More options from $132.99 - $185.01
- Free Shipping

Quick View
HPE Juniper Networking EX2300-C Switch, Compact Fanless 12-port 10/100/1000BASE-T PoE+, 2 X 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-C-12P
- Brand: Juniper Networks
- Series: EX2300-C
- Part Number: EX2300-C-12P
- Switch Type: Layer 3 Switch
- Model #: EX2300-C-12P
- $1,080.00 –
- More options from $1,080.00 - $2,911.00
- Free Shipping

