Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
- $221.92 –
- Free Shipping

Quick View
D-Link 16-Port Gigabit Unmanaged/Plug and Play Switch | Fanless| Slim Metal Compact | Desktop - (DGS-1016S)
- Brand: D-Link
- Series: ProSafe
- Part Number: DGS-1016S
- Format: Desktop
- Model #: RNAB08GYJ13XG

Quick View
16 Port PoE Switch with 2 Gigabit Uplink Ethernet Port, 250W High Power, Support IEEE802.3af/at, Rackmount Unmanaged Plug and Play
- Model #: BEMokerLink16POE250W
- $159.99 –
- Free Shipping

Quick View
TRENDnet TEG-S16g 16-port Gigabit GREENnet Switch(Rack Mount)
- Weight: 7.7000
- Features: • GREENnet technology reduces power consumption by up to 70%* • 16 x Gigabit RJ-45 ports • Sturdy rackmount metal switch with built-in power supply • 32 Gbps forwarding capacity • NDAA / TAA compliant (U.S. and Canada only) • Lifetime Warranty
- Model #: TEG-S16g (V2.0R)
- $74.99 –

Quick View
TRENDnet 16-Port Industrial Gigabit L2 Managed DIN-Rail Switch, TI-G160i, 16 x Gigabit Ports, NDAA & TAA Compliant, 32 Gbps Switching Capacity, Black
- Brand: TRENDnet
- Model: TI-G160i
- Weight: 2.7500
- Features: • 16 x Gigabit ports • 32Gbps switching capacity • Hardened IP40 rated metal housing • Includes DIN-rail mounting bracket • Operating temperature range of -40° – 75° C (-40° – 167° F) • Supports LACP, STP/RSTP, VLAN, and IGMP Snooping • IEEE 802.1p QoS with queue scheduling support • Bandwidth control per port • Remote cloud management with TRENDnet Hive™ (Additional fee applies) • Redundant power inputs with
- Model #: TI-G160i (V2)
- $450.08
- $449.99 –

Quick View
16 Port Gigabit PoE Switch with 2 Gigabit Uplink, 16 PoE+ Port 1000Mbps, 250W 802.3af/at, Metal Desktop/Rackmount, Unmanaged Plug and Play Network Switch
- Model #: BEYuanLey16POE
- $199.99 –
- Free Shipping

Quick View
Power USB Hub 3.0, atolla 16 Port USB Splitter with 12V/6A Power Adapter and Individual Switches, High-Speed Data Transfer for Laptop, PC, Mac, and More Devices
- Model #: 433411539966
- $93.69 –
- Free Shipping

Quick View
D-Link Ethernet Switch, 16 Port 10/100 Unmanaged Desktop, Fanless Rackmount Network Hub Internet (DSS-16+)
- Brand: D-Link
- Format: Desktop
- Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3 Nway Auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p Qos Prioritization
- Network Management Type: Smart
- Model #: DSS-16+
- $74.90 –
- Free Shipping

Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16FP-2G
- Format: Rack-mountable
- Model #: C1300-16FP-2G
- $1,130.99 –
- More options from $1,104.81 - $1,164.17
- Free Shipping

Quick View
Extreme Networks 5420F 24-port Switch with 8 ports 90W and 16 ports 30W PoE, 4 x 1/10Gb SFP+ ports, Base software included | 5420F-8W-16P-4XE
- Brand: Extreme Networks
- Series: 5420 Series
- Part Number: 5420F-8W-16P-4XE
- Network Management Type: Managed
- Model #: 5420F8W16P4XE
- $7,780.00
- $5,162.99 –
- Save: $2,617.01 (33%)
- Free Shipping

Quick View
Aten Cs1716a 16-port Ps/2 Usb Kvm Switch - 16 X 1 - 16 X Sphd-15 Keyboard/mouse/video - 1u - Rack-m
- Model #: CS1716A
- $579.99 –
- Free Shipping

Quick View
TRENDnet 16-Port Hardened Industrial Unmanaged Gigabit DIN-Rail Switch, TI-G162, 14 x Gigabit Ports, 2 x Gigabit SFP Slots,32Gbps Switching Capacity, IP30 Ethernet Network Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3z
- Primary Ports: 14 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: TI-G162
- $458.32 –
- Free Shipping

Quick View
TP-Link TL-SG116E 16 Port Gigabit Unmnged Pro Switch
- Model #: TL-SG116E
- $97.19 –
- More options from $97.19 - $119.28
- Free Shipping

Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: 19-inch Rack-mountable Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 16 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-16T4S
- $872.50
- See price in cart
- More options from $871.99
- Free Shipping

Quick View
Cisco Business CBS220-16T-2G Ethernet Switch, 16 Ports - Manageable - 2 Layer Supported
- Part Number: CBS220-16T-2G-NA
- Format: Rack-mountable
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Number of SFP Slots: 2
- Model #: CBS22016T2GNA
- $241.99 –
- More options from $241.99 - $296.25
- $5.99 Shipping

Quick View
Trendnet 16-Port Industrial Gigabit
- Weight: 1.8
- Model #: 710931161854
- $305.24 –
- Free Shipping

Quick View
- $119.28 –
- Free Shipping

Quick View
Extreme Networks 5320 16-port 30W PoE Switch w/AC Power, 2 x 1/10Gb SFP+ ports | 5320-16P-2MXT-2X
- Brand: Extreme Networks
- Series: 5320 Series
- Part Number: 5320-16P-2MXT-2X
- Format: Rackmount
- Model #: 5320-16P-2MXT-2X
- $3,738.00
- $2,394.99 –
- Save: $1,343.01 (35%)
- Free Shipping

Quick View
Extreme Networks 5420F 48-port Switch with 16 ports 90W multi-rate and 32 ports 30W PoE, 4x 1/10Gb SFP+ ports | 5420F-16MW-32P-4XE
- Brand: Extreme Networks
- Series: 5420 Series
- Part Number: 5420F-16MW-32P-4XE
- Management Interface: Interfaces: 16 x 100M/1G/2.5GBASE-T 802.3bt (90W) ports MACsec-capable 32 x 10/100/1000BASE-T 802.3at (30W) ports Full / Half-Duplex(autosensing) MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420F16MW32P4XE
- $15,432.00
- $10,424.99 –
- Save: $5,007.01 (32%)
- Free Shipping

















