Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Aruba Instant On 1830 24-Port Gb | 12-Port Class 4 PoE Smart Switch (195W) - 24x 1G | 2X SFP | US Cord (JL813A#ABA)
- Model #: 26452300229627
- $791.77 –
- Free Shipping

Quick View
D-Link DGS-1008MP 8-Port Gigabit Unmanaged Metal Desktop Switch with 8 PoE+ Port - Up to 30 W per Port with 125 W PoE Budget
- Model #: 26452300228101
- $144.77 –
- Free Shipping

Quick View
PoE Texas 8-Port Passive PoE Injector, 48V 120W, 10/100
- Model #: 26452300231323
- $142.77 –
- Free Shipping

Quick View
TRENDnet 8-Port Industrial Gigabit PoE+ DIN-Rail Switch, TI-PG80
- Model #: 880395144035
- $255.99 –
- $5.99 Shipping

Quick View
1500ft 8 Port Long Range PoE+ Switch, PoE Extension with Continuous Run of cat5e/cat6, Fast Ethernet 10/100Mbps, 30W IEEE802.3at/af
- Model #: 617327139018
- $370.99 –
- $5.99 Shipping

Quick View
YuanLey 8 Port PoE Switch with 2 Gigabit Uplink, 8 PoE+ Port 100Mbps, 120W 802.3af/at, Extend Function, Metal, Fanless, Unmanaged Plug and Play Network Switch
- Model #: 617327107116
- $71.99 –
- $5.99 Shipping

Quick View
Ubiquiti TOUGHSwitch PoE Pro - Switch - 8 Ports - Managed - Desktop (TS-8-PRO)
- Model #: 880395149580
- $692.99 –
- $5.99 Shipping

Quick View
TRENDnet TI-PG103i,10-Port Industrial Gigabit L2 Managed PoE+
- Model #: 617327115586
- $706.99 –
- $5.99 Shipping

Quick View
BV-Tech 8-Port PoE+ Gigabit Switch with 2 Gigabit Uplinks, 96W Total Power, NDAA Compliant, 802.3af/at, 30W per Port
- Model #: 617327136970
- $183.99 –
- $5.99 Shipping
![MORRELLCOM 8 Giga Ethernet Ports [8 PoE Ports] + 2 Giga SFP Ports Waterproof Managed Industrial Switch MORRELLCOM 8 Giga Ethernet Ports [8 PoE Ports] + 2 Giga SFP Ports Waterproof Managed Industrial Switch](https://c1.neweggimages.com/productimage/nb300/C0CPD26030115A9N7CD.jpg)
Quick View
MORRELLCOM 8 Giga Ethernet Ports [8 PoE Ports] + 2 Giga SFP Ports Waterproof Managed Industrial Switch
- Model #: 617327066154
- $479.99 –
- $5.99 Shipping

Quick View
All 8 Port Gigabit PoE Switch 120W Ethernet Unmanaged Switch
- Model #: vfrtR421983485293
- $108.66 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 120W Built-in Power, 802.3af/at Compliant, Managed PoE+ Switch Support VLAN, QoS, Fanless Metal, Plug and Play(Desktop/Wall Mount)
- Model #: vfrtR421983485248
- $79.66 –
- Free Shipping

Quick View
All 8 Port Gigabit PoE Switch 120W Ethernet Unmanaged Switch
- Model #: 430488915440upergoCove
- $106.88 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 120W Built-in Power, 802.3af/at Compliant, Managed PoE+ Switch Support VLAN, QoS, Fanless Metal, Plug and Play(Desktop/Wall Mount)
- Model #: 430488915396upergoCove
- $77.88 –
- Free Shipping

Quick View
8 Port PoE Gigabit Managed Switch, 8x100/1000Mbps PoE+ Port, IEEE802.3af/at, 120W Power Supply, L2 Smart Web Managed, Fanless Metal Ethernet Switch
- Model #: C750-HALCEN-GS717-8
- $123.98 –
- Free Shipping

Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-804HPT
- $259.60 –
- More options from $248.99 - $259.60
- Free Shipping

Quick View
Gigabit POE Switch, 5 Port and 8 Port PoE Switch, IEEE802.3af/at, Unmanaged Plug and Play, Sturdy Metal Fanless
- Model #: C750-HALCEN-GS717-42
- $203.18 –
- Free Shipping

Quick View
Indoor/Outdoor Industrial Enclosure with Integrated 8 Port Gigabit PoE+, 2 Port 1000BASE SFP Switch, IEEE802.3af/at POE 246W Power Supply, Plug and Play, Metal IP65 Case, -40 to 158°F
- Model #: C750-HALCEN-GS717-40
- $873.98 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch, 8 PoE+ Ports 1000Mbps, 802.3af/at 120W, Metal Fanless Unmanaged Plug and Play
- Model #: C750-HALCEN-GS717-29
- $105.95 –
- Free Shipping

Quick View
8 Port PoE Switch with 2 Gigabit Uplink, 802.3af/at PoE+ 100Mbps, 120W Built-in Power, Extend to 250Meter, Metal Plug & Play
- Model #: C750-HALCEN-GS717-2
- $121.48 –
- Free Shipping

Quick View
8 Port 2.5G POE Managed Switch with 10G SFP+ Slot, IEEE8023af/at PoE 135W, Mini Size Metal Fanless, Easy Web Managed Network Switch
- Model #: C750-HALCEN-GS717-31
- $288.97 –
- Free Shipping

Quick View
8 Port Outdoor Gigabit PoE Switch, 8 PoE+ Ports 1000Mbps, 802.3af/at 120W, Weatherproof Fanless Unmanaged Plug and Play
- Model #: C750-HALCEN-GS717-23
- $148.97 –
- Free Shipping

Quick View
PoE Switch, 6 Port and 10 Port PoE Switch, Support IEEE802.3af/at, Fanless Metal Plug & Play
- Model #: C750-HALCEN-GS717-41
- $203.95 –
- Free Shipping

Quick View
8 Port 2.5G PoE Switch with 10G SFP+ Slot, 8 x 2.5G Base-T Ports Compatible with 10/100/1000Mbps, IEEE8023af/at PoE 135W, Metal Unmanaged Fanless Small Network Switch
- Model #: C750-HALCEN-GS717-11
- $173.95 –
- Free Shipping

Quick View
8 Port 2.5 Gigabit PoE Managed Switch, 8x2.5G POE, 2x10G Ethernet, 4x10G SFP+, IEEE8023af/at PoE 120W, Web/CLI L3 Managed, Desktop|Rackmount Network Switch
- Model #: C750-HALCEN-GS717-32
- $688.98 –
- Free Shipping

Quick View
802.3af PoE Splitter with 5 Volts Output and PoE Texas 8 Port PoE Switch
- Model #: RCCWB09PM9FTTL
- $221.99 –
- More options from $220.99
- Free Shipping

Quick View
8 Port 802.3bt POE++ Extreme Power POE Injector Hub, 90 Watts on Each Port, 250 Total Watts Budget, Up to 10G 10/100/1000/10000 Speeds Each Port
- Model #: RCCWB0FJ8ZRXQS
- $360.99 –
- More options from $359.99
- Free Shipping

Quick View
D-Link 8-Port EasySmart Gigabit PoE Ethernet Switch - Lifetime Warranty (DGS-1100-08P)
- Brand: D-Link
- Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
- Network Management Type: Smart
- Primary Ports: 8 x RJ45
- Model #: DGS-1100-08P
- $117.24 –
- Free Shipping

Quick View
Ubiquiti - UniFi Switch (USW-Lite-16-PoE, 16 Gigabit Ethernet Ports, 8 PoE+ Ports, Wall Mounted)
- Model #: RCCWB08PMDVS6F
- $342.99 –
- More options from $341.99
- Free Shipping

Quick View
Lysora LCS-8GS-P 8-Port Gigabit PoE+ Switch (10 Ports Total), 120W Budget, SFP Combo Uplink, Fanless Silent, PoE Watchdog, Cloud Managed, NDAA Compliant
- Model #: LCS-8GS-P
- $198.00 –
- Free Shipping

Quick View
Lysora LS2P-8MG2XS-P 8-Port 2.5G Multi-Gigabit PoE+ Managed Switch, 240W Budget, 2x 10G SFP+ Uplinks, L2 VLAN STP LACP, Rack Mount, NDAA Compliant
- Model #: LS2P-8MG2XS-P
- $598.00 –
- Free Shipping

Quick View
Amcrest 8-Port POE+ Power Over Ethernet POE Switch with Metal Housing, 8-Ports POE+ 802.3af/at 96w (AGPS8E8P-AT-96-V2)
- Model #: AIWU471646906412
- $118.55 –
- Free Shipping




