Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Show More
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
VLAN Support
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
TRENDnet 8-Port 10/100Mbps PoE Switch, 4 x 10/100 Ports, 4 x 10/100 PoE Ports, 30W PoE Power Budget, 1.6 Gbps Switching Capacity, 802.3af, Lifetime Protection, Black, TPE-S44
Quick View
TRENDnet 8-Port 10/100Mbps PoE Switch, 4 x 10/100 Ports, 4 x 10/100 PoE Ports, 30W PoE Power Budget, 1.6 Gbps Switching Capacity, 802.3af, Lifetime Protection, Black, TPE-S44
  • Weight: 2.4800
  • Features: • 4 x 10/100Mbps PoE ports • 4 x 10/100Mbps ports • 30W PoE power budget • 1.6Gbps switching capacity • Sturdy metal switch • Plug and Play installation • Lifetime TRENDnet manufacturer Warranty
  • Model #: TPE-S44 (Version v4.0R)
  •  
  • $47.99 –
  • $6.99 Shipping
Direct from TRENDnet Direct from TRENDnet
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
Quick View
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port 10/100TX
  • MAC Address Table: 8K
  • Model #: FSD-1008HP
  •  
  • $88.99 –
  • Free Shipping
Planet GS-4210-8P2S 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet GS-4210-8P2S 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
  • Format: Desktop
  • MAC Address Table: 8K entries
  • VLAN Support: Yes
  • Jumbo Frames: 10K bytes
  • Model #: GS-4210-8P2S
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P4S
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Quick View
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 10/100/1000T 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: IGS-4215-8P2T2S
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
Quick View
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
  • MAC Address Table: 4K
  • Switching Method: Store and Forward
  • Model #: FGSD-1008HPS
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P2S2X
ZyXEL GS1920-8HPv2 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
Quick View
ZyXEL GS1920-8HPv2 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
  • Brand: ZyXEL
  • Series: GS1920
  • Part Number: GS1920-8HPV2
  • Switch Type: Manageable
  • Model #: GS1920-8HPV2