Skip to main content
  • In Stock
  • Sold by Newegg
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
Sold by
VLAN Support
Availability
Useful Links
Customer Ratings
Sort By:
View:
GS-4210-24UP4C 24-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
  •  
  • $1,035.99 –
  • Free Shipping
Planet IGT-815AT Industrial Compact 100/1000BASE-X to 10/100/1000BASE-T Media Converter
Quick View
  •  
  • $187.99 –
  • Free Shipping
PLANET IGS-501T: 5-Port Industrial Gigabit Ethernet Switch
Quick View
  •  
  • $203.99 –
  • Free Shipping
IGS-10020MT Industrial L2+ 8-Port 10/100/1000T + 2 100/1000X SFP Managed Switch
Quick View
  •  
  • $702.99 –
  • Free Shipping
GSW-1601 Gigabit Ethernet Switch16-Port 10/100/1000Mbps
Quick View
  •  
  • $158.99 –
  • Free Shipping
XT-705A 10G/5G/2.5G/1G/100M Copper to 10GBASE-X SFP+ Media Converter
Quick View
  •  
  • $344.99 –
  • Free Shipping
Planet Net Switch 1000T 24P Planet Gsw-2401 (19")
Quick View
  •  
  • $202.99 –
  • Free Shipping
Planet MGS-6311-8P2X 8-Port PoE+ Managed Switch
Quick View
  •  
  • $1,150.99 –
  • Free Shipping
Planet 8-Port L3 PoE+ Managed Switch SGS-6310-8P4X
Quick View
  •  
  • $1,348.99 –
  • Free Shipping
Planet 24-Port Managed Switch GS-6311-24T4X
Quick View
  •  
  • $1,103.99 –
  • Free Shipping
Planet IGS-4215-8UP2T2S, W128204622
Quick View
  •  
  • $1,158.99 –
  • Free Shipping
PLANET IGS-5225-8P2T2S L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T+ 2-Port 100/1000X SFP Managed Ethernet Switch
Quick View
PLANET IGS-5225-8P2T2S L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T+ 2-Port 100/1000X SFP Managed Ethernet Switch

OUT OF STOCK

  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1ad Q-in-Q VLAN stacking IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 1588 PTPv2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 ITU G.8032 ERPS Ring
  • Primary Ports: 8 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports 2 x 100/1000BASE-X mini-GBIC/SFP slots for SFP ty...
  • Model #: IGS-5225-8P2T2S
  •  
  • $604.99 –
  • Free Shipping
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)

OUT OF STOCK

  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • $121.99 –
  • Free Shipping
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
PLANET Technology - GS-4210-24T2S - Planet 24-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces - 24 Ports - Manageable - 4 Layer Supported - Modular - Twisted Pair, Optical Fiber - 1U
Quick View
PLANET Technology - GS-4210-24T2S - Planet 24-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces - 24 Ports - Manageable - 4 Layer Supported - Modular - Twisted Pair, Optical Fiber - 1U

OUT OF STOCK

  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
  • Primary Ports: 24-port 10/100/1000BASE-T Gigabit RJ45 copper 2 x 100/1000BASE-X mini-GBIC / SFP slots
  • MAC Address Table: 8K
  • Switching Method: Store and Forward
  • Model #: GS-4210-24T2S
  •  
  • $197.99 –
  • Free Shipping
PLANET IGS-10020MT Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40~75 Degrees C)
Quick View
PLANET IGS-10020MT Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40~75 Degrees C)

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX / 100Base-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
  • Primary Ports: 8 x 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports 2 x 1000Base-SX/LX/BX SFP interfaces (Port-9 and Port-10)
  • MAC Address Table: 8K entries, automatic source address learning and ageing...
  • Model #: IGS-10020MT
PLANET WGS-5225-8P2S Managed Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch
Quick View
PLANET WGS-5225-8P2S Managed Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots for SFP type auto detection
  • MAC Addres...
  • Model #: WGS-5225-8P2S
  •  
  • $374.99 –
  • Free Shipping
PLANET IGS-4215-4P4T2S Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40~75 degrees C)
Quick View
PLANET IGS-4215-4P4T2S Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40~75 degrees C)

OUT OF STOCK

  • Primary Ports: 8-port 10/100/1000BASE-T Gigabit RJ45 copper with 4-port IEEE 802.3at/af PoE Injector (Port-1 to Port-4) 2 x 100/1000BASE-X mini-GBIC / SFP slots, SFP type auto detection
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 8K
  • Switching Method: Store and Forward
  • Model #: IGS-4215-4P4T2S
PLANET IFGS-1022HPT Unmanaged Industrial 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP Combo Ethernet Switch
Quick View
PLANET IFGS-1022HPT Unmanaged Industrial 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP Combo Ethernet Switch

OUT OF STOCK

  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x Flow Control and Back Pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port Gigabit TP/SFP
  • MAC Address Table: 16K
  • Model #: IFGS-1022HPT
  •  
  • $315.99 –
  • Free Shipping
Planet GSD-908HP 8-Port 10/100/1000T 802.3at PoE + 1-Port Gigabit Desktop Switch
Quick View
Planet GSD-908HP 8-Port 10/100/1000T 802.3at PoE + 1-Port Gigabit Desktop Switch

OUT OF STOCK

  • Format: Desktop
  • Primary Port Speed: 10/100/1000Mbps
  • PoE: Yes
  • Model #: GSD-908HP
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch

OUT OF STOCK

  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3bt Power over Ethernet ready RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 5 x RJ45 + 2 SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-4UP1T2S
  •  
  • $563.99 –
  • Free Shipping
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen

OUT OF STOCK

  • Format: Wall Mountable
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Switching Method: Store and Forward
  • Model #: WGS-5225-8P2SV
  •  
  • $444.99 –
  • Free Shipping
PLANET FGSD-1011HP 8-Port 10/100TX 802.3at/af PoE + 1-Port 10/100/1000T + 1-Port 100/1000X SFP Desktop Switch
Quick View
PLANET FGSD-1011HP 8-Port 10/100TX 802.3at/af PoE + 1-Port 10/100/1000T + 1-Port 100/1000X SFP Desktop Switch

OUT OF STOCK

  • Format: Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX / LX IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 8 x 10/100 Mbps Fast Ethernet ports 1 x 10/100/1000BASE-T Gigabit Ethernet port 1 x 1000BASE-X mini-GBIC SFP interface
  • MAC Address Table: 4K
  • Model #: FGSD-1011HP
  •  
  • $122.99 –
  • Free Shipping
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch
Quick View
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3: Ethernet IEEE 802.3u: Fast Ethernet IEEE 802.3ab: Gigabit Ethernet IEEE 802.3x: Flow Control
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-803
Planet GS-4210-24PL4C 24-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 440W PoE budget
Quick View
Planet GS-4210-24PL4C 24-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 440W PoE budget

OUT OF STOCK

  • Format: Rackmount
  • Standards: IEEE 802.3/3u, IEEE 802.3af/at
  • VLAN Support: Yes
  • Jumbo Frames: 10K bytes
  • Model #: GS-4210-24PL4C
Planet ISW-504PT 5-Port 10/100 Mbps with 4-Port PoE Industrial Ethernet Switch - Wide Temperature
Quick View
Planet ISW-504PT 5-Port 10/100 Mbps with 4-Port PoE Industrial Ethernet Switch - Wide Temperature

OUT OF STOCK

  • Format: DIN Rail Mount
  • Primary Port Speed: 10/100Mbps
  • PoE: Yes
  • Layer: 2
  • Model #: ISW-504PT
  •  
  • $215.99 –
  • Free Shipping
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
Quick View
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)

OUT OF STOCK

  • Brand: PLANET
  • Format: 19-inch Desktop size, 1U Height, Rack Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Network Management Type: Unmanaged
  • Model #: GSW-2620VHP
PLANET Technology - GSD-604HP - 4-Port 10/100/1000T 802.3at POE + 2-Port 10/100/1000T Desktop Switch (55W POE Budget,
Quick View
PLANET Technology - GSD-604HP - 4-Port 10/100/1000T 802.3at POE + 2-Port 10/100/1000T Desktop Switch (55W POE Budget,

OUT OF STOCK

  • Format: Desktop
  • Uplink Ports: 2
  • Uplink Interface: RJ45
  • Primary Ports: 6 10/100/1000Mbps Gigabit Ethernet ports
  • Model #: GSD-604HP
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
Quick View
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)

OUT OF STOCK

  • Brand: PLANET
  • Format: 19-inch Desktop size, 1U Height, Rack Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Network Management Type: Unmanaged
  • Model #: GSW-1820VHP